Протокол IP : Протокол IS-IS

Настройка IS-IS для IP в маршрутизаторах Cisco

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Назначение этого документа – показать базовую конфигурацию взаимодействия промежуточных систем (IS-IS) для IP на маршрутизаторах Cisco. В дополнение к конфигурации, как контролировать различную информацию о IS-IS, продемонстрирован, такие как сведения о голосовании Designated Intermediate System (DIS) и информация о базе данных IS-IS.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения в этом документе основываются на Cisco IOS Выпуск ПО Ã¯Â¿Â½ 12.1 (5) T9.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Пример конфигурации IS-IS

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Чтобы включить IS-IS для IP на маршрутизаторе Cisco и иметь его, обмениваются сведениями о маршрутизации с другими включенными маршрутизаторами IS-IS, необходимо выполнить эти две задачи:

  • Включение процесса IS-IS и назначение области

  • Включите IS-IS для IP-маршрутизации на интерфейсе

Другие задачи конфигурации необязательны, однако две задачи, описанные выше, необходимо выполнить. Для получения дополнительной информации о задачах произвольной конфигурации обратитесь к Настройке Интегрированный IS-IS.

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/13795/is-is-ip-config.jpg

Конфигурации

Эти конфигурации используются в данном документе:

Примеры конфигурации ниже настраивают все маршрутизаторы в вышеупомянутой топологии с этими параметрами:

  • Область 49.0001

  • Уровень 1 (L1) и маршрутизаторы Уровня 2 (L2) (это - по умолчанию, пока в противном случае не задано),

  • Нет дополнительных параметров

  • Запуск IS-IS только для IP

  • Интерфейсы обратной связи (заглушки объявлены с помощью IS-IS, IS-IS не разрешен)

Маршрутизатор 1
!
interface Loopback0
ip address 172.16.1.1 255.255.255.255

!--- Creates loopback interface and assigns
!--- IP address to interface Loopback0.

!
interface Ethernet0
ip address 172.16.12.1 255.255.255.0
ip router isis 


!--- Assigns IP address to interface Ethernet0 
!--- and enables IS-IS for IP on the interface.

!
router isis
passive-interface Loopback0
net 49.0001.1720.1600.1001.00
!

!--- Enables the IS-IS process on the router, 
!--- makes loopback interface passive 
!--- (does not send IS-IS packets on interface), 
!--- and assigns area and system ID to router.

Маршрутизатор 2
!
interface Loopback0
ip address 172.16.2.2 255.255.255.255

!--- Creates loopback interface and assigns 
!--- IP address to interface Loopback0.

!
Interface Ethernet0
ip address 172.16.12.2 255.255.255.0
ip router isis

!--- Assigns IP address to interface Ethernet0 
!--- and enables IS-IS for IP on the interface.

!
Interface Serial0
ip address 172.16.23.1 255.255.255.252
ip router isis

!--- Assigns IP address to interface Serial0 
!--- and enables IS-IS for IP on the interface.

!
router isis 
passive-interface Loopback0
net 49.0001.1720.1600.2002.00
!

!--- Enables the IS-IS process on the router,
!--- makes loopback interface passive 
!--- (does not send IS-IS packets on interface), 
!--- and assigns area and system ID to router. 

Маршрутизатор 3
!
interface Loopback0
ip address 172.16.3.3 255.255.255.255 

!--- Creates loopback interface 
!--- and assigns IP address to 
!--- interface Loopback0.

!
Interface Serial0
ip address 172.16.23.2 255.255.255.252
ip router Isis

!--- Assigns IP address to 
!--- interface Serial0 and enables 
!--- IS-IS for IP on the interface.

!
router isis 
passive-interface Loopback0
net 49.0001.1234.1600.2231.00
!

!--- Enables the IS-IS process on the router, 
!--- makes loopback interface passive 
!--- (does not send IS-IS packets on interface), 
!--- and assigns area and system ID to router.

Мониторинг при использовании протокола IS-IS

Существует множество команд show, предназначенных для контроля состояния IS-IS на маршрутизаторе Cisco. Документ демонстрирует ряд базовых команд на основе вышеприведенных конфигураций маршрутизаторов.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Мониторинг окрестностей IS-IS

Чтобы отобразить смежные соединения для конкретного маршрутизатора, используйте команду show clns neighbor. Это - выходные данные этой команды от Маршрутизатора 1 (R1) и Маршрутизатора 2 (R2):

R1# show clns neighbor
System Id   Interface  SNPA            State  Holdtime  Type Protocol
R2          Et0        0000.0c47.b947  Up     24        L1L2 ISIS
    
R2# show clns neighbor
System Id  Interface  SNPA             State  Holdtime  Type Protocol
R1         Et0        0000.0c09.9fea   Up     24        L1L2 ISIS
R3         Se0        *HDLC*           Up     28        L1L2 ISIS

В приведенном выше примере R1 распознает R2 в своем интерфейсе E0 с помощью типа смежности L1L2. Поскольку R1 и R2 используют конфигурации по умолчанию, они отправляют и получают приветствия L1 и L2.

R2 распознает R1 на интерфейсе E0, а маршрутизатор 3 (R3) на своем интерфейсе S0. Приведенные выше пояснения также справедливы и для этого типа смежности.

Так как R1 и R2 находятся на том же Интерфейсе Ethernet, существует DIS и для L1 и для L2. Можно проверить это использование команды show clns interface <int> на Маршрутизаторе 1, как показано ниже:

R1# show clns interface ethernet 0
Ethernet0 is up, line protocol is up
  Checksums enabled, MTU 1497, Encapsulation SAP
  Routing Protocol: ISIS
    Circuit Type: level-1-2
    Interface number 0x0, local circuit ID 0x1
    Level-1 Metric: 10, Priority: 64, Circuit ID: R2.01
    Number of active level-1 adjacencies: 1
    Level-2 Metric: 10, Priority: 64, Circuit ID: R2.01
    Number of active level-2 adjacencies: 1
    Next ISIS LAN Level-1 Hello in 5 seconds
    Next ISIS LAN Level-2 Hello in 1 seconds

В приведенных выше выходных данных R2 выступает в качестве системы DIS. Маршрутизатор R2 (DIS) формирует пакет состояния канала (LSP) псевдоузла, обозначенный ненулевым идентификатором LSP – R2.01

Начиная с Metric/Priority то же для обоих маршрутизаторов в L1/L2, системой разрешения конфликтов для DIS является самый высокий Адрес точек подключения подсети (SNPA) на сегменте LAN. SNPA адрес относится к адресам канала передачи данных и в этом случае является MAC адресом. Другой экземпляр адресов канала передачи данных был бы адресами X.25 и Frame Relay DLCI.

Обратите внимание, что DIS выбирается для обоих уровней и что нет запасного DIS, как в случае с протоколом открытого поиска кратчайшего пути (OSPF), у которого есть резервный отмеченный маршрутизатор (DR).

Другие интересные особенности выходных данных, приведенных выше, следующие:

  • Тип сети: L1L2

  • Метрики и приоритеты L1 и L2 имеют значения по умолчанию: 10 и 64

  • Смежности L1 и L2: 1 (из перспективы R1 в интерфейсе Ethernet - это только R2)

  • Приветствия IS-IS LAN для L1 и L2

  • Максимальный размер пакета (MTU): 1497. Это вызвано тем, что заголовок IS-IS Взаимодействия открытых систем (OSI) инкапсулируется в 3 байтах 802.2 заголовка.

Мониторинг базы данных IS-IS

Команда show isis database (detail) отображает содержание базы данных IS-IS. Это - выходные данные этой команды, когда выполнено на R2. Поскольку IS-IS является протоколом на основе состояния каналов, то база данных состояний каналов должны одной и той же для любого маршрутизатора в одной зоне.

R2# show isis database
ISIS Level-1 Link State Database:
LSPID         LSP Seq Num  LSP Checksum  LSP Holdtime    ATT/P/OL
R1.00-00      0x0000008B   0x6843        55              0/0/0
R2.00-00    * 0x00000083   0x276E        77              0/0/0
R2.01-00    * 0x00000004   0x34E1        57              0/0/0
R3.00-00      0x00000086   0xF30E        84              0/0/0
ISIS Level-2 Link State Database:
LSPID         LSP Seq Num  LSP Checksum  LSP Holdtime    ATT/P/OL
R1.00-00      0x00000092   0x34B2        41              0/0/0
R2.00-00    * 0x0000008A   0x7A59        115             0/0/0
R2.01-00    * 0x00000004   0xC3DA        50              0/0/0
R3.00-00      0x0000008F   0x0766        112             0/0/0

В приведенном ниже выводе есть несколько вещей, на которые следует обратить внимание. Во-первых, о LSP-ID:

LSP-ID, R1.00-00, может быть разломан на три раздела: R1/00/00

  • R1 = идентификатор системы

  • 00 = ненулевое значение для псевдоузла. Оповещение R2.01-00 – псевдоузел LSP.

  • 00 = количество фрагмента. В этом случае существует только количество фрагмента 00, который указывает, что все совпадение данных в этот фрагмент LSP, и не было никакой потребностью создать больше фрагментов. Если бы были получены сведения, которые не помещались бы в первый LSP, IS-IS создала бы больше фрагментов LSP, например, 01, 02 и так далее.

* обозначает LSP, которые генерировались этим маршрутизатором, маршрутизатор, на котором была выполнена команда показа. Кроме того, поскольку этот маршрутизатор имеет уровень L1 и L2, он содержит базу данных L1 и L2.

Можно также посмотреть на определенный LSP и использовать подробное ключевое слово для показа дополнительных сведений. Пример этого показывают здесь:

R2# show isis database R2.00-00 detail
ISIS Level-1 LSP R2.00-00
LSPID         LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
R2.00-00    * 0x00000093   0x077E        71            0/0/0
  Area Address: 49.0001
  NLPID:        0xCC
  Hostname: R2
  IP Address:   172.16.2.2 
  Metric: 10         IP 172.16.12.0 255.255.255.0
  Metric: 0          IP 172.16.2.2 255.255.255.255
  Metric: 10         IP 172.16.23.0 255.255.255.252
  Metric: 10         IS R2.01
  Metric: 10         IS R3.00
ISIS Level-2 LSP R2.00-00
LSPID         LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
R2.00-00    * 0x0000009A   0x5A69        103           0/0/0
  Area Address: 49.0001
  NLPID:        0xCC
  Hostname: R2
  IP Address:   172.16.2.2
  Metric: 10         IS R2.01
  Metric: 10         IS R3.00
  Metric: 10         IP 172.16.23.0 255.255.255.252
  Metric: 10         IP 172.16.1.1 255.255.255.255
  Metric: 10         IP 172.16.3.3 255.255.255.255
  Metric: 0          IP 172.16.2.2 255.255.255.255
  Metric: 10         IP 172.16.12.0 255.255.255.0

Вывод, представленный выше, показывает, что адрес обратной линии этого маршрутизатора объявлен со значением 0. Это происходит из-за того, что петля объявлена с помощью команды passive-interface в процессе IS-IS маршрутизатора, а интерфейс обратной связи как таковой не включен для IS-IS. Все другие префиксы IP имеют значение 10, которое является стоимостью по умолчанию на интерфейсах с IS-IS.

Проверка.

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 13795