Протокол IP : Протокол HSRP

Общие сведения о команде ip unnumbered и ее настройке

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

В данном документе разъясняется концепция команды ip unnumbered и предоставляется несколько примеров конфигураций для справки. Команда ip unnumbered configuration позволяет включить IP-обработку на последовательном интерфейсе, не назначая явный IP-адрес. Интерфейс ip unnumbered может «позаимствовать» IP-адрес другого интерфейса, уже настроенного на маршрутизаторе, с сохранением сети и адресного пространства.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. в Условные обозначения технических терминов Cisco.

Что такое ненумерованный интерфейс?

Считайте сеть показанной ниже. Маршрутизатор А имеет последовательный интерфейс S0 и интерфейс Ethernet E0.

/image/gif/paws/13786/20a_new.gif

Ethernet A маршрутизатора 0 интерфейсов может быть настроена с IP-адресом как показано ниже:

interface Ethernet0
ip address 172.16.10.254 255.255.255.0

Логически, для включения IP на интерфейсном S0 необходимо было бы настроить уникальный IP - адрес на нем. Однако также возможно включить IP на Последовательном интерфейсе и перевести его в рабочее состояние, не назначая уникальный IP - адрес на него. Это сделано путем заимствования IP-адреса, уже настроенного на одном из других интерфейсов маршрутизатора. Чтобы сделать это, командный режим интерфейса ненумерованного ip используется как показано ниже.

interface Serial 0
ip unnumbered Ethernet 0

Ip, ненумерованный <тип>, командный режим интерфейса <number> одалживает IP-адрес с заданного интерфейса на интерфейс, на котором была настроена команда. Использование команды ip unnumbered приводит к IP-адресу, разделяемому двумя интерфейсами. Таким образом, в нашем примере, IP-адрес, который был настроен на Интерфейсе Ethernet, также назначен на Последовательный интерфейс, и оба включенные интерфейса обычно функционируют. Это может быть проверено с помощью выходных данных команды show ip interface brief, как показано ниже:

RouterA# show ip interface brief 

Interface    IP-Address      OK?    Method   Status   Protocol
Ethernet0    172.16.10.254   YES    manual   up       up
Serial0      172.16.10.254   YES    manual   up       up

Как вы можете видеть от выходных данных команды show ip interface brief выше, последовательный интерфейс имеет IP-адрес, идентичный тому из Интерфейса Ethernet, и оба интерфейса полностью функциональны. Интерфейс, который заимствует своей адрес у одного из других функциональных интерфейсов маршрутизатора, называется «ненумерованным интерфейсом». В нашем примере Serial 0 является ненумерованным интерфейсом.

Единственный реальный недостаток, от которого страдает ненумерованный интерфейс, - то, что это недоступно удаленному тестированию и управлению. Необходимо также помнить, что ненумерованный интерфейс должен одолжить свой адрес у интерфейса, который в порядке. Если ненумерованный интерфейс указывает на интерфейс, который не функционален (т.е. который не разоблачает "Интерфейсный статус", "Протокол UP"), ненумерованный интерфейс не работает. Это точно, почему рекомендуется, чтобы не отказывала точка ненумерованного интерфейса к интерфейсу обратной связи начиная с loopback. Наконец, помните, что команда ip unnumbered работает на интерфейсы точка-точка только. При настройке команды на Мультиинтерфейсе доступа (т.е. Ethernet) или интерфейс обратной связи, следующие сообщения отображены:

RouterA(config)# int e0 
RouterA(config-if)# ip unnumbered serial 0 
Point-to-point (non-multi-access) interfaces only 
RouterA(config-if)# ip unnumbered loopback 0 
Point-to-point (non-multi-access) interfaces only  

IP и ненумерованный IP

В маршрутизаторе Cisco каждый интерфейс, соединенный с интерфейсом сети, должен соответствовать отдельной подсети. Интерфейсы напрямую подключаемых маршрутизаторов подключаются к одному сегменту сети и получают IP-адреса от одной подсети. Если маршрутизатору нужно отправить данные в сеть, непосредственно не связанную, он заглядывает в свою таблицу маршрутизации и направляет пакет на следующий непосредственно связанный переход к месту назначения. Если в таблице отсутствует маршрут, маршрутизатор направляет пакет в шлюз последнего ресурса. Когда маршрутизатор, напрямую подключенный к назначению, получает пакет, он доставляет его напрямую конечному узлу.

Таблица IP-маршрутизации содержит или маршруты в подсети или маршруты крупной сети. Для каждого маршрута есть один или несколько непосредственно подсоединенных адресов следующих узлов. Маршруты в подсети объединены или суммированы по умолчанию в границах крупной сети для сокращения размера таблицы маршрутизации.

Примечание: Схема объединения, обсужденная выше, принимает традиционный протокол маршрутизации вектора пути, такой как Протокол RIP или Протокол IGRP.

Давайте рассматривать IP-адреса присвоения к интерфейсам маршрутизатора с помощью сети класса B, которая была разделена на подсети с помощью восьми битов выделения подсети. Для каждого интерфейса необходима уникальная подсеть. Хотя каждое двухточечное последовательное соединение имеет только две конечные точки к адресам, если каждому последовательному интерфейсу присваивается подсеть в целом, используется 254 доступных адресов для каждого интерфейса, где необходимо только два адреса. Если мы используем IP, ненумерованный на каждом последовательном интерфейсе, мы сохраняем адресное пространство; адрес интерфейса LAN (локальной сети) "одалживается" и используется в качестве адреса источника для обновлений маршрута и пакетов из источника от последовательного интерфейса. Таким образом адресное пространство сохранено. Ненумерованный IP имеет смысл только в двухточечных каналах.

Маршрутизатор, который получает обновленные данные маршрутизации, задает исходящий адрес обновления в качестве следующего узла в таблице маршрутизации. Обычно для следующего перехода используется непосредственно подключенный сетевой узел. Это не происходит, если используются ненумерованные интерфейсы IP, так как каждый последовательный интерфейс "заимствует" свой IP-адрес у другого интерфейса LAN, каждый из которых находится в другой подсети и, возможно, в другой крупной сети. При настройке ненумерованных IP маршруты, узнанные через интерфейс с ненумерованным IP, имеют интерфейс следующего узла вместо обновления исходного адреса маршрутизации. Таким образом избегают проблемы неправильного адреса следующего узла благодаря тому, что источник обновления маршрутизации, приходящий от следующего узла, напрямую не подключен.

Примеры конфигураций

Примечание: Информация в этих примерах конфигурации основывается на Cisco Версия программного обеспечения 12.2 (10b) IOS� и была протестирована на маршрутизаторах Cisco серии 2500.

Давайте посмотреть на четыре других примера конфигурации для ненумерованного IP.

Примечание: Мы, возможно, использовали интерфейсы обратной связи вместо интерфейсов Ethernet.

Одна основная сеть, разные подсети

Рисунок 1 показывает, что по обе стороны от последовательного соединения у нас есть та же крупная сеть с другими подсетями.

Рисунок 1 – Схема построения сети

20a.gif

Маршрутизатор 1.1.1.1 Маршрутизатор 2.2.2.2
Current configuration:

interface Ethernet0
 ip address 171.68.178.196 255.255.255.192 

interface Serial0
 ip unnumbered Ethernet0

router igrp 10
 network 171.68.0.0 

Current configuration:

interface Ethernet 0
 ip address 171.68.179.1 255.255.255.192
 
interface Serial 0
 ip unnumbered Ethernet0 

router igrp 10
 network 171.68.0.0 

Router 1.1.1.1# show ip route

     171.68.0.0/26 is subnetted, 3 subnets
I       171.68.179.0 [100/8976] via 171.68.179.1, 00:00:02, Serial0
C       171.68.178.192 is directly connected, Ethernet0
I       171.68.0.0 [100/8976] via 171.68.179.1, 00:00:02, Serial0

Router 1.1.1.1# ping 171.68.179.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 171.68.179.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/30/32 ms


Router 2.2.2.2# show ip route

     171.68.0.0/26 is subnetted, 3 subnets
C       171.68.179.0 is directly connected, Ethernet0
I       171.68.178.192 [100/8976] via 171.68.178.196, 00:00:02, Serial0
I       171.68.0.0 [100/8976] via 171.68.178.196, 00:00:02, Serial0
     
Router 2.2.2.2# ping 171.68.178.196

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 171.68.178.196, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/32 ms

Сведения о маршруте о подсетях правильно поддержаны в этом сценарии.

Разные крупные сети без подсетей

Рисунок 2 показывает, что по обе стороны от последовательного соединения у нас есть другие крупные сети и никакие подсети.

Рисунок 2 - Диаграмма сети

/image/gif/paws/13786/20b.gif

Маршрутизатор 1.1.1.1 Маршрутизатор 2.2.2.2
Current configuration:

interface Ethernet0
 ip address 171.68.178.196 255.255.0.0 

interface Serial0
 ip unnumbered Ethernet0 
 
router igrp 10
 network 171.68.0.0 
Current configuration:

interface Ethernet 0
 ip address 172.68.1.1 255.255.0.0 

interface Serial 0
 ip unnumbered Ethernet0 
 
router igrp 10
 network 172.68.0.0

Router 1.1.1.1# show ip route

C    171.68.0.0/16 is directly connected, Ethernet0
I    172.68.0.0/16 [100/8976] via 172.68.1.1, 00:01:26, Serial0

Router 1.1.1.1# ping 172.68.1.1

Sending 5, 100-byte ICMP Echos to 172.68.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms


Router 2.2.2.2# show ip route

I    171.68.0.0/16 [100/8976] via 171.68.178.196, 00:00:21, Serial0
C    172.68.0.0/16 is directly connected, Ethernet0

Router 2.2.2.2# ping 171.68.178.196

Sending 5, 100-byte ICMP Echos to 171.68.178.196, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/29/32 ms

Основная сеть с подсетью, основная сеть без подсети

Рисунок 3 показывает, что на одной стороне последовательного соединения у нас есть крупная сеть с подсетью, и с другой стороны крупная сеть без подсетей.

Рисунок 3 – Диаграмма сети

/image/gif/paws/13786/20c.gif

Маршрутизатор 1.1.1.1 Маршрутизатор 2.2.2.2
Current configuration:

interface Ethernet0
 ip address 171.68.178.196 255.255.255.192

interface Serial0
 ip unnumbered Ethernet0 
 
router igrp 10
 network 171.68.0.0 
Current configuration:

interface Ethernet 0
 ip address 172.68.1.1 255.255.0.0

interface Serial 0
 ip unnumbered Ethernet0 
 
router igrp 10
 network 172.68.0.0

Router 1.1.1.1# show ip route

     171.68.0.0/26 is subnetted, 1 subnets
C       171.68.178.192 is directly connected, Ethernet0
I    172.68.0.0/16 [100/8976] via 172.68.1.1, 00:00:03, Serial0

Router 1.1.1.1# ping 172.68.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.68.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/31/32 ms


Router 2.2.2.2# show ip route

     171.68.0.0/16 is variably subnetted, 2 subnets, 2 masks
I       171.68.178.192/32 [100/8976] via 171.68.178.196, 00:00:48, Serial0
I       171.68.0.0/16 [100/8976] via 171.68.178.196, 00:00:48, Serial0
C    172.68.0.0/16 is directly connected, Ethernet0

Router 2.2.2.2# ping 171.68.178.196

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 171.68.178.196, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/29/32 ms

Примечание: До версии программного обеспечения Cisco IOS 11.0 (2) вы обязаны помещать статический маршрут для основной сети 171.68.0.0/16 в Маршрутизаторе 2.2.2.2.

В этом сценарии происходит потеря данных подсети, поскольку программа принимает их за маршрут хоста. В версии программного обеспечения Cisco IOS 11.0 (2) и выше, Протокол IGRP и Протокол RIP решают эту проблему путем передачи объединенного маршрута за основной сетью по ненумерованным каналам связи точка-точка.

Две основных сети и их подсети

Рисунок 4 показывает, что с обеих сторон последовательного соединения у нас есть две других крупных сети с соответствующими подсетями.

Рисунок 4 – Диаграмма сети

/image/gif/paws/13786/20d.gif

Маршрутизатор 1.1.1.1 Маршрутизатор 2.2.2.2
Current configuration:

interface Ethernet0
 ip address 171.68.178.196 255.255.255.192 

interface Serial0
 ip unnumbered Ethernet0 
 
router igrp 10
 network 171.68.0.0
Current configuration:

interface Ethernet 0
 ip address 172.68.1.1 255.255.255.192 
 
interface Serial 0
 ip unnumbered Ethernet0 
 
router igrp 10
 network 172.68.0.0 

Router 1.1.1.1# show ip route

     171.68.0.0/26 is subnetted, 1 subnets
C       171.68.178.192 is directly connected, Ethernet0
     172.68.0.0/16 is variably subnetted, 2 subnets, 2 masks
I       172.68.0.0/16 [100/8976] via 172.68.1.1, 00:00:02, Serial0
I       172.68.1.0/32 [100/8976] via 172.68.1.1, 00:00:02, Serial0

Router 1.1.1.1# ping 172.68.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.68.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/81/280 ms


Router 2.2.2.2# show ip route

     171.68.0.0/16 is variably subnetted, 2 subnets, 2 masks
I       171.68.178.192/32 [100/8976] via 171.68.178.196, 00:00:22, Serial0
I       171.68.0.0/16 [100/8976] via 171.68.178.196, 00:00:22, Serial0
     172.68.0.0/26 is subnetted, 1 subnets
C       172.68.1.0 is directly connected, Ethernet0

Router 2.2.2.2# ping 171.68.178.196

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 171.68.178.196, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/31/32 ms

Примечание: В версиях ПО Cisco IOS ниже чем 11.0(2) требуется поместить статический маршрут для основной сети 171.68.0.0/16 в Маршрутизатор 2.2.2.2 и для 172.68.0.0/16 в Маршрутизатор 1.1.1.1.

В этом сценарии происходит потеря данных подсети, поскольку программа принимает их за маршрут хоста. В Cisco IOS software version 11.0(2) и более поздней IGRP и RIP исправляют проблему, посылая объединенный маршрут для основной сети через ненумерованные каналы точка-точка.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 13786