Протокол IP : Групповая IP-адресация

Почему разреженный режим PIM не работает со статическим маршрутом к адресу HSRP?

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ объясняет, почему многоадресные пакеты не пересылаются при настройке статического маршрута на адрес протокола маршрутизатора горячего резервирования (HSRP) соседнего узла разреженного режима для масштабируемого протокола маршрутизации (PIM).

Предварительные условия

Требования

Для использования данного документа требуется знание следующих тем:

  • HSRP

  • Разреженный режим PIM

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. в Условные обозначения технических терминов Cisco.

Схема сети

http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-multicast/13783-hsrpmcasta.gif

На рисунке выше, Маршрутизаторы 2 и 3 говорят HSRP на подсети 10.1.3.0, и Маршрутизатор 2 является активным маршрутизатором. Маршрутизаторы 1, 2, и 3 говорят Протокол EIGRP, и Маршрутизатор 4 имеет статический маршрут по умолчанию к виртуальному адресу HSRP.

Конфигурации

Маршрутизатор 1 Маршрутизатор 2
Current configuration:

! 
ip multicast-routing 
! 
! 
interface Loopback0 
ip address 10.10.10.10 255.255.255.255 
no ip directed-broadcast 
! 
interface Ethernet0 
no ip address 
no ip directed-broadcast 
shutdown 
! 
interface Ethernet1 
ip address 10.1.1.1 255.255.255.0 
no ip directed-broadcast 
ip pim sparse-mode 
! 
interface Serial1 
no ip address 
no ip directed-broadcast 
encapsulation frame-relay 
! 
interface Serial1.1 point-to-point 
ip address 10.1.2.1 255.255.255.252 
no ip directed-broadcast 
ip pim sparse-mode 
frame-relay interface-dlci 612 
! 
! 
interface Serial1.2 point-to-point 
ip address 10.1.2.5 255.255.255.252 
no ip directed-broadcast 
ip pim sparse-mode 
frame-relay interface-dlci 613 
! 
router eigrp 1 
network 10.0.0.0 
no auto-summary 
! 
ip classless 
no ip http server 
ip pim rp-address 10.10.10.10 
! 

end
Current configuration:

! 
ip multicast-routing 
ip dvmrp route-limit 20000 
! 
! 
interface Ethernet1 
ip address 10.1.3.1 255.255.255.0 
no ip redirects 
ip pim sparse-mode 
standby 1 priority 110 preempt 
standby 1 ip 10.1.3.3 
! 
interface Serial1 
no ip address 
encapsulation frame-relay 
! 
interface Serial1.1 point-to-point 
ip address 10.1.2.2 255.255.255.252 
ip pim sparse-mode 
frame-relay interface-dlci 621 
! 
router eigrp 1 
network 10.0.0.0 
no auto-summary 
! 
ip classless 
ip pim rp-address 10.10.10.10 
!

end
Маршрутизатор 3 Маршрутизатор 4
Current configuration:

! 
ip multicast-routing 
ip dvmrp route-limit 20000 
! 
interface Ethernet1 
ip address 10.1.3.2 255.255.255.0 
no ip redirects 
ip pim sparse-mode 
standby 1 priority 100 preempt 
standby 1 ip 10.1.3.3 
! 
interface Serial1 
no ip address 
encapsulation frame-relay 
! 
interface Serial1.2 point-to-point 
ip address 10.1.2.6 255.255.255.252 
ip pim sparse-mode 
frame-relay interface-dlci 631 
! 
router eigrp 1 
network 10.0.0.0 
no auto-summary 
eigrp log-neighbor-changes 
! 
ip classless 
no ip http server 
ip pim rp-address 10.10.10.10 
!

end
Current configuration:

ip multicast-routing 
ip dvmrp route-limit 20000 
! 
! 
! 
interface Ethernet0 
ip address 10.1.4.1 255.255.255.0 
no ip directed-broadcast 
ip igmp join-group 239.1.2.3 
! 
interface Ethernet1 
ip address 10.1.3.4 255.255.255.0 
no ip directed-broadcast 
ip pim sparse-mode 
! 
no ip http server 
ip classless 
ip route 0.0.0.0 0.0.0.0 10.1.3.3 
ip pim rp-address 10.10.10.10 
!

end

Для моделирования хоста на Ethernet 0, команда ip igmp join-group была настроена на этом интерфейсе на Маршрутизаторе 4:

router4# ip igmp join-group 

IGMP Connected Group Membership 
Group Address Interface Uptime Expires Last Reporter 
224.0.1.40 Ethernet1 4d23h never 10.1.3.1 
239.1.2.3 Ethernet0 4d23h never 10.1.4.1 

Маршрутизатор 4 может выполнить эхо-тест адреса точки встречи (RP):

Type escape sequence to abort. 

Sending 5, 100-byte ICMP Echos to 10.10.10.10, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/61/68 ms

Посмотрите на многоадресный маршрут (mroute) таблица:

Router4# show ip mroute 239.1.2.3 

IP Multicast Routing Table 

Flags: D - Dense, S - Sparse, C - Connected, L - Local, P - Pruned 
R - RP-bit set, F - Register flag, T - SPT-bit set, J - Join SPT 
X - Proxy Join Timer Running 

Timers: Uptime/Expires 
Interface state: Interface, Next-Hop or VCD, State/Mode 
(*, 239.1.2.3), 00:04:28/00:00:00, RP 10.10.10.10, flags: SJCL 
Incoming interface: Ethernet1, RPF nbr 10.1.3.3 
Outgoing interface list: 
Ethernet0, Forward/Sparse, 00:02:12/00:02:53 

Поскольку существует получатель для этой группы (из-за команды ip igmp join-group, используемой в Маршрутизаторе 4), сборка (*, G) запись в таблице mroute. Обратите внимание, что соседом для пересылки по обратному пути (RPF) для записи (*,G) является резервный адрес протокола HSRP 10.1.3.3. Однако нет (S, G) запись, что означает, что трафик не получается от источника.

Так как у маршрутизатора 4 есть заинтересованный получатель для группы, он должен отправлять сообщение PIM Join/Prune своим PIM-соседям. Чтобы просмотреть окружение PIM маршрутизатора 4, введите команду show ip pim neighbor, как показано ниже:

Router4# show ip pim neighbor 

PIM Neighbor Table 
Neighbor Address Interface Uptime Expires Ver Mode 
10.1.3.1 Ethernet1 4d23h 00:01:41 v2 
10.1.3.2 Ethernet1 4d23h 00:01:36 v2

Если включена команда debug ip pim 239.1.2.3, маршрутизатор 4 создает это сообщение соединения/отсечения PIM, но фактически его не отправляет:

*Mar 6 18:32:48: PIM: Полученный RP, доступный на Ethernet1 с 10.10.10.10 *Мар 6 18:32:48: для группы 239.1.2.3 *6 марта 18:33:14: PIM: Построение Сообщения присоединения/отключения для 239.1.2.3 *6 марта 18:34:13: PIM: Формирование сообщения Join/Prune (обрезать/присоединить) для 239.1.2.3

Почему маршрутизатор не отправляет сообщение Join/Prune? RFC 2362 leavingcisco.com сообщает, что "маршрутизатор передает периодическое Сообщение присоединения/отключения к каждому отдельному окружению RPF, привязанному к каждому (S, G), (*, G) и (*, *, RP) запись. Сообщения Join/Prune посылаются, только если соседний узел RPF – это соседний узел PIM."

Сосед RPF в данном примере – это 10.1.3.3, что является резервным адресом HSRP, используемым статическим маршрутом по умолчанию. Однако этот адрес не является соседом PIM. Резервный адрес HSRP не содержится в списке в качестве соседа PIM, так как два маршрутизатора HSRP (маршрутизаторы Routers 2 и 3) не получают сообщения соседа PIM с резервного адреса HSRP.

Для решения этой проблемы измените настройки четвертого маршрутизатора так, чтобы соседний RPF стал также соседним PIM. Выполните это, включив маршрутизатор 4 в процесс EIGRP, так чтобы он узнавал адрес RP через EIGRP.

Примечание: Поскольку маршрутизатор 4 имеет возможность выполнять протокол маршрутизации, для его подключения не следует надеяться на резервный адрес HSRP. Протокол HSRP предназначен для обеспечения быстрого и эффективного резервирования или избыточности для переключения при отказе хостов.

Ниже описывается новая конфигурация маршрутизатора 4 с включенной поддержкой EIGRP.

ip multicast-routing 
ip dvmrp route-limit 20000 
! 
! 
! 
interface Ethernet0 
ip address 10.1.4.1 255.255.255.0 
no ip directed-broadcast 
ip igmp join-group 239.1.2.3 
! 
interface Ethernet1 
ip address 10.1.3.4 255.255.255.0 
no ip directed-broadcast 
ip pim sparse-mode 
!
router eigrp 1
network 10.0.0.0
no auto-summary
! 
no ip http server 
ip classless 
ip route 0.0.0.0 0.0.0.0 10.1.3.3 
ip pim rp-address 10.10.10.10 
!
end 

Примечание: Вместо включения маршрутизатора Router4 в процесс EIGRP (предпочтительный метод), добавьте статические mroute в Router4, чтобы добавить его RPF к реальным IP-адресам маршрутизатора, поскольку mroute предпочтительны по сравнению с одноадресной таблицей маршрутизации в проверках RPF., Например, добавьте ip mroute 0.0.0.0 0.0.0.0 10.1.3.2.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 13783