Протокол IP : Технология NAT

Пулы NAT и нулевая подсеть

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

В настоящем документе показано, как пулы преобразование сетевых адресов (NAT) подчиняются нулевым правилам подсети, как любые другие IP-адреса.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Сведения, представленные в этом документе, были получены от устройств в специфической лабораторной среде. Все устройства, используемые в этом документе, были запущены с чистой конфигурацией (конфигурацией по умолчанию). При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Теоретические сведения

Если настроить пул NAT таким образом, что адреса в пуле являются частью нулевой подсети, то это приведет к сбою преобразования NAT.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, использованных в данном документе, см. в разделе Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/13777/7a.gif

В этом примере конфигурации внутреннее устройство имеет маршрут по умолчанию маршрутизатора NAT. Внешнее устройство имеет статический маршрут к адресу, в который преобразовано внутреннее устройство. У маршрутизатора NAT следующая конфигурация NAT:

ip nat pool test 171.68.1.1 171.68.1.10 netmask  255.255.240.0
ip nat inside source list 7 pool test 

interface s 0
ip address 171.16.4.6 255.255.255.0
ip nat inside

interface s 1
ip address 171.16.6.6 255.255.255.0
ip nat outside

access-list 7 permit host 171.16.4.4

Заметьте, что адреса в тесте пула NAT являются нулевыми адресами подсети. При выполнении эхо-теста с внутреннего на внешнее устройство происходит сбой, так как не выполняется преобразование адресов. При выполнении команды debug ip nat на маршрутизаторе NAT она показывает эти сообщения:

NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5
NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5
NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5
NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5
NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5

Примечание: В выходных данных отладки "(A)" означает возникновение ошибки при трансляции после маршрутизации.

Примечание: Во избежание этой проблемы настройте команду ip subnet-zero в маршрутизаторе NAT. Команда выполнена по умолчанию в Cisco Выпуск ПО IOS� 12.0. В более ранних Cisco IOS Software Release это не включено по умолчанию. Если NAT не настроен должным образом, когда используется с PAT, то преобразование NAT может отказать. Это коды ошибки преобразования NAT:

 A = Inside to outside fails after routing
 B = Outside to inside fails before routing
 C = Outside to inside fails after routing 
 D = Helpered fails 
 L = Internally generated packet fails 
 E = Inside to outside fails after routing

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 13777