Протокол IP : Протокол BGP

Настройка возможности BGP Local-AS

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ объясняет характеристику local-as Протокола BGP, которая была сначала доступна в Cisco Выпуск ПО IOS� 12.0 (5) S.

Характеристика local-as позволяет маршрутизатору, казаться, быть участником второй автономной системы (AS), в дополнение к ее реальному AS. Эту функцию можно использовать только для истинных одноранговых узлов eBGP. Вы не можете использовать эту функцию для двух узлов, которые являются участниками других под-AS конфедерации.

Предварительные условия

Требования

Этот документ требует понимания принципов работы протокола маршрутизации BGP. См. примеры практического применения BGP.

Используемые компоненты

Сведения в этом документе применяются к этим версиям программного и аппаратного обеспечения.

  • Программное обеспечение Cisco IOS версии 12.2 (28)

  • Маршрутизаторы Cisco серии 2500

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Синтаксис команды

Этот список показывает синтаксис команд, что конфигурации в этом документе используют.

Local-AS не может быть настроен для отдельных узлов в группе одноранговых узлов.

Local-AS не может иметь номера AS локального протокола BGP или количества AS удаленного узла.

Команда local-as допустима только в том случае, если узел является истинным узлом eBGP. Это не работает для двух узлов в других под-AS в конфедерации.

См. Справочник по командам BGP для дополнительных сведений о командах BGP.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Общие сведения

Характеристика local-as полезна, если ISP-A покупает ISP-B, но клиенты ISP-B не хотят модифицировать любые схемы равноправного информационного обмена или конфигурации. Характеристика local-as позволяет маршрутизаторам в ISP-B становиться участниками AS ISP-A. В то же время эти маршрутизаторы, кажется их клиентам сохраняют свой номер AS ISP-B.

На рисунке 1 ISP-A еще не купил ISP-B. На рисунке 2 ISP-A купил ISP-B, и ISP-B использует характеристику local-as.

На рисунке 2 ISP-B принадлежит AS 100 и ISP-C к AS 300. При пиринге с ISP-C ISP-B использует AS 200 в качестве своего номера AS с использованием соседней команды local-as 200 ISP-C. В обновлениях, передаваемых от ISP-B до ISP-C, AS_SEQUENCE в Атрибуте as_path содержит "200 100". Эти "200" предварительно ожидается ISP-B из-за команды local-as 200, настроенной для ISP-C.

Обычно объединенный ISP-A/B перенумеровывает маршрутизаторы в ISP-B, чтобы быть частью AS 100. Что, если ISP-C неспособен изменить свои конфигурации eBGP с ISP-B? До характеристики local-as объединенный ISP-A/B должен поддержать два номера AS. Команда local-as позволяет ISP-A/B физически быть одним AS, в то время как это, кажется, два AS к ISP-C.

Настройка

В данном разделе содержится информация о настройке функций, описанных в этом документе.

Примечание: Для обнаружения дополнительных сведений об использовании этого документа команд используйте Средство поиска команд Command Lookup Tool (только зарегистрированные клиенты).

Сетевые графики

Этот документ использует эти сетевые установки.

Рисунок 1

/image/gif/paws/13761/39a.gif

Рис. 2

/image/gif/paws/13761/39b.gif

Конфигурации

Эти конфигурации используются в данном документе.

ISP-B (AS 100, local-as 200)
hostname ISP-B
! 
interface serial 0 
ip address 192.168.1.1 255.255.255.252 
! 
interface ethernet 0 
ip address 192.168.4.1 255.255.255.0 
! 
router bgp 100 

!--- Note the AS number 100. This is the AS number of ISP-A, which is now
!--- used by all routers in ISP-B after its acquisition by ISP-A.

 neighbor 192.168.1.2 remote-as 300 

!--- Defines the e-BGP connection to ISP-C.

 neighbor 192.168.1.2 local-as 200 

!--- This command makes the remote router in ISP-C to see this
!--- router as belonging to AS 200 instead of AS 100. 
!--- This also make this router to prepend AS 200 in 
!--- all updates to ISP-C.

network 192.168.4.0
! 
!

ИСП C (автономная система 300)
hostname ISP-C
! 
interface serial 1 
ip address 192.168.1.2 255.255.255.252 
! 
interface ethernet 0 
ip address 192.168.9.1 255.255.255.0 
! 
router bgp 300 
 neighbor 192.168.1.1 remote-as 200

!--- Defines the e-BGP connection to ISP-B.


!--- Note AS is 200 and not AS 100.
 
 network 192.168.9.0 
! 
!

Проверка

Этот раздел предоставляет сведения, можно использовать, чтобы подтвердить, что должным образом работает конфигурация.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

См. Справочник по командам BGP для узнавания больше о командах показа, используемых в этом разделе.

Просмотрите таблицу маршрутизации BGP, чтобы видеть, как команда local-as изменила AS_PATH. То, что вы наблюдаете, - то, что ISP-B предварительно ожидает AS 200 к обновлениям, которые переданы и получены от ISP-C. Кроме того, обратите внимание, что ISP-B находится в AS номер 100.

ISP-B# 
show ip bgp summary

  BGP router identifier 192.168.4.1, local AS number 100 
  BGP table version is 3, main routing table version 3 
  2 network entries and 2 paths using 266 bytes of memory 
  2 BGP path attribute entries using 104 bytes of memory 
  1 BGP AS-PATH entries using 24 bytes of memory 
  0 BGP route-map cache entries using 0 bytes of memory 
  0 BGP filter-list cache entries using 0 bytes of memory 
  BGP activity 2/6 prefixes, 2/0 paths, scan interval 15  secs 

  Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd 
  192.168.1.2     4   300      29      29        3    0    0 00:25:19       1

В этих выходных данных обратите внимание, что ISP-C рассматривает ISP-B как часть AS 200.

ISP-C# show ip bgp summary 
  BGP table version is 3, main routing table version 3 
  2 network entries (2/6 paths) using 480 bytes of memory 
  2 BGP path attribute entries using 192 bytes of memory 
  0 BGP route-map cache entries using 0 bytes of memory 
  0 BGP filter-list cache entries using 0 bytes of memory 

  Neighbor        V    AS MsgRcvd MsgSent  TblVer InQ OutQ   Up/Down  State/PfxRcd 
  192.168.1.1     4   200      34      34       3   0    0  00:30:19   1

Обратите внимание в этих выходных данных, что ISP-B предварительно ожидает "200" к маршрутам, изученным из ISP-C.

ISP-B# 
show ip bgp

  BGP table version is 3, local router ID is 192.168.4.1 
  Status codes: s suppressed, d damped, h history, * valid, > best, i - internal 
  Origin codes: i - IGP, e - EGP, ? - incomplete 

  Network          Next Hop            Metric LocPrf  Weight   Path 
  *> 192.168.4.0      0.0.0.0               0          32768   i 
  *> 192.168.9.0      192.168.1.2           0              0   200 300 i

Обратите внимание на то, что ISP-C видит маршруты от ISP-B с AS_PATH "200 100".

ISP-C# show ip bgp 
  BGP table version is 3, local router ID is 192.168.1.2 
  Status codes: s suppressed, d damped, h history, * valid, > best, i - internal 
  Origin codes: i - IGP, e - EGP, ? - incomplete 

  Network          Next Hop          Metric LocPrf  Weight Path 
  *> 192.168.4.0      192.168.1.1         0              0 200 100 i 
  *> 192.168.9.0      0.0.0.0             0          32768 i

Эти команды показывают настроенные значения local-as в своих выходных данных:

ISP-B# show ip bgp neighbors 192.168.1.2
BGP neighbor is 192.168.1.2,  remote AS 300,  local AS 200, external link
  BGP version 4, remote router ID 192.168.9.1
  BGP state = Established, up for 00:22:42
  Last read 00:00:42, hold time is 180, keepalive interval is 60 seconds
  Neighbor capabilities:
    Route refresh: advertised and received(old & new)
    Address family IPv4 Unicast: advertised and received
  Message statistics:
    InQ depth is 0
    OutQ depth is 0
                         Sent       Rcvd
    Opens:                  1          1
    Notifications:          0          0
    Updates:                2          1
    Keepalives:            25         25
    Route Refresh:          0          1
    Total:                 28         28
  Default minimum time between advertisement runs is 30 seconds

! Output Suppressed

Устранение неполадок

Команда debug ip bgp updates отображает принятые префиксы со своими атрибутами от соседнего узла. Эти выходные данные показывают, что префикс 192.168.4.0/24 получен с ПУТЕМ AS 200, 100.

ISP-C#
*May 10 12:45:14.947: BGP(0): 192.168.1.1 computing updates, afi 0, neighbor ver
sion 0, table version 5, starting at 0.0.0.0
*May 10 12:45:14.947: BGP(0): 192.168.1.1 send UPDATE (format) 192.168.9.0/24, n
ext 192.168.1.2, metric 0, path
*May 10 12:45:14.947: BGP(0): 192.168.1.1 1 updates enqueued (average=52, maximu
m=52)
*May 10 12:45:14.947: BGP(0): 192.168.1.1 update run completed, afi 0, ran for 0
ms, neighbor version 0, start version 5, throttled to 5
*May 10 12:45:14.947: BGP: 192.168.1.1 initial update completed
*May 10 12:45:15.259: BGP(0): 192.168.1.1 rcvd UPDATE w/ attr: nexthop 192.168.1
.1, origin i, metric 0, path 200 100
ISP-C#
*May 10 12:45:15.259: BGP(0): 192.168.1.1 rcvd 192.168.4.0/24
*May 10 12:45:15.279: BGP(0): Revise route installing 192.168.4.0/24 -> 192.168.
1.1 to main IP table
ISP-C#

Дополнительные сведения


Document ID: 13761