Протокол IP : Протокол BGP

Возможности учета: политики учета BGP и политики учета BGP на выходном интерфейсе

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Функция учета политик (PA) Протокола BGP позволяет вам объяснять IP - трафик дифференцированно путем присвоения счетчиков на основе списка сообщества, количества AS и/или AS_PATH на на основание входного интерфейса.

Учет Выходного интерфейса BGP PA представляет несколько расширений, чтобы включить BGP PA на выходном интерфейсе и включать учет на основе адреса источника для обоих трафиков ввод/вывода на интерфейсе. Счетчикам на основе параметров, таких как список сообщества, номер автономной системы или путь автономной системы назначают определить IP - трафик.

Предварительные условия

Требования

Прежде чем вы используете функцию BGP PA, включите технологию CEF или Distributed Cisco Express Forwarding (dCEF) на маршрутизаторе.

Используемые компоненты

Функция BGP PA сначала поддерживается придерживающимися платформами, которые поддерживают Cisco IOS Release 12.0 (9) S.

  • Series маршрутизаторы Cisco 7200, 7500 и 12000

Количество платформ, которые поддерживают эту функцию в Cisco IOS Release 12.2 (13) T, намного больше. Платформы включают:

  • 1400, 1600, 1700, 2600, 3600, 7100, 7200, 7500, AS5300, AS5350, AS5400, AS5800, AS5850, ICS7750, URM IGX 8400, MGX 8850, uBR7200.

Учет Выходного интерфейса BGP PA был добавлен в 12.0 (22) S и сначала представлен как новая характеристика в 12.3 (4) T. Существуют многие Cisco platfoms, которые поддерживают эту функцию.

Примечание: Для получения обновленных данных относительно поддержки платформ для этой функции обратитесь к ILS Cisco Feature Navigator (только зарегистрированные клиенты).

Сведения, представленные в этом документе, были получены от устройств в специфической лабораторной среде. Все устройства, используемые в этом документе, были запущены с чистой конфигурацией (конфигурацией по умолчанию). При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Теоретические сведения

Эта функция была сначала доступна на Cisco Выпуск ПО IOS� 12.0 (9) ED S. Для функции учета политик для работы необходимо включить BGP и CEF/dCEF на маршрутизаторе.

Использование учета политики BGP, можно объяснить трафик (и применить составление счетов) согласно маршруту, который это пересекает. Например, можно объяснить трафик, который это маршрутизировало внутренний, международный, наземный, или спутник. Таким образом можно определить и объяснить весь трафик на для отдельных клиентов.

Эта функция использует преимущества команды table-map BGP , которая классифицирует префиксы, которые это помещает в таблицу маршрутизации согласно списку сообщества, количеству AS, AS_PATH, и т.д. На основе этих условий соответствия учетная политика BGP определяет номер блока (в настоящее время 1 - 64) таблицы учета, привязанной к каждому интерфейсу. Каждый блок представляет классификацию трафика, которая позволяет IP - трафику составляться дифференцированно списком сообщества, количеством AS или AS_PATH на входной интерфейс.

Для получения дополнительной информации обратитесь к Учету Политики BGP.

Примечание: BGP PA измеряет и классифицирует IP - трафик, который передан или получен от, другие узлы. PA был ранее доступен на входном интерфейсе только.

Политика BGP, Считающая Функцию учета Выходного интерфейса, представляет несколько расширений, чтобы включить BGP PA на выходном интерфейсе и включать учет на основе адреса источника для обоих трафиков ввод/вывода на интерфейсе. Счетчикам на основе параметров, таких как список сообщества, номер автономной системы или путь автономной системы назначают определить IP - трафик. Учет выходного интерфейса был добавлен в Cisco IOS Release 12.0 (22) S.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. в Условные обозначения технических терминов Cisco.

Настройка учета политики BGP

  1. Задайте сообщества в списках сообщества (или определите списки AS_PATH), которые классифицируют трафик для учета.

    ip community-list 30 permit 100:190
      ip community-list 40 permit 100:198
      ip community-list 50 permit 100:197
      ip community-list 60 permit 100:296
      ip community-list 70 permit 100:201
      !
  2. Определите route-map к спискам match community и определите соответствующие номера блока.

    route-map set_bucket permit 10
    match community 30
    set traffic-index 2
    !
    route-map set_bucket permit 20
    match community 40
    set traffic-index 3
    !
    route-map set_bucket permit 30
    match community 50
    set traffic-index 4
    !
    route-map set_bucket permit 40
    match community 60
    set traffic-index 5
    !
    route-map set_bucket permit 50
    match community 70
    set traffic-index 6 
  3. Используйте команду table-map под BGP для изменения количества блока, когда таблица IP-маршрутизации будет обновлена с маршрутами, изученными из BGP.

    router bgp 110
      table-map set_bucket
      network 15.1.1.0 mask 255.255.255.0
      neighbor 14.1.1.1 remote-as 100
      !
      ip classless
      ip bgp-community new-format 
  4. Включите функцию учета политик на входном интерфейсе, связанном с клиентом.

    interface POS7/0
      ip address 15.1.1.2 255.255.255.0
      no ip directed-broadcast
      bgp-policy accounting
      no keepalive
      crc 32
      clock source internal

Политика BGP Настройки, считающая учет выходного интерфейса

Учет Выходного интерфейса конфигурации BGP Pa подобен BGP PA. Первый шаг трех, описанный в предыдущем разделе, является точно тем же. Единственное изменение находится в команде bgp-policy accounting, которая используется для активации опции PA на интерфейсе. В примере ниже BGP PA включен на Интерфейсе пакетной передачи POS (по сети Sonet) 7/0. Критерии Pa основываются на адресе источника выходного трафика

interface POS7/0
 ip address 10.15.1.2 255.255.255.0
 bgp-policy accounting output source
 no keepalive
 crc 32
 clock source internal

команды show, отслеживающие отчетность политики

Для осмотра, какой префикс назначен к который блока и который сообщество (или сообщества) используйте команды show ip cef и show ip bgp.

Router# show ip cef 196.240.5.0 detail
196.240.5.0/24, version 21, cached adjacency to POS7/2
0 packets, 0 bytes, traffic_index 4
  via 14.1.1.1, 0 dependencies, recursive
   next hop 14.1.1.1, POS7/2 via 14.1.1.0/30
   valid cached adjacency

Router# show ip bgp 196.240.5.0
BGP routing table entry for 196.240.5.0/24, version 2
Paths: (1 available, best #1)
  Not advertised to any peer
  100
    14.1.1.1 from 14.1.1.1 (32.32.32.32)
      Origin IGP, metric 0, localpref 100, valid, external, best
      Community: 100:197

Для рассмотрения поинтерфейсной статистики трафика используйте команду show cef interface policy-statistics.

LC-Slot7# show cef interface policy-statistics
:
POS7/0 is up (if_number 8)
Bucket    Packets               Bytes

1          0                      0
2          0                      0
3          50                     5000
4          100                    10000
5          100                    10000
6          10                     1000
7          0                      0
8          0                      0

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 13760