Протокол IP : Протокол BGP

Пример конфигурации для удаления частных номеров AS в BGP

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ содержит примеры конфигурации для удаления частных номеров автономных систем (AS) из исходящих обновлений eBGP. Номера AS подразделяются на две категории: частные и публичные. Подобно ситуации с частными и публичными IP-адресами, частный номер AS невозможно объявить в Интернете. Публичные номера AS занимают диапазон от 1 до 64511, а частные номера AS — от 64512 до 65535. Можно использовать частные номера AS, чтобы разделить большие числа AS на несколько маленьких чисел AS, соединенных через eBGP. Кроме того, в случае подключения к одному поставщику услуг Интернета, последний может назначить частный номер AS для экономии публичных номеров AS. Однако эти частные номера AS потребуется удалить перед отправкой обновлений в глобальную ячеистую структуру BGP (Интернет).

Примечание: Если вы соединяетесь со множественными интернет-провайдерами, присвоение частного количества AS не рекомендуется. Если сеть заказчика соединяется с одиночным интернет-провайдером (или одиночный размещенный или двойной размещенный), может использоваться частное количество AS.

Обратитесь к Удалению Частных автономных номеров в системе в BGP для получения дополнительной информации о частном количестве AS.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения в этом документе применяются к этим версиям программного и аппаратного обеспечения:

  • Cisco выпуск ПО IOS� 12.2 (27)

  • Cisco 2501 и маршрутизаторы Cisco 2503

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Более подробную информацию о применяемых в документе обозначениях см. в описании условных обозначений, используемых в технической документации Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

Этот документ использует сетевую установку, в которой Маршрутизатор 3 использует частный AS количество 65000, и Маршрутизатор 1 и Маршрутизатор 2 используют Общее количество AS 1 AS и AS 5 соответственно.

Маршрутизатор 2 находится в Облаке Поставщика услуг с Маршрутизатором 1 (рабочий AS 1) и Маршрутизатором 3 (рабочий AS 65000) как его клиенты.

/image/gif/paws/13758/36-1.gif

Передайте и получите обновления

Эта процедура объясняет последовательность событий, которые происходят, когда Маршрутизатор 3 объявляет сеть (10.0.0.0/24 в этом случае).

  1. Маршрутизатор 3 объявляет сеть 10.0.0.0/24 с атрибутом пути AS 65000 к Маршрутизатору 2.

  2. Маршрутизатор 2 получает обновление от Маршрутизатора 3 и делает запись для сети 10.0.0.0 / 24 в ее таблице маршрутизации со следующим переходом как 172.16.0.1 (последовательный интерфейс S0 на Маршрутизаторе 3).

  3. Маршрутизатор 2 (Устройство Поставщика услуг), когда настроено с командой neighbor 192.168.0.2 remove-private-AS, снимает изоляцию с частного количества AS и создает новый обновленный пакет с его собственным количеством AS как атрибут пути AS для 10.0.0.0/24 сети и передает то же к Маршрутизатору 1, который находится в AS1.

  4. Маршрутизатор 1 получает обновление eBGP для сети 10.0.0.0/24 и делает запись в ее таблице маршрутизации со следующим переходом как 192.168.0.1 (S1 последовательного интерфейса на Маршрутизаторе 2). Атрибут пути AS для этой сети, как замечено на Маршрутизаторе 1 (маршрутизатор 2) AS 5. Таким образом частному количеству AS препятствуют ввести таблицы BGP Интернета.

Конфигурации

Эти конфигурации используются в данном документе:

Маршрутизатор 3
Current configuration :
!
interface Ethernet0
 ip address 10.0.0.1 255.255.255.0
!
interface Serial0
 ip address 172.16.0.1 255.255.255.0
!
router bgp 65000
 network 10.0.0.0 mask 255.255.255.0
 neighbor 172.16.0.2 remote-as 5

!--- Configures Router 2 as an eBGP neighbor in public AS 5. 

!
end

Маршрутизатор 2
Current configuration :
!
!
interface Ethernet0
 ip address 172.30.1.1 255.255.0.0
!
interface Serial0
 ip address 172.16.0.2 255.255.255.0
!
interface Serial1
 ip address 192.168.0.1 255.255.255.0
!
router bgp 5
 network 172.30.0.0
 network 192.168.0.0
 neighbor 172.16.0.1 remote-as 65000

!--- Configures Router 3 as an eBGP neighbor in private AS 65000.

 neighbor 192.168.0.2 remote-as 1

!--- Configures Router 1 as an eBGP neighbor in public AS 1. 

 neighbor 192.168.0.2 remove-private-AS

!--- Removes the private AS numbers from outgoing eBGP updates.

!
!
end

Маршрутизатор 1
Current configuration :
!
version 12.2
!
!
interface Serial0
 ip address 192.168.0.2 255.255.255.0
 !
router bgp 1
 neighbor 192.168.0.1 remote-as 5

!--- Configures Router 2 as an eBGP neighbor in public AS 5.

!
end

Формат ТОЧКИ автономной системы

Данный пример объясняет, как преобразовать количество AS, больше, чем от 65535 до 4-байтовой Автономной системы (формат ASDOT).

Перед конфигурацией ASDOT

Router#show run | beg router 
router bgp 131280
no synchronization 
bgp log-neighbor-changes 
no auto-summary 

Конфигурация ASDOT

Router(config-router)#bgp asnotation dot 
Router(config-router)#end 

После конфигурации

Router#show run | beg router bgp 
router bgp 2.208  <== 
no synchronization 
bgp asnotation dot 
bgp log-neighbor-changes 
no auto-summary ! 

Проверка.

Этот раздел предоставляет сведения, можно использовать, чтобы подтвердить, что должным образом работает конфигурация.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Сообщения отладки, взятые с командой debug ip bgp updates на Маршрутизаторе 1, показывают, что обновление для сети 10.0.0.0/24 полученный от Маршрутизатора 2 (192.68.0.1) имеет атрибут пути AS 5, который является количеством AS Маршрутизатора 2. Команда show ip bgp на Маршрутизаторе 2 и Маршрутизаторе 1 также иллюстрирует то же.

Router1#
1w1d: %BGP-5-ADJCHANGE: neighbor 192.168.0.1 Up
1w1d: BGP(0): 192.168.0.1 computing updates, afi 0, 
       neighbor version 0, table version 1, starting at 0.0.0.0
1w1d: BGP(0): 192.168.0.1 update run completed, afi 0, 
       ran for 0ms, neighbor version 0, start version 1, throttled to 1
1w1d: BGP: 192.168.0.1 initial update completed
1w1d: BGP(0): 192.168.0.1 rcvd UPDATE w/ attr: nexthop 
       192.168.0.1, origin i, path 5
1w1d: BGP(0): 192.168.0.1 rcvd 10.0.0.0/24
1w1d: BGP(0): Revise route installing 10.0.0.0/24 -> 192.168.0.1 
      to main IP table
1w1d: BGP(0): 192.168.0.1 computing updates, afi 0, neighbor 
      version 1, table version 2, starting at 0.0.0.0
1w1d: BGP(0): 192.168.0.1 update run completed, afi 0, ran for 0ms,
      neighbor version 1, start version 2, throttled to 2

Router2#show ip bgp
BGP table version is 3, local router ID is 192.168.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
    Network         Next Hop      Metric  LocPrf Weight   Path
 *> 10.0.0.0/24     172.16.0.2         0              0   65000 i
 *> 172.30.0.0      0.0.0.0            0         32768    i
 

Router1#show ip bgp
BGP table version is 19, local router ID is 192.168.0.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
    Network          Next Hop      Metric  LocPrf  Weight  Path
 *> 10.0.0.0/24      192.168.0.1                        0  5 i
 *> 172.30.0.0       192.168.0.1        0               0  5 i

Таблица BGP Маршрутизатора 2 показывает, что сеть 10.0.0.0 происходит из AS 65000. Таблица BGP Маршрутизатора 1 показывает, что та же сеть происходит из AS 5. Это вызвано тем, что команды neighbor 192.168.0.2 remove-private-as на Маршрутизаторе 2, который снимает изоляцию с частного количества AS и препятствует тому, чтобы частное количество AS достигло Интернета. По этой причине в AS 1 (маршрутизаторе 1) предоставляется согласованный просмотр AS 5 как источника сети 10.0.0.0/24.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 13758