Протокол IP : Протокол BGP

Пример конфигурации для iBGP и eBGP с или без Loopback Address

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (19 декабря 2015) | Отзыв


Содержание


Введение

BGP - это протокол exterior gateway protocol (EGP), используемый для выполнения внутридоменной маршрутизации в сетях TCP/IP. Маршрутизатор под управлением BGP должен установить соединение (на порту TCP 179) с каждой из сторон BGP прежде, чем станет возможен обмен обновлениями BGP. Если стороны BGP находятся в разных автономных системах (AS), то сеанс BGP между такими двумя сторонами BGP называется внешним сеансом BGP (eBGP). Если же стороны BGP находятся в одной автономной системе, то сеанс BGP между ними называется внутренним сеансом BGP (iBGP).

По умолчанию равноправная связь устанавливается с использованием IP-адреса интерфейса, ближайшего к равноправному маршрутизатору. Однако с помощью команды neighbor update-source, любой в рабочем состоянии интерфейс, включая интерфейс обратной связи, может быть задан, чтобы использоваться для установления TCP - подключений. Этот метод пиринга с использованием интерфейса обратной связи полезен, так как это не переведет сеанс BGP в нерабочее состояние, когда будут разнообразные пути между Одноранговыми соединениями по протоколу BGP, которые иначе привели бы к разъединению сеанса BGP, если выключается физический интерфейс, используемый для установления сеанса. В дополнение к этому это также позволяет маршрутизаторам рабочий BGP со сложными соединениями между ними для распределения нагрузки по доступным путям.

В этот документ включены образцы конфигурации для iBGP и для eBGP, с петлевыми адресами и без них.

Примечание: Вы можете использовать эти конфигурации для установления соседского окружения. См. Использование Border Gateway Protocol для Междоменной маршрутизации для большего количества сложных конфигураций.

Предварительные условия

Требования

Прежде чем приступить к данной конфигурации, необходимо убедиться в выполнении следующего требования:

  • Знание протоколов BGP

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования. Выходные данные команды, показанные в этом документе, были взяты от маршрутизаторов серии "2500", выполняющих версию 12.2 (24a) IOS�.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. Cisco Technical Tips Conventions.

Настройка

Этот раздел содержит следующие примеры конфигурации:

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Схема сети

В настоящем документе используется следующая схема сети:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/13751-23a.gif

конфигурация iBGP

В этой конфигурации оба маршрутизатора находятся в AS 400.

R1-AGS R6-2500
Current configuration:

!-- Output suppressed.

interface Serial1
 ip address 10.10.10.1 255.255.255.0
!
router bgp 400

!--- Enables BGP for the autonomous
!--- system 400.

 neighbor 10.10.10.2 remote-as 400
 
!--- Specifies a neighbor 10.10.10.2
 !--- in the remote AS 400, making
 !--- this an iBGP connection.  
!-- Output suppressed.

end
Current configuration:

!-- Output suppressed.

interface Serial0
ip address 10.10.10.2 255.255.255.0
!
router bgp 400
 neighbor 10.10.10.1 remote-as 400

!-- Output suppressed.

end

конфигурация eBGP

В этой конфигурации R1-AGS маршрутизатора находится в AS 300, и маршрутизатор R6-2500 находится в AS 400.

R1-AGS R6-2500
Current configuration:

!-- Output suppressed

interface Serial1
 ip address 10.10.10.1 255.255.255.0
!
router bgp 300

!--- Enables BGP for the autonomous
!--- system 300.

 neighbor 10.10.10.2 remote-as 400
 
!--- Specifies a neighbor 10.10.10.2
 !--- in the remote AS 400, making
 !--- this an eBGP connection.


!-- Output suppressed.

end
Current configuration:

!-- Output suppressed.

interface Serial0
ip address 10.10.10.2 255.255.255.0
!
router bgp 400
 neighbor 10.10.10.1 remote-as 300

!-- Output suppressed.

end

При использовании eBGP узлы должны быть подключены напрямую. Если они непосредственно не связаны, команда neighbor ebgp-multihop должна использоваться и путь через IGP, или статический маршрут для достижения узла должен существовать для маршрутизаторов для установления отношений соседей. В то время как маршрутизатор R6-2500 принадлежит AS 400, в конфигурации выше, маршрутизатор R1-AGS принадлежит AS 300.

конфигурация iBGP с Адресом обратной связи

Можно настроить iBGP с помощью адреса обратной связи (или любой другой в рабочем состоянии интерфейс) как показано в этом разделе.

R1-AGS R6-2500
Current configuration:


!-- Output suppressed.

interface Loopback0
  ip address 1.1.1.1 255.255.255.255
 !
 interface Serial1
  ip address 10.10.10.1 255.255.255.0
 !
 router bgp 300
  neighbor 2.2.2.2 remote-as 300
  neighbor 2.2.2.2 update-source Loopback0
  
!--- This command specifies that the TCP
  !--- connection with the specified external
  !--- peer should be established using the
  !--- address on the loopback interface.

 !
 ip route 2.2.2.2 255.255.255.255 10.10.10.2
 
!--- This static route ensures that the 
 !--- remote peer address used for peering
 !--- is reachable.
!-- Output suppressed.

end
Current configuration:


!-- Output suppressed.

interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial0
 ip address 10.10.10.2 255.255.255.0
!
router bgp 300
 neighbor 1.1.1.1 remote-as 300
 neighbor 1.1.1.1 update-source Loopback0
!
ip route 1.1.1.1 255.255.255.255 10.10.10.1

!-- Output suppressed.

end

конфигурация eBGP с Адресом обратной связи

Можно также настроить eBGP с помощью адреса обратной связи (или любой другой в рабочем состоянии интерфейс) как показано в этом разделе. Интерфейсы обратной связи используются этим способом для гарантии достижимости в сетях с разнообразными путями как показано в Распределении нагрузки Использование Адреса обратной связи как раздел Соседнего BGP узел Распределения нагрузки с BGP в Одиночном и Многосетевых средах: Примеры конфигураций.

R1-AGS R6-2500
Current configuration:


!-- Output suppressed.


interface Loopback0
  ip address 1.1.1.1 255.255.255.255
 !
 interface Serial1
  ip address 10.10.10.1 255.255.255.0
 !
 router bgp 300
  neighbor 2.2.2.2 remote-as 400
  neighbor 2.2.2.2 ebgp-multihop 2
 
 !--- This command changes the ttl value in 
  !--- order to allow the packet to reach the 
  !--- external BGP peer which is not directly
  !--- connected or is using an interface other
  !--- than the directly connected interface.

  neighbor 2.2.2.2 update-source Loopback0
  
!--- This command specifies that the TCP
  !--- connection with the external BGP
  !--- peer should be established using the
  !--- address on the loopback interface.
 !

 ip route 2.2.2.2 255.255.255.255 10.10.10.2

 !--- This static route ensures that the 
 !--- remote peer address used for peering
 !--- is reachable.


!-- Output suppressed.


end
Current configuration:


!-- Output suppressed.


interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial0
 ip address 10.10.10.2 255.255.255.0
!
router bgp 400
 neighbor 1.1.1.1 remote-as 300
 neighbor 1.1.1.1 ebgp-multihop 2
 neighbor 1.1.1.1 update-source Loopback0
!
ip route 1.1.1.1 255.255.255.255 10.10.10.1


!-- Output suppressed.


end

Проверка

Сведения, содержащиеся в этих разделах, позволяют удостовериться, что конфигурация функционирует нормально. Некоторые команды show поддерживаются Интерпретатором выходных данных; это позволяет выполнять анализ выходных данных команды show.

Проверьте конфигурацию iBGP

Используйте команду show ip bgp neighbors, чтобы отобразить информацию о TCP и соединениях Протокола BGP и проверить, установлено ли Одноранговое соединение по протоколу BGP. Выходные данные команды show ip bgp neighbors ниже показов состояние BGP как 'Установленное', который указывает, что отношение Однорангового соединения по протоколу BGP было установлено успешно.

R1-AGS# show ip bgp neighbors | include BGP
BGP neighbor is 10.10.10.2,  remote AS 400, internal link
  BGP version 4, remote router ID 2.2.2.2
  BGP state = Established, up for 00:04:20
  BGP table version 1, neighbor version 1
R1-AGS#

Команда show ip bgp neighbors использовалась выше с модификатором |, включают BGP. Это делает выходные данные более читаемыми путем фильтрации выходных данных команды и отображения соответствующих частей только.

Кроме того, команда show ip bgp summary может также использоваться для отображения статуса всех соединений BGP, как показано ниже.

R1-AGS(9)# show ip bgp summary
BGP router identifier 10.1.1.2, local AS number 400	
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.10.10.2      4   400       3       3        1    0    0 00:00:26        0

Проверьте конфигурацию eBGP

Используйте команду show ip bgp neighbors, чтобы отобразить информацию о TCP и соединениях Протокола BGP и проверить, установлено ли Одноранговое соединение по протоколу BGP. Выходные данные команды show ip bgp neighbors ниже показов состояние BGP как 'Установленное', который указывает, что отношение Однорангового соединения по протоколу BGP было установлено успешно.

R1-AGS# show ip bgp neighbors | include BGP
BGP neighbor is 10.10.10.2,  remote AS 400, external link
  BGP version 4, remote router ID 2.2.2.2
  BGP state = Established, up for 00:00:17
  BGP table version 1, neighbor version 1

Кроме того, команда show ip bgp summary может также использоваться для отображения статуса всех соединений BGP, как показано ниже.

R1-AGS(9)# show ip bgp summary
BGP router identifier 10.10.10.1, local AS number 300
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.10.10.2      4   400       3       3        1    0    0 00:00:26        0

Проверьте конфигурацию iBGP с Адресом обратной связи

Используйте команду show ip bgp neighbors, чтобы отобразить информацию о TCP и соединениях Протокола BGP и проверить, установлено ли Одноранговое соединение по протоколу BGP. Выходные данные команды show ip bgp neighbors ниже показов состояние BGP как 'Установленное', который указывает, что отношение Однорангового соединения по протоколу BGP было установлено успешно.

R1-AGS# show ip bgp neighbors | include BGP
BGP neighbor is 2.2.2.2,  remote AS 300, internal link
  BGP version 4, remote router ID 2.2.2.2
  BGP state = Established, up for 00:00:28
  BGP table version 1, neighbor version 1
R1-AGS#

Кроме того, команда show ip bgp summary может также использоваться для отображения статуса всех соединений BGP, как показано ниже.

R1-AGS(9)# show ip bgp summary
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4   400       3       3        1    0    0 00:00:26        0

Проверьте конфигурацию eBGP с Адресом обратной связи

Используйте команду show ip bgp neighbors, чтобы отобразить информацию о TCP и соединениях Протокола BGP и проверить, установлено ли Одноранговое соединение по протоколу BGP. Выходные данные команды show ip bgp neighbors ниже показов состояние BGP как 'Установленное', который указывает, что отношение Однорангового соединения по протоколу BGP было установлено успешно.

R1-AGS# show ip bgp neighbors | include BGP
BGP neighbor is 2.2.2.2,  remote AS 400, external link
  BGP version 4, remote router ID 2.2.2.2
  BGP state = Established, up for 00:00:16
  BGP table version 1, neighbor version 1
  External BGP neighbor may be up to 2 hops away.

Кроме того, команда show ip bgp summary может также использоваться для отображения статуса всех соединений BGP, как показано ниже.

R1-AGS(9)# show ip bgp summary
BGP router identifier 1.1.1.1, local AS number 300
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4   400       3       3        1    0    0 00:00:26        0

Устранение неполадок

См. то, Почему Соседние BGP узел Переключаются Между Простаивающим, Подключением и Активными состояниями? и Устранение проблем BGP для сведений об устранении проблем.


Дополнительные сведения


Document ID: 13751