Многопротокольная коммутация по меткам (MPLS) : MPLS

Выбор основной конфигурации MPLS с использованием протокола OSPF

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ иллюстрирует настройку основной сети многопротокольной коммутации по меткам (MPLS). Обратитесь к Примерам конфигурации и техническим примечаниям на Странице технической поддержки MPLS для получения дополнительной информации о том, как настроить сложные вопросы, такие как VPN или Регулирование трафика (TE).

Предварительные условия

Требования

Cisco рекомендует быть знакомыми с главной операцией MPLS. Сошлитесь на Обзор Многопротокольной коммутации по меткам для обзора MPLS.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Cisco выпуски ПО IOS� 12.2 (28)

  • Маршрутизаторы Cisco 3600

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Механизм

Обычно сети MPLS являются базовыми сетями, состоящими из маршрутизаторов с включенным MPLS, которые называются маршрутизаторами с коммутацией меток (LSR). Обычно сеть состоит из базового LSR с граничным LSR, который применяет метки к пакетам.

Это - механизм настройки сети MPLS:

  1. Таблицы маршрутизации других LSR вычислены с Протоколом IGP. Если вы планируете развернуть MPLS TE, требуется протокол состояния соединений, такой как Протокол OSPF или Обмен информацией между промежуточными системами (IS-IS).

  2. Протокол распределения меток (label distribution protocol, LDP) используется для связывания маршрутов и меток. Эти привязки проверяются по таблицам маршрутизации. Если маршрут (префикс/маска и следующий переход) изученный из LDP совпадает с маршрутом, изученным из IGP в таблице маршрутизации, запись создана в метке что вперед информационные ядра (LFIB) на LSR.

LSR использует этот механизм переадресации:

  1. Как только граничный LSR получает непомеченный пакет, таблица скоростной маршрутизации Cisco проверена, и метка наложена на пакет в случае необходимости. Этот LSR вызывает восходящие LSR.

  2. По прибытию маркированного пакета во входном интерфейсе базового LSR LFIB предоставляет исходящий интерфейс и новую метку, которая привязана к исходящему пакету.

  3. Маршрутизатор перед последним маршрутизатором коммутации метки (LSR) (предпоследний переход) отбрасывает метку и передает пакет без нее. Последний переход называется «выход на поверхность LSR».

Эта схема иллюстрирует эту сетевую установку:

/image/gif/paws/13736/1b.gif

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: В заказе fo находят дополнительные сведения о командах используемыми в этом документе, используют Средство поиска команд Command Lookup Tool (только зарегистрированные клиенты).

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/13736/1a.gif

Краткое Руководство по конфигурации

Используйте эту процедуру в качестве руководства по быстрой настройке.

  1. Настройка обычного режима работы сети (для определения базовых адресов пересылки по спецификации MPLS требуется наличие стандартного IP-соединения).

  2. Гарантируйте, что протокол маршрутизации (OSPF или IS-IS) работает правильно. Эти команды выделены курсивом в конфигурациях в следующем разделе.

  3. Включите ip cef, поскольку лучшая производительность использует ip cef, распределенный, когда доступный в режиме обычной конфигурации. Это показывают полужирным в конфигурациях в следующем разделе.

  4. Включите ip mpls или ip коммутации на основе тэгов на более старых Cisco IOS Software Release, в режиме обычной конфигурации и в каждом интерфейсе, как показано полужирным в конфигурациях в следующем разделе. Даже когда команда mpls ip используется, выходные данные show running могут все еще показать команду как ip коммутации на основе тэгов в некоторых Cisco IOS Software Release, как показано в конфигурациях в следующем разделе.

    Примечание: LSR должны иметь Интерфейсы обратной связи с маской адреса 32 битов, и эти интерфейсы должны быть достижимыми с таблицей маршрутизации глобального IP - адреса.

Конфигурации

Эти конфигурации используются в данном документе:

Pomerol

!
version 12.2

!
hostname Pomerol
!
ip subnet-zero
!
ip cef
!
interface Loopback0
 ip address 10.10.10.3 255.255.255.255
!
interface Serial2/0
 ip address 10.1.1.21 255.255.255.252
 tag-switching ip
!
interface Serial3/0
 ip address 10.1.1.6 255.255.255.252
 tag-switching ip
!
interface Serial4/0
 ip address 10.1.1.9 255.255.255.252
 tag-switching ip
!
router ospf 10
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 9
! 
ip classless
!
end

Pulligny

!
version 12.2
!
hostname Pulligny
!
!
ip subnet-zero
!
ip cef
!
interface Loopback0
 ip address 10.10.10.2 255.255.255.255
!
interface Serial2/0
 ip address 10.1.1.2 255.255.255.252
 tag-switching ip
!
interface Serial3/0
 ip address 10.1.1.10 255.255.255.252
 tag-switching ip
!
router ospf 10
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 9
!
ip classless
!
end

Pauillac
!
version 12.2
!
hostname Pauillac
!
ip subnet-zero
!
ip cef
!
interface Loopback0
 ip address 10.10.10.1 255.255.255.255
!
interface Serial2/0
 ip address 10.1.1.13 255.255.255.252
 tag-switching ip
!
interface Serial3/0
 ip address 10.1.1.17 255.255.255.252
 tag-switching ip
!
interface Serial4/0
 ip address 10.1.1.1 255.255.255.252
 tag-switching ip
!
interface Serial5/0
 ip address 10.1.1.5 255.255.255.252
 tag-switching ip
!
router ospf 10
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 9
!
ip classless
!
end

PEscara
!
version 12.2
!
hostname Pescara
!
ip subnet-zero
!
ip cef
!
interface Loopback0
 ip address 10.10.10.4 255.255.255.255
!
interface Serial2/0
 ip address 10.1.1.14 255.255.255.252
 tag-switching ip
!
router ospf 10
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 9
!
ip classless
!
end

Pesaro
!
version 12.2
!
hostname Pesaro
!
ip subnet-zero
!
ip cef
!
interface Loopback0
 ip address 10.10.10.6 255.255.255.255
!
interface Serial2/0
 ip address 10.1.1.22 255.255.255.252
 tag-switching ip
!
router ospf 10
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 9
!
ip classless
!
end

Перуджа
!
version 12.2
!
hostname Perugia
!
ip subnet-zero
!
ip cef
!
interface Loopback0
 ip address 10.10.10.5 255.255.255.255
!
interface Serial2/0
 ip address 10.1.1.18 255.255.255.252
 tag-switching ip
!
router ospf 10
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 9
!
ip classless
!
end

Проверка.

В данном разделе содержатся сведения о проверке работы конфигурации.

Команды, используемые в Настройке Основной MPLS Использование Примера конфигурации IS-IS, также применимы.

Для иллюстрирования этого примера конфигурации посмотрите на индивидуальный пункт назначения, например 10.10.10.4, на LSR Pomerol.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • show ip route для проверки IP route для этого назначения в таблице IP-маршрутизации:

    Pomerol#show ip route 10.10.10.4
    Routing entry for 10.10.10.4/32
      Known via "ospf 10", distance 110, metric 129, type intra area
      Last update from 10.1.1.5 on Serial3/0, 17:29:23 ago
      Routing Descriptor Blocks:
      * 10.1.1.5, from 10.10.10.4, 17:29:23 ago, via Serial3/0
          Route metric is 129, traffic share count is 1
    
  • show mpls forwarding-table — Используемый для проверки таблицы пересылки MPLS, которая является эквивалентом коммутации по меткам таблицы IP-маршрутизации для стандартного IP routing. Это содержит входящие и исходящие метки и описания пакетов.

    Pomerol#show mpls forwarding-table 
    Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
    tag    tag or VC   or Tunnel Id      switched   interface
    16     Pop tag     10.1.1.12/30      636        Se3/0      point2point
    17     Pop tag     10.10.10.1/32     0          Se3/0      point2point
    18     21          10.10.10.4/32     0          Se3/0      point2point
    19     Pop tag     10.1.1.0/30       0          Se4/0      point2point
           Pop tag     10.1.1.0/30       0          Se3/0      point2point
    20     Pop tag     10.10.10.6/32     612        Se2/0      point2point
    21     Pop tag     10.1.1.16/30      0          Se3/0      point2point
    22     16          10.10.10.5/32     0          Se3/0      point2point
    23     Pop tag     10.10.10.2/32     0          Se4/0      point2point
  • подробность show mpls forwarding-table — Используемый для наблюдения Данных таблицы пересылки MPLS:

    Pomerol#show mpls forwarding-table 10.10.10.4 32 detail
    Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
    tag    tag or VC   or Tunnel Id      switched   interface
    18     21          10.10.10.4/32     0          Se3/0      point2point
            MAC/Encaps=4/8, MRU=1500, Tag Stack{21}
            0F008847 00015000
            No output feature configured
        Per-packet load-sharing
  • show mpls ldp bindings или показывает связывания обработки телеметрических данных коммутации на основе тэгов (на основе которого Cisco IOS Software Release вы используете) — Используемый для наблюдения связываний метки, привязанных к индивидуальному пункту назначения. Оба локальная переменная, а также удаленные связывания могут быть замечены.

    Pomerol#show tag-switching tdp bindings 10.10.10.4 32
      tib entry: 10.10.10.4/32, rev 14
            local binding:  tag: 18
            remote binding: tsr: 10.10.10.1:0, tag: 21
            remote binding: tsr: 10.10.10.2:0, tag: 23
            remote binding: tsr: 10.10.10.6:612, tag: 20 
    
    

    Обратите внимание на то, что метки для каждого класса переадресации установлены в каждом LSR, даже если они не находятся на предпочтительном (самом коротком) пути. В этом случае пакет, предназначенный к 10.10.10.4/32, может пойти 10.10.10.1 (с меткой 21) или 10.10.10.2 (с меткой 23). LSR выбирает первое решение, потому что оно самое короткое. Это решение принято со стандартной таблицей IP-маршрутизации, которая в этом случае, создан с OSPF.

  • подробность show ip cef — Используемый, чтобы проверить, что скоростная маршрутизация Cisco работает должным образом и что метки подкачаны правильно:

    Pomerol#show ip cef 10.10.10.4 detail
    10.10.10.4/32, version 37, cached adjacency to Serial3/0
    0 packets, 0 bytes
      tag information set
        local tag: 18
        fast tag rewrite with Se3/0, point2point, tags imposed: {21}
      via 10.1.1.5, Serial3/0, 0 dependencies
        next hop 10.1.1.5, Serial3/0
        valid cached adjacency
        tag rewrite with Se3/0, point2point, tags imposed: {21}
    

Устранение неполадок

Обратитесь к Устранению проблем MPLS для получения информации о том, как устранить неполадки MPLS.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 13736