Многопротокольная коммутация по меткам (MPLS) : MPLS

Настройка основной MPLS с использованием протокола IS-IS

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Здесь показан пример конфигурации для установки сети многопротокольной коммутации по меткам (MPLS) для решения дальнейших задач, таких как виртуальная частная сеть (VPN) или регулирование трафика (подробности см. в примерах конфигурации на странице технической поддержки MPLS).

Предварительные условия

Требования

Прежде чем использовать эту конфигурацию, убедитесь, что выполняются следующие условия:

  • Для осуществления MPLS вы требуете Маршрутизатора Cisco 2600 или позже.

  • Выберите требуемую Cisco IOS с MPLS с помощью Software Advisor (только зарегистрированные клиенты).

  • Проверьте для дополнительного ОЗУ и флэш-памяти, требуемой выполнять MPLS в маршрутизаторах. Интерфейсные карты WAN (WIC), WIC-1T и WIC-2T, могут использоваться.

Используемые компоненты

Сведения, содержащиеся в данном документе, относятся к следующим версиям программного и аппаратного обеспечения.

  • Cisco 3640, Cisco 3660, Cisco 4500 и маршрутизаторы Cisco 2610

  • Cisco Выпуск ПО IOS� 12.2 (6-й) работает на всех маршрутизаторах

Сведения, представленные в этом документе, были получены от устройств в специфической лабораторной среде. Все устройства, используемые в этом документе, были запущены с чистой конфигурацией (конфигурацией по умолчанию). При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Теоретические сведения

Обычно сети MPLS являются базовыми сетями, состоящими из маршрутизаторов с включенным MPLS, которые называются маршрутизаторами с коммутацией меток (LSR). В основном, сеть состоит из ядерных LSR и фронтальный LSR, ответственных за метки пакетов.

Механизм установки сети MPLS следующий.

  • Таблицы маршрутизации различных LSR рассчитываются с использованием протокола внутреннего шлюза (IGP). При развертывании систем для трафика MPLS необходим протокол маршрутизации с учетом состояния связи, например OSPF (протокол открытого поиска кратчайшего пути) или IS-IS (протокол взаимодействия промежуточных систем).

  • Протокол распределения меток (label distribution protocol, LDP) используется для связывания маршрутов и меток. Эти привязки проверяются по таблицам маршрутизации. Если маршрут (префикс/маска и следующий узел), полученный по протоколу LDP, совпадает с маршрутом по протоколу IGP из таблицы маршрутизации, запись создается в базе данных для переадресации по меткам (LFIB) на коммутаторе-маршрутизаторе MPLS.

LSR использует следующий механизм переадресации.

  • После того, как маршрутизатор с коммутацией по маркерам (LSR) получает непомеченный пакет, проверяется таблица быстрой коммутации Cisco и при необходимости пакету присваивается маркер. Этот LSR вызывает восходящие LSR.

  • По прибытии помеченного пакета на входящий интерфейс центрального LSR LFIB указывает исходящий интерфейс и метку, связанную с исходящим пакетом.

  • Маршрутизатор перед последним маршрутизатором коммутации метки (LSR) (предпоследний переход) отбрасывает метку и передает пакет без нее. Последний переход называется «выход на поверхность LSR».

На следующей диаграмме изображена схема сети.

/image/gif/paws/13735/1b.gif

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/13735/1a.gif

Конфигурации

Эти конфигурации используются в данном документе:

Краткое Руководство по конфигурации

Выполните эти шаги для настройки MPLS:

  1. Настройка обычного режима работы сети (для определения базовых адресов пересылки по спецификации MPLS требуется наличие стандартного IP-соединения).

  2. Убедитесь, что протокол маршрутизации (OSPF или IS-IS) работает правильно. Эти команды показывают курсивом в конфигурациях в этом разделе.

  3. Включите скоростную передачу, используя команду ip cef (или более быстродействующую команду ip cef distributed, если она доступна) в общем режиме настройки конфигурации (эта команда в примерах данного раздела выделяется полужирным шрифтом).

  4. Используйте команду mpls ip (или команду tag-switching ip на более старых Cisco IOS Software Release) в режиме обычной конфигурации и в каждом интерфейсе (показанный полужирным в конфигурациях в этом разделе) для включения.

    Примечание: LSR должны иметь интерфейсы обратной связи с маской адреса 32 бита.

Pomerol
Current configuration:
!
version 12.2
!
hostname Pomerol
!
ip cef

!--- Enables Cisco Express Forwarding globally.

!
interface Loopback0
 ip address 10.10.10.3 255.255.255.255
 ip router isis 

!--- Assigns an IP address to interface loopback0 
!--- and enables IS-IS for IP on the interface.

!
interface Serial0/0
 encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
 ip address 10.1.1.6 255.255.255.252
 ip router isis   
 tag-switching ip

!--- Enables dynamic Label Switching of 
!--- IPv4 packets on an interface.

 frame-relay interface-dlci 301   
!
interface Serial0/0.2 point-to-point
 ip address 10.1.1.9 255.255.255.252
 ip router isis  
 tag-switching ip
 frame-relay interface-dlci 303   
!
interface Serial0/0.3 point-to-point
 ip address 10.1.1.21 255.255.255.252
 ip router isis 
 tag-switching ip
 frame-relay interface-dlci 306   
!
router isis  
 net 49.0001.0000.0000.0003.00
 is-type level-1
!
ip classless
!
end

Pulligny
Current configuration:
!
version 12.1
!
hostname Pulligny
!
ip cef
!
interface Loopback0
 ip address 10.10.10.2 255.255.255.255
!
interface Serial0/1
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
 ip address 10.1.1.2 255.255.255.252
 ip router isis 
 tag-switching ip
 frame-relay interface-dlci 201   
!
interface Serial0/0.2 point-to-point
 ip address 10.1.1.10 255.255.255.252
 ip router isis 
tag-switching ip
 frame-relay interface-dlci 203   
!
router isis
 redistribute static ip
 passive-interface Loopback0
 net 49.0001.0000.0000.0002.00
 is-type level-1

!--- Enables the IS-IS process on the router,
!--- makes loopback interface passive 
!--- (does not send IS-IS packets on interface), 
!--- and assigns area and system ID to router.

!
ip classless
!
end

Pauillac
Current configuration : 2366 bytes
!
version 12.1
!
hostname pauillac
!
ip cef
!
interface Loopback0
 ip address 10.10.10.1 255.255.255.255
 ip router isis
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
 ip address 10.1.1.1 255.255.255.252
 ip router isis
 tag-switching ip
 frame-relay interface-dlci 102   
!
interface Serial0/0.2 point-to-point
 ip address 10.1.1.5 255.255.255.252
 ip access-group 150 out
 ip router isis 
 tag-switching ip
 frame-relay interface-dlci 103   
!
interface Serial0/0.3 point-to-point
 bandwidth 512
 ip address 10.1.1.13 255.255.255.252
 ip router isis 
 tag-switching ip
 frame-relay interface-dlci 104   
!
interface Serial0/0.4 point-to-point
 ip address 10.1.1.17 255.255.255.252
 ip router isis 
 tag-switching ip
 frame-relay interface-dlci 105
!
!
router isis
 net 49.0001.0000.0000.0001.00
 is-type level-1
!
ip classless
!
end

Проверка.

В данном разделе содержатся сведения о проверке работы конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • show tag-switching tdp neighbor

  • show tag-switching tdp bindings

  • show tag-switching forwarding-table

  • show tag-switching forwarding-table a.b.c.d detail

  • traceroute a.b.c.d

Полный список команд включен в Справочник по командам MPLS. Другие примеры команды show описаны в Настройке Основной MPLS Использование OSPF.

Образец выходных данных

Эти выходные данные фокусируются на LDP. LDP, в настоящее время внедренный в IOS, является TDP (Протокол распределения Метки), который содержит некоторые запатентованные Cisco расширения, но это использоваться с LDP, официальным протоколом IETF для распределения меток. TDP будет заменен LDP в будущем.

Можно использовать команду show tag-switching tdp * для подтверждения состояния TDP. Вы видите соседние узлы с командой show tag-switching tdp neighbor.

Pulligny# show tag-switching tdp discovery
Local TDP Identifier:    
	10.10.10.2:0
TDP Discovery Sources:    
  Interfaces:
 Serial0/0.1: xmit/recv            
   TDP Id: 10.10.10.1:0
 Serial0/0.2: xmit/recv
   TDP Id: 10.10.10.3:0

!--- Ensure you are able to ping this IP address
!--- If not, check whether a route exists in the routing table

Pulligny# show tag-switching tdp neighbor 
Peer TDP Ident: 10.10.10.1:0; Local TDP Ident 10.10.10.2:0
        TCP connection: 10.10.10.1.711 - 10.10.10.2.11001
        State: Oper; PIEs sent/rcvd: 27907/27925; ; Downstream
        Up time: 2w2d
        TDP discovery sources:
          Serial0/0.1
        Addresses bound to peer TDP Ident:
          10.1.1.1        10.1.1.13       10.1.1.17       10.10.10.1      
          10.1.1.5        10.200.28.89    
Peer TDP Ident: 10.10.10.3:0; Local TDP Ident 10.10.10.2:0
        TCP connection: 10.10.10.3.11001 - 10.10.10.2.711
        State: Oper; PIEs sent/rcvd: 22893/22874; ; Downstream
        Up time: 1w6d
        TDP discovery sources:
          Serial0/0.2
        Addresses bound to peer TDP Ident:
          10.200.28.91    10.1.1.6        10.1.1.9        10.1.1.21       
          10.10.10.3

Можно использовать команду show tag-switching tdp bindings для просмотра установленных связываний между метками и маршрутами.

Pulligny# show tag-switching tdp bindings 
(...)
  tib entry: 10.10.10.4/32, rev 22
        local binding:  tag: 21
        remote binding: tsr: 10.10.10.1:0, tag: 22
        remote binding: tsr: 10.10.10.3:0, tag: 25
  tib entry: 10.10.10.6/32, rev 51
        local binding:  tag: 23
        remote binding: tsr: 10.10.10.3:0, tag: 18
        remote binding: tsr: 10.10.10.1:0, tag: 20
(...)

Можно использовать команду show tag-switching forwarding-table для наблюдения, какие связывания используются для построения LFIB.

Pulligny# show tag-switching forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface 
16     Pop tag     10.1.1.4/30       0          Se0/0.2    point2point       
       Pop tag     10.1.1.4/30       0          Se0/0.1    point2point
17     Pop tag     10.1.1.20/30      0          Se0/0.2    point2point
18     Pop tag     10.10.10.3/32     0          Se0/0.2    point2point
19     Pop tag     10.10.10.1/32     0          Se0/0.1    point2point
20     Pop tag     10.1.1.12/30      0          Se0/0.1    point2point
21     Pop tag     10.1.1.16/30      0          Se0/0.1    point2point
22     20          10.10.10.5/32     0          Se0/0.1    point2point
23     22          10.10.10.6/32     0          Se0/0.2    point2point
24     22          10.10.10.4/32     0          Se0/0.1    point2point

Можно использовать команду show tag-switching forwarding-table 10.10.10.4 detail, чтобы посмотреть детали заданного получателя.

Pulligny# show tag-switching forwarding-table 10.10.10.4 detail 
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
21     22          10.10.10.4/32     12103      Se0/0.1    point2point  
        MAC/Encaps=4/8, MTU=1500, Tag Stack{22}
        30918847 00016000
    Per-packet load-sharing

Если сеть делает распространение IP TTL, для просмотра переходов, можно также использовать команду traceroute. Обратитесь к Многопротокольной коммутации по меткам на маршрутизаторах Cisco для получения дополнительной информации о команде mpls ip ttl propagate.

Pesaro# traceroute 10.10.10.4

Type escape sequence to abort.
Tracing the route to 10.10.10.4

  1 10.1.1.21 [MPLS: Label 25 Exp 0] 296 msec 256 msec 244 msec
  2 10.1.1.5 [MPLS: Label 22 Exp 0] 212 msec 392 msec 352 msec
  3 10.1.1.14 436 msec *  268 msec

Примечание: В результате появляется Exp 0, если экспериментальное поле было использовано для качества обслуживания (QoS).

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 13735