Многопротокольная коммутация по меткам (MPLS) : MPLS

Настройка основной VPN MPLS с RIP на стороне клиента

28 июля 2013 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (16 ноября 2007) | Отзыв


Содержание


Введение

Этот пример конфигурации иллюстрирует виртуальную частную сеть (VPN) многопротокольной коммутации по меткам (MPLS) для случая, когда протокол маршрутной информации (RIP) присутствует на стороне клиента.

Функция VPN, когда использующийся с MPLS, позволяет нескольким сайтам прозрачно соединять через сеть поставщика услуг. Одна сеть поставщика услуг может поддерживать несколько различных IP сетей VPN. Каждый VPN IP появляется как частная сеть, отдельная от всех других сетей. Каждый узел в VPN посылает IP-пакеты другим узлам в таком же VPN.

Каждая сеть VPN связана с одним или более коммутируемым или пересылаемым экземпляром (VRF). VRF состоит из таблицы IP-маршрутизации, полученной Таблицы Cisco Expressorwarding (CEF), и ряда интерфейсов, которые используют таблицу пересылки.

Маршрутизатор поддерживает отдельную маршрутизацию и таблицу CEF для каждого VRF. Это предотвращает отправление информации вне VPN и позволяет такой-же подсети использоваться в нескольких VPN, без проблем с дублированием IP-адресов.

Маршрутизатор, использующий протокол BGP (пограничный шлюзовый протокол), распространяет данные VPN-маршрутизации через расширенные сообщества BGP.

Для получения дополнительной информации относительно распространения обновлений через VPN см. Целевые группы для маршрута VPN, Распространение данных маршрутизации в VPN по протоколу BGP, и Передающие разделы MPLS в виртуальных частных сетях MPLS.

Предварительные условия

Требования

Для данного документа отсутствуют предварительные условия.

Используемые компоненты

Мы разработали и протестировали эту конфигурацию используя версии программного и аппаратного обеспечения ниже:

  • Граничные маршрутизаторы провайдеров: Функциональность MPLS VPN находится в Периферийных маршрутизаторах. Используйте ILS Навигатора Функции (только зарегистрированные клиенты) для определения, какие комбинации программного и аппаратного обеспечения можно использовать.

  • Граничные маршрутизаторы клиентов: Используйте любой маршрутизатор, который в состоянии обмениваться сведениями о маршрутизации с его Периферийным маршрутизатором.

  • P-маршрутизаторы и коммутаторы. В этом документе использовались коммутаторы ATM, такие как MSR, BPX и MGX. Однако, потому что документ фокусируется на функции MPLS VPN, мы, возможно, также использовали основанный MPLS кадра в ядре с маршрутизаторами, такими как Cisco 12000.

Сведения, представленные в этом документе, получены для устройств в особой лабораторной среде. Все устройства, описанные в данном документе, были запущены с конфигурацией по умолчанию. При работе в действующей сети необходимо понимать возможные последствия выполнения любой команды.

Описание сети

Мы устанавливаем стандартную магистраль ATM MPLS используя открытую зону 0 Первого Самого Короткого Пути (OSPF) как протокол Interior Gateway Protocols (IGP). Мы настроили два других VPN используя эта магистраль. Первый VPN использует RIP как свою абонентскую границу к границе поставщика (CE-PE) протокол маршрутизации; другой VPN использует BGP как свой протокол маршрутизации PE-CE. Мы настроили различный loopback и статические маршруты на Маршрутизаторах CE для моделирования присутствия других маршрутизаторов и сетей.

Примечание. BGP должен использоваться как IGP VPN между Периферийными маршрутизаторами, так как используя расширенные сообщества (группа узлов) BGP являются единственным способом транспортировать сведения о маршрутизации для VPN между Периферийными маршрутизаторами.

Примечание. Сеть ATM использовалась как магистральная сеть для создания этой конфигурации. Эта конфигурация применена к ATM (и другой) протокол (ы). Периферийные маршрутизаторы должны быть в состоянии достигнуть друг друга, используют сеть MPLS для конфигурации VPN для работы.

Условные обозначения

Приведенные ниже буквы соответствуют различным типам используемых маршрутизаторов и коммутаторов.

  • P - Основной маршрутизатор провайдера.

  • PE - маршрутизатор на стороне поставщика.

  • CE – Граничный маршрутизатор клиента.

  • C – маршрутизатор клиента.

Типичную конфигурацию, иллюстрирующую эти условные обозначения, показывают в приведенном ниже рисунке:

/image/gif/paws/13732/mpls_vpn_rip_mplsvpn.gif

Дополнительные сведения об условных обозначениях в документах см. в Условные обозначения технических терминов Cisco.

Процедура конфигурации

В этом разделе содержатся сведения о настройке функций, описанных в данном документе. Документация по Cisco IOS, найденная в виртуальных частных сетях MPLS также, описывает эту процедуру настройки.

Примечание. Для просмотра дополнительных сведений о командах, применяемых в этом документе, ,используйте Средство поиска команд IOS Command Lookup Tool (только зарегистрированные клиенты).

Схема сети

В данном документе используется сетевая установка, показанная на следующей схеме.

/image/gif/paws/13732/mpls_vpn_rip_mv_rip.gif

Часть I

Шаги ниже помогут вам настраивать правильно.

Включите команду ip cef. Если используя Маршрутизатор Cisco 7500, гарантируйте, что распределенная команда ip cef выполнена, где доступный, для улучшения производительности на PE, как только установлен MPLS.

  1. Создайте VRF для каждого VPN используя ip vrf [Маршрутизация VPN | название экземпляра VRF] команда. При создании VRF, быть уверенным:

    • Задайте, что корректный признак маршрута, используемый для того VPN, использует команду ниже. distinguisher используется для расширения IP-адреса и позволяет вам определять, которому VPN это принадлежит.

      rd [VPN route distinguisher]
      
    • Установите импорт и экспортируйте свойства для расширенных сообществ (группа узлов) BGP используя команда ниже. Эти свойства используются для того, чтобы фильтровать импорт и экспортируют процесс.

      route-target {export | import | both} [target VPN extended community] 
      
  2. Настройте сведения о переадресации для соответствующих интерфейсов, используют ip vrf forwarding [имя таблицы] команда и не забывают устанавливать IP-адрес впоследствии.

  3. В зависимости от используемого протокола маршрутизации PE-CE сделайте один или больше придерживающегося:

    • Определите статические маршруты следующим образом:

      ip route vrf vrf-name prefix mask [next-hop-address] [interface {interface-number}] 
      
    • Настройте RIP используя следующая команда:

      address-family ipv4 vrf [VPN routing | forwarding instance name] 
      

      Как только вы завершили один или оба из шагов выше, введите обычные команды Конфигурации RIP.

      Примечание. Эти команды применяются только к интерфейсам переадресации текущего VRF. Перераспределите корректный BGP в RIP и не забудьте задавать используемую метрику.

    • Задайте сведения о соседях BGP.

    • Настройте конфигурацию OSPF с помощью новой команды IOS:

      router ospf process-id vrf [VPN routing | forwarding instance name] 
      

    Примечание. Эти команды применимы только к интерфейсам переадресации настоящего VRF. Перераспределите корректные сведения о маршрутизации BGP в OSPF и задайте используемую метрику. Как только процесс OSPF к VRF завершен, даже если процесс OSPF не задан в командной строке, этот ID процесса всегда используется для этого определенного VRF.

Часть II

Настройка BGP между PE маршрутизаторами. Существует несколько способов настроить протокол BGP, например с помощью отражателя маршрутов или методов конфедерации. Метод, показанный здесь, является непосредственной конфигурацией соседнего устройства. Это является самым простым и наименее масштабируемым.

  1. Объявите различных соседей.

  2. Введите vrf ipv4 address-family [Маршрутизация VPN | название экземпляра VRF] команда для каждого VPN, существующего в этом Периферийном маршрутизаторе. При необходимости выполните одно или несколько следующих действий:

    • Перераспределите данные статической маршрутизации.

    • Перераспределите Сведения о маршрутизации RIP.

    • Перераспределение данных OSPF-маршрутизации.

    • Включите соседство BGP с CE-маршрутизаторами.

  3. Введите режим для семейство адресов vpnv4 и:

    • Активируйте соседей.

    • Укажите необходимость использования расширенного сообщества. Данное действие является обязательным.

Примеры конфигураций

В Конфигурации Alcalzaba линии, определенные для конфигурации VPN, показывают полужирным.

Alcazaba
!
ip vrf vrf101
 rd 1:101
 route-target export 1:101
 route-target import 1:101
!
ip cef
!
interface Loopback0
 ip address 223.0.0.3 255.255.255.255
!
interface Ethernet1/1
 ip vrf forwarding vrf101
 ip address 150.150.0.1 255.255.255.0
!
interface ATM3/0
 no ip address
 no ip mroute-cache
 no ATM ilmi-keepalive
 PVC qsaal 0/5 qsaal
 PVC ilmi 0/16 ilmi
 !
!
interface ATM3/0.1 tag-switching
 ip address 10.0.0.17 255.255.255.252
 tag-switching ATM vpi 2-4
 tag-switching ip
!
interface ATM4/0
 no ip address
 no ATM ilmi-keepalive
!
interface ATM4/0.1 tag-switching
 ip address 10.0.0.13 255.255.255.252
 tag-switching ATM vpi 2-4
 tag-switching ip 
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
 network 223.0.0.3 0.0.0.0 area 0
!
router rip
 version 2
 !
 address-family ipv4 vrf vrf101
 version 2
 redistribute bgp 1 metric 0
 network 150.150.0.0
 no auto-summary
 exit-address-family
!
router bgp 1
 no synchronization
 neighbor 125.2.2.2 remote-as 1
 neighbor 125.2.2.2 update-source Loopback0
 neighbor 223.0.0.21 remote-as 1
 neighbor 223.0.0.21 update-source Loopback0
 no auto-summary
 !
 address-family ipv4 vrf vrf101
 redistribute rip
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 125.2.2.2 activate
 neighbor 125.2.2.2 send-community extended
 neighbor 223.0.0.21 activate
 neighbor 223.0.0.21 send-community extended
 no auto-summary
 exit-address-family
!

Kozel
!
ip vrf vrf101
 rd 1:101
 route-target export 1:101
 route-target import 1:101
!
ip cef
!
interface Loopback0
 ip address 223.0.0.21 255.255.255.255
!
interface Ethernet1/1
 ip vrf forwarding vrf101
 ip address 200.200.0.1 255.255.255.0
!
interface ATM4/0
 no ip address
 no ATM scrambling cell-payload
 no ATM ilmi-keepalive
 PVC qsaal 0/5 qsaal     
 PVC ilmi 0/16 ilmi
!
interface ATM4/0.1 tag-switching
 ip address 10.0.0.6 255.255.255.252
 tag-switching ATM vpi 2-4
 tag-switching ip
!
router ospf 1
 log-adjacency-changes
 network 10.0.0.0 0.0.0.255 area 0
 network 223.0.0.21 0.0.0.0 area 0
!
router rip
 version 2
 !
 address-family ipv4 vrf vrf101
 version 2
 redistribute bgp 1 metric 1
 network 200.200.0.0
 no auto-summary
 exit-address-family
!
router bgp 1
 no synchronization
 neighbor 125.2.2.2 remote-as 1
 neighbor 125.2.2.2 update-source Loopback0
 neighbor 223.0.0.3 remote-as 1
 neighbor 223.0.0.3 update-source Loopback0
 no auto-summary
 !
 address-family ipv4 vrf vrf101
 redistribute rip
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 125.2.2.2 activate
 neighbor 125.2.2.2 send-community extended
 neighbor 223.0.0.3 activate
 neighbor 223.0.0.3 send-community extended
 no auto-summary
 exit-address-family
!

Medina
Current configuration:
!
ip vrf vrf101
 rd 1:101
 route-target export 1:101
 route-target import 1:101
ip cef
!
interface Loopback1
 ip vrf forwarding vrf101
 ip address 11.2.2.2 255.255.255.252
!
interface ATM2/0
 no ip address
 no ATM ilmi-keepalive
!
interface ATM2/0.66 tag-switching
 ip address 125.1.4.2 255.255.255.252
 tag-switching ip
!
interface Ethernet1/1
 ip vrf forwarding vrf101
 ip address 11.3.3.1 255.255.255.252
!
router ospf 1
 
 network 125.1.4.0 0.0.0.3 area 0
 network 125.2.2.2 0.0.0.0 area 0
!
router rip
 version 2
 network 11.0.0.0
 !
 address-family ipv4 vrf vrf101
 version 2
 redistribute bgp 1 metric 1
 network 11.0.0.0
 no auto-summary
 exit-address-family
!
router bgp 1
 no synchronization
 neighbor 223.0.0.3 remote-as 1
 neighbor 223.0.0.3 update-source Loopback0
 neighbor 223.0.0.21 remote-as 1
 neighbor 223.0.0.21 update-source Loopback0
 !
 address-family ipv4 vrf vrf101
 redistribute connected
 redistribute static
 redistribute rip
 default-information originate
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 223.0.0.3 activate
 neighbor 223.0.0.3 send-community extended
 neighbor 223.0.0.21 activate
 neighbor 223.0.0.21 send-community extended
 exit-address-family
!

Быстрый
Current configuration:


!
interface Loopback0
 ip address 223.0.0.12 255.255.255.255
!         
interface Loopback2
 ip address 7.7.7.7 255.255.255.0
!
interface FastEthernet0/1
 ip address 150.150.0.2 255.255.255.0
 duplex auto
 speed auto
!
router rip
 version 2
 redistribute static
 network 7.0.0.0
 network 10.0.0.0
 network 150.150.0.0
 no auto-summary
!
ip route 158.0.0.0 255.0.0.0 Null0
!

Damme
!
interface Loopback1
 ip address 6.6.6.6 255.0.0.0
!
interface FastEthernet0/0
 ip address 10.200.10.14 255.255.252.0
 duplex auto
 speed autoa
!
router bgp 158
 no synchronization
 network 6.0.0.0
 network 10.200.0.0 mask 255.255.252.0
 neighbor 10.200.10.3 remote-as 1
 no auto-summary
!

Pivrnec
Current configuration:
!
interface Loopback0
 ip address 223.0.0.22 255.255.255.255
!
interface Loopback1
 ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/1
 ip address 200.200.0.2 255.255.255.0
 duplex auto
 speed auto
!
router rip
 version 2
 redistribute static
 network 6.0.0.0
 network 200.200.0.0
 no auto-summary
!
ip route 69.0.0.0 255.0.0.0 Null0
!

Guilder
!
interface Loopback2
 ip address 150.150.0.1 255.255.0.0
!
interface Ethernet0/2
 ip address 201.201.201.2 255.255.255.252
!
router bgp 69
 no synchronization
 network 7.7.7.0 mask 255.255.0.0
 network 150.150.0.0
 network 201.201.201.0 mask 255.255.255.252
 redistribute connected
 neighbor 201.201.201.1 remote-as 1
 no auto-summary
!

Purkmister
Current configuration:
!
interface Loopback0
 ip address 11.5.5.5 255.255.255.252
!
interface FastEthernet0/1
 ip address 11.3.3.2 255.255.255.252
 duplex auto
 speed auto
!
router rip
 version 2
 network 11.0.0.0
!

команды "debug" и "show"

Перед использованием команд debug ознакомьтесь с документом Важные сведения о командах debug. Команды маршрутизации перечислены здесь:

  • show ip rip database vrf – показывает информацию, содержащуюся в базе данных RIP для отдельного VRF.

  • show ip bgp vpnv4 vrf – отображает адреса VPN из таблицы BGP.

  • команда "show ip route vrf" Отображает таблицу IP-маршрутизации, привязанную к VRF.

  • show ip route; Отображает все статические IP - маршруты, или установленных используя аутентификация, авторизация и учет (AAA) функция загрузок маршрута.

Некоторые команды show поддерживаются Средством интерпретации выходных данных (только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

На Периферийном маршрутизаторе метод маршрутизации PE-CE, такой как RIP, BGP, или статичный, и Обновления BGP PE-PE указывает на таблицу маршрутизации, используемую для определенного VRF. Можно отобразить сведения RIP для определенного VRF, как показано ниже:

Alcazaba# show ip rip database vrf vrf101
 0.0.0.0/0 auto-summary  
 0.0.0.0/0
 [2] via 150.150.0.2, 00:00:12, Ethernet1/1
 6.0.0.0/8 auto-summary
 6.6.6.6/32 redistributed
 [1] via 223.0.0.21,
 7.0.0.0/8 auto-summary
 7.7.7.0/24
 [1] via 150.150.0.2, 00:00:12, Ethernet1/1 
 10.0.0.0/8 auto-summary
 10.0.0.0/8 redistributed
 [1] via 125.2.2.2,
 10.0.0.0/16
 [1] via 150.150.0.2, 00:00:12, Ethernet1/1 
 10.200.8.0/22
 [1] via 150.150.0.2, 00:00:12, Ethernet1/1 
 11.0.0.0/8 auto-summary
 11.0.0.4/30 redistributed
 [1] via 125.2.2.2,
 11.1.1.0/30 redistributed
 [1] via 125.2.2.2,
 11.3.3.0/30 redistributed
 [1] via 125.2.2.2,
 11.5.5.4/30 redistributed
 [1] via 125.2.2.2,
 69.0.0.0/8 auto-summary
 69.0.0.0/8 redistributed
 [1] via 223.0.0.21,
 150.150.0.0/16 auto-summary
 150.150.0.0/24 directly connected, Ethernet1/1
 158.0.0.0/8
 [1] via 150.150.0.2, 00:00:17, Ethernet1/1
 200.200.0.0/24 auto-summary 
 200.200.0.0/24 redistributed 
 [1] via 223.0.0.21,

Можно отобразить информацию BGP для определенного VRF используя команда vrf show ip bgp vpnv4. Результаты передачи данных в зоне ответственности поставщика услуг от внутреннего BGP (iBGP) обозначены мной в выходных данных ниже.

Alcazaba# show ip bgp vpnv4 vrf vrf101 
   BGP table version is 46, local router ID is 223.0.0.3 
   Status codes: s suppressed, d damped, h history, * valid, best, i - internal    
   Origin codes: i - IGP, e - EGP, ? - incomplete  
 Network Next Hop Metric LocPrf Weight Path 
   Route Distinguisher: 1:101 (default for vrf vrf101) 
   *i6.6.6.6/32 223.0.0.21 1 100 0 ? 
   * 7.7.7.0/24 150.150.0.2 1 32768 ? 
   * 10.0.0.0/16 150.150.0.2 1 32768 ? 
   * 10.200.8.0/22 150.150.0.2 1 32768 ? 
   *i11.2.2.0/30 125.2.2.2 0 100 0 ? 
   *i11.3.3.0/30 125.2.2.2 0 100 0 ? 
   *i11.5.5.4/30 125.2.2.2 1 100 0 ? 
   *i69.0.0.0 223.0.0.21 1 100 0 ? 
   * 150.150.0.0/24 0.0.0.0 0 32768 ? 
   * 158.0.0.0/8 150.150.0.2 1 32768 ? 
   *i200.200.0.0 223.0.0.21 0 100 0 ?

Проверьте таблицу глобальной маршрутизации для VRF и на PE и на Маршрутизаторах CE. Эти VRF должны совпасть. Для Периферийного маршрутизатора необходимо задать, что VRF использует команду show ip route vrf:

Alcazaba# show ip route vrf vrf101
   Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP   
   D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
   E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
   i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, IA - ISIS inter area    
   * - candidate default, U - per-user static route, o - ODR
   P - periodic downloaded static route
    Gateway of last resort is not set
   B 69.0.0.0/8 [200/1] via 223.0.0.21, 00:11:03
   B 200.200.0.0/24 [200/0] via 223.0.0.21, 00:11:03
    6.0.0.0/32 is subnetted, 1 subnets
   B 6.6.6.6 [200/1] via 223.0.0.21, 00:11:03 
    7.0.0.0/24 is subnetted, 1 subnets
   R 7.7.7.0 [120/1] via 150.150.0.2, 00:00:05, Ethernet1/1 
    10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
   R 10.0.0.0/16 [120/1] via 150.150.0.2, 00:00:05, Ethernet1/1 
   R 10.200.8.0/22 [120/1] via 150.150.0.2, 00:00:05, Ethernet1/1 
    11.0.0.0/30 is subnetted, 3 subnets
   B 11.3.3.0 [200/0] via 125.2.2.2, 00:07:05
   B 11.2.2.0 [200/0] via 125.2.2.2, 00:07:05
   B 11.5.5.4 [200/1] via 125.2.2.2, 00:07:05
    150.150.0.0/24 is subnetted, 1 subnets
   C 150.150.0.0 is directly connected, Ethernet1/1
   R 158.0.0.0/8 [120/1] via 150.150.0.2, 00:00:06, Ethernet1/1

Аналогичная команда на Pivrnec является командой show ip route, с тех пор для каждого клиента (и порт заказчика Customer Edge) маршрутизатор, это - стандартная таблица маршрутизации.

Pivrnec# show ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP  
  D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
  N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
  E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
  i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, IA - ISIS inter area  
  * - candidate default, U - per-user static route, o - ODR 
  P - periodic downloaded static route Gateway of last resort is not 
  set S 69.0.0.0/8 is directly connected, Null0 
  223.0.0.0/32 is subnetted, 1 subnets 
 C 223.0.0.22 is directly connected, Loopback0 
 C 200.200.0.0/24 is directly connected, FastEthernet0/1 
  6.0.0.0/32 is subnetted, 1 subnets 
 C 6.6.6.6 is directly connected, Loopback1 
  7.0.0.0/24 is subnetted, 1 subnets 
 R 7.7.7.0 [120/1] via 200.200.0.1, 00:00:23, FastEthernet0/1 
  10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks 
 R 10.0.0.0/16 [120/1] via 200.200.0.1, 00:00:23, FastEthernet0/1 
 R 10.200.8.0/22 [120/1] via 200.200.0.1, 00:00:24, FastEthernet0/1 
  11.0.0.0/30 is subnetted, 3 subnets 
 R 11.3.3.0 [120/1] via 200.200.0.1, 00:00:24, FastEthernet0/1 
 R 11.2.2.0 [120/1] via 200.200.0.1, 00:00:25, FastEthernet0/1 
 R 11.5.5.4 [120/1] via 200.200.0.1, 00:00:25, FastEthernet0/1 
  150.150.0.0/24 is subnetted, 1 subnets 
 R 150.150.0.0 [120/1] via 200.200.0.1, 00:00:25, FastEthernet0/1 
 R 158.0.0.0/8 [120/1] via 200.200.0.1, 00:00:25, FastEthernet0/1

Метки MPLS

Проверьте стек меток, используемый для любого маршрута следующим образом:

Alcazaba# show tag-switching forwarding-table vrf vrf101 11.5.5.5 detail    
   Local Outgoing Prefix Bytes tag Outgoing Next Hop
   tag tag or VC or Tunnel Id switched interface
   None 2/91 11.5.5.4/30 0 AT4/0.1 point2point
    MAC/Encaps=4/12, MTU=4466, Tag Stack{2/91(vcd=69) 37} 
    00458847 0004500000025000

Можно использовать обычные команды для того, чтобы просмотреть выделения метки вместе с идентификатором виртуального пути и идентификатором виртуального канала (VPI/VCI) отношения как показано в том, Как Устранить неполадки MPLS VPN.

Совмещенные адреса

Можно использовать тот же адрес в других VPN, не вмешиваясь в другие VPN. Данный пример показывает, что адрес 6.6.6.6 подключен дважды: к Pivrnec в VPN 101 и к Damme в VPN 102. Мы можем проверить, что это использует команду ping на одном сайте и команду debug ip icmp на другом сайте.

Guilder# ping 6.6.6.6
   Type escape sequence to abort.
   Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
   !!!!!
   Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms

Damme# debug ip icmp
   ICMP packet debugging is on
   6d22h: ICMP: echo reply sent, src 6.6.6.6, DST 201.201.201.2
   6d22h: ICMP: echo reply sent, src 6.6.6.6, DST 201.201.201.2
   6d22h: ICMP: echo reply sent, src 6.6.6.6, DST 201.201.201.2
   6d22h: ICMP: echo reply sent, src 6.6.6.6, DST 201.201.201.2
   6d22h: ICMP: echo reply sent, src 6.6.6.6, DST 201.201.201.2

Пример выходных данных отладки

Обратитесь к Потоку пакетов в Среде MPLS VPN, чтобы видеть, что пример выходных данных использует одинаковую конфигурацию.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении неполадок.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 13732