Многопротокольная коммутация по меткам (MPLS) : MPLS

Проектирование основного трафика MPLS с использованием примера конфигурации OSPF

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

В документе представлен пример конфигурации для реализации технических средств регулирования трафика (TE) на верхних уровнях существующей сети Многопротокольной коммутации по меткам (MPLS) с помощью Frame Relay и OSPF (Open Shortest Path First). В нашем примере реализуются два динамических туннеля (автоматически создаваемых входными маршрутизаторами с коммутацией по меткам [LSR]) и два туннеля, использующих явные пути.

TE – это общее имя, которое используется в различных технологиях для оптимизации использования предоставляемой емкости магистрали и топологии.

Технологии организации трафика MPLS (MPLS TE) позволяют интегрировать достигнутые в этой области возможности (например, в использовании протоколов 2-го уровня, таких как ATM) в протоколы 3-го уровня (IP). MPLS TE использует расширения существующих протоколов (протокол обмена между промежуточными системами (IS-IS), протокол резервирования ресурсов (RSVP), OSPF) для расчета и формирования однонаправленный туннелей, которые настраиваются в соответствии с ограничениями сети. Потоки трафика сопоставляются в разных туннелях в зависимости от их пункта назначения.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в этом документе, касаются следующих версий программного обеспечения и оборудования:

  • Cisco выпуски ПО IOS� 12.0 (11) S и 12.1 (3a) T

  • Маршрутизаторы Cisco 3600

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Функциональные компоненты

Следующая таблица описывает функциональные компоненты этого примера конфигурации:

Компонент Описание
Интерфейсы IP-туннелей 2-й уровень: интерфейс туннеля MPLS является головной секцией пути с коммутацией меток (LSP). Он сконфигурирован с набором потребностей в ресурсах, таких как полоса пропускания и приоритет. Третий уровень: туннельный интерфейс LSP является головным узлом однонаправленного виртуального канала к конечной точке туннеля.
RSVP с расширением TE RSVP используется для установки и обслуживания туннелей LSP на основе рассчитанного пути с использованием сообщений PATH и резервирования RSVP. Спецификация протокола RSVP была расширена, так что сообщения RESV также распространяют сведения меток.
IGP с информацией о состоянии канала [IS-IS или OSPF с расширением TE] Используется для непрерывной передачи сведений о топологии и ресурсах из модуля управления каналом. IS-IS использует новые Типы - Длина-Значения (TLV); OSPF использует Описания локального состояния соединениий типа 10 (также названный Непрозрачными LSA).
Модуль вычисления пути MPLS TE Действует только на заголовок LSP и определяет путь, используя сведения из базы данных состояний каналов.
Модуль управления связью MPLS TE При каждой пересылке пути коммутации по метке этот модуль выполняет контроль использования полосы пропускания канала для сигнальных сообщений RSVP и учет сведений о топологии и ресурсах, передаваемых OSPF или IS-IS.
Переадресация коммутации меток Основной механизм пересылки MPLS на основе меток.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В настоящем документе используется следующая схема сети:

/image/gif/paws/13731/mplsteisis1.gif

Краткое Руководство по конфигурации

Можно использовать следующие шаги для выполнения быстрой настройки. См. Регулирование трафика MLPS и Усовершенствования для более подробной информации.

  1. Настройте сеть обычной конфигурации. (В данном случае использовался Frame Relay.).)

    Примечание: Это является обязательным для устанавливания интерфейса обратной связи с маской IP 32 битов. Этот адрес используется для настройки сети MPLS и TE с помощью протокола маршрутизации. Этот адрес обратной линии должен быть достижим с помощью таблицы глобальной маршрутизации.

  2. Настройте протокол маршрутизации для сети MPLS. Это должен быть протокол маршрутизации с учетом состояния линий (IS-IS или OSPF). В режиме настройки протокола маршрутизации введите следующие команды:

    • Для IS-IS:

      metric-style [wide | both]
      mpls traffic-eng router-id LoopbackN 
      mpls traffic-eng [level-1 | level-2 |]
      
    • Для OSPF:

      mpls traffic-eng area X 
      mpls traffic-eng router-id LoopbackN (must have a 255.255.255.255 mask)
  3. Активируйте функцию MPLS TE. Введите "ip cef" (либо "ip cef distributed", если доступно, чтобы улучшить производительность) в общем режиме настройки. Разблокировать многопротокольный коммутатор метки (MPLS) (ip коммутации тегов) на каждом соответствующем интерфейсе. Введите туннель с техническими средствами регулирования трафика mpls для включения MPLS TE, а также RSVP для Туннелей TE нулевой пропускной способности.

  4. Включите RSVP путем ввода ip rsvp bandwidth XXX на каждом участвующем интерфейсе для ненулевых туннелей пропускной способности.

  5. Настройте туннели, которые будут использоваться для техники обеспечения трафика (TE). Имеется много параметров, которые можно настроить для туннеля MPLS TE, но команда tunnel mode mpls traffic-eng обязательна. Команда tunnel mpls traffic-eng autoroute announce сообщает о присутствии туннеля по протоколу маршрутизации.

    Примечание: Не забудьте использовать ip unnumbered loopbackN для IP-адреса интерфейсов туннеля.

    В данной конфигурации мы видим два динамических туннеля (Pescara_t1 и Pescara_t3) с различной пропускной способностью (и приоритетами), идущих от маршрутизатора Pescara до маршрутизатора Pesaro, и два туннеля (Pesaro_t158 и Pesaro_t159), использующих явный маршрут от Pesaro до Pescara.

Файлы конфигурации

В данном документе используются следующие конфигурации. Включены только соответствующие части файлов конфигурации. Команды, используемые для включения MPLS, находятся в синем тексте; команды, определенные для TE (включая RSVP), являются полужирным текстом.

Pesaro
Current configuration:

!

version 12.1

!

hostname Pesaro

!


ip cef


!

mpls traffic-eng tunnels

!

interface Loopback0

 ip address 10.10.10.6 255.255.255.255

!

interface Tunnel158

 ip unnumbered Loopback0

 tunnel destination 10.10.10.4

 tunnel mode mpls traffic-eng

 tunnel mpls traffic-eng autoroute announce

 tunnel mpls traffic-eng priority 2 2

 tunnel mpls traffic-eng bandwidth 158

 tunnel mpls traffic-eng path-option 1 explicit name low

!

interface Tunnel159

 ip unnumbered Loopback0

 tunnel destination 10.10.10.4

 tunnel mode mpls traffic-eng

 tunnel mpls traffic-eng autoroute announce

 tunnel mpls traffic-eng priority 4 4

 tunnel mpls traffic-eng bandwidth 159

 tunnel mpls traffic-eng path-option 1 explicit name straight

!

interface Serial0/0

 no ip address

 encapsulation frame-relay

!

interface Serial0/0.1 point-to-point

 bandwidth 512

 ip address 10.1.1.22 255.255.255.252

 
tag-switching ip


 mpls traffic-eng tunnels 

 frame-relay interface-dlci 603   

 ip rsvp bandwidth 512 512

!

router ospf 9

 network 10.1.1.0 0.0.0.255 area 9

 network 10.10.10.0 0.0.0.255 area 9

 mpls traffic-eng area 9

 mpls traffic-eng router-id Loopback0

!

ip classless

!

ip explicit-path name low enable

 next-address 10.1.1.21 

 next-address 10.1.1.10 

 next-address 10.1.1.1 

 next-address 10.1.1.14 

!

ip explicit-path name straight enable

 next-address 10.1.1.21 

 next-address 10.1.1.5 

 next-address 10.1.1.14 

!

end

PEscara
Current configuration:

!

version 12.0

!

hostname Pescara

!


ip cef


!

mpls traffic-eng tunnels

!

interface Loopback0

 ip address 10.10.10.4 255.255.255.255

!

interface Tunnel1

 ip unnumbered Loopback0

 no ip directed-broadcast

 tunnel destination 10.10.10.6

 tunnel mode mpls traffic-eng

 tunnel mpls traffic-eng autoroute announce

 tunnel mpls traffic-eng priority 5 5

 tunnel mpls traffic-eng bandwidth 25

 tunnel mpls traffic-eng path-option 2 dynamic

!

interface Tunnel3

 ip unnumbered Loopback0

 no ip directed-broadcast

 tunnel destination 10.10.10.6

 tunnel mode mpls traffic-eng

 tunnel mpls traffic-eng autoroute announce

 tunnel mpls traffic-eng priority 6 6

 tunnel mpls traffic-eng bandwidth  69

 tunnel mpls traffic-eng path-option 1 dynamic

!

interface Serial0/1

 no ip address

 encapsulation frame-relay

!

interface Serial0/1.1 point-to-point

 bandwidth 512

 ip address 10.1.1.14 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 401   

 ip rsvp bandwidth 512 512

!

router ospf 9

 network 10.1.1.0 0.0.0.255 area 9

 network 10.10.10.0 0.0.0.255 area 9

 mpls traffic-eng area 9

 mpls traffic-eng router-id Loopback0

!

end

Pomerol
Current configuration:



version 12.0

!

hostname Pomerol

!


ip cef


!

mpls traffic-eng tunnels

!

interface Loopback0

 ip address 10.10.10.3 255.255.255.255

!

interface Serial0/1

 no ip address

 encapsulation frame-relay

!

interface Serial0/1.1 point-to-point

 bandwidth 512

 ip address 10.1.1.6 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 301   

 ip rsvp bandwidth 512 512

!

interface Serial0/1.2 point-to-point

 bandwidth 512

 ip address 10.1.1.9 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 302   

 ip rsvp bandwidth 512 512

!

interface Serial0/1.3 point-to-point

 bandwidth 512

 ip address 10.1.1.21 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 306   

 ip rsvp bandwidth 512 512

!

router ospf 9

 network 10.1.1.0 0.0.0.255 area 9

 network 10.10.10.0 0.0.0.255 area 9

 mpls traffic-eng area 9

 mpls traffic-eng router-id Loopback0

!

ip classless

!

end

Pulligny
Current configuration:

!

version 12.1

!

hostname Pulligny

!


ip cef


!

mpls traffic-eng tunnels

!

interface Loopback0

 ip address 10.10.10.2 255.255.255.255

!

interface Serial0/1

 no ip address

 encapsulation frame-relay

!

interface Serial0/1.1 point-to-point

 bandwidth 512

 ip address 10.1.1.2 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 201   

 ip rsvp bandwidth 512 512

!

interface Serial0/1.2 point-to-point

 bandwidth 512

 ip address 10.1.1.10 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 203   

 ip rsvp bandwidth 512 512

!

router ospf 9

 network 10.1.1.0 0.0.0.255 area 9

 network 10.10.10.0 0.0.0.255 area 9

 mpls traffic-eng area 9

 mpls traffic-eng router-id Loopback0

!

ip classless

!

end

Pauillac
!

version 12.1

!

hostname pauillac

!


ip cef


!

mpls traffic-eng tunnels

!

interface Loopback0

 ip address 10.10.10.1 255.255.255.255

!

interface Serial0/0

 no ip address

 encapsulation frame-relay

!

interface Serial0/0.1 point-to-point

 bandwidth 512

 ip address 10.1.1.1 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 102   

 ip rsvp bandwidth 512 512

!

interface Serial0/0.2 point-to-point

 bandwidth 512

 ip address 10.1.1.5 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 103   

 ip rsvp bandwidth 512 512

!

interface Serial0/0.3 point-to-point

 bandwidth 512

 ip address 10.1.1.13 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 104   

 ip rsvp bandwidth 512 512

!

router ospf 9

 network 10.1.1.0 0.0.0.255 area 9

 network 10.10.10.0 0.0.0.255 area 9

 mpls traffic-eng area 9

 mpls traffic-eng router-id Loopback0

!

ip classless

!

end

Проверка

В этом разделе содержатся сведения, которые помогают убедиться в надлежащей работе конфигурации.

Общие команды показа проиллюстрированы в MPLS Настройки Основное Регулирование трафика Использование IS-IS. Следующие команды характерны для MPLS TE с OSPF и продемонстрированы ниже:

  • show ip ospf mpls traffic-eng link

  • show ip ospf database opaque-area

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Пример выходных данных команды show

Можно использовать команду show ip ospf mpls traffic-eng link для наблюдения то, что будет объявлено OSPF в данном маршрутизаторе. Характеристики RSVP выделены ниже полужирным шрифтом: это значения полосы пропускания, доступной для резервирования, указываемой в объявлениях и фактически используемой. Можно просмотреть пропускную способность канала, используемого Pescara_t1 (с приоритетом 5) и Pescara_t3 (с приоритетом 6).

Pesaro# show ip ospf mpls traffic-eng link 

  OSPF Router with ID (10.10.10.61) (Process ID 9)

  Area 9 has 1 MPLS TE links. Area instance is 3.

  Links in hash bucket 48.
    Link is associated with fragment 0. Link instance is 3 
      Link connected to Point-to-Point network
      Link ID : 10.10.10.3 Pomerol
      Interface Address : 10.1.1.22
      Neighbor Address : 10.1.1.21
      Admin Metric : 195
      Maximum bandwidth : 64000
      Maximum reservable bandwidth : 64000
      Number of Priority : 8
      Priority 0 : 64000       Priority 1 : 64000     
      Priority 2 : 64000       Priority 3 : 64000     
      Priority 4 : 64000       Priority 5 : 32000     
      Priority 6 : 24000       Priority 7 : 24000   
      Affinity Bit : 0x0

Команда show ip ospf database может быть ограничена к LSA Типа 10 и показывает базу данных, которая используется процессом MPLS TE для вычисления лучшего маршрута (для TE) для динамических туннелей (Pescara_t1 и Pescara_t3 в данном примере). Это можно увидеть в следующем частичном выходе:

Pesaro# show ip ospf database opaque-area 

  OSPF Router with ID (10.10.10.61) (Process ID 9)

  Type-10 Opaque Link Area Link States (Area 9)

  LS age: 397
  Options: (No TOS-capability, DC)
  LS Type: Opaque Area Link
  Link State ID: 1.0.0.0
  Opaque Type: 1
  Opaque ID: 0
  Advertising Router: 10.10.10.1
  LS Seq Number: 80000003
  Checksum: 0x12C9
  Length: 132
  Fragment number : 0

    MPLS TE router ID : 10.10.10.1 Pauillac

    Link connected to Point-to-Point network
      Link ID : 10.10.10.3
      Interface Address : 10.1.1.5
      Neighbor Address : 10.1.1.6
      Admin Metric : 195
      Maximum bandwidth : 64000
      Maximum reservable bandwidth : 48125
      Number of Priority : 8
      Priority 0 : 48125       Priority 1 : 48125     
      Priority 2 : 48125       Priority 3 : 48125     
      Priority 4 : 48125       Priority 5 : 16125     
      Priority 6 : 8125        Priority 7 : 8125      
      Affinity Bit : 0x0

    Number of Links : 1
  LS age: 339
  Options: (No TOS-capability, DC)
  LS Type: Opaque Area Link
  Link State ID: 1.0.0.0
  Opaque Type: 1
  Opaque ID: 0
  Advertising Router: 10.10.10.2
  LS Seq Number: 80000001
  Checksum: 0x80A7
  Length: 132
  Fragment number : 0

    MPLS TE router ID : 10.10.10.2 Pulligny

    Link connected to Point-to-Point network
      Link ID : 10.10.10.1
      Interface Address : 10.1.1.2
      Neighbor Address : 10.1.1.1
      Admin Metric : 195
      Maximum bandwidth : 64000
      Maximum reservable bandwidth : 64000
      Number of Priority : 8
      Priority 0 : 64000       Priority 1 : 64000     
      Priority 2 : 64000       Priority 3 : 64000     
      Priority 4 : 64000       Priority 5 : 64000     
      Priority 6 : 64000       Priority 7 : 64000     
      Affinity Bit : 0x0

    Number of Links : 1

 LS age: 249
  Options: (No TOS-capability, DC)
  LS Type: Opaque Area Link
  Link State ID: 1.0.0.0
  Opaque Type: 1
  Opaque ID: 0
  Advertising Router: 10.10.10.3
  LS Seq Number: 80000004
  Checksum: 0x3DDC
  Length: 132
  Fragment number : 0

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.


Дополнительные сведения


Document ID: 13731