Протокол IP : Протокол RIP

Пример конфигурации запускаемого расширения для RIP

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ показывает примеры конфигурации с помощью команды настройки интерфейса ip rip triggered.

Инициированные расширения к протоколу маршрутной информации (RIP) увеличивают эффективность последовательных каналов связи "точка-точка". Эта функция поддерживается на всех платформах рабочий Cisco Выпуск ПО IOS� 12.0 (1) T и выше. Инициированные расширения помогают избежать двух распространенных проблем с применением протокола RIP для подключения к WAN:

  • Периодическое широковещания с помощью RIP может помешать закрытию цепей WAN.

  • Даже на исправных двухточечных каналах служебная информация периодических передач RIP может серьезно повредить нормальную передачу данных.

Для активации этой опции используйте команду настройки интерфейса ip rip triggered на обоих стороны ссылки. См. примеры конфигураций, приведенные ниже.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

В данном документе используется сеть, изображенная на следующей схеме.

/image/gif/paws/13720/51a.gif

Конфигурации

В данном документе используются следующие конфигурации.

S3-3640
interface Serial1/0 
  ip address 172.16.1.1 255.255.255.0
  ip rip triggered
 ! 
 router rip
  network 172.16.0.0 

S3-3620
interface Loopback8
 ip address 172.19.1.1 255.255.255.0
!
interface Ethernet0/3
 ip address 172.18.1.1 255.255.255.0
!
interface Serial1/0
 ip address 172.16.1.2 255.255.255.0
 ip rip triggered
!
router rip
 network 172.16.0.0
 network 172.18.0.0
 network 172.19.0.0

Проверка.

В данном разделе содержатся сведения о проверке работы конфигурации.

Маршруты, изученные интерфейсом, который настроен с ip rip triggered, показывают как постоянное значение в Базе данных RIP и таблице маршрутизации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • {\f3 show ip route}–{\f3 показывает текущее состояние таблицы маршрутизации.}

  • show ip rip database- Записи сводного адреса Показов в записях базы данных маршрутизации RIP при необходимости направляют, суммируются основанные на сводном адресе.

S3-3640#show ip route
C       172.16.1.0/24 is directly connected, Serial1/0
R    172.19.0.0/16 [120/1] via 172.16.1.2, Serial1/0
R    172.18.0.0/16 [120/1] via 172.16.1.2, Serial1/0

S3-3640#show ip rip database
172.18.0.0/16    auto-summary
172.18.0.0/16
    [1] via 172.16.1.2, 00:02:44 (permanent), Serial1/0
	* Triggered Routes:
     - [1] via 172.16.1.2, Serial1/0
172.19.0.0/16    auto-summary
172.19.0.0/16
    [1] via 172.16.1.2, 00:02:45 (permanent),Serial1/0
  	* Triggered Routes:
     - [1] via 172.16.1.2, Serial1/0

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Команды для устранения неполадок

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Примечание: Прежде чем применять команды отладки, ознакомьтесь с разделом "Важные сведения о командах отладки".

  • события debug ip rip - Отображают информацию на транзакциях маршрутизации RIP.

S3-3640#debug ip rip events
RIP: received v1 triggered request from 172.16.1.2 on Serial1/0
RIP: start retransmit timer of 172.16.1.2
RIP: received v1 triggered ack from 172.16.1.2 on Serial1/0
RIP: Stopped retrans timer for 172.16.1.2
RIP: sending v1 ack to 172.16.1.2 via Serial1/0 (172.16.1.1),

Заключение

При включении активированных добавочных номеров к RIP обновления маршрутизации передаются в WAN только если происходит одно из следующих событий:

  • Маршрутизатор получает определенный запрос на обновление маршрутизации, побуждающий отослать всю базу данных.

  • Информация от другого интерфейса модифицирует базу данных маршрутизации, которая заставляет только последние изменения передаваться.

  • Интерфейс подходит или выключается, который заставляет часть базы данных передаваться.

  • Маршрутизатор включается впервые с целью проверки, отправлено ли хотя бы одно обновление, после чего отправляется вся база данных.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 13720