Протокол IP : Протокол OSPF

Проблемы с использованием OSPF в режиме NBMA и широковещательном режиме через ретрансляцию кадров

21 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

В этих технических примечаниях рассматривается проблема с присутствием маршрутов OSPF в базе данных состояния каналов, но не в таблице маршрутизации в полностью ячеистой среде Frame Relay. Дополнительные сценарии см. в разделе "Почему некоторые маршруты OSPF находятся в базе данных, но не в таблице маршрутизации?"?

Предварительные условия

Требования

Читатели данного документа должны обладать знаниями по следующим темам:

  • OSPF

  • Frame Relay

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования. Однако приведенная в данном документе конфигурация протестирована и обновлена с использованием следующих версий программного и аппаратного обеспечения:

  • Cisco 2500 Series Router

  • Cisco версия 12.2 (24a) IOS�

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Теоретические сведения

Пример ниже использует полностью сетчатую среду Frame Relay. Сетевая диаграмма и конфигурации показаны ниже:

/image/gif/paws/13696/24a.gif

Doc
interface Ethernet0 
 ip address 50.50.50.50 255.255.255.0 

interface Serial0 
 encapsulation frame-relay 

!--- Enables Frame Relay encapsulation on the interface.

interface Serial0.1 multipoint 

!--- The subinterface is configured as a multipoint link.

 ip address 10.10.10.5 255.255.255.0 
 ip ospf network broadcast 

!--- This command is used to define the network type as broadcast.


!--- The network type is defined on nonbroadcast networks to
 

!--- avoid configuring the neighbors explicitly.

 frame-relay map ip 10.10.10.6 101 broadcast 
 frame-relay map ip 10.10.10.10 100 broadcast 

!--- To define the mapping between a destination protocol address


!--- and the data-link connection identifier (DLCI) used to
 

!--- connect to the destination address.
  

!--- The broadcast keyword is used to forward broadcasts to
 

!--- this address when broadcast/multicast is
 

!--- disabled because of non-broadcast medium.

router ospf 1 
 network 0.0.0.0 255.255.255.255 area 0

Сонный
interface Ethernet0 
  ip address 70.70.70.70 255.255.255.0 

 interface Serial0 
  encapsulation frame-relay

!--- Enables Frame Relay encapsulation on the interface. 

interface Serial0.1 multipoint 

!--- The subinterface is configured as a multipoint link.

  ip address 10.10.10.6 255.255.255.0 
  ip ospf network broadcast

!--- This command is used to define the network type as broadcast.

!--- The network type is defined on nonbroadcast networks to 

!--- avoid configuring the neighbors explicitly. 

  frame-relay map ip 10.10.10.5 101 broadcast 
  frame-relay map ip 10.10.10.10 102 broadcast 

!--- To define the mapping between a destination protocol address
!--- and the DLCI used to connect to the destination address.   
!--- The broadcast keyword is used to forward broadcasts to 
!--- this address when broadcast/multicast is 
!--- disabled because of non-broadcast medium.

 router ospf 1 
  network 0.0.0.0 255.255.255.255 area 0

Sneezy
interface Ethernet0 
  ip address 60.60.60.60 255.255.255.0 

 interface Serial0 
  encapsulation frame-relay 

!--- Enables Frame Relay encapsulation on the interface.

 interface Serial0.1 multipoint

!--- The subinterface is configured as a multipoint link. 

  ip address 10.10.10.10 255.255.255.0 
  ip ospf network broadcast

!--- This command is used to define the network type as broadcast.
!--- The network type is defined on nonbroadcast networks to 
!--- avoid configuring the neighbors explicitly.
 


  frame-relay map ip 10.10.10.5 100 broadcast 
  frame-relay  map ip 10.10.10.6 102 broadcast 

!--- To define the mapping between a destination protocol address
!--- and the DLCI used to connect to the destination address.   
!--- The broadcast keyword is used to forward broadcasts to 
!--- this address when broadcast/multicast is 
!--- disabled because of non-broadcast medium.

 router ospf 1 
  network 0.0.0.0 255.255.255.255 area 0

Проблема

Первоначально таблицы соседей всех маршрутизаторов включают все маршруты. Событие имеет место, который заставляет Дока и Сонный отбрасывать друг друга от их таблиц соответствующего соседа. Из таблиц соседей, приведённых в этом разделе, мы можем видеть, что таблица соседей Doc не имеет записи 70.70.70.70, а таблица соседей Sleepy не имеет записи 50.50.50.50.

Таблица соседей Doc
doc# 
show ip ospf neighbor

  
 Neighbor ID Pri State        Dead Time Address     Interface
 60.60.60.60 1   FULL/DR      00:00:33 10.10.10.10  Serial0.1
Таблица Sleepy Neighbor
sleepy# show ip ospf neighbor

 Neighbor ID Pri State        Dead Time Address     Interface
 60.60.60.60 1   FULL/BDR     00:00:32 10.10.10.10  Serial0.1
Таблица Sneezy Neighbor
sneezy# show ip ospf neighbor

 Neighbor ID Pri State        Dead Time Address     Interface
 50.50.50.50 1   FULL/DROTHER 00:00:36  10.10.10.5  Serial0.1
 70.70.70.70 1   FULL/DR      00:00:31  10.10.10.6  Serial0.1

Кроме того, Doc теряет все маршруты OSPF от своей таблицы маршрутизации, и Sleepy и Sneezy больше не имеют 50.50.50.0 (Подсеть LAN doc) в их таблицах маршрутизации.

Таблица маршрутизации Doc
doc# 
show ip route

 Gateway of last resort is not set
      10.0.0.0 255.255.255.0 is subnetted, 1 subnets
 C       10.10.10.0 is directly connected, Serial0.1
      50.0.0.0 255.255.255.0 is subnetted, 1 subnets
 C       50.50.50.0 is directly connected, Ethernet0
Сонная таблица маршрутизации
sleepy# show ip route
 Gateway of last resort is not set
      10.0.0.0/ 24 is subnetted, 1 subnets
 C       10.10.10.0 is directly connected, Serial0.1
      60.0.0.0/ 24 is subnetted, 1 subnets
 O       60.60.60.0 [110/ 11175] via 10.10.10.10, 00: 07: 25, Serial0.1
      70.0.0.0/ 24 is subnetted, 1 subnets
 C    70.70.70.0 is directly connected, Ethernet0
Таблица маршрутизации Sneezy
sneezy# show ip route
 Gateway of last resort is not set
      10.0.0.0/ 24 is subnetted, 1 subnets
 C       10.10.10.0 is directly connected, Serial0.1
      60.0.0.0/ 24 is subnetted, 1 subnets
 C       60.60.60.0 is directly connected, Ethernet0
      70.0.0.0/ 24 is subnetted, 1 subnets
 O       70.70.70.0 [110/ 11175] via 10.10.10.6, 00: 07: 53, Serial0.1

Хотя Doc не содержит маршрутов OSPF в своей таблице маршрутизации, однако, на основании выходных данных видно, что у Doc есть полная база данных OSPF.

База данных Doc
doc# 
show ip ospf database


                               OSPF Router with ID (50.50.50.50) (Process ID 1)

                                          Router Link States (Area 0)

 Link ID       ADV Router    Age    Seq#        Checksum Link count
 50.50.50.50   50.50.50.50   169    0x80000030  0x3599   2
 60.60.60.60   60.60.60.60   1754   0x8000002F  0xD26D   2
 70.70.70.70   70.70.70.70   1681   0x8000002D  0xFDD9   2

                                           Net Link States (Area 0)

 Link ID       ADV Router    Age    Seq#        Checksum
 10.10.10.6    70.70.70.70   569    0x8000002B  0x8246

Состояние каналов сети формируется выделенным маршрутизатором, который определяет все маршрутизаторы, подключенные к сети. В выходных данных ниже, мы видим, что DR не перечисляет Идентификатор маршрутизатора Doc (50.50.50.50) как присоединенный маршрутизатор, который ломает модель трансляции. Doc не устанавливает маршруты OSPF, полученные через сеть Frame Relay.

Сетевое состояние канала
doc# 
show ip ospf database network 10.10.10.6


                                           Net Link States (Area 0)

 LS Type: Network Links
 Link State ID: 10.10.10.6 (address of Designated Router)
 Advertising Router: 70.70.70.70

 Network Mask: 255.255.255.0
       Attached Router: 70.70.70.70
       Attached Router: 60.60.60.60

Еще один способ рассмотрения заключается в том, что Doc объявляет Sneezy как DR и ожидает, что Sneezy создаст сеть с учетом состояния связи. Однако, поскольку Sneezy не является выделенным маршрутизатором, он не создает состояние сетевого канала, что в свою очередь не позволяет Doc установить маршрутизаторы в его таблице маршрутизации.

Таблица соседей Doc
doc# show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
60.60.60.60       1   FULL/DR         00:00:29    10.10.10.10     Serial0.1

Причины

Согласно базе данных, DR для облака Frame Relay – это Sleepy. Однако Sleepy не видит Doc в качестве соседа OSPF. Как видно из данного примера, проверка связи (ping) от Sleepy к Doc выдает ошибку:

sleepy# ping 10.10.10.5

Type escape sequence to abort.
Sending 5, 100- byte ICMP Echos to 10.10.10.5, timeout is 2 seconds:
.....
Success rate is 0 percent (0/ 5)

Выходные данные по команде show frame-relay map в Sleepy показывают, что идентификатор DLCI, переходящий в Doc, неактивен. Это объясняет, почему Sleepy не может выполнить проверку доступности для Doc, а также, — почему они не видят друг друга в качестве соседей. Именно событие и вызвало эту проблему:

sleepy# show frame-relay map
Serial0.1 (up): ip 10.10.10.5 dlci 101( 0x65,0x1850), static,
              broadcast,
              CISCO, status defined, inactive

Serial0.1 (up): ip 10.10.10.10 dlci 102( 0x66,0x1860), static,
              broadcast,
              CISCO, status defined, active

Так как соединение PVC между Doc и Sleepy, а также между Doc и указанным маршрутизатором (DR) разорвано, Doc объявит все LSA от Sneezy (который не относится к DR) недосягаемыми. Модель широковещательной рассылки по Frame Relay работает должным образом, если глобальная сеть Frame является полностью ячеистой. Если постоянные виртуальные каналы (PVC) разорваны, это может привести к проблемам в базе данных OSPF, о чем свидетельствует приведенный ниже результат команды show ip ospf database, в котором отображается сообщение о недоступности маршрутизатора Adv.

Таблица соседей Doc
doc# 
show ip ospf database router

             OSPF Router with ID (50.50.50.50) (Process ID 1)

                Router Link States (Area 0)

  LS age: 57
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 50.50.50.50
  Advertising Router: 50.50.50.50
  LS Seq Number: 800000D4
  Checksum: 0x355D
  Length: 48
  Number of Links: 2

    Link connected to: a Transit Network
     (Link ID) Designated Router address: 10.10.10.10
     (Link Data) Router Interface address: 10.10.10.5
      Number of TOS metrics: 0
       TOS 0 Metrics: 64

    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 50.50.50.0
     (Link Data) Network Mask: 255.255.255.0
      Number of TOS metrics: 0
       TOS 0 Metrics: 10


  Adv Router is not-reachable
  LS age: 367
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 60.60.60.60
  Advertising Router: 60.60.60.60
  LS Seq Number: 800000C9
  Checksum: 0xC865
  Length: 48
  Number of Links: 2

    Link connected to: a Transit Network
     (Link ID) Designated Router address: 10.10.10.6
     (Link Data) Router Interface address: 10.10.10.10
      Number of TOS metrics: 0
       TOS 0 Metrics: 64

    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 60.60.60.0
     (Link Data) Network Mask: 255.255.255.0
      Number of TOS metrics: 0
       TOS 0 Metrics: 10


  Adv Router is not-reachable
  LS age: 53
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 70.70.70.70
  Advertising Router: 70.70.70.70
  LS Seq Number: 800000CA
  Checksum: 0xEDD4
  Length: 48
  Number of Links: 2

    Link connected to: a Transit Network
     (Link ID) Designated Router address: 10.10.10.6
     (Link Data) Router Interface address: 10.10.10.6
      Number of TOS metrics: 0
       TOS 0 Metrics: 64

    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 70.70.70.0
     (Link Data) Network Mask: 255.255.255.0
      Number of TOS metrics: 0
       TOS 0 Metrics: 10

Решение

Во время настройки OSPF для работы в сети с широковещательной рассылкой или без широковещательной рассылки, с многоадресной рассылкой, должна быть возможность связи всех устройств непосредственно (как минимум) с назначенным маршрутизатором. Модель широковещания и NBMA основана на концепции полностью ячеистой сети Frame Relay. Если постоянный виртуальный канал (PVC) отключается, сеть перестает быть полносвязной, и правильная работа протокола OSPF невозможна.

В среде Frame Relay если уровень 2 нестабилен, как в примере, не рекомендуется использовать тип сети с широковещанием OSPF. Вместо этого воспользуйтесь многоточечным интерфейсом OSPF.


Дополнительные сведения


Document ID: 13696