Протокол IP : Протокол OSPF

Стратегия масштабируемого резервирования ISDN для больших сетей OSPF

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Эти Технические примечания описывают стратегию резервирования для расширяемой сети ISDN для больших сетей OSPF. Ранее, было необходимо выделить один интерфейс ISDN на граничном маршрутизаторе области OSPF (ABR) для каждой области, которая потребовала выполнения резервное копирование. Это значит, что если вы имели 50 областей OSPF, которым была необходима резервная копия, вы требовали бы 50 интерфейсов ISDN, которые смогли бы распространяться через несколько резервных ABR. В целях нашего обсуждения резервный ABR является ABR, который завершает соединения ISDN, которые установлены, когда отказывает основное соединение. Давайте смотреть на то, почему необходимо для каждой области иметь специальный интерфейс ISDN на резервном ABR.

Это ограничение было навлечено фактом, что интерфейс может только принадлежать одной области за один раз. Так как ISDN традиционно использует устаревшую Маршрутизацию с соединением по требованию (DDR) код, и все B-каналы на физической цепи ISDN связаны к одному объекту точка - многоточка уровня одиночной сети, названному интерфейсом номеронабирателя. Таким образом, даже при том, что Primary Rate Interface (PRI) имеет 23 B-канала, все каналы на этой физической цепи ISDN принадлежат тому же интерфейсу сетевого уровня, SerialX:23, и этот интерфейс может только принадлежать одной области OSPF. Факт, что мы можем физически оконечные вызовы от 23 отдельных узлов на этом PRI, потрачен впустую, так как все каналы должны совместно использовать ту же конфигурацию на уровне сети. Таким образом у нас есть ограничение, что каждая область, которая требует выполнения резервное копирование, должна иметь один специальный интерфейс ISDN на резервном ABR.

Предварительные условия

Требования

Для данного документа отсутствуют предварительные условия.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Сведения, представленные в этом документе, были получены от устройств в специфической лабораторной среде. Все устройства, используемые в этом документе, были запущены с чистой конфигурацией (конфигурацией по умолчанию). При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Общие сведения

Cisco IOS версия 11.2 � представила функцию, названную профилями DDR. Одно из фундаментальных различий между унаследованным профилем DDR и профилями DDR является фактом, что физические цепи ISDN больше не соединяются к тому же интерфейсу сетевого уровня. Вместо этого у нас есть возможность определить несколько профилей DDR, которые являются объектами сетевого уровня с некоторыми cвязанными параметрами DDR также. Когда входящий вызов приедет на цепь ISDN, мы динамически свяжем вызов с соотвествующем профилем номеронабирателя основанному на проверенном имени пользователя или id вызывающего. Можно определить еще много профилей DDR, чем у вас есть физические цепи ISDN, таким образом позволяя вам превысить намеченную сумму и, в сущности, положиться на статистическое мультиплексирование вызовов ISDN.

Это, кажется, прорыв для нашей стратегии резервного копирования OSPF. Так как каждый профиль DDR имеет свой собственный cвязанный IP-адрес (и поэтому область OSPF), если у нас было 50 областей OSPF для создания копии, мы можем настроить 50 других профилей DDR на резервном ABR. Мы не требуем 50 других интерфейсов ISDN больше, мы можем использовать гораздо меньше, в зависимости от уровня превышения подписки, которое мы можем обработать в нашей резервной сети. Когда входящий вызов поступает в резервный ABR, мы связываем вызов от области, которая снизилась до соответствующего профиля DDR в той же области.

К сожалению, есть несколько проблем с профилями номеронабирателя. Предварительное конфигурирование профилей DDR размещает каждый профиль DDR в соответствующей области, которой принадлежит выполненная резервное копирование область. Это вызывает:

  • Дополнительные LSA, которые будут генерироваться, один для каждого профили DDR.

  • Зоны автоматически будут изолированы в виду того, что профиль номеронабирателя будет соединением через шлейф в область. (Интерфейсы номеронабирателя никогда не выключаются так, OSPF создает тупиковую ссылку для каждого интерфейса номеронабирателя, настроенного на маршрутизаторе).

  • Каждый профиль DDR вводит один дополнительный маршрут в область, которая может быть нежелательным при выполнении суммирования.

  • Любое изменение в базе данных LSA (изменения соединения в любом месте сети) влечёт за собой генерацию вызова ISDN.

  • В виду того что области LSA переполняются каждые 30 минут для того чтобы обеспечить синхронизацию баз данных LSA через автономную систему, вызов ISDN произведен к каждой области во время переполнения.

Примечание: Возможно избежать последнего сценария при использовании OSPF По требованию функция в IOS 11.2. Однако каждый резервный маршрутизатор в каждой области должен быть обновлен к 11.2 для понимания опции Линии связи по требованию (DC) во время смежного формирования.

Функция Виртуальных профилей в Cisco 11.3 решает все вышеупомянутые проблемы. Виртуальные профили основаны на профилях номеронабирателя, так что снова мы имеют разъединение интерфейса сетевого уровня+B1231 от физической цепи ISDN. Когда входящий вызов сделан, Однако виртуальные профили расширяют профили DDR путем разрешения конфигурации динамического интерфейса. Конфигурация интерфейса сохранена на центральном сервере (в нашем сценарии, AAA-сервер, поддерживающий или TACACS + или Протокол RADIUS), и загружена к маршрутизатору по требованию. Когда область набирает назад в ABR, физическая цепь ISDN связана с динамическим интерфейсом, названным интерфейсом виртуального доступа. Конфигурация интерфейса виртуального доступа получена от virtual-template и, самое главное, от AAA-сервера. Мы храним IP-адрес виртуального профиля на AAA-сервере, и это применилось к интерфейсу виртуального доступа, с которым была связана физическая цепь ISDN. Когда соединение ISDN разъединено, виртуальный профиль (или интерфейс виртуального доступа, с которым была связана область) уничтожен, соединение ISDN готово к следующему вызову ISDN.

С PRI, мы имеем возможность поддерживать до 23 звоноков сразу от таких же или различных мест. С PPP multilink, включенным на резервном ABR, когда новый вызов поступает, мы сравниваем проверенное имя пользователя с тем из существующих виртуальных профилей. Если соответствие найдено (вызов, инициируемый из той же области), мы связываем ссылки вместе в многоканальное соединение, которое позволяет физические цепи ISDN, которые происходят из одинаковой позиции для совместного использования того же интерфейса сетевого уровня (виртуальный профиль). Физические цепи ISDN, которые происходят из различных областей (чье проверенное имя пользователя отличается от виртуальных профилей, уже созданных) связаны с новыми виртуальными профилями, и новые интерфейсы виртуального доступа созданы с их конфигурациями, загруженными от AAA-сервера.

Так как мы больше не предварительно конфигурируем профили DDR на резервном ABR, мы не встречаемся с упомянутыми выше проблемами профиля DDR. Отсутствие предварительного конфигурирования также позволяет резервным ABR масштабироваться легко по несколько шасси и устраняет избыточную служебную информацию управления.

На резервном ABR () действительно, однако, необходимо предварительно сконфигурировать операторы сети OSPF, которые привязывают подсеть к определенной области.

Схема сети

В примере, показанном ниже, у нас есть два маршрутизатора в области 0, isdn2-1 и isdn2-2. isdn2-1 имеет основное соединение к isdn1-7, который находится в области 100. isdn1-5 является ABR для области 100 и набирает в isdn2-2, который является маршрутизатором резервного аггрегирования. isdn1-4 является другим маршрутизатором в области 100, от которого мы можем выполнить traceroute для мониторинга пути IP - трафика. isdn1-5 имеет OSPF, по требованию работающий; это первоначально синхронизирует до isdn2-2 и таким образом имеет полные данные межобластных маршрутов, включая объединенный маршрут. Однако стоимость выше на резервном интерфейсе, таким образом предпочтительный путь все еще через isdn1-7.

/image/gif/paws/13695/23a.gif

Конфигурации

Давайте посмотреть на текущие конфигурации маршрутизаторов в приведенном выше примере.

isdn2-1
interface Loopback0
  ip address 10.0.1.1 255.255.255.0
 !
 interface Loopback1
  ip address 10.0.2.2 255.255.255.0
 !
 interface Loopback2
  ip address 10.0.3.3 255.255.255.0
 !
 interface Tunnel0
  ip address 10.100.100.2 255.255.255.0
  ip ospf cost 100
  tunnel source Ethernet2/0
  tunnel destination 172.16.25.9
  tunnel key 1234
 !
 interface Ethernet2/0
  ip address 172.16.25.51 255.255.255.240
 !
 router ospf 10
  redistribute static subnets route-map cisco_summary
  network 10.0.0.0 0.0.255.255 area 0
  network 172.16.25.48 0.0.0.15 area 0
  network 10.100.100.0 0.0.0.255 area 100
  default-metric 100
 !
 ip default-gateway 172.16.25.49
 ip classless
 ip route 171.68.0.0 255.254.0.0 172.16.25.49
 ip route 172.16.25.9 255.255.255.255 172.16.25.49
 no logging buffered
 access-list 101 permit ip 171.68.0.0 0.0.255.255 255.254.0.0 0.0.255.255
 route-map cisco_summary permit 10
  match ip address 101
  set metric 200

isdn2-2
aaa new-model
aaa authentication login default none
aaa authentication ppp default if-needed tacacs+
aaa authorization network tacacs+
aaa accounting network start-stop tacacs
!
interface Ethernet0
ip address 172.16.25.52 255.255.255.240
!
interface Virtual-Template1
no ip address
ppp authentication chap
!
interface Serial0:23
no ip address
encapsulation ppp
dialer-group 1
isdn incoming-voice modem
no peer default ip address
ppp authentication chap
!
interface Group-Async1
ip unnumbered Ethernet0
ip tcp header-compression passive
encapsulation ppp
async mode interactive
peer default ip address pool default
ppp authentication chap
group-range 1 24
!
router ospf 10
network 10.0.0.0 0.0.255.255 area 0
network 10.200.0.0 0.0.255.255 area 200
network 172.16.25.48 0.0.0.15 area 0
network 10.100.200.0 0.0.0.255 area 100
!
ip local pool default 172.16.25.59 172.16.25.62
virtual-profile virtual-template 1
virtual-profile aaa
dialer-list 1 protocol ip permit
tacacs-server host 171.68.207.32
tacacs-server key cisco

isdn1-5
interface Ethernet0
  ip address 172.16.25.5 255.255.255.240
 !
 interface BRI0
  ip address 10.100.200.1 255.255.255.0
  encapsulation ppp
  ip ospf cost 1500
  ip ospf demand-circuit
  no peer default ip address
  dialer map ip 10.100.200.2 name isdn2-2 broadcast 4327528
  dialer-group 1
  ppp authentication chap
  ppp chap hostname ospf_backup1
 !
 router ospf 10
  network 0.0.0.0 255.255.255.255 area 100
 !
 dialer-list 1 protocol ip permit

isdn1-7
interface Tunnel0
ip address 10.100.100.1 255.255.255.0
ip ospf cost 100
tunnel source Ethernet0
tunnel destination 172.16.25.51
tunnel key 1234
!
interface Ethernet0
ip address 172.16.25.9 255.255.255.240
media-type 10BaseT
!
router ospf 10
redistribute static
network 0.0.0.0 255.255.255.255 area 100
!
ip classless
ip route 172.16.25.51 255.255.255.255 172.16.25.1

isdn1-4
interface Ethernet0
  ip address 172.16.25.4 255.255.255.240
 !
 router ospf 10
  network 0.0.0.0 255.255.255.255 area 100

команды "show"

Ниже приводится выходные данные команды show для маршрутизаторов выше.

команды isdn2-1 show

isdn2-1#show ip ospf
 Routing Process "ospf 10" with ID 10.0.2.2
 Supports only single TOS(TOS0) routes
 It is an area border and autonomous system boundary router
 Summary Link update interval is 00:30:00 and the update due in 00:00:06
 External Link update interval is 00:30:00 and the update due in 00:27:25
 Redistributing External Routes from,
    static with metric mapped to 100, includes subnets in redistribution
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Number of DCbitless external LSA 0
 Number of DoNotAge external LSA 0
 Number of areas in this router is 2. 2 normal 0 stub 0 nssa
    Area BACKBONE(0)
        Number of interfaces in this area is 4
        Area has no authentication
        SPF algorithm executed 38 times
        Area ranges are
        Link State Update Interval is 00:30:00 and due in 00:29:21
        Link State Age Interval is 00:20:00 and due in 00:06:06
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
    Area 100
        Number of interfaces in this area is 1
        Area has no authentication
        SPF algorithm executed 35 times
        Area ranges are
        Link State Update Interval is 00:30:00 and due in 00:00:37
        Link State Age Interval is 00:20:00 and due in 00:00:05
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 6

isdn2-1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is 172.16.25.49 to network 0.0.0.0

     10.0.0.0/24 is subnetted, 4 subnets
C       10.0.2.0 is directly connected, Loopback1
C       10.0.3.0 is directly connected, Loopback2
C       10.100.100.0 is directly connected, Tunnel0
C       10.0.1.0 is directly connected, Loopback0
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.16.25.48/28 is directly connected, Ethernet2/0
S       172.16.25.9/32 [1/0] via 172.16.25.49
S    171.68.0.0/15 [1/0] via 172.16.25.49

команды isdn2-2 show

isdn2-2#show ip ospf
 Routing Process "ospf 10" with ID 172.16.25.52
 Supports only single TOS(TOS0) routes
 It is an area border router
 Summary Link update interval is 00:30:00 and the update due in 00:03:21
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Number of DCbitless external LSA 0
 Number of DoNotAge external LSA 0
 Number of areas in this router is 3. 3 normal 0 stub 0 nssa
    Area BACKBONE(0)
        Number of interfaces in this area is 26
        Area has no authentication
        SPF algorithm executed 9 times
        Area ranges are
        Link State Update Interval is 00:30:00 and due in 00:03:20
        Link State Age Interval is 00:20:00 and due in 00:03:19
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
    Area 100
        Number of interfaces in this area is 0
        Area has no authentication
        SPF algorithm executed 34 times
        Area ranges are
        Link State Update Interval is 00:30:00 and due in 00:00:00
        Link State Age Interval is 00:20:00 and due in 00:03:19
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 10
    Area 200
        Number of interfaces in this area is 0
        Area has no authentication
        SPF algorithm executed 1 times
        Area ranges are
        Link State Update Interval is 00:30:00 and due in 00:00:00
        Link State Age Interval is 00:20:00 and due in 00:03:19
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0

isdn2-2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is 172.16.25.49 to network 0.0.0.0

     172.16.0.0/28 is subnetted, 1 subnets
C       172.16.25.48 is directly connected, Ethernet0
     10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
O IA    10.100.100.0/24 [110/110] via 172.16.25.51, 00:07:07, Ethernet0
O       10.0.3.3/32 [110/11] via 172.16.25.51, 00:09:40, Ethernet0
O       10.0.2.2/32 [110/11] via 172.16.25.51, 00:09:40, Ethernet0
O       10.0.1.1/32 [110/11] via 172.16.25.51, 00:09:40, Ethernet0
O E2 171.68.0.0/15 [110/200] via 172.16.25.49, 00:07:07, Ethernet0

isdn2-2#show ip ospf interface virtual-template 1
Virtual-Template1 is down, line protocol is down
   OSPF not enabled on this interface

команды isdn1-7 show

isdn1-7#show ip ospf
 Routing Process "ospf 10" with ID 172.16.25.9
 Supports only single TOS(TOS0) routes
 It is an autonomous system boundary router
 External Link update interval is 00:30:00 and the update due in 00:03:54
 Redistributing External Routes from,
    static
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Number of DCbitless external LSA 0
 Number of DoNotAge external LSA 0
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
    Area 100
        Number of interfaces in this area is 3
        Area has no authentication
        SPF algorithm executed 32 times
        Area ranges are
        Link State Update Interval is 00:30:00 and due in 00:10:38
        Link State Age Interval is 00:20:00 and due in 00:10:38
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 6

isdn1-7#show ip ospf neighbor details
 Neighbor 172.16.25.5, interface address 172.16.25.5
    In the area 100 via interface Ethernet0
    Neighbor priority is 1, State is FULL
    DR is 172.16.25.5 BDR is 172.16.25.4
    Options 2
    Dead timer due in 00:00:32
 Neighbor 172.16.25.4, interface address 172.16.25.4
    In the area 100 via interface Ethernet0
    Neighbor priority is 1, State is FULL
    DR is 172.16.25.5 BDR is 172.16.25.4
    Options 2
    Dead timer due in 00:00:39
 Neighbor 10.0.2.2, interface address 10.100.100.2
    In the area 100 via interface Tunnel0
    Neighbor priority is 1, State is FULL
    DR is 0.0.0.0 BDR is 0.0.0.0
    Options 2
    Dead timer due in 00:00:37

isdn1-7#show ip ospf interface tunnel0
Tunnel0 is up, line protocol is up
  Internet Address 10.100.100.1/24, Area 100
  Process ID 10, Router ID 172.16.25.9, Network Type POINT_TO_POINT, Cost: 100
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:04
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)

isdn1-7#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is 172.16.25.1 to network 0.0.0.0

     172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
O IA    172.16.25.48/28 [110/1520] via 172.16.25.5, 00:10:33, Ethernet0
S       172.16.25.51/32 [1/0] via 172.16.25.1
C       172.16.25.0/28 is directly connected, Ethernet0
C       172.16.25.3/32 is directly connected, Virtual-Access1
     10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
O IA    10.0.3.3/32 [110/1521] via 172.16.25.5, 00:10:33, Ethernet0
O IA    10.0.2.2/32 [110/1521] via 172.16.25.5, 00:10:33, Ethernet0
O IA    10.0.1.1/32 [110/1521] via 172.16.25.5, 00:10:33, Ethernet0
C       10.100.100.0/24 is directly connected, Tunnel0
O       10.100.65.1/32 [110/11] via 172.16.25.5, 00:10:33, Ethernet0
O       10.100.60.1/32 [110/11] via 172.16.25.5, 00:10:33, Ethernet0
O       10.100.55.1/32 [110/11] via 172.16.25.5, 00:10:33, Ethernet0
O       10.100.50.1/32 [110/11] via 172.16.25.5, 00:10:33, Ethernet0
O       10.100.200.0/24 [110/1510] via 172.16.25.5, 00:10:33, Ethernet0
O E2 171.68.0.0/15 [110/200] via 172.16.25.5, 00:10:33, Ethernet0

команды isdn1-5 show

isdn1-5#show ip ospf
 Routing Process "ospf 10" with ID 172.16.25.5
 Supports only single TOS(TOS0) routes
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Number of DCbitless external LSA 0
 Number of DoNotAge external LSA 3
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
    Area 100
        Number of interfaces in this area is 6
        Area has no authentication
        SPF algorithm executed 45 times
        Area ranges are
        Link State Update Interval is 00:30:00 and due in 00:05:12
        Link State Age Interval is 00:20:00 and due in 00:05:11
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 7

isdn1-5#show ip ospf neighbor details
 Neighbor 172.16.25.52, interface address 10.100.200.2
    In the area 100 via interface BRI0
    Neighbor priority is 1, State is FULL
    Options 34
    Dead timer due in 00:00:34
 Neighbor 172.16.25.9, interface address 172.16.25.9
    In the area 100 via interface Ethernet0
    Neighbor priority is 1, State is FULL
    Options 2
    Dead timer due in 00:00:36
 Neighbor 172.16.25.4, interface address 172.16.25.4
    In the area 100 via interface Ethernet0
    Neighbor priority is 1, State is FULL
    Options 2
    Dead timer due in 00:00:36

isdn1-5#show ip ospf interface bri0
BRI0 is up, line protocol is up (spoofing)
  Internet Address 10.100.200.1/24, Area 100
  Process ID 10, Router ID 172.16.25.5, Network Type POINT_TO_POINT, Cost: 1500
  Configured as demand circuit.
  Run as demand circuit.
  DoNotAge LSA allowed.
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:02
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 172.16.25.52  (Hello suppressed)
  Suppress hello for 1 neighbor(s)

isdn1-5#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 10 subnets, 2 masks
O IA    10.0.3.3/32 [110/111] via 172.16.25.9, 00:00:56, Ethernet0
O IA    10.0.2.2/32 [110/111] via 172.16.25.9, 00:00:56, Ethernet0
O IA    10.0.1.1/32 [110/111] via 172.16.25.9, 00:00:56, Ethernet0
O       10.100.100.0/24 [110/110] via 172.16.25.9, 00:00:56, Ethernet0
C       10.100.65.0/24 is directly connected, Loopback3
C       10.100.60.0/24 is directly connected, Loopback2
C       10.100.55.0/24 is directly connected, Loopback1
C       10.100.50.0/24 is directly connected, Loopback0
C       10.100.200.2/32 is directly connected, BRI0
C       10.100.200.0/24 is directly connected, BRI0
     172.16.0.0/28 is subnetted, 2 subnets
O IA    172.16.25.48 [110/120] via 172.16.25.9, 00:00:57, Ethernet0
C       172.16.25.0 is directly connected, Ethernet0
O E2 171.68.0.0/15 [110/200] via 172.16.25.9, 00:00:58, Ethernet0

команды isdn1-4 show

isdn1-4#show ip ospf
 Routing Process "ospf 10" with ID 172.16.25.4
 Supports only single TOS(TOS0) routes
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Number of DCbitless external LSA 0
 Number of DoNotAge external LSA 3
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
    Area 100
        Number of interfaces in this area is 1
        Area has no authentication
        SPF algorithm executed 27 times
        Area ranges are
        Link State Update Interval is 00:30:00 and due in 00:20:41
        Link State Age Interval is 00:20:00 and due in 00:00:40
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 6

isdn1-4#show ip ospf neighbor details
 Neighbor 172.16.25.9, interface address 172.16.25.9
    In the area 100 via interface Ethernet0
    Neighbor priority is 1, State is FULL
    Options 2
    Dead timer due in 00:00:35
 Neighbor 172.16.25.5, interface address 172.16.25.5
    In the area 100 via interface Ethernet0
    Neighbor priority is 1, State is FULL
    Options 2
    Dead timer due in 00:00:30

isdn1-4#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
O IA    10.0.3.3/32 [110/111] via 172.16.25.9, 00:02:00, Ethernet0
O IA    10.0.2.2/32 [110/111] via 172.16.25.9, 00:02:01, Ethernet0
O IA    10.0.1.1/32 [110/111] via 172.16.25.9, 00:02:01, Ethernet0
O       10.100.100.0/24 [110/110] via 172.16.25.9, 00:02:11, Ethernet0
O       10.100.65.1/32 [110/11] via 172.16.25.5, 00:02:11, Ethernet0
O       10.100.60.1/32 [110/11] via 172.16.25.5, 00:02:11, Ethernet0
O       10.100.55.1/32 [110/11] via 172.16.25.5, 00:02:11, Ethernet0
O       10.100.50.1/32 [110/11] via 172.16.25.5, 00:02:11, Ethernet0
O       10.100.200.0/24 [110/1510] via 172.16.25.5, 00:02:11, Ethernet0
     172.16.0.0/28 is subnetted, 2 subnets
O IA    172.16.25.48 [110/120] via 172.16.25.9, 00:02:01, Ethernet0
C       172.16.25.0 is directly connected, Ethernet0
O E2 171.68.0.0/15 [110/200] via 172.16.25.9, 00:02:01, Ethernet0

Отладка и проверка

Текущий маршрут от isdn1-4 до 171.68.191.1 через isdn1-7 по туннельному интерфейсу к isdn2-1, и на до 172.16.25.49.

isdn1-4#show ip route 171.68.0.0
Routing entry for 171.68.0.0/15, supernet
  Known via "ospf 10", distance 110, metric 200, type extern 2, forward metric 120
  Redistributing via ospf 10
  Last update from 172.16.25.9 on Ethernet0, 00:00:04 ago
  Routing Descriptor Blocks:
  * 172.16.25.9, from 10.0.2.2, 00:00:04 ago, via Ethernet0
      Route metric is 200, traffic share count is 1

Мы видим, что этот маршрут использует команду traceroute на хосте во внутренней сети Cisco. То, как пакет возвращается к нам, не важно в этом сценарии.

isdn1-4#traceroute 171.68.191.1

Type escape sequence to abort.
Tracing the route to dpeng-sun.cisco.com (171.68.200.127)

  1 172.16.25.9 4 msec 4 msec 4 msec      (isdn1-7)
  2 10.100.100.2 4 msec 8 msec 8 msec     (isdn2-1)
  3 172.16.25.49 4 msec 4 msec 4 msec
  4 171.68.191.1 8 msec 8 msec 4 msec

Давайте изменим ключ туннеля на isdn1-7, чтобы заставить туннельный интерфейс выключаться. Если мы ждем полный интервал простоя (40 секунд длина интервала исчезновения по умолчанию), узел обнаружен как вниз, и наша резервная копия начинается.

isdn1-7#
*Mar  1 02:31:17.916: OSPF: 10.0.2.2 address 10.100.100.2 on Tunnel0 is dead

Резервный маршрутизатор области является isdn1-5. Это выполняет OSPF по требованию, таким образом, это имеет полные данные внутриобластных маршрутов через маршрутизатор резервного аггрегирования. Однако стоимость OSPF через резервное соединение выше, таким образом когда основное соединение между областью 100 и магистралью произошло, пакеты все еще текут через isdn1-7. Так как мы сломали основное соединение на isdn1-7, маршрут isdn1-5 теперь лучше, и изменение в базе данных OSPF вызывает вызов к маршрутизатору резервного аггрегирования.

isdn1-5#
*Mar  7 04:58:09.955: ISDN BR0: TX ->  SETUP pd = 8  callref = 0x05
*Mar  7 04:58:09.959:         Bearer Capability i = 0x8890
*Mar  7 04:58:09.959:         Channel ID i = 0x83
*Mar  7 04:58:09.963:         Keypad Facility i = '4327528'
*Mar  7 04:58:10.103: ISDN BR0: RX <-  CALL_PROC pd = 8  callref = 0x85
*Mar  7 04:58:10.107:         Channel ID i = 0x89
*Mar  7 04:58:10.963: ISDN BR0: RX <-  CONNECT pd = 8  callref = 0x85
*Mar  7 04:58:10.975: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
*Mar  7 04:58:11.007: ISDN BR0: TX ->  CONNECT_ACK pd = 8  callref = 0x05
*Mar  7 04:58:12.019: %LINEPROTO-5-UPDOWN: 
Line protocol on Interface BRI0:1, changed state to up
*Mar  7 04:58:17.131: %ISDN-6-CONNECT: 
Interface BRI0:1 is now connected to 4327528 isdn2-2
*Mar  7 04:58:24.159: OSPF: 
Cannot see ourself in hello from 172.16.25.52 on BRI0, state INIT
*Mar  7 04:58:27.867: OSPF: Rcv DBD from 172.16.25.52 on BRI0 seq 0x6FE 
opt 0x22 flag 0x7 len 32 state INIT
*Mar  7 04:58:27.871: OSPF: 2 Way Communication to 172.16.25.52 
on BRI0, state 2WAY
*Mar  7 04:58:27.875: OSPF: Send DBD to 172.16.25.52 on BRI0 seq 
0xEBC opt 0x22 flag 0x7 len 32
*Mar  7 04:58:27.879: OSPF: NBR Negotiation Done. We are the SLAVE
*Mar  7 04:58:27.879: OSPF: Send DBD to 172.16.25.52 on BRI0 seq 
0x6FE opt 0x22 flag 0x2 len 432
*Mar  7 04:58:28.031: OSPF: Rcv DBD from 172.16.25.52 on BRI0 seq 
0x6FF opt 0x22 flag 0x3 len 432 state EXCHANGE
*Mar  7 04:58:28.035: OSPF: Send DBD to 172.16.25.52 on BRI0 seq 
0x6FF opt 0x22 flag 0x0 len 32
*Mar  7 04:58:28.043: OSPF: Database request to 172.16.25.52
*Mar  7 04:58:28.043: OSPF: sent LS REQ packet to 10.100.200.2, 
length 24
*Mar  7 04:58:28.079: OSPF: Rcv DBD from 172.16.25.52 on BRI0 seq 
0x700 opt 0x22 flag 0x1 len 32 state EXCHANGE
*Mar  7 04:58:28.079: OSPF: Exchange Done with 172.16.25.52 on BRI0
*Mar  7 04:58:28.083: OSPF: Send DBD to 172.16.25.52 on BRI0 seq 
0x700 opt 0x22 flag 0x0 len 32
*Mar  7 04:58:28.099: OSPF: Synchronized with 172.16.25.52 on BRI0, 
state FULL
*Mar  7 04:58:28.099: OSPF: Tried to build Router LSA within 
MinLSInterval

Процедура резервирования на isdn1-5 завершена, и интерфейс ISDN является теперь ссылкой между областью 100 и магистральной областью.

isdn1-5#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 10 subnets, 2 masks
O IA    10.0.3.3/32 [110/1511] via 10.100.200.2, 00:00:35, BRI0
O IA    10.0.2.2/32 [110/1511] via 10.100.200.2, 00:00:35, BRI0
O IA    10.0.1.1/32 [110/1511] via 10.100.200.2, 00:00:35, BRI0
O       10.100.100.0/24 [110/110] via 172.16.25.9, 00:00:35, Ethernet0
C       10.100.65.0/24 is directly connected, Loopback3
C       10.100.60.0/24 is directly connected, Loopback2
C       10.100.55.0/24 is directly connected, Loopback1
C       10.100.50.0/24 is directly connected, Loopback0
C       10.100.200.2/32 is directly connected, BRI0
C       10.100.200.0/24 is directly connected, BRI0
     172.16.0.0/28 is subnetted, 2 subnets
O IA    172.16.25.48 [110/1510] via 10.100.200.2, 00:00:36, BRI0
C       172.16.25.0 is directly connected, Ethernet0
O E2 171.68.0.0/15 [110/200] via 10.100.200.2, 00:00:37, BRI0

isdn1-5#show ip route 171.68.0.0
Routing entry for 171.68.0.0/15, supernet
  Known via "ospf 10", distance 110, metric 200, type extern 2, forward metric 1510
  Redistributing via ospf 10
  Last update from 10.100.200.2 on BRI0, 00:09:33 ago
  Routing Descriptor Blocks:
  * 10.100.200.2, from 10.0.2.2, 00:09:33 ago, via BRI0
      Route metric is 200, traffic share count is 1

Считая isdn1-4 теперь, мы видим, что объединенный маршрут для внутренней сети Cisco теперь имеет следующий переход isdn1-5.

isdn1-4#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
O IA    10.0.3.3/32 [110/1521] via 172.16.25.5, 00:01:49, Ethernet0
O IA    10.0.2.2/32 [110/1521] via 172.16.25.5, 00:01:49, Ethernet0
O IA    10.0.1.1/32 [110/1521] via 172.16.25.5, 00:01:49, Ethernet0
O       10.100.100.0/24 [110/110] via 172.16.25.9, 00:01:49, Ethernet0
O       10.100.65.1/32 [110/11] via 172.16.25.5, 00:01:49, Ethernet0
O       10.100.60.1/32 [110/11] via 172.16.25.5, 00:01:49, Ethernet0
O       10.100.55.1/32 [110/11] via 172.16.25.5, 00:01:49, Ethernet0
O       10.100.50.1/32 [110/11] via 172.16.25.5, 00:01:49, Ethernet0
O       10.100.200.0/24 [110/1510] via 172.16.25.5, 00:01:49, Ethernet0
     172.16.0.0/28 is subnetted, 2 subnets
O IA    172.16.25.48 [110/1520] via 172.16.25.5, 00:01:49, Ethernet0
C       172.16.25.0 is directly connected, Ethernet0
O E2 171.68.0.0/15 [110/200] via 172.16.25.5, 00:01:49, Ethernet0

isdn1-4#show ip route 171.68.0.0
Routing entry for 171.68.0.0/15, supernet
  Known via "ospf 10", distance 110, metric 200, type extern 2, 
  forward metric 1520
  Redistributing via ospf 10
  Last update from 172.16.25.5 on Ethernet0, 00:02:04 ago
  Routing Descriptor Blocks:
  * 172.16.25.5, from 10.0.2.2, 00:02:04 ago, via Ethernet0
      Route metric is 200, traffic share count is 1

Команда traceroute демонстрирует, что изменился путь.

isdn1-4#traceroute 171.68.191.1

     Type escape sequence to abort.
     Tracing the route to dpeng-sun.cisco.com (171.68.200.127)

       1 172.16.25.5 4 msec 4 msec 4 msec         (isdn1-5)
       2 10.100.200.2 16 msec 16 msec 16 msec     (isdn2-2)
       3 172.16.25.49 28 msec 16 msec 72 msec
       4 171.68.191.1 16 msec 16 msec 16 msec

Давайте смотреть на то, что происходит на маршрутизаторе резервного аггрегирования, когда основное соединение (туннельный интерфейс) не работает и наборы резервного маршрутизатора области в. Во-первых, маршрутизатор резервного аггрегирования принимает вызов от резервного маршрутизатора области:

*Mar  1 01:12:20.587: ISDN Se0:23: RX <-  SETUP pd = 8  callref = 0x1B
*Mar  1 01:12:20.591:         Bearer Capability i = 0x8890
*Mar  1 01:12:20.595:         Channel ID i = 0xA98393
*Mar  1 01:12:20.599:         Calling Party Number i = '!', 0x83, '4082322044'
*Mar  1 01:12:20.603:         Called Party Number i = 0xC1, '4084327528'
*Mar  1 01:12:20.691: %LINK-3-UPDOWN: Interface Serial0:18, changed state to up
*Mar  1 01:12:20.727: Se0:18 PPP: Treating connection as a callin
*Mar  1 01:12:20.731: Se0:18 PPP: Phase is ESTABLISHING, Passive Open
*Mar  1 01:12:20.735: Se0:18 LCP: State is Listen
*Mar  1 01:12:20.755: ISDN Se0:23: TX ->  CALL_PROC pd = 8  callref = 0x801B
*Mar  1 01:12:20.759:         Channel ID i = 0xA98393
*Mar  1 01:12:20.791: ISDN Se0:23: TX ->  CONNECT pd = 8  callref = 0x801B
*Mar  1 01:12:20.791:         Channel ID i = 0xA98393
*Mar  1 01:12:20.863: ISDN Se0:23: RX <-  CONNECT_ACK pd = 8  callref = 0x1B

Согласование PPP начинается:

*Mar  1 01:12:20.995: Se0:18 LCP: I CONFREQ [Listen] id 166 len 34
*Mar  1 01:12:20.999: Se0:18 LCP:    AuthProto CHAP 
(0x0305C22305)
*Mar  1 01:12:21.003: Se0:18 LCP:    MagicNumber 0x20039D53 
(0x050620039D53)
*Mar  1 01:12:21.003: Se0:18 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 01:12:21.007: Se0:18 LCP:    EndpointDisc 1 Local 
(0x130F016F7370665F6261636B757031)
*Mar  1 01:12:21.015: Se0:18 LCP: O CONFREQ [Listen] id 9 len 15
*Mar  1 01:12:21.015: Se0:18 LCP:    AuthProto CHAP 
(0x0305C22305)
*Mar  1 01:12:21.019: Se0:18 LCP:    MagicNumber 0x60812EEF 
(0x050660812EEF)
*Mar  1 01:12:21.023: Se0:18 LCP: O CONFREJ [Listen] id 166 len 23
*Mar  1 01:12:21.027: Se0:18 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 01:12:21.027: Se0:18 LCP:    EndpointDisc 1 Local 
(0x130F016F7370665F6261636B757031)
*Mar  1 01:12:21.043: Se0:18 LCP: I CONFACK [REQsent] id 9 len 15
*Mar  1 01:12:21.047: Se0:18 LCP:    AuthProto CHAP 
(0x0305C22305)
*Mar  1 01:12:21.051: Se0:18 LCP:    MagicNumber 0x60812EEF 
(0x050660812EEF)
*Mar  1 01:12:21.055: Se0:18 LCP: I CONFREQ [ACKrcvd] id 167 len 15
*Mar  1 01:12:21.055: Se0:18 LCP:    AuthProto CHAP 
(0x0305C22305)
*Mar  1 01:12:21.059: Se0:18 LCP:    MagicNumber 0x20039D53 
(0x050620039D53)
*Mar  1 01:12:21.063: Se0:18 LCP: O CONFACK [ACKrcvd] id 167 len 15
*Mar  1 01:12:21.063: Se0:18 LCP:    AuthProto CHAP 
(0x0305C22305)
*Mar  1 01:12:21.067: Se0:18 LCP:    MagicNumber 0x20039D53 
(0x050620039D53)
*Mar  1 01:12:21.071: Se0:18 LCP: State is Open

Как только LCP заканчивает выполнять согласование, мы продолжаемся к аутентификации:

*Mar  1 01:12:21.071: Se0:18 PPP: Phase is AUTHENTICATING, 
by both
*Mar  1 01:12:21.075: Se0:18 CHAP: O CHALLENGE id 9 len 28 
from "isdn2-2"
*Mar  1 01:12:21.155: Se0:18 CHAP: I CHALLENGE id 61 len 33 
from "ospf_backup1"
*Mar  1 01:12:21.159: Se0:18 CHAP: I RESPONSE id 9 len 33 
from "ospf_backup1"

Мы передали наш вызов Протокола аутентификации по квитированию вызова (CHAP) и получили ответ от узла. Обратите внимание на то, что маршуртизатор резервной области утверждает, что был "ospf_backup1" вместо действительного имени хоста маршрутизатора "isdn1-5". Это происходит, потому что мы использовали команду ppp chap hostname для отвержения по умолчанию.

Так как мы подтвердили подлинность этого пользователя, использующего TACACS +, затем мы связываемся с TACACS + сервер.

*Mar  1 01:12:21.167: AAA/AUTHEN: create_user (0x35F5BC) 
user='ospf_backup1' ruser='' port='Serial0:18' 
rem_addr='4082322044/4084327528' authen_type=CHAP service=PPP priv=1
*Mar  1 01:12:21.171: AAA/AUTHEN/START (1579536474): 
port='Serial0:18' list='' action=SENDAUTH service=PPP
*Mar  1 01:12:21.175: AAA/AUTHEN/START (1579536474): 
using "default" list
*Mar  1 01:12:21.179: AAA/AUTHEN (1579536474): 
status = UNKNOWN
*Mar  1 01:12:21.179: AAA/AUTHEN/START (1579536474): 
Method=TACACS+
*Mar  1 01:12:21.183: TAC+: send AUTHEN/START packet 
ver=193 id=1579536474
*Mar  1 01:12:21.403: TAC+: ver=193 id=1579536474 
received AUTHEN status = PASS
*Mar  1 01:12:21.403: AAA/AUTHEN (1579536474): 
status = PASS
*Mar  1 01:12:21.411: AAA/AUTHEN: free_user (0x35F5BC) 
user='ospf_backup1' ruser='' port='Serial0:18' 
rem_addr='4082322044/4084327528' authen_type=CHAP service=PPP priv=1
*Mar  1 01:12:21.415: Se0:18 CHAP: Waiting for peer 
to authenticate first
*Mar  1 01:12:21.419: AAA/AUTHEN: create_user (0x35F5BC) 
user='ospf_backup1' ruser='' port='Serial0:18' 
rem_addr='4082322044/4084327528' authen_type=CHAP service=PPP priv=1
*Mar  1 01:12:21.423: AAA/AUTHEN/START (3035786780): 
port='Serial0:18' list='' action=LOGIN service=PPP
*Mar  1 01:12:21.427: AAA/AUTHEN/START (3035786780): 
using "default" list
*Mar  1 01:12:21.427: AAA/AUTHEN (3035786780): 
status = UNKNOWN
*Mar  1 01:12:21.431: AAA/AUTHEN/START (3035786780): 
Method=TACACS+
*Mar  1 01:12:21.431: TAC+: send AUTHEN/START packet 
ver=193 id=3035786780
*Mar  1 01:12:21.655: TAC+: ver=193 id=3035786780 
received AUTHEN status = PASS
*Mar  1 01:12:21.659: AAA/AUTHEN (3035786780): 
status = PASS

Так как пароль корректен, и маршуртизатор резервной области заверен, мы теперь продолжаемся к этапу авторизации.

*Mar  1 01:12:21.663: AAA/AUTHOR/LCP Se0:18: 
Authorize LCP
*Mar  1 01:12:21.667: AAA/AUTHOR/LCP: Serial0:18: 
(221407121): user='ospf_backup1'
*Mar  1 01:12:21.667: AAA/AUTHOR/LCP: Serial0:18: 
(221407121): send AV service=ppp
*Mar  1 01:12:21.671: AAA/AUTHOR/LCP: Serial0:18: 
(221407121): send AV protocol=lcp
*Mar  1 01:12:21.671: AAA/AUTHOR/LCP: Serial0:18: 
(221407121): Method=TACACS+
*Mar  1 01:12:21.675: AAA/AUTHOR/TAC+: (221407121): 
user=ospf_backup1
*Mar  1 01:12:21.679: AAA/AUTHOR/TAC+: (221407121): 
send AV service=ppp
*Mar  1 01:12:21.679: AAA/AUTHOR/TAC+: (221407121): 
send AV protocol=lcp
*Mar  1 01:12:21.903: TAC+: (221407121): received 
author response status = PASS_ADD
*Mar  1 01:12:21.911: AAA/AUTHOR (221407121): 
Post authorization status = PASS_ADD
*Mar  1 01:12:21.911: AAA/AUTHOR/LCP Se0:18: 
Processing AV service=ppp
*Mar  1 01:12:21.915: AAA/AUTHOR/LCP Se0:18: 
Processing AV protocol=lcp
*Mar  1 01:12:21.915: AAA/AUTHOR/LCP Se0:18: 
Processing AV interface-config=ip address 
10.100.200.2 255.255.255.0\nip ospf cost 1500

Авторизация завершена. Мы получаем пару атрибут-значение (AVP), указывающую, что определенные, некоторый конфигурации должны быть на интерфейсе, который мы создаем.

Теперь, когда проверка подлинности и авторизация для LCP завершена, мы сообщаем узлу, им позволяют войти.

*Mar  1 01:12:21.927: Se0:18 CHAP: O SUCCESS id 9 len 4
*Mar  1 01:12:21.927: Se0:18 CHAP: O RESPONSE id 61 
len 28 from "isdn2-2"
*Mar  1 01:12:21.951: Se0:18 CHAP: I SUCCESS id 61 len 4

Процесс LCP завершен, и теперь Протокол управления сетью (NCP) будет создан, что означает, что мы требуем интерфейса. Мы активировали опцию виртуальных профилей, таким образом, мы клонируем интерфейс виртуального доступа от виртуального интерфейса, затем настраиваем конфигурацию с помощью AVP, полученных от AAA.

Давайте смотреть на то, как мы создаем интерфейс виртуального доступа.

*Mar  1 01:12:21.955: Vi1 VTEMPLATE: Reuse Vi1, 
recycle queue size 0
*Mar  1 01:12:21.955: Vi1 VTEMPLATE: Set default 
settings with no ip address
*Mar  1 01:12:22.363: Vi1 VTEMPLATE: Hardware address 
0060.3ef1.6f74
*Mar  1 01:12:22.391: %LINEPROTO-5-UPDOWN: 
Line protocol on Interface Serial0:18, changed state to up
*Mar  1 01:12:22.399: %LINEPROTO-5-UPDOWN: 
Line protocol on Interface Virtual-Access1, changed state to up
*Mar  1 01:12:22.451: %LINK-3-UPDOWN: 
Interface Virtual-Access1, changed state to up
*Mar  1 01:12:22.455: Vi1 PPP: Treating connection 
as a dedicated line
*Mar  1 01:12:22.459: Vi1 PPP: Phase is ESTABLISHING, 
Active Open
*Mar  1 01:12:22.463: Vi1 LCP: O CONFREQ [Closed] 
id 33 len 10
*Mar  1 01:12:22.467: Vi1 LCP:    MagicNumber 0x60813499 
(0x050660813499)

Базовая конфигурация интерфейса виртуального доступа прибывает из виртуального интерфейса 1, как задано в конфигурации.

*Mar  1 01:12:22.483: Vi1 VTEMPLATE: 
Has a new cloneblk vtemplate, now it has vtemplate
*Mar  1 01:12:22.487: Vi1 VTEMPLATE: 
Undo default settings
*Mar  1 01:12:22.899: Vi1 VTEMPLATE: 
************* CLONE VACCESS1 *****************
*Mar  1 01:12:22.899: Vi1 VTEMPLATE: 
Clone from vtemplate1
interface Virtual-Access1
no ip address
encap ppp
no ip address
no ip mroute-cache
ppp authentication chap
ppp multilink
end

Интерфейс виртуального доступа запускает.

*Mar  1 01:12:23.671: Vi1 PPP: 
Phase is TERMINATING
*Mar  1 01:12:23.671: Vi1 PPP: 
Phase is ESTABLISHING, Active Open
*Mar  1 01:12:23.679: Vi1 LCP: 
O CONFREQ [Closed] id 34 len 15
*Mar  1 01:12:23.679: Vi1 LCP:    
AuthProto CHAP (0x0305C22305)
*Mar  1 01:12:23.683: Vi1 LCP:    
MagicNumber 0x6081395A (0x05066081395A)
*Mar  1 01:12:23.743: Vi1 PPP: 
Phase is TERMINATING
*Mar  1 01:12:23.747: Vi1 PPP: 
Phase is ESTABLISHING, Active Open
*Mar  1 01:12:23.751: Vi1 LCP: 
O CONFREQ [Closed] id 35 len 29
*Mar  1 01:12:23.755: Vi1 LCP:    
AuthProto CHAP (0x0305C22305)
*Mar  1 01:12:23.759: Vi1 LCP:    
MagicNumber 0x608139A3 (0x0506608139A3)
*Mar  1 01:12:23.759: Vi1 LCP:    
MRRU 1524 (0x110405F4)
*Mar  1 01:12:23.763: Vi1 LCP:    
EndpointDisc 1 Local (0x130A016973646E322D32)
*Mar  1 01:12:23.847: Vi1 AAA/AUTHOR: LCP_DOWN
*Mar  1 01:12:23.847: Vi1 AAA/AUTHOR: LCP_DOWN

Теперь давайте загружать AVP конфигурации, который мы получили от AAA-сервера. Это задает IP-адрес для интерфейса и также модифицирует стоимость OSPF по умолчанию.

*Mar  1 01:12:23.947: Vi1 VTEMPLATE: 
Has a new cloneblk AAA, now it has vtemplate/AAA
*Mar  1 01:12:23.951: Vi1 VTEMPLATE: 
************* CLONE VACCESS1 *****************
*Mar  1 01:12:23.955: Vi1 VTEMPLATE: 
Clone from AAA
interface Virtual-Access1
ip address 10.100.200.2 255.255.255.0
ip ospf cost 1500
end

*Mar  1 01:12:24.123: OSPF: 
Interface Virtual-Access1 going Up
*Mar  1 01:12:24.127: Vi1 PPP: 
Unsupported or un-negotiated protocol. Link ip
*Mar  1 01:12:24.235: 
AAA/AUTHEN: dup_user (0x35DEA0) user='ospf_backup1' 
ruser='' port='Serial0:18' rem_addr='4082322044/4084327528' 
authen_type=CHAP service=PPP priv=1 source='AAA dup vp_create'

Немного придирок позволяет нам вызывать согласованное состояние LCP.

*Mar  1 01:12:24.239: Vi1 LCP: 
I FORCED CONFREQ len 11
*Mar  1 01:12:24.243: Vi1 LCP:    
AuthProto CHAP (0x0305C22305)
*Mar  1 01:12:24.247: Vi1 LCP:    
MagicNumber 0x60812EEF (0x050660812EEF)
*Mar  1 01:12:24.247: Vi1 PPP: 
Phase is UP

Мы теперь готовы выполнить согласование о NCP.

*Mar  1 01:12:24.251: AAA/AUTHOR/FSM Vi1: (0): 
Can we start IPCP?
*Mar  1 01:12:24.263: AAA/AUTHOR/FSM: Virtual-Access1: 
(2432251470): user='ospf_backup1'
*Mar  1 01:12:24.263: AAA/AUTHOR/FSM: Virtual-Access1: 
(2432251470): send AV service=ppp
*Mar  1 01:12:24.267: AAA/AUTHOR/FSM: Virtual-Access1: 
(2432251470): send AV protocol=ip
*Mar  1 01:12:24.271: AAA/AUTHOR/FSM: Virtual-Access1: 
(2432251470): Method=TACACS+
*Mar  1 01:12:24.275: AAA/AUTHOR/TAC+: (2432251470): 
user=ospf_backup1
*Mar  1 01:12:24.275: AAA/AUTHOR/TAC+: (2432251470): 
send AV service=ppp
*Mar  1 01:12:24.279: AAA/AUTHOR/TAC+: (2432251470): 
send AV protocol=ip
*Mar  1 01:12:24.503: TAC+: (2432251470): received 
author response status = PASS_ADD
*Mar  1 01:12:24.507: AAA/AUTHOR (2432251470): Post 
authorization status = PASS_ADD
*Mar  1 01:12:24.515: AAA/AUTHOR/FSM Vi1: We can 
start IPCP
*Mar  1 01:12:24.519: Vi1 IPCP: O CONFREQ [Closed] 
id 17 len 10
*Mar  1 01:12:24.523: Vi1 IPCP:    
Address 10.100.200.2 (0x03060A64C802)
*Mar  1 01:12:24.523: Se0:18 PPP: Phase is FORWARDED
*Mar  1 01:12:24.527: Se0:18 IPCP: PPP phase is FORWARDED, 
discarding packet
*Mar  1 01:12:24.531: Se0:18 IPCP: PPP phase is FORWARDED, 
discarding packet
*Mar  1 01:12:25.851: Vi1 LCP: TIMEout: Time 0x424F98 
State Open

Узел хочет назначить 10.100.200.1 на его интерфейсе.

*Mar  1 01:12:26.031: Vi1 IPCP: I CONFREQ [REQsent] 
id 56 len 10
*Mar  1 01:12:26.035: Vi1 IPCP:    Address 10.100.200.1 
(0x03060A64C801)
*Mar  1 01:12:26.035: AAA/AUTHOR/IPCP Vi1: Start.  
Her address 10.100.200.1, we want 0.0.0.0

Мы сделали запрос TACACS + сервер для авторизации IP-адреса.

*Mar  1 01:12:26.039: AAA/AUTHOR/IPCP Vi1: 
Processing AV service=ppp
*Mar  1 01:12:26.043: AAA/AUTHOR/IPCP Vi1: 
Processing AV protocol=ip
*Mar  1 01:12:26.043: AAA/AUTHOR/IPCP Vi1: 
Processing AV addr=10.100.200.1
*Mar  1 01:12:26.047: AAA/AUTHOR/IPCP Vi1: 
Authorization succeeded

Авторизацию предоставляют.

*Mar  1 01:12:26.047: AAA/AUTHOR/IPCP Vi1: Done.  
Her address 10.100.200.1, we want 10.100.200.1

Мы подтверждаем их запрошенный IP - адрес.

*Mar  1 01:12:26.051: Vi1 IPCP: 
O CONFACK [REQsent] id 56 len 10
*Mar  1 01:12:26.059: Vi1 IPCP:    
Address 10.100.200.1 (0x03060A64C801)
*Mar  1 01:12:26.067: Vi1 LCP: 
O PROTREJ [Open] id 36 len 10 protocol CDPCP (0x820701350004)
*Mar  1 01:12:26.727: %ISDN-6-CONNECT: 
Interface Serial0:18 is now connected to 4082322044 ospf_backup1
*Mar  1 01:12:26.875: Vi1 IPCP: 
TIMEout: Time 0x425294 State ACKsent
*Mar  1 01:12:26.879: Vi1 IPCP: 
O CONFREQ [ACKsent] id 18 len 10
*Mar  1 01:12:26.879: Vi1 IPCP:    
Address 10.100.200.2 (0x03060A64C802)

Узел подтверждает наш IP-адрес.

*Mar  1 01:12:26.899: Vi1 IPCP: 
I CONFACK [ACKsent] id 18 len 10
*Mar  1 01:12:26.903: Vi1 IPCP:    
Address 10.100.200.2 (0x03060A64C802)
*Mar  1 01:12:26.903: Vi1 IPCP: 
State is Open
*Mar  1 01:12:26.911: Vi1 AAA/AUTHOR: 
IP_UP
*Mar  1 01:12:26.911: Vi1 AAA/PER-USER: 
processing author params.
*Mar  1 01:12:26.919: Vi1 IPCP: 
Install route to 10.100.200.1

Так как IP находится полностью на этом интерфейсе, OSPF синхронизирует и устанавливает смежность.

*Mar  1 01:12:29.427: OSPF: Rcv hello from 10.0.2.2 area 0 
from Ethernet0 172.16.25.51
*Mar  1 01:12:29.427: OSPF: End of hello processing
*Mar  1 01:12:35.295: OSPF: service_maxage: Trying to 
delete MAXAGE LSA
*Mar  1 01:12:37.823: OSPF: Rcv hello from 172.16.25.5 
area 100 from Virtual-Access1 10.100.200.1
*Mar  1 01:12:37.823: OSPF: 2 Way Communication to 
172.16.25.5 on Virtual-Access1, state 2WAY
*Mar  1 01:12:37.827: OSPF: Send DBD to 172.16.25.5 on 
Virtual-Access1 seq 0x6FE opt 0x22 flag 0x7 len 32
*Mar  1 01:12:37.831: OSPF: End of hello processing
*Mar  1 01:12:37.871: OSPF: Rcv DBD from 172.16.25.5 on 
Virtual-Access1 seq 0xEBC opt 0x22 flag 0x7 len 32 state EXSTART
*Mar  1 01:12:37.875: OSPF: First DBD and we are not SLAVE
*Mar  1 01:12:37.927: OSPF: Rcv DBD from 172.16.25.5 on 
Virtual-Access1 seq 0x6FE opt 0x22 flag 0x2 len 432 state EXSTART
*Mar  1 01:12:37.931: OSPF: NBR Negotiation Done. 
We are the MASTER
*Mar  1 01:12:37.939: OSPF: Send DBD to 172.16.25.5 on 
Virtual-Access1 seq 0x6FF opt 0x22 flag 0x3 len 432
*Mar  1 01:12:37.943: OSPF: Database request to 172.16.25.5
*Mar  1 01:12:37.947: OSPF: sent LS REQ packet to 10.100.200.1, 
length 96
*Mar  1 01:12:38.031: OSPF: Rcv DBD from 172.16.25.5 on 
Virtual-Access1 seq 0x6FF opt 0x22 flag 0x0 len 32 state EXCHANGE
*Mar  1 01:12:38.035: OSPF: Send DBD to 172.16.25.5 on 
Virtual-Access1 seq 0x700 opt 0x22 flag 0x1 len 32
*Mar  1 01:12:38.115: OSPF: Rcv DBD from 172.16.25.5 on 
Virtual-Access1 seq 0x700 opt 0x22 flag 0x0 len 32 state EXCHANGE
*Mar  1 01:12:38.119: OSPF: Exchange Done with 172.16.25.5 
on Virtual-Access1
*Mar  1 01:12:38.119: OSPF: Synchronized with 172.16.25.5 
on Virtual-Access1, state FULL

Синхронизация OSPF завершена между резервным маршрутизатором области и маршрутизатором резервного аггрегирования. О OSPF по требованию выполняют согласование так, соединение ISDN произошло только, когда существует течение трафика данных.

isdn2-2#show ip ospf interface virtual-access 1
Virtual-Access1 is up, line protocol is up
  Internet Address 10.100.200.2/24, Area 100
  Process ID 10, Router ID 172.16.25.52, 
  Network Type POINT_TO_POINT, Cost: 1500
  Run as demand circuit.
  DoNotAge LSA allowed.
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, 
  Wait 40, Retransmit 5
    Hello due in 00:00:05
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 172.16.25.5  
	(Hello suppressed)
  Suppress hello for 1 neighbor(s)

isdn2-2#show interface virtual-access 1 config
Virtual-Access1 is a Virtual Profile interface

Building configuration...

interface Virtual-Access1 configuration...
ip address 10.100.200.2 255.255.255.0
ip ospf cost 1500
no ip mroute-cache
ppp authentication chap

Вот TACACS + профиль isdn1-5:

user = ospf_backup1 {
        chap = cleartext "cisco"

        service = ppp protocol = lcp {
                interface-config = "ip address 10.100.200.2 255.255.255.0\nip ospf cost 1500"
        }

        service = ppp protocol = ip {
                addr = 10.100.200.1
        }
}

И Профиль RADIUS:

ospf_backkup1 Password = "cisco"
        Service-Type = Framed,
        Framed-Protocol = PPP,
        Framed-IP-Address = 10.100.200.1
        cisco-avpair = "interface-config=ip address 10.100.200.2 255.255.255.0\nip ospf cost 1

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 13695