Протокол IP : Протокол OSPF

Загрузочная конфигурация протокола предпочтения кратчайшего пути (OSPF) через подчиненные интерфейсы Frame Relay

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

В этом документе представлены примеры конфигурации протокола OSPF на подынтерфейсах Frame Relay.

Предварительные условия

Требования

Прежде чем вы используйте эту конфигурацию, убедитесь что вы соблюдаете этим требованиям:

  • Основное понимание Frame Relay и конфигурации OSPF

Обратитесь к OSPF Настройки и Настройке и устранению проблем сети Frame Relay для получения дополнительной информации.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Маршрутизаторы Cisco 2503

  • Cisco версия программного обеспечения 12.3 (3) IOS� на обоих маршрутизаторах

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. в Условные обозначения технических терминов Cisco.

Общие сведения

Чтобы настроить и устранить неполадки OSPF по сети, у вас должно быть хорошее понимание основной топологии сети. Механизм обнаружения соседей, выбор выделенного маршрутизатора (DR) и выделенного резервного маршрутизатора (BDR) и обновление переполнящих связей на нём. Основная топология Layer 2 может быть одной из этих:

  • Широковещательный мультидоступ (например, Ethernet) — Широковещательная сеть является той, которая позволяет широковещанию или пакетам групповой адресации передаваться по сети и следовательно каждому устройству, которое в состоянии связываться непосредственно с любым устройством в сегменте. Сеть множественного доступа является сетью, которая подключает больше чем два устройства. Обратитесь к Начальным конфигурациям для Ospf через среду трансляции для получения дополнительной информации.

  • Точка-точка (такой как последовательные соединения с точка-точка и High-Level Data Link Control (PPP/HDLC)) — сети с двухточечным соединением также позволяют широковещанию или пакетам групповой адресации передаваться по сети, и эти сети подключают только два устройства на сегменте. Обратитесь к Начальным конфигурациям для OSPF по Каналу типа точка-точка для получения дополнительной информации.

  • Нешироковещательный мультидоступ (NBMA), такой как сети Frame Relay — These не поддерживают широковещательные сообщения или многоадресные сообщения, но может подключить больше, чем устройства и мультидоступ в природе. Обратитесь к Начальным конфигурациям для OSPF по Нешироковещательным Ссылкам для получения дополнительной информации.

  • Точка - многоточка — Это - набор каналов типа точка-точка между различными устройствами на сегменте. Эти сети также позволяют широковещанию или пакетам групповой адресации передаваться по сети. Эти сети могут представлять сегмент множественного доступа как множественные каналы связи точка-точка, которые подключают все устройства на сегменте.

Когда OSPF выполнен в сети, два важных события происходят, прежде чем сведениями о маршрутизации обмениваются:

  • Соседние узлы обнаружены с помощью многоадресных пакетов запроса приветствия.

  • DR и BDR избраны для каждой сети множественного доступа для оптимизации процесса создания смежностей. Все маршрутизаторы в том сегменте должны быть в состоянии связаться непосредственно с DR и BDR для соответствующего соседства (в случае сети с двухточечным соединением, DR и BDR не необходимы, так как существует только два маршрутизатора в сегменте, и следовательно выборы не имеют место).

Для успешного обнаружения соседей на сегменте сеть должна позволить широковещательным сообщениям или пакетам групповой адресации передаваться.

В широковещательном мультиуровне доступа 2 топологии поддерживаются широковещательные сообщения; поэтому, маршрутизатор, который выполняет OSPF, может обнаружить окружения OSPF автоматически и выбрать любой маршрутизатор DR и BDR, так как любое устройство может говорить со всеми другими маршрутизаторами в том широковещательном сегменте.

В топологии с двухточечным соединением соседние узлы обнаружены автоматически, так как соседние узлы напрямую подключаются друг другу через канал типа точка-точка, и широковещание или пакеты групповой адресации переданы по сети; однако, DR и Выбор BDR не имеют место, как объяснено ранее.

В топологии сети NBMA, которая по существу нетранслируемая, соседи не обнаружены автоматически. OSPF пытается выбрать DR и BDR вследствие к характеру сети со множественным доступом сети, но сбои выборов, так как не обнаружены соседние узлы. Соседние узлы должны быть настроены вручную для преодоления этих проблем. Кроме того, дополнительная настройка необходима в топологии звезды, чтобы удостовериться, что маршрутизаторы концентратора, которые имеют подключение с любым маршрутизатором на конце луча, избраны DR и BDR. С другой стороны, вы можете изменить конфигурацию на интерфейсе NBMA для того, чтобы создать OSPF и надеяться, что это другой тип сети который не имеет таких проблем.

Корректная конфигурация необходима для правильной работы OSPF.

Подинтерфейсы Frame Relay могут работать в двух режимах:

  • Технология "точка-точка" подчиненный интерфейс типа точка-точка Frame Relay настроен, подинтерфейс эмулирует сеть с двухточечным соединением, и OSPF обрабатывает его как двухточечный тип сети.

  • Многоточечный — Когда многоточечный подчиненный интерфейс Frame Relay настроен, OSPF обрабатывает этот подинтерфейс как тип сети NBMA.

Программное обеспечение Cisco IOS использует команду ip ospf network , чтобы позволить гибкости выполненный OSPF на интерфейсе в других режимах:

ip ospf network {широковещание | нешироковещательный | {точка - многоточка [нешироковещательный] | точка-точка}}

Настраивать раздел этого документа содержит примеры конфигурации для OSPF по подчиненным интерфейс типа точка-точка Frame Relay, OSPF по многоточечным подчиненным интерфейс Frame Relay с широковещанием, нешироковещательным, и сети точка-многие точки.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

Этот документ использует сетевую установку, показанную здесь:

/image/gif/paws/13693/22a.gif

Конфигурации

Этот документ использует конфигурации, показанные в этом разделе.

Двухточечная конфигурация

R4-2503
interface Loopback0
      ip address 3.3.3.3 255.255.255.255
     !
     interface Serial0
      no ip address
      encapsulation frame-relay
     
!--- To enable Frame Relay encapsulation
 
     
!--- on the interface.


      no keepalive
     !
     interface Serial0.1 point-to-point
     
!--- The subinterface is configured to
 
     
!--- function as a point-to-point link
 
     
!--- with this command.

      ip address 1.1.1.2 255.255.255.0
      frame-relay interface-dlci 16   
     
!--- To assign a data-link connection identifier
 
     
!--- (DLCI) to a specified Frame Relay subinterface.

     
!--- Without this command,  all the DLCIs are assigned
 
     
!--- to the physical interface.

     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0
     !

R1-2503
interface Loopback0
      ip address 2.2.2.2 255.255.255.255
     !
     interface Serial0
      no ip address
      encapsulation frame-relay
     
!--- To enable Frame Relay encapsulation on
 
     
!--- the interface.

      no keepalive
      clockrate 2000000
     !
     interface Serial0.1 point-to-point
     
!--- The subinterface is configured to function
 
     
!--- as a point-to-point link with this command.

      ip address 1.1.1.1 255.255.255.0
      frame-relay interface-dlci 16  
     
!--- To assign a data-link connection identifier
 
     
!--- (DLCI) to a specified Frame Relay subinterface.
 
     
!--- Without this command, all the DLCIs are
 
     
!--- assigned to the physical interface.
 
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0
     !

Рекомендации по проверке для двухточечной конфигурации

Команды, выделенные здесь, полезны для проверки:

  • show ip ospf neighbor команда используется для показа информации об окружении OSPF.

  • show ip ospf interface команда используется для показа связанной с OSPF интерфейсной информации.

Выходные данные этих команд показывают здесь:

R4-2503# show ip ospf neighbor
      
     Neighbor ID  Pri   State      Dead Time   Address   Interface
     2.2.2.2        1   FULL/  -   00:00:33    1.1.1.1   Serial0.1

Примечание: В этих выходных данных состояние соседей OSPF показывают как "FULL / -", но не обозначено состояние DR и BDR. Это вызвано тем, что нет никакого DR и Выбора BDR на канале типа точка-точка.

R4-2503# show ip ospf interface s0 
     %OSPF: OSPF not enabled on Serial0

R4-2503# show ip ospf interface s0.1
     Serial0.1 is up, line protocol is up 
       Internet Address 1.1.1.2/24, Area 0 
       Process ID 1, Router ID 3.3.3.3, Network Type POINT_TO_POINT, Cost: 64
       Transmit Delay is 1 sec, State POINT_TO_POINT,
       Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
         oob-resync timeout 40
         Hello due in 00:00:09
	   Index 1/1, flood queue length 0
       Next 0x0(0)/0x0(0)
       Last flood scan length is 1, maximum is 1
       Last flood scan time is 0 msec, maximum is 0 msec	 
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 2.2.2.2
       Suppress hello for 0 neighbor(s)
	   
R1-2503# show ip ospf neighbor
      
     Neighbor ID   Pri   State      Dead Time   Address  Interface
     3.3.3.3         1   FULL/  -   00:00:37    1.1.1.2  Serial0.1 

R1-2503# show ip ospf interface s0
     %OSPF: OSPF not enabled on Serial0
     
R1-2503# show ip ospf interface s0.1
     Serial0.1 is up, line protocol is up 
       Internet Address 1.1.1.1/24, Area 0 
       Process ID 1, Router ID 2.2.2.2, Network Type POINT_TO_POINT, Cost: 64
       Transmit Delay is 1 sec, State POINT_TO_POINT,
       Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
         oob-resync timeout 40
         Hello due in 00:00:03
	   Index 1/1, flood queue length 0
       Next 0x0(0)/0x0(0)
       Last flood scan length is 1, maximum is 1
       Last flood scan time is 0 msec, maximum is 0 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 3.3.3.3
       Suppress hello for 0 neighbor(s)

Многоточечная конфигурация с широковещательной сетью

В этой конфигурации тип сети изменен для радиовещания с командой ip ospf network broadcast. Теперь, сеть NBMA просматривается как широковещательная сеть множественного доступа, где DR и Выбор BDR имеют место. Команды карты Frame Relay также собираются передать широковещательные адреса.

R4-2503
interface Loopback0
      ip address 3.3.3.3 255.255.255.255
     !
     interface Serial0
      no ip address
      encapsulation frame-relay
      no keepalive
     !
     interface Serial0.2 multipoint
     
!--- The subinterface is treated as a multipoint link.
 
      ip address 1.1.1.2 255.255.255.0
      ip ospf network broadcast
     
!--- This command is used to define the network
 
     
!--- type as broadcast. The network type is defined
 
     
!--- on non-broadcast networks so as to not configur
 
	    
!--- the neighbors explicitly.

      frame-relay map ip 1.1.1.1 16 broadcast
     
!--- To define the mapping between a destination
 
     
!--- protocol address and the data-link connection
 
     
!--- identifier (DLCI) used to connect to the
 
     
!--- destination address. The broadcast keyword
 
     
!--- is used to forward broadcasts and multicasts
 
     
!--- to this address.

     !
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0
     !

R1-2503
interface Loopback0
     ip address 2.2.2.2 255.255.255.255
     !
     !         
     interface Serial0
      no ip address
      encapsulation frame-relay
      no keepalive
      clockrate 2000000
     !
     interface Serial0.2 multipoint
     
!--- The subinterface is treated as a multipoint link.
 
      ip address 1.1.1.1 255.255.255.0
      ip ospf network broadcast
     
!--- This command is used to define the network
 
     
!--- type as broadcast. The network type is defined
 
     
!--- on non-broadcast networks so as not configure
 
     
!--- the neighbors explicitly.

      frame-relay map ip 1.1.1.2 16 broadcast
     
!--- To define the mapping between a
 
     
!--- destination protocol address and the data-link
 
     
!--- connection identifier (DLCI) used to connect
 
     
!--- to the destination address.  The broadcast
 
     
!--- keyword is used to forward broadcasts and multicasts

     
!--- to this address.

     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0
     !

Примечание: Если подинтерфейс настроен как точка-точка, тот же подинтерфейс не может быть повторно назначен как многоточечный подчиненный интерфейс, пока не повторно загружен маршрутизатор. В этом случае другой подчиненный интерфейс используется для многоточечной конфигурации.

Рекомендации по проверке для многоточечной конфигурации с широковещательной сетью

R4-2503# show ip ospf neighbor      
     Neighbor ID   Pri   State      Dead Time   Address   Interface
     2.2.2.2         1   FULL/BDR   00:00:32    1.1.1.1   Serial 0.2
     
R4-2503# show ip ospf interface s0
     %OSPF: OSPF not enabled on Serial0
     
R4-2503# show ip ospf interface s0.2
     Serial0.2 is up, line protocol is up 
       Internet Address 1.1.1.2/24, Area 0 
       Process ID 1, Router ID 3.3.3.3, Network Type BROADCAST, Cost: 64
       Transmit Delay is 1 sec, State DR, Priority 1
       Designated Router (ID) 3.3.3.3, Interface address 1.1.1.2
       Backup Designated router (ID) 2.2.2.2, Interface address 1.1.1.1
       Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
          oob-resync timeout 40         
          Hello due in 00:00:05
     Index 1/1, flood queue length 0
     Next 0x0(0)/0x0(0)
     Last flood scan length is 1, maximum is 1
     Last flood scan time is 0 msec, maximum is 0 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 2.2.2.2  (Backup Designated Router)
       Suppress hello for 0 neighbor(s)	   
R1-2503# show ip ospf neighbor
      
     Neighbor ID   Pri   State     Dead Time   Address   Interface
     3.3.3.3         1   FULL/DR   00:00:35    1.1.1.2   Serial0.2
     
R1-2503# show ip ospf interface s0
     %OSPF: OSPF not enabled on Serial0
     
R1-2503# show ip ospf interface s0.2
     Serial0.2 is up, line protocol is up 
       Internet Address 1.1.1.1/24, Area 0 
       Process ID 1, Router ID 2.2.2.2, Network Type BROADCAST, Cost: 64
       Transmit Delay is 1 sec, State BDR, Priority 1
       Designated Router (ID) 3.3.3.3, Interface address 1.1.1.2
       Backup Designated router (ID) 2.2.2.2, Interface address 1.1.1.1
       Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
          oob-resync timeout 40         
          Hello due in 00:00:01
      Index 1/1, flood queue length 0     
       Next 0x0(0)/0x0(0)     
       Last flood scan length is 1, maximum is 1     
       Last flood scan time is 0 msec, maximum is 0 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 3.3.3.3  (Designated Router)
       Suppress hello for 0 neighbor(s)

Многоточечная конфигурация с нешироковещательная сетью

В этой конфигурации сеть является нешироковещательной, который не позволяет соседним узлам быть обнаруженными автоматически. Соседняя команда используется для ручной настройки окружений OSPF. Однако эта команда необходима только с версиями программного обеспечения Cisco IOS ранее, чем 10.0. Как альтернативное решение, выполните команду ip ospf network для изменения типа сети по умолчанию (см. Многоточечную конфигурацию с примером конфигурации Широковещательной сети). Обратитесь к "Предотвращению DRs и соседнюю Команду на NBMA" раздел Руководства по проектированию OSPF для получения дополнительной информации. DR и BDR избраны из-за характера сети со множественным доступом.

R4-2503
interface Loopback0
      ip address 3.3.3.3 255.255.255.255
     !
     interface Serial0
      no ip address
      encapsulation frame-relay
      no keepalive
     !
     interface Serial0.2 multipoint
      ip address 1.1.1.2 255.255.255.0
      frame-relay map ip 1.1.1.1 16 broadcast
      ip ospf priority 2
      
!--- This command assigns a higher priority for this router on this interface,
      !--- so that it gets elected as the DR. In case of a Hub and Spoke topology,
      !--- the hub should be elected as the DR as it has connectivity to all the spokes.
 
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0
     !

R1-2503
interface Loopback0
      ip address 2.2.2.2 255.255.255.255
     !
     interface Serial0
      no ip address
      encapsulation frame-relay
      no keepalive
      clockrate 2000000
     !
     interface Serial0.2 multipoint
      ip address 1.1.1.1 255.255.255.0
      frame-relay map ip 1.1.1.2 16 broadcast
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0
      neighbor 1.1.1.2 

     
!--- Used to manually configure neighbors.

     

Рекомендации по проверке для многоточечной конфигурации с нешироковещательная сетью

R4-2503# show ip ospf neighbor
      
     Neighbor ID   Pri   State      Dead Time   Address   Interface
     2.2.2.2         1   FULL/BDR   00:01:56    1.1.1.1   Serial0.2
     
R4-2503# show ip ospf interface s0
     %OSPF: OSPF not enabled on Serial0
     
R4-2503# show ip ospf interface s0.2
     Serial0.2 is up, line protocol is up 
       Internet Address 1.1.1.2/24, Area 0 
       Process ID 1, Router ID 3.3.3.3, Network Type NON_BROADCAST, Cost: 64
       Transmit Delay is 1 sec, State DR,Priority 2
       Designated Router (ID) 3.3.3.3, Interface address 1.1.1.2
       Backup Designated router (ID) 2.2.2.2, Interface address 1.1.1.1
       Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
          oob-resync timeout 40         
          Hello due in 00:00:25
       Index 1/1, flood queue length 0     
        Next 0x0(0)/0x0(0)     
        Last flood scan length is 1, maximum is 1     
        Last flood scan time is 0 msec, maximum is 0 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 2.2.2.2  (Backup Designated Router)
       Suppress hello for 0 neighbor(s)	   
R1-2503# show ip ospf neighbor
      
     Neighbor ID   Pri   State      Dead Time   Address   Interface
     3.3.3.3         2   FULL/DR    00:01:52    1.1.1.2   Serial0.2
     
R1-2503# show ip ospf interface s0
     %OSPF: OSPF not enabled on Serial0
     
R1-2503# show ip ospf interface s0.2
     Serial0.2 is up, line protocol is up 
       Internet Address 1.1.1.1/24, Area 0 
       Process ID 1, Router ID 2.2.2.2, Network Type NON_BROADCAST, Cost: 64
       Transmit Delay is 1 sec, State BDR, Priority 1
       Designated Router (ID) 3.3.3.3, Interface address 1.1.1.2
       Backup Designated router (ID) 2.2.2.2, Interface address 1.1.1.1
       Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
          oob-resync timeout 40         
          Hello due in 00:00:01
       Index 1/1, flood queue length 0     Next 0x0(0)/0x0(0)     
       Last flood scan length is 1, maximum is 1
       Last flood scan time is 0 msec, maximum is 0 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 3.3.3.3  (Designated Router)
       Suppress hello for 0 neighbor(s)

Многоточечная конфигурация с сетью точка-многие точки

В этой конфигурации тип сети изменен с командой ip ospf network point-to-multipoint для функционирования как набор каналов типа точка-точка. Соседние узлы обнаружены автоматически и DR, и Выбор BDR не имеет место.

R4-2503
interface Loopback0
      ip address 3.3.3.3 255.255.255.255
     !
     interface Serial0
      no ip address
      encapsulation frame-relay
      no keepalive
     !
     interface Serial0.2 multipoint
      ip address 1.1.1.2 255.255.255.0
      ip ospf network point-to-multipoint
     
!--- To configure an interface as
!--- point-to-multipoint for non-broadcast media.
 
     
     frame-relay map ip 1.1.1.1 16 broadcast
     !
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0
     !

R1-2503
interface Loopback0
      ip address 2.2.2.2 255.255.255.255
     !
     interface Serial0
      no ip address
      encapsulation frame-relay
      no keepalive
      clockrate 2000000
     !
     interface Serial0.2 multipoint
      ip address 1.1.1.1 255.255.255.0
      ip ospf network point-to-multipoint
     
!--- To configure an interface as
 
     
!--- point-to-multipoint for non-broadcast media.

     frame-relay map ip 1.1.1.2 16 broadcast
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0
     !

Рекомендации по проверке для многоточечной конфигурации с сетью точка-многие точки

R4-2503# show ip ospf neighbor
      
     Neighbor ID   Pri   State      Dead Time   Address   Interface
     2.2.2.2         1   FULL/  -   00:01:58    1.1.1.1   Serial0.2
     
R4-2503# show ip ospf interface s0
   %OSPF: OSPF not enabled on Serial0
     
R4-2503# show ip ospf interface s0.2
     Serial2.1 is up, line protocol is up 
       Internet Address 1.1.1.2/24, Area 0 
       Process ID 1, Router ID 3.3.3.3, Network Type POINT_TO_MULTIPOINT, Cost: 64
       Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
       Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
          oob-resync timeout 40         
          Hello due in 00:00:07
      Index 1/1, flood queue length 0     
      Next 0x0(0)/0x0(0)     
      Last flood scan length is 1, maximum is 2     
      Last flood scan time is 0 msec, maximum is 0 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 2.2.2.2
       Suppress hello for 0 neighbor(s)
	   
R1-2503# show ip ospf neighbor
      
     Neighbor ID   Pri   State      Dead Time   Address   Interface
     3.3.3.3         1   FULL/  -   00:01:49    1.1.1.2   Serial0.2
     
R1-2503# show ip ospf interface s0 
     %OSPF: OSPF not enabled on Serial0
     
R1-2503# show ip ospf interface s0.2
     Serial0.2 is up, line protocol is up 
       Internet Address 1.1.1.1/24, Area 0 
       Process ID 1, Router ID 2.2.2.2, Network Type POINT_TO_MULTIPOINT, Cost: 64
       Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
       Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
          oob-resync timeout 40         
          Hello due in 00:00:00
        Index 1/1, flood queue length 0     
        Next 0x0(0)/0x0(0)     
        Last flood scan length is 1, maximum is 2     
        Last flood scan time is 0 msec, maximum is 0 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 3.3.3.3
       Suppress hello for 0 neighbor(s)

Проверка.

Для подтверждения конфигураций используйте подразделы, предоставленные в Настраивать разделе этого документа.

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Прежде чем вы решите любые связанные с окружением OSPF проблемы на сети NBMA, важно помнить, что сеть NBMA может быть настроена в этих режимах работы с командой ip ospf network:

  • Технология "точка-точка"

  • Точка - многоточка

  • Широковещание

  • NBMA

Hello и Интервалы простоя каждого режима описаны в этой таблице:

Тип сети Интервал приветствия (secs) Интервал простоя (secs)
Технология "точка-точка" 10 40
Точка - многоточка 30 120
Широковещание 10 40
Нешироковещательный 30 120

Когда OSPF настроен на физическом интерфейсе (например, интерфейсный S0) широковещательной мультитехнологии доступа non, такой как Frame Relay, тип сети по умолчанию NON_BROADCAST назначен. Когда OSPF настроен на подчиненных интерфейс типа точка-точка, тип интерфейса по умолчанию POINT_TO_POINT назначен. Когда OSPF настроен на многоточечных подчиненных интерфейс, тип интерфейса по умолчанию NON_BROADCAST назначен.

Когда сеть NBMA составлена из комбинации физических интерфейсов и логических интерфейсов (подинтерфейсы) на других маршрутизаторах, другие Типы сети OSPF играют роль. Несоответствия Hello, вероятно, произойдут в таких случаях; в результате соседства OSPF не сформированы.

Обратитесь к проблемам с Рабочим OSPF в РЕЖИМЕ NBMA по OSPF Frame Relay и Устранения проблем для получения дополнительной информации о том, как устранить неполадки OSPF.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 13693