Протокол IP : Протокол OSPF

Начальные настройки для протокола OSPF в нешироковещательных подключениях

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

В нешироковещательных системах, таких как Frame Relay, X.25, ATM и Switched Multimegabit Data Service (SMDS), протокол OSPF может работать в двух режимах:

Вы должны определить тип сети на нешироковещательных сетях для того чтобы воизбежать установления инструкций окружения. Ниже примеры конфигурации для OSPF по нешироковещательным ссылкам. Используйте команду show ip ospf interface проверить тип сети OSPF интерфейса, и команду show ip ospf, которая используется для определения статуса соседнего маршрутизатора.

Предварительные условия

Требования

Этот документ требует, чтобы вы поняли базовую конфигурацию протокола маршрутизации Протокола OSPF.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Маршрутизаторы Cisco 2500

  • Cisco Выпуск ПО IOS� 12.2 (24a) работающий на маршрутизаторах

Сведения, представленные в этом документе, были получены от устройств в специфической лабораторной среде. Все устройства, используемые в этом документе, были запущены с чистой конфигурацией (конфигурацией по умолчанию). При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Схема сети

Ниже схема сети, используемая в примерах конфигурации в этом документе.

/image/gif/paws/13690/18a_01.gif

Конфигурации для NBMA (с использованием широковещания сетевого типа)

Маршрутизатор 1
interface Loopback0
      ip address 3.3.3.3 255.255.255.255
     !
     !
     interface Serial2
      ip address 1.1.1.2 255.255.255.0
      encapsulation frame-relay
      ip ospf network broadcast
      no keepalive
      frame-relay map ip 1.1.1.1 16 broadcast
     !
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0

Маршрутизатор 2
interface Loopback0
      ip address 2.2.2.2 255.255.255.255
     !
     interface Serial1/0
      ip address 1.1.1.1 255.255.255.0
      encapsulation frame-relay
      ip ospf network broadcast
      no keepalive
      clockrate 2000000
      frame-relay map ip 1.1.1.2 16 broadcast
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0
     !

Советы по проверке

Ниже выходные данные команды show для Router1.

Router1# show ip ospf neighbor
      
     Neighbor ID     Pri   State           Dead Time   Address         Interface
     2.2.2.2           1   FULL/BDR        00:00:37    1.1.1.1         Serial2
     
Router1# show ip ospf interface s2
     Serial2 is up, line protocol is up 
       Internet Address 1.1.1.2/24, Area 0 
       Process ID 1, Router ID 3.3.3.3, Network Type BROADCAST, Cost: 64
       Transmit Delay is 1 sec, State DR, Priority 1 
       Designated Router (ID) 3.3.3.3, Interface address 1.1.1.2
       Backup Designated router (ID) 2.2.2.2, Interface address 1.1.1.1
       Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
         Hello due in 00:00:00
       Index 1/1, flood queue length 0
       Next 0x0(0)/0x0(0)
       Last flood scan length is 1, maximum is 2
       Last flood scan time is 0 msec, maximum is 4 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 2.2.2.2  (Backup Designated Router)
       Suppress hello for 0 neighbor(s)

И выходные данные для Router2 следующие.

Router2# show ip ospf neighbor
      
     Neighbor ID     Pri   State           Dead Time   Address         Interface
     3.3.3.3           1   FULL/DR         00:00:38     1.1.1.2         Serial1/0
     
Router2# show ip ospf interface s1/0
     Serial1/0 is up, line protocol is up 
       Internet Address 1.1.1.1/24, Area 0 
       Process ID 1, Router ID 2.2.2.2, Network Type BROADCAST, Cost: 64
       Transmit Delay is 1 sec, State BDR, Priority 1 
       Designated Router (ID) 3.3.3.3, Interface address 1.1.1.2
       Backup Designated router (ID) 2.2.2.2, Interface address 1.1.1.1
       Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
         Hello due in 00:00:03
       Index 1/1, flood queue length 0
       Next 0x0(0)/0x0(0)
       Last flood scan length is 1, maximum is 2
       Last flood scan time is 0 msec, maximum is 4 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 3.3.3.3  (Designated Router)
       Suppress hello for 0 neighbor(s)

Настройки для NBMA (с использованием утверждений соседей)

Маршрутизатор 1
interface Loopback0
      ip address 3.3.3.3 255.255.255.255
     !
     interface Serial2
      ip address 1.1.1.2 255.255.255.0
      encapsulation frame-relay
      ip ospf priority 2
      no keepalive
      frame-relay map ip 1.1.1.1 16
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0
      neighbor 1.1.1.1
     !

Маршрутизатор 2
interface Loopback0
      ip address 2.2.2.2 255.255.255.255
     !
     interface Serial1/0
      ip address 1.1.1.1 255.255.255.0
      encapsulation frame-relay
      no keepalive
      clockrate 2000000
      frame-relay map ip 1.1.1.2 16
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0
      neighbor 1.1.1.2
     !

Примечание: В конфигурациях, показанных выше, ip ospf priority, 2 команды на Router1 устанавливают более высокий приоритет интерфейса, чем значение приоритета по умолчанию 1, который делает его DR и Router2 BDR для сети NBMA. В случае необходимости можно заставить значение приоритета в 0 настраивать маршрутизатор, чтобы никогда стать DR/BDR. Это особенно важно в хабе и споук-сетях, и споук-сетях, где хаб должен быть настроен чтобы стать DR, и как споуки не должны быть ни DR, ни BDR. Хотя настройка инструкции окружения на одном конце достаточна для формирования смежности, это - полезный прием для настраивания его на обоих концы как показано. Также, командам frame relay map не нужно иметь параметр передачи потому, что пакеты OSPF однонаправлены с инструкцией окружения.

Советы по проверке

Ниже выходные данные команды show для Router1.

Router1# show ip ospf neighbors
      
     Neighbor ID     Pri   State           Dead Time   Address         Interface
     2.2.2.2           1   FULL/BDR        00:01:39    1.1.1.1         Serial2
     
Router1# show ip ospf interface s2
     Serial2 is up, line protocol is up 
       Internet Address 1.1.1.2/24, Area 0 
       Process ID 1, Router ID 3.3.3.3, Network Type NON_BROADCAST, Cost: 64
       Transmit Delay is 1 sec, State DR, Priority 1 
       Designated Router (ID) 3.3.3.3, Interface address 1.1.1.2
       Backup Designated router (ID) 2.2.2.2, Interface address 1.1.1.1
       Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
         Hello due in 00:00:19
       Index 1/1, flood queue length 0
       Next 0x0(0)/0x0(0)
       Last flood scan length is 2, maximum is 2
       Last flood scan time is 0 msec, maximum is 0 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 2.2.2.2  (Backup Designated Router)
       Suppress hello for 0 neighbor(s)

И выходные данные для Router2 следующие.

Router2# show ip ospf neighbor
      
     Neighbor ID     Pri   State           Dead Time   Address         Interface
     3.3.3.3           1   FULL/DR         00:01:49     1.1.1.2         Serial1/0
     
Router2# show ip ospf interface s1/0
     Serial1/0 is up, line protocol is up 
       Internet Address 1.1.1.1/24, Area 0 
       Process ID 1, Router ID 2.2.2.2, Network Type NON_BROADCAST, Cost: 64
       Transmit Delay is 1 sec, State BDR, Priority 1 
       Designated Router (ID) 3.3.3.3, Interface address 1.1.1.2
       Backup Designated router (ID) 2.2.2.2, Interface address 1.1.1.1
       Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
         Hello due in 00:00:01
       Index 1/1, flood queue length 0
       Next 0x0(0)/0x0(0)
       Last flood scan length is 2, maximum is 2
       Last flood scan time is 0 msec, maximum is 0 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 3.3.3.3  (Designated Router)
       Suppress hello for 0 neighbor(s)

Конфигурации соединений типа «точка-много точек»

Маршрутизатор 1
interface Loopback0
      ip address 3.3.3.3 255.255.255.255
     !
     interface Serial2
      ip address 1.1.1.2 255.255.255.0
      encapsulation frame-relay
      ip ospf network point-to-multipoint
      no keepalive
      frame-relay map ip 1.1.1.1 16 broadcast
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0
     !

Маршрутизатор 2
interface Loopback0
      ip address 2.2.2.2 255.255.255.255
     !
     interface Serial1/0
      ip address 1.1.1.1 255.255.255.0
      encapsulation frame-relay
      ip ospf network point-to-multipoint
      no keepalive
      clockrate 2000000
      frame-relay map ip 1.1.1.2 16 broadcast
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0

Советы по проверке

Ниже выходные данные команды show для Router1.

Router1# show ip ospf neighbors
      
     Neighbor ID     Pri   State           Dead Time   Address         Interface
     2.2.2.2           1   FULL/  -        00:01:53    1.1.1.1         Serial2
     
Router1# show ip ospf interface s2
     Serial2 is up, line protocol is up 
       Internet Address 1.1.1.2/24, Area 0 
       Process ID 1, Router ID 3.3.3.3, Network Type POINT_TO_MULTIPOINT, Cost: 64
       Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
       Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
         Hello due in 00:00:18
       Index 1/1, flood queue length 0
       Next 0x0(0)/0x0(0)
       Last flood scan length is 1, maximum is 1
       Last flood scan time is 0 msec, maximum is 0 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 2.2.2.2
       Suppress hello for 0 neighbor(s)

И выходные данные для Router2 следующие.

Router2# show ip ospf neighbor
      
     Neighbor ID     Pri   State           Dead Time   Address         Interface
     3.3.3.3           1   FULL/  -        00:01:58     1.1.1.2         Serial1/0

Router2# show ip ospf interface s1/0
     Serial1/0 is up, line protocol is up 
       Internet Address 1.1.1.1/24, Area 0 
       Process ID 1, Router ID 2.2.2.2, Network Type POINT_TO_MULTIPOINT, Cost: 64
       Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
       Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
         Hello due in 00:00:18
       Index 1/1, flood queue length 0
       Next 0x0(0)/0x0(0)
       Last flood scan length is 1, maximum is 1
       Last flood scan time is 0 msec, maximum is 0 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 3.3.3.3
       Suppress hello for 0 neighbor(s)

Примечание: Нет никакого DR и BDR, избранного, когда сеть NBMA настроена как Точка - многоточка как показано в выходных данных, так как это обработано как набор каналов типа точка-точка.

Для получения дополнительной информации посмотрите OSPF Настройки по Другим Физическим сетям.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 13690