Протокол IP : Протокол OSPF

Начальные конфигурации для OSPF в двухточечных подключениях

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

В каналах типа точка-точка, таких как Высокоуровневое Управление Каналом Передачи Данных (HDLC) и протокол точка-точка (PPP), процесс OSPF запускается как двухточечный тип сети. Данный тип сети используется по умолчанию. В этом документе иллюстрируется пример конфигураций для OSPF через канал связи "точка-точка". Другие виды сетей, поддерживаемые OSPF — точка-многоточка, широковещательная сеть и нешироковещательная сеть. Для определения типа сети на интерфейсе с OSPF, выполните команду show ip ospf interface.

Примеры, объясненные в этом документе, работают и с HDLC и с инкапсуляциями PPP.

Предварительные условия

Требования

У читателей данной документации должны быть некоторые базовые знания о протоколе маршрутизации OSPF. Для получения дополнительной информации о протоколе маршрутизации OSPF обратитесь к Открытому Кратчайшему пути Первую документацию.

Используемые компоненты

Сведения в этом документе применяются к этим версиям программного и аппаратного обеспечения.

  • Маршрутизаторы Cisco 2500

  • Выпуск ПО IOS� Cisco 12.2 (27), который работает на маршрутизаторах

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

OSPF по каналу типа точка-точка с IP-адресами на последовательных интерфейсах

Этот раздел предоставляет вам информацию, которую можно использовать для настройки маршрутизаторов, которые выполняют OSPF и связаны через последовательный двухточечный канал с использованием инкапсуляции HDLC с IP-адресами, настроенными на последовательных интерфейсах.

Примечание: Для обнаружения дополнительных сведений об использовании этого документа команд используйте Средство поиска команд Command Lookup Tool (только зарегистрированные клиенты).

Схема сети

/image/gif/paws/13687/15a.gif

Конфигурации

В этом разделе используются следующие конфигурации.

Маршрутизатор 1
Router1
!
interface Loopback0
� ip address 3.3.3.3 255.255.255.255
!
interface Serial0
�ip address 1.1.1.2 255.255.255.0
!
router ospf 1
network 1.1.1.0 0.0.0.255 area 0

!--- Configures the Serial Interface S0 under OSPF area 0.

!

Router-2
Router2
!
interface Loopback0
�ip address 2.2.2.2 255.255.255.255
!
interface Serial0
�ip address 1.1.1.1 255.255.255.0
�clockrate 2000000
!
router ospf 1
network 1.1.1.0 0.0.0.255 area 0

!--- Configures the Serial Interface S0 under OSPF area 0..

OSPF по каналу типа точка-точка с ненумерованными интерфейсами

Этот раздел предоставляет вам информацию, которую можно использовать для настройки маршрутизаторов, которые выполняют OSPF как протокол маршрутизации и связаны через последовательный двухточечный канал с инкапсуляцией PPP и с Ненумерованными последовательными интерфейсами. Ненумерованные последовательные интерфейсы являются интерфейсами, которые не имеют их собственного IP-адреса. Эти интерфейсы одалживают IP-адрес у другого интерфейса на маршрутизаторе, которому настроили IP-адрес. Для получения дополнительной информации о Ненумерованных последовательных интерфейсах обратитесь к Пониманию и Настройке команду ip unnumbered.

Примечание: Для обнаружения дополнительных сведений об использовании этого документа команд используйте Средство поиска команд Command Lookup Tool (только зарегистрированные клиенты).

Схема сети

/image/gif/paws/13687/15b.gif

Конфигурации

В этом разделе используются следующие конфигурации.

Маршрутизатор 1
!

interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface Serial0
 ip unnumbered loopback 0

!--- Configures Serial 0 as an unnumbered interface.

 encapsulation ppp

!--- Configures the Encapsulation on the interface as PPP.

!
router ospf 1
  network 3.3.3.0 0.0.0.255 area 0

!--- Configures the Loopback Interface L0 under OSPF area 0.

!

Router-2
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial0
 ip unnumbered loopback 0

!--- Configures Serial 0 as an unnumbered interface.

 encapsulation ppp

!--- Configures the Encapsulation on the interface as PPP.

!
router ospf 1
  network 2.2.2.0 0.0.0.255 area 0

!--- Configures the Loopback Interface L0 under OSPF area 0..

!

Проверка

Этот раздел предоставляет сведения, можно использовать, чтобы подтвердить, что должным образом работает конфигурация.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Проверьте конфигурацию OSPF с IP-адресами на последовательных интерфейсах

Это - выходные данные команды show ip ospf neighbor, выполненные на Router1.

Router1#show ip ospf neighbor
   Neighbor ID   Pri   State       Dead Time       Address        Interface
     2.2.2.2      1   FULL/ -       00:00:32       1.1.1.1         Serial 0

Эти выходные данные показывают, что Router1 имеет один соседний узел с Идентификатором маршрутизатора 2.2.2.2 и сформировал полную смежность с этим соседним узлом. Адресом 1.1.1.1 является IP-адрес интерфейса Serial0 на Router2.

Для дополнительных сведений о команде show ip ospf neighbor обратитесь к тому, Что Показывает Команда show ip ospf neighbor?

Это - выходные данные команды show ip ospf interface serial 0 на Router1. Эти выходные данные показывают Тип сети OSPF для интерфейсного Serial0 как точка-точка.

Router1# show ip ospf interface serial 0 
   Serial0 is up, line protocol is up 
   Internet Address 1.1.1.2/24, Area 0 
   Process ID 1, Router ID 3.3.3.3, Network Type POINT_TO_POINT, Cost: 64
   Transmit Delay is 1 sec, State POINT_TO_POINT,
   Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
   Hello due in 00:00:05
   Index 1/1, flood queue length 0
   Next 0x0(0)/0x0(0)
   Last flood scan length is 1, maximum is 1
   Last flood scan time is 0 msec, maximum is 0 msec
   Neighbor Count is 1, Adjacent neighbor count is 1 
   Adjacent with neighbor 2.2.2.2
   Suppress hello for 0 neighbor(s)

Точно так же данный пример отображает выходные данные для show ip ospf neighbor и команд show ip ospf interface на Router2.

Router2# show ip ospf neighbor
   Neighbor ID     Pri    State     Dead Time     Address      Interface
    3.3.3.3         1     FULL/ -    00:00:32      1.1.1.2      Serial0

Router2# show ip ospf interface serial 0
   Serial0 is up, line protocol is up 
   Internet Address 1.1.1.1/24, Area 0 
   Process ID 1, Router ID 2.2.2.2, Network Type POINT_TO_POINT, Cost: 64
   Transmit Delay is 1 sec, State POINT_TO_POINT,
   Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:05
   Index 1/1, flood queue length 0
   Next 0x0(0)/0x0(0)
   Last flood scan length is 1, maximum is 1
   Last flood scan time is 0 msec, maximum is 0 msec
   Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 3.3.3.3
   Suppress hello for 0 neighbor(s)

Проверьте конфигурацию OSPF с ненумерованными интерфейсами

Команда show ip ospf neighbor на маршрутизаторах Router1 и Router2 подтверждает полную смежность. Эти выходные данные показывают Тип сети OSPF для интерфейсного Serial0 как точка-точка. Можно также видеть, что интернет-адрес 0.0.0.0 для последовательного интерфейса на обоих маршрутизаторах. Это вызвано тем, что IP-адрес одолжен от интерфейса обратной связи (в этом случае) на основании команды ip unnumbered.

Router1#show ip ospf neighbor
      Neighbor ID  Pri   State    Dead Time    Address      Interface
      2.2.2.2      1   FULL/ -    00:00:37    2.2.2.2       Serial0

Router1# show ip ospf interface serial 0
Serial0 is up, line protocol is up
  Internet Address 0.0.0.0/24, Area 0
  Process ID 1, Router ID 3.3.3.3, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:08
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 2.2.2.2
  Suppress hello for 0 neighbor(s)

Данный пример отображает выходные данные команд show ip ospf neighbor и show ip ospf interface serial 0 на Router2.

Router2#show ip ospf neighbor
      Neighbor ID   Pri   State   Dead Time   Address   Interface
      3.3.3.3        1   FULL/ -  00:00:30    3.3.3.3    Serial0

Router2# show ip ospf interface serial 0
Serial0 is up, line protocol is up
  Internet Address 0.0.0.0/24, Area 0
  Process ID 1, Router ID 2.2.2.2, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:08
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 3.3.3.3
  Suppress hello for 0 neighbor(s)

Данный пример показывает выходные данные команды show ip route на Router1 с encapsulation PPP и использованием ненумерованных интерфейсов.

Router1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Serial0
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback0

Данный пример отображает выходные данные команды show ip route на маршрутизаторе 2 с encapsulation PPP и использованием ненумерованных интерфейсов.

Router2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Serial0

Данный пример отображает выходные данные команды show ip route на Router1 с encapsulation HDLC и использованием ненумерованных интерфейсов.

Router1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 2.2.2.2, 00:00:08, Serial0
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback0

Данный пример отображает выходные данные команды show ip route на Router2 с encapsulation HDLC и использованием ненумерованных интерфейсов.

Router1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

        2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
     3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/65] via 3.3.3.3, 00:01:28, Serial0

Примечание: Когда ненумерованная конфигурация IP используется на последовательных интерфейсах, выходные данные команды show ip route могли бы отличаться между PPP и инкапсуляциями HDLC. PPP устанавливает маршрут хоста к IP-адресу, который используется на последовательном интерфейсе в другом конце как непосредственно связанная сеть. Если тот же префикс также изучен через OSPF как в этой конфигурации, это отображается только как связанный маршрут (поскольку эти выходные данные show ip route показывают). Это вызвано тем, что связанные маршруты имеют меньшее административное расстояние, чем OSPF и более предпочтены. Можно изменить это поведение при запуске команды no peer neighbor-route под последовательными интерфейсами, которая препятствует тому, чтобы маршрут хоста был установлен, и рассматривает его как маршрут OSPF.

Дело обстоит не так с HDLC, потому что это не устанавливает маршрут хоста. Когда ненумерованный IP используется, HDLC устанавливает маршрут OSPF для адреса на другом конце.

Устранение неполадок

Для получения информации о том, как решить проблемы OSPF, обратитесь к Устранению проблем OSPF.


Дополнительные сведения


Document ID: 13687