Протокол IP : Протокол OSPF

Часто встречающаяся проблема маршрутизации с адресом пересылки OSPF

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

В этом документе описываются понятия и проблемы, связанные с адресом пересылки в протоколе OSPF. См. документ: «Почему некоторые маршруты OSPF присутствуют в базе данных, но не в таблице маршрутизации?»? для получения дополнительной информации по устранению неполадок для протокола OSPF.

Проблема, объясненная в этом документе, только заметна с Cisco Выпуски ПО IOS� ранее, чем 12.1 (3). Поведение при перераспределении изменилось в Cisco IOS Software Release 12.1 (3) и позднее. Для получения дополнительной информации обратитесь к идентификатору ошибки Cisco CSCdp72526 (только зарегистрированные клиенты). Для этого дефекта есть список релизов программного обеспечения Cisco IOS с поврежденными и исправленными версиями. Также обратитесь к Перераспределению Связанных сетей в OSPF, где объяснено изменение в поведении Cisco IOS.

Предварительные условия

Требования

Для использования данного документа требуется знание следующих тем:

  • Основные IP-маршрутизации.

  • Основные понятия и термины протокола маршрутизации OSPF.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Маршрутизаторы Cisco 2503

  • Cisco Выпуск ПО IOS� 12.2 (24a) работающий на всех маршрутизаторах

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Описание адреса пересылки OSPF

Когда трафик маршрутизируется к внешней автономной системе (AS), как показано на этом рисунке, понятие адреса пересылки OSPF было представлено для предотвращения дополнительных переходов.

/image/gif/paws/13682/10a.gif

На рисунке показаны два маршрутизатора из домена OSFP, которые подсоединяются к внешнему домену. Однако только Маршрутизатор 1 обменивается сведениями о маршрутизации с Маршрутизатором 100. Маршрутизатор 1 перераспределяет информацию, изученную из Маршрутизатора 100 в OSPF, и объявляет информацию к остатку домена OSPF. При этом маршрутизатор 1 становится следующим узлом (или адресом пересылки) для информации, которую он преобразует в домен OSPF. Когда Маршрутизатор 2 получает пакет от домена OSPF, предназначенного для адреса во внешнем домене, это передает пакет к Маршрутизатору 1. Маршрутизатор 1 тогда вперед это к Маршрутизатору 100. Понятие адреса пересылки позволяет этому дополнительному переходу избежаться, потому что это позволяет Маршрутизатору 1 задавать IP-адрес другого маршрутизатора как адрес пересылки. На рисунке Маршрутизатор 1 может задать Маршрутизатор 100 как адрес пересылки для внешней информации, которую Маршрутизатор 1 перераспределяет в домен OSPF. Когда Маршрутизатор 2 получает пакет от домена OSPF, предназначенного для адреса во внешнем домене, это передает пакет к Маршрутизатору 100. В результате устраняется дополнительный "прыжок" через маршрутизатор 1.

Значение адреса пересылки, заданного граничным маршрутизатором автономной системы (ASBR) (Маршрутизатор 1 на предыдущем рисунке), может быть или 0.0.0.0 или ненулевое. Адрес 0.0.0.0 означает, что исходный маршрутизатор (ASBR) является следующим узлом. Адрес пересылки определен этими условиями:

  • Адрес пересылки установлен в 0.0.0.0, если ASBR перераспределяет маршруты, и OSPF не включен на интерфейсе следующего маршрутизатора для тех маршрутов. Если Маршрутизатору 1 не включали OSPF на Интерфейсе Ethernet, это истинно на рисунке.

  • Эти условия устанавливают поле адреса пересылки в ненулевой адрес:

    • OSPF включен на интерфейсе следующего маршрутизатора ASBR AND

    • Интерфейс следующего маршрутизатора ASBR непассивен под OSPF AND

    • Интерфейсом следующего маршрутизатора ASBR не является AND "точка-точка"

    • Интерфейсом следующего маршрутизатора ASBR не является AND точка - много точек

    • Адрес интерфейса следующего маршрутизатора ASBR подпадает под диапазон сети, заданный в команде router ospf.

  • Все другие условия, помимо этих, устанавливают адрес переадресации в 0.0.0.0.

Для информации о том, как адрес пересылки задается и влияет на выбор пути, см. Влияния адреса пересылки на выбор пути Type 5 LSA.

Типичные проблемы маршрутизации OSPF, связанные с адресом пересылки

/image/gif/paws/13682/10b_01.gif

Маршрутизатор R2513, который работает только на RIP (и может быть присоединен к сети RIP-only), добавлен к сети Token Ring в диаграмме. Когда маршрутизаторы, определенные в R2513, перераспределяются в сети OSPF с помощью ASBR (R2515), некоторые маршруты не устанавливаются в таблицу маршрутизации определенных маршрутизаторов. Информация о соответствующей конфигурации каждого из маршрутизаторов дана в этих таблицах.

hostname R2504
interface Serial0
ip address 1.1.1.2 255.255.255.0
         
interface TokenRing0
ip address 3.3.4.2 255.255.255.0
         
router ospf 1
network 1.1.1.0 0.0.0.255 area 0
network 3.0.0.0 0.255.255.255 area 1
area 1 range 3.0.0.0 255.0.0.0

имя хоста R2507
interface Serial0
ip address 1.1.1.1 255.255.255.0
         
interface Serial1
ip address 7.7.7.1 255.255.255.0
         
router ospf 1
network 1.1.1.1 0.0.0.0 area 0
default- information originate metric 20
         
ip route 0.0.0.0 0.0.0.0 Serial1 

hostname R2513
interface TokenRing0
ip address 3.3.4.4 255.255.255.0
       
interface ethernet 0
ip address 200.1.1.4 255.255.255.0
       
router rip
network 3.0.0.0
network 200.1.1.0

имя узла R2515
interface TokenRing0
ip address 3.3.4.3 255.255.255.0
       
interface ethernet 0
ip address 3.44.66.3 255.255.255.0
       
interface ethernet 1
ip address 3.22.88.3 255.255.255.0
       
router ospf 1
redistribute rip metric 20 subnets
network 0.0.0.0 255.255.255.255 area 1
       
router rip
network 3.0.0.0

passive-interface ethernet 0
passive-interface ethernet 1

Конфигурации в таблице показывают, что R2515 перераспределяет RIP в OSPF и что R2504 (маршрутизатор area border router [ABR]) создает сводную сеть 3.0.0.0/8.

Это таблицы маршрутизации для каждого из включенных маршрутизаторов OSPF:

R2507# 
show ip route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0
         1.0.0.0/ 24 is subnetted, 1 subnets
C          1.1.1.0 is directly connected, Serial0
         3.0.0.0/ 8 is variably subnetted, 4 subnets, 2 masks
O IA        3.0.0.0/ 8 [110/ 70] via 1.1.1.2, 00: 15: 37, Serial0
O E2        3.3.4.0/ 24 [110/ 20] via 1.1.1.2, 00: 06: 37, Serial0
O E2        3.22.88.0/ 24 [110/ 20] via 1.1.1.2, 00: 06: 37, Serial0
O E2        3.44.66.0/ 24 [110/ 20] via 1.1.1.2, 00: 06: 37, Serial0
          7.0.0.0/ 24 is subnetted, 1 subnets
C           7.7.7.0 is directly connected, Serial1
S*     0.0.0.0/ 0 is directly connected, Serial1


R2504# show ip route
Gateway of last resort is 1.1.1.1 to network 0.0.0.0
            1.0.0.0/ 24 is subnetted, 1 subnets
C             1.1.1.0 is directly connected, Serial0
            3.0.0.0/ 8 is variably subnetted, 4 subnets, 2 masks
S             3.0.0.0/ 8 is directly connected, Null0
C             3.3.4.0/ 24 is directly connected, TokenRing0
O             3.22.88.0/ 24 [110/ 11117] via 3.3.4.3, 00: 15: 16, TokenRing0
O             3.44.66.0/ 24 [110/ 11117] via 3.3.4.3, 00: 15: 16, TokenRing0
O  E2 200.1.1.0/ 24 [110/ 20] via 3.3.4.4, 00: 06: 16, TokenRing0
O* E2 0.0.0.0/ 0 [110/ 20] via 1.1.1.1, 00: 15: 16, Serial0

R2515# show ip route
 Gateway of last resort is 3.3.4.2 to network 0.0.0.0
            1.0.0.0/ 24 is subnetted, 1 subnets
 O IA         1.1.1.0 [110/ 70] via 3.3.4.2, 00: 10: 28, TokenRing0
            3.0.0.0/ 24 is subnetted, 3 subnets
 C            3.3.4.0 is directly connected, TokenRing0
 R          200.1.1.0/ 24 [120/ 1] via 3.3.4.4, 00: 00: 10, TokenRing0
 O* E2 0.0.0.0/ 0 [110/ 20] via 3.3.4.2, 00: 10: 28, TokenRing0

Отсутствие сети в таблице маршрутизации

R2515 имеет полученный маршрут RIP(R) для сети 200.1.1.0/24. R2515 является ASBR и перераспределяет протокол RIP в OSPF. R2504 учится о сети 200.1.1.0/24 от R2515 и устанавливает его в своей таблице маршрутизации как Внешний тип ospf 2 (E2) маршрут. Проблема состоит в том, что у R2507 нет сети 200.1.1.0/24 в его таблице маршрутизации.

R2507 имеет внешние маршруты для сетей 3.3.4.0/24, 3.22.88.0/24 и 3.44.66.0/24, даже при том, что все эти сети должны быть включены в сводку 3.0.0.0/8.

Причина, которую разоблачают эти внешние маршруты, состоит в том, что ASBR, который перераспределяет RIP в OSPF, имеет RIP, работающий на этих трех подсетях. Это поэтому перераспределяет подсети как внешние маршруты в OSPF. Так как эти подсети являются внешними маршрутами, они не суммированы ABR (R2504). Внешние маршруты OSPF могут только быть суммированы ASBR. В этом случае, R2515. ABR суммирует только внутренние маршруты OSPF от области 1 в область 0.

Примечание: С исправлением идентификатора ошибки Cisco CSCdp72526 (только зарегистрированные клиенты) OSPF не генерирует описание локального состояния соединениий (LSA) type-5 перекрытой внешней сети. R2507 только имеет итоговый межобластной маршрут 3.0.0.0/8. После этого, R2507 устанавливает 200.1.1.0/24, как адрес пересылки, и он доступен через межобластной маршрут 3.0.0.0/8. Это соответствует RFC 2328 leavingcisco.com.

Эти выходные данные показывают внешний LSA для сети 200.1.1.0/24 в базе данных OSPF R2507:

R2507# 
show ip ospf data external 200.1.1.0

       OSPF Router with ID (7.7.7.1) (Process ID 1)
       Type- 5 AS External Link States
       LS age: 72
       Options: (No TOS- capability, DC)
       LS Type: AS External Link
       Link State ID: 200.1.1.0 (External Network Number )
       Advertising Router: 3.44.66.3
       LS Seq Number: 80000001
       Checksum: 0xF161
       Length: 36
       Network Mask: /24
                   Metric Type: 2 (Larger than any link state path)
                   TOS: 0
                   Metric: 20
                   Forward Address: 3.3.4.4
                   External Route Tag: 0

OSPF позволяет ASBR задавать другой маршрутизатор как адрес пересылки к внешним маршрутам. В этом случае ASBR (R2515) задает 3.3.4.4 в качестве адреса пересылки для внешней сети 200.1.1.0.

RFC 2328 leavingcisco.com, разделите 16.4 (Вычисление внешних маршрутов AS), состояния:

"Если адрес пересылки является ненулевым, поиск адрес пересылки в таблице маршрутизации. Соответствующая запись таблицы маршрутизации должна задать внутри-областной путь или путь промежуточной области; если никакой такой путь не существует, ничего не сделайте с LSA и рассмотрите следующее в списке".

В данном примере маршрут к адресу пересылки 3.3.4.4 показывают здесь:

R2507# 
show ip route 3.3.4.4

       Routing entry for 3.3.4.0/ 24
           Known via "ospf 1", distance 110, metric 20,type extern 2, forward metric 70
           Redistributing via ospf 1
           Last update from 1.1.1.2 on Serial0, 00: 00: 40 ago
           Routing Descriptor Blocks:
           * 1.1.1.2, from 3.44.66.3, 00: 00: 40 ago, via Serial0
              Route metric is 20, traffic share count is 1

С адресом пересылки 3.3.4.4 совпадает внешний маршрут 3.3.4.0/24 вместо объединенного маршрута промежуточной области 3.0.0.0/8 из-за самого длинного правила соответствия. Поскольку маршрутизатор не имеет внутреннего маршрута OSPF к адресу пересылки, он не устанавливает внешний маршрут 200.1.1.0/24 в таблице маршрутизации. Использование внешнего маршрута для достижения другого внешнего маршрута может привести к петлям. Поэтому OSPF не разрешает его.

Не суммируйте на ABR

Как можно гарантировать, что ненулевой адрес пересылки существует в таблице маршрутизации как внутри-областное или межобластной маршрут?

Первое решение не состоит в том, чтобы суммировать на ABR.

Второе решение не состоит в том, чтобы настроить тип LSA 3 фильтрования. Если тип, 3 маршрута фильтрованы, Адрес пересылки, который появляется на выходных данных команды show ip ospf database external, не достижим. Это делает внешнюю сеть недостижимой. В этом случае, R2504. Это заставляет маршрутизаторы в области 0 иметь межобластные маршруты (вместо внешних маршрутов) для всех определенных подсетей в других областях.

Используйте эти команды для удаления суммирования на ABR:

R2504(config)# 
router ospf 1

R2504(config- router)# no area 1 range 3.0.0.0 255.0.0.0

Результаты этой команды в таблице маршрутизации на R2507 показывают здесь:

R2507# show ip route
       Gateway of last resort is 0.0.0.0 to network 0.0.0.0
                 1.0.0.0/ 24 is subnetted,        1 subnets
       C            1.1.1.0        is directly connected, Serial0
                 3.0.0.0/ 24 is subnetted,        3 subnets
       O IA      3.3.4.0 [110/ 70] via 1.1.1.2, 00: 00:        48, Serial0
       O IA      3.22.88.0 [110/ 80] via 1.1.1.2, 00:        00: 48, Serial0
       O IA      3.44.66.0 [110/ 80] via 1.1.1.2, 00:        00: 48, Serial0
                 7.0.0.0/ 24 is subnetted,        1 subnets
       C           7.7.7.0 is        directly connected, Serial1
       O E2 200.1.1.0/ 24 [110/ 20] via 1.1.1.2, 00: 00: 48, Serial0
       S*     0.0.0.0/ 0 is directly connected, Serial1
	   
	  R2507# show ip route 3.3.4.4
     Routing entry for 3.3.4.0/24
      Known via "ospf 1", distance 110, metric 70, type inter area
      Last update from 1.1.1.2 on Serial1, 00:03:52 ago
      Routing Descriptor Blocks:
      * 1.1.1.2, from 3.3.4.2, 00:03:52 ago, via Serial1
          Route metric is 74, traffic share count is 1

От выходных данных вы видите, что адрес 3.3.4.4 достижим через межобластной маршрут к сети 3.3.4.0/24. Маршрутизатор R2507 изучает маршрут этой сети и через LSA Type-5 и через LSA Type-3, после того, как будет удалено суммирование на ABR R2504. Так как OSPF предпочитает межобластной маршрут по внешнему маршруту к той же сети, он устанавливает его как межобластной маршрут. Синус R2507 теперь имеет межобластной маршрут к адресу пересылки 3.3.4,4, внешняя сеть 200.1.1.0/24, также установлен в ее таблице маршрутизации.

Примечание: Если NSSA (Не Так Плотная область) будет использоваться и если тип, 3 фильтрования LSA сделано на ABR NSSA, то тот же недостижимый Адрес пересылки проблемы будет существовать.

Не допускайте перераспределение подсети на OSPF в качестве внешнего маршрута

Другое решение состоит в том, чтобы предотвратить подсеть 3.3.4.0 от того, чтобы быть перераспределенным в OSPF как внешний маршрут, так как OSPF работает на нем. Эти команды настройки в ASBR (R2515) создают route-map. Это используется перераспределять командой, чтобы позволить только сети 200.1.1.0/24 быть перераспределенной в OSPF. ABR (R2504) все еще суммирует внутренние маршруты OSPF от области 1 в область 0.

R2515# configure terminal
R2515(config)# router ospf 1
R2515(config-router)# redistribute rip metric 20 subnets route-map rip_to_ospf_filter
R2515(config-router)# exit
   
R2515(config)# 
access-list 28 permit 200.1.1.0 0.0.0.255
   
R2515(config)# 
route-map rip_to_ospf_filter permit 10
R2515(config-route-map)# 
match ip address 28

Результаты этой команды в таблице маршрутизации на R2507 показывают здесь:

R2507# show ip route
       Gateway of last resort is 0.0.0.0 to network 0.0.0.0
                 1.0.0.0/ 24 is subnetted,        1 subnets
       C            1.1.1.0        is directly connected, Serial0
       O IA  3.0.0.0/ 8 [110/ 70] via 1.1.1.2, 00: 07: 05, Serial0
                 7.0.0.0/ 24 is subnetted,        1 subnets
       C            7.7.7.0        is directly connected, Ethernet0
       O E2  200.1.1.0/ 24 [110/ 20] via 1.1.1.2, 00: 00: 21, Serial0
       S*      0.0.0.0/ 0 is directly connected, Ethernet0

Единственный внешний маршрут в таблице маршрутизации является 200.1.1.0/24. Эта сеть находится в таблице маршрутизации, потому что адрес пересылки этой внешней сети (3.3.4.1) покрыт объединенным маршрутом 3.0.0.0/8, который является межобластным маршрутом.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 13682