Протокол IP : Протокол EIGRP

Что означают сообщения EIGRP "Not On Common Subnet"?

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ объясняет, почему Cisco, маршрутизатор IOS� может испытать сообщение об ошибках not on common subnet, когда маршрутизатор настроен с Протоколом EIGRP.

EIGRP использует hello-пакеты групповой адресации для взаимодействия с EIGRP-соседями. Если EIGRP получает hello-пакет, отправленный с IP-адреса подсети, не настроенной в принимающем интерфейсе EIGRP, EIGRP выдает сообщение об ошибке:

timestamp: IP-EIGRP: Neighbor neighbor_IP_address not on common subnet for interface

Предварительные условия

Требования

Этот документ требует основного понимания протоколов IP-маршрутизации и Протокола маршрутизации EIGRP в целом. Для получения дополнительной информации о протоколах IP-маршрутизации и протоколу EIGRP см. следующие документы:

Используемые компоненты

Сведения в этом документе основываются на Cisco IOS Software Release 12.2 (10b) на маршрутизаторах Cisco серии 2500.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

Cisco рекомендует настроить все маршрутизаторы на сегменте сети с основными IP - адресами в той же подсети. Данный пример показывает общую конфигурацию протокола EIGRP:

/image/gif/paws/13674/15a1.gif

Конфигурации

Эти конфигурации используются в данном документе:

_________________________ М1
hostname R1
!
interface Ethernet0
ip address 10.1.1.1 255.255.255.0
!
router eigrp 1
network 10.0.0.0
!
end

_________________________ М2
hostname R2
!
interface Ethernet0
ip address 10.1.1.2 255.255.255.0
!
router eigrp 1
network 10.0.0.0
!
end

Проверка.

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Выполните команду show ip eigrp neighbor, чтобы проверить, что оба маршрутизатора видят друг друга.

R1#show ip eigrp neighbor

IP-EIGRP neighbors for process 1

H   Address                 Interface   Hold Uptime   SRTT   RTO  Q  Seq

                                        (sec)         (ms)       Cnt Num

0   10.1.1.2                Et0           12 00:00:16    0  3000  0  23
R2#show ip eigrp neighbor

IP-EIGRP neighbors for process 1

H   Address                 Interface   Hold Uptime   SRTT   RTO  Q  Seq

                                        (sec)         (ms)       Cnt Num

0   10.1.1.1                Et0           14 00:01:19   12   200  0  11

Устранение неполадок

Используйте этот раздел для устранения неполадок своей конфигурации.

Отсутствие соседей

Если все настроено должным образом, вы видите, что формируется отношение Соседнего eigrp. Измените конфигурацию R2. Поместите интерфейс R2 Ethernet0 в другую подсеть.

R2#configure terminal

R2(config)#interface ethernet0

R2(config-if)#ip address 10.1.2.2 255.255.255.0

R2(config-if)#end

Теперь рассмотрим конфигурацию R2:

hostname R2
!
interface Ethernet0
ip address 10.1.2.2 255.255.255.0
!
router eigrp 1
network 10.0.0.0
!
end

Теперь вы начинаете получать сообщения об ошибках на приеме пакета приветствия EIGRP. В этом случае сообщения появляются приблизительно каждые 15 секунд как на R1, так и на R2:

R1

3w0d: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 

01:05:01: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
01:05:15: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
01:05:30: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
01:05:44: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
R2

3w0d: IP-EIGRP: Neighbor 10.1.1.1 not on common subnet for Ethernet0 

00:48:40: IP-EIGRP: Neighbor 10.1.1.1 not on common subnet for Ethernet0 (10.1.)
00:48:54: IP-EIGRP: Neighbor 10.1.1.1 not on common subnet for Ethernet0 (10.1.)
00:49:08: IP-EIGRP: Neighbor 10.1.1.1 not on common subnet for Ethernet0 (10.1.)
00:49:22: IP-EIGRP: Neighbor 10.1.1.1 not on common subnet for Ethernet0 (10.1.)

Несмотря на сообщения об ошибках, EIGRP работает правильно со всеми другими соседними узлами R1 или R2. Обновленные выходные данные команды show ip eigrp neighbor показывают, что сообщение об ошибке указывается на наличие серьезной проблемы между R1 и R2. Маршрутизаторы больше не являются соседями и не обмениваются данными маршрутизации.

R1

R1#show ip eigrp neighbor
IP-EIGRP neighbors for process 1
R2

R2#show ip eigrp neighbor
IP-EIGRP neighbors for process 1

Вспомогательный IP-адрес

Эта проблема может также наблюдаться в сетях, которые используют дополнительные IP-адреса, если сети неправильно настроены. Добавьте вторичный адрес в R2:

R2

R2#configure terminal

R2(config)#interface ethernet0

R2(config-if)#ip address 10.1.1.2 255.255.255.0 secondary

R2(config-if)#end

Конфигурация R2 теперь выглядит следующим образом:

hostname R2
!
interface Ethernet0
ip address 10.1.2.2 255.255.255.0


ip address 10.1.1.2 255.255.255.0 secondary
!
router eigrp 1
network 10.0.0.0
!
end

Теперь R2 распознает 10.1.1.0/24 как правильную подсеть для интерфейса Ethernet0, поэтому стандартное сообщение об ошибке подсети на R2 больше не отображается. R2 показывает R1 как Соседний eigrp, и R2 получает и принимает пакеты приветствия R1.

Router2#show ip eigrp neighbor
IP-EIGRP neighbors for process 1
H   Address                 Interface   Hold Uptime   SRTT   RTO  Q  Seq Type
                                        (sec)         (ms)       Cnt Num
0   10.1.1.1                Et0           12 00:00:35    1  5000  1  0

Однако R1 не показывает R2 как соседний узел, и R1 не принимает обновления маршрута от R2. Это означает, что R2 непрерывно перезагружает свое соседство с R1. На R1 продолжит появляться сообщение not on common subnet error, при этом в списке таблицы соседей EIGRP R2 не отображается.

R1#show ip eigrp neighbor

IP-EIGRP neighbors for process

01:20:54: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
01:21:08: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
01:21:22: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
01:21:36: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)

Это происходит, потому что обновления EIGRP всегда используют первичный IP-адрес исходящего интерфейса как исходный адрес. Измените основной адрес на R1 для соответствия основной подсети R2 (10.1.2.1/24 в этом примере).

Можно настроить некоторые сети с двумя отдельными подсетями на том же физическом сегменте. В этом случае маршрутизаторы EIGRP на одной подсети могут не быть в состоянии связаться с маршрутизаторами EIGRP на другой подсети. При выполнении программного обеспечения Cisco IOS версии 11.3, 12.0, или позже, можно отключить сообщения об ошибках not on common subnet с использованием команды no eigrp log-neighbor-warnings.

Примечание: Cisco обычно не рекомендует использование команды no eigrp log-neighbor-warnings. Команда отключает не на сообщениях стандартной ошибки подсети на всех интерфейсах, что процесс EIGRP использует. Используйте команду с усмотрением.

Настройте команду no eigrp log-neighbor-warnings в режиме конфигурации маршрутизатора EIGRP.

Router#configure terminal

Router(config)#router eigrp 1

Router(config-router)#no eigrp	log-neighbor-warnings

Общая Причина для сообщения об ошибках

EIGRP использует hello-пакеты групповой адресации для взаимодействия с EIGRP-соседями. EIGRP генерирует не на сообщении стандартной ошибки подсети, когда это получает пакет приветствия EIGRP, полученный от IP-адреса на подсети, которая не настроена на ее интерфейсе получения.

Это общая причина для этого сообщения об ошибках:

  • Неверная конфигурация интерфейсов или портов коммутатора или проблемы с кабельной системой.

  • Несоответствие основных / вторичных IP - адресов на соседнем интерфейсе.

  • Коммутатор/концентратор пропускает пакеты групповой адресации к другим портам.

  • При использовании коммутатора локальной сети (LAN) vlan, возможно, присоединились к маршрутизаторам вместе.

  • Другой маршрутизатор использует EIGRP, дающий объявление в той же подсети / vlan как этот маршрутизатор, и неправильно сконфигурирован с неправильным количеством AS.

Для решения этой проблемы проверьте эти элементы:

  • Проверьте, что кабель связан правильно.

  • Перепроверьте конфигурацию интерфейса для IP-адресов неверна настроенного на локальной переменной и соседних маршрутизаторах.

  • Проверьте, что основной адрес интерфейса находится в той же подсети как основной адрес соседнего маршрутизатора.

  • Если к соединению Соседнего eigrp присоединяются через концентратор LAN, используйте отдельные концентраторы, чтобы разбить широковещательный домен для каждого логического сегмента LAN или не настроить log-neighbor-warnings eigrp для устранения ошибок.

  • Если существует включенный коммутатор, проверьте конфигурацию коммутатора, чтобы удостовериться, что другие сегменты LAN не настроены, чтобы быть в той же VLAN, которые совместно используют тот же широковещательный домен.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 13674