Технологии LRE и xDSL : Поддержка асимметричных цифровых абонентских линий (ADSL)

Настройка WIC ADSL Cisco 1700/2600/3600 как клиента PPPoE с NAT

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (12 ноября 2015) | Отзыв


Содержание


Введение

Маршрутизаторы серии Cisco 1700, 2600 и 3600 поддерживают интерфейсную карту WAN (WIC) с асимметричной цифровой абонентской линии (ADSL). Все три платформы настраиваются в значительной мере аналогично. Однако существуют различия в аппаратных средствах и в Cisco Выпуск ПО IOS�, который требуется для каждого. Во всем этом документе, Cisco 1700, 2600 и 3600 называются «Cisco ADSL WIC».”

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • Выпуск ПО Cisco 6400 UAC-NRP IOS 12.1 (3) DC1

  • Выпуск ПО Cisco 6400 UAC-NSP IOS 12.1 (3) дБ

  • Выпуск Cisco 6130 DSLAM-NI2 IOS 12.1(5)DA

Для поддержки ADSL WIC на Cisco 2600/3600, необходимо следующее оборудование:

2600 3600
Слоты разветвителя WIC монтажной панели NM-1FE1R2W
NM-2W NM-1FE2W
  NM-2FE2W
  NM-2W

Важно: Для Cisco 3600 эти аппаратные средства не поддерживают ADSL WIC:

  • NM-1E1R2W

  • NM-1E2W

  • NM-2E2W

Для поддержки ADSL WIC необходимы следующие минимальные Cisco IOS Software Releases:

  • Программное обеспечение Cisco IOS версии 12.1(5)YB (Только плюс версии) на Cisco 2600/3600

  • Cisco IOS Software Release IOS 12.1 (3) XP или позже (Только плюс версии или набор характеристик ADSL) на Cisco 1700. Набор функций ADSL определяется параметром y7 в имени образа. Например, c1700-sy7-mz.121-3. XP.bin.

  • При загрузке образа для Cisco 1700 удостоверьтесь, что вы выбираете имя образа 1700. Не загружайте образы 1720 или 1750. Эти функции не поддерживают ADSL WIC.

Для поддержки Протокола PPPoE у вас должен быть набор функций ADSL+PLUS. Набор функций только для ADSL не поддерживает PPPoE для Cisco 1700.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Общие сведения

В программном обеспечении Cisco IOS версии 12.1(3)XG Функция клиента PPPoE представлена для CISCO ADSL WIC. Эта возможность позволяет перенести функции PPPoE в маршрутизатор. Множественные PC могут быть установлены позади CISCO ADSL WIC. Прежде чем их трафик передается Сеансу PPPoE, он может шифроваться, фильтроваться и т.д. Кроме того, Технология NAT может работать.

В этом документе отображается клиент PPPoE, настроенный для работы с интерфейсом Технологии ATM (интерфейс DSL) на Cisco ADSL WIC.

Конфигурацию процессора маршрутизации узла (NRP) на Cisco 6400 можно также использовать на другом маршрутизаторе, который служит собирающим устройством и имеет ATM-интерфейс.

Настройка

Этот раздел предоставляет сведения для настройки функций, описанных в этом документе.

Примечание: Для обнаружения дополнительных сведений о командах в этом документе используйте Средство поиска команд Command Lookup Tool (только зарегистрированные клиенты).

Схема сети

В настоящем документе используется следующая схема сети:

/image/gif/paws/12964/wicadsl_pppoe_client.gif

Конфигурации

PPPoE настроен на CISCO ADSL WIC с командами виртуальной частной коммутируемой сети (VPDN). Гарантируйте настройку этих команд сначала.

Примечание: Для получения информации о том, как изменить размер максимального размера передаваемого блока данных (MTU), обратитесь к Устранению проблем Максимального размера передаваемого блока данных в Возможности внешнего подключения по телефонной линии PPPoE.

Эти конфигурации используются в данном документе:

CISCO ADSL WIC
!
vpdn enable
no vpdn logging
!
vpdn-group pppoe
  request-dialin

!--- You are the PPPoE client that asks to establish a session
!--- with the aggregation unit (6400 NRP). These VPDN commands
!--- are not needed with Cisco IOS Software Release 12.2(13)T
!--- or later.

   protocol pppoe
!

!--- Internal Ethernet network.

!
interface FastEthernet0
 ip address 10.92.1.182 255.255.255.0
 ip nat inside

!--- DSL interface.

!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 bundle-enable
 dsl operating-mode auto
 hold-queue 224 in

!--- All defaults.
!--- PPPoE runs on top of AAL5SNAP. However, the
!--- encap aal5snap command is not used.

!
interface ATM0.1 point-to-point
 pvc 1/1
  pppoe-client dial-pool-number 1

!--- pvc 1/1 is an example value that must be changed to match
!--- the value used by the ISP.

 !

!--- The PPPoE client code ties into a dialer interface upon
!--- which a virtual-access interface is cloned.

!
interface Dialer1
 ip address negotiated
 ip mtu 1492

!--- Ethernet MTU default = 1500 (1492 + PPPoE headers = 1500)

 ip nat outside
 encapsulation ppp
 dialer pool 1

!--- Ties to the ATM interface.

 ppp authentication chap callin
 ppp chap hostname <username>
 ppp chap password <password>
!

!--- The ISP instructs you about the type of authentication
!--- to use.
!--- To change from PPP Challenge Handshake Authentication
!--- Protocol (CHAP) to PPP Password Authentication Protocol
!--- (PAP), replace these three lines:
!---    ppp authentication chap callin
!---    ppp chap hostname <username>
!---    ppp chap password <password>
!--- with these two lines:
!---    ppp authentication pap callin
!---    ppp pap sent-username <username> password <password>
!--- For NAT, overload on the Dialer1 interface and add a
!--- default route out, because the dialer IP address can
!--- change.

ip nat inside source list 1 interface Dialer1 overload 
ip classless 
ip route 0.0.0.0 0.0.0.0 dialer1 
no ip http server 
! 
access-list 1 permit 10.92.1.0 0.0.0.255 

!--- For NAT. 

! 

Cisco 6400
Cisco 6400 ***
local ppp user

!--- You can also use aaa.

username <username> password <password>

!--- Begin with the VPDN commands. Notice that you bind the
!--- PPPoE here to a virtual-template, instead of on the ATM
!--- interface. You can not (at this time) use more than one 
!--- virtual-template (or VPDN group) for PPPoE beginning with
!--- the VPDN commands.

vpdn enable
no vpdn logging
!
vpdn-group pppoe
 accept-dialin

!--- PPPoE server mode.

  protocol pppoe
  virtual-template 1
!
!
interface ATM0/0/0
 no ip address
 no atm ilmi-keepalive
 hold-queue 500 in

!--- The binding to the virtual-template interface is
!--- configured in the VPDN group.

!
interface ATM0/0/0.182 point-to-point
 pvc 1/82
  encapsulation aal5snap

!--- This needs the command on the server side.

  protocol pppoe
 !
!

!--- Virtual-template is used instead of dialer interface.

!
interface Virtual-Template1
 ip unnumbered Loopback10
 ip mtu 1492
 peer default ip address pool ippool
 ppp authentication chap
!
!
interface Loopback10
 ip address 8.8.8.1 255.255.255.0
!
ip local pool ippool 9.9.9.1 9.9.9.5

Проверка

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

Используйте этот раздел для устранения неполадок своей конфигурации.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Примечание: Обратитесь к документу Важная информация о командах отладки, прежде чем использовать команды debug.

Отладьте PPPoE-клиент

Для отладки клиента PPPoE в Cisco ADSL WIC или в Cisco 6400, необходимо принять во внимание стек протоколов. Можно начать в нижней части устранять неполадки.

  1. Физический уровень DSL:

    Убедитесь что линия функционирует и подготовлена.

    show interface atm0
    ATM0 is up, line protocol is up
      Hardware is PQUICC_SAR (with Alcatel ADSL Module)
    
    show dsl interface atm0
    
    !--- Look for “Showtime” in the first few lines.
    
    ATU-R (DS)
    ATU-C (US)
    Modem Status:    Showtime (DMTDSL_SHOWTIME)
    
  2. Уровень ATM:

    Если ATM-интерфейс подключен, выполните команду debug atm packet, чтобы видеть, входит ли что-нибудь от интернет-провайдера.

    Примечание: При использовании этой команды исходящие пакеты не видны из-за способа их обработки.

    Выходные данные должны быть аналогичны следующим данным: в полях типа, SAP, CTL и OUI должен отображаться входящий пакет ATM AAL5SNAP:

    debug atm packet
    03:21:32: ATM0(I):
    VCD:0x2 VPI:0x1 VCI:0x1 Type:0x0 SAP:AAAA CTL:03 OUI:0080C2 TYPE:0007 Length:0x30
    03:21:32: 0000 0050 7359 35B7 0001 96A4 84AC 8864 1100 0001 000E C021 09AB 000C 0235
    03:21:32: 279F 0000 0000
    03:21:32:
  3. Уровень Ethernet:

    Завершенные Фреймы Ethernet находятся в пакетах AAL5SNAP. Отсутствует команда debug Ethernet packet. Однако необходимо выполнить некоторые отладки VPDN (отладки PPPoE для программного обеспечения Cisco IOS версии 12.2(13)T или позже) для наблюдения кадров PPPoE.

    Для справки, Ethernet фрейм, который является PPPoE фреймом, содержит один из этих двух Ethernet типов:

    • 0x8863 Ethertype = пакет управления PPPoE (обрабатывает сеанс PPPoE)

    • 0x8864 Ethertype = пакет данных PPPoE (содержит пакеты PPP)

    Важное замечание: в PPPoE используются два сеанса. Сеанс PPPoE, являющийся VPDN L2TP типом сеанса, и PPP сеанс. Для установления PPPoE у вас есть Фаза установления сеанса PPPoE и этап установления сеанса PPP.

    Завершение обычно включает фазу завершения PPP и фазу завершения PPPoE.

    Установка фазы PPPoE определяет PPPoE-клиент и сервер (MAC-адреса) и назначает идентификатор сеанса. После этого завершено, нормальное установление ppp происходит точно так же, как любой другой PPP - подключение.

    Для отладки используйте отладки PPPoE VPDN (отладки PPPoE для программного обеспечения Cisco IOS версии 12.2(13)T или позже), чтобы определить, успешен ли этап установки связи PPPoE.

    #debug vpdn pppoe-events (debug pppoe events)
    06:17:58: Sending PADI: vc=1/1
    
    !--- A broadcast Ethernet frame (in this case encapsulated in ATM)
    !--- requests a PPPoE server, “Are there any PPPoE servers out there?”
    
    06:18:00:  PPPOE: we've got our pado and the pado timer went off
    
    !--- This is a unicast reply from a PPPoE server
    !--- (very similar to a DHCP offer).
    
    06:18:00: OUT PADR from PPPoE tunnel
    
    !--- This is a unicast reply that accepts the offer.
    
    06:18:00: IN PADS from PPPoE tunnel
    
    !--- This is a confirmation and completes the establishment.
    
    

    Установление PPP соединения начинается как и любая другая РРР инициация. После того, как Сеанс PPPoE установлен, команды show vpdn проблемы (покажите сеанс pppe для программного обеспечения Cisco IOS версии 12.2(13)T или позже) получить статус.

    # show vpdn (show pppoe session)
    %No active L2TP tunnels
    %No active L2F tunnels
    
    PPPoE Tunnel and Session Information Total tunnels 1 sessions 1
    
    PPPoE Tunnel Information
    
    Session count: 1
    
    PPPoE Session Information
    SID      RemMAC          LocMAC      Intf    VASt   OIntf   VC
    1    0050.7359.35b7  0001.96a4.84ac  Vi1     UP     AT0     11
    

    Получите сведения о количестве пакетов через show vpdn session все (show pppoe session все) команда.

    show vpdn session all (show pppoe session all)
    %No active L2TP tunnels
    %No active L2F tunnels
    
    PPPoE Session Information Total tunnels 1 sessions 1
    
    session id: 1
    local MAC address: 0001.96a4.84ac, remote MAC address: 0050.7359.35b7
    virtual access interface: Vi1, outgoing interface: AT0, vc: 1/1
        1656 packets sent, 1655 received, 24516 bytes sent, 24486 received
    

    Другие команды отладки:

    • debug vpdn pppoe-data (debug pppoe data)

    • pppoe-errors debug vpdn (ошибки debug pppoe)

    • пакеты pppoe debug vpdn (пакеты debug pppoe)

  4. Уровень PPP:

    После того, как Сеанс PPPoE установлен, отладки PPP являются тем же для любого другого установления соединения PPP.

    Применяются те же команды "debug ppp negotiation" и "debug ppp authentication". Вот пример выходных данных.

    Примечание: В этом примере, именя хоста - «client1».” Название удаленного Cisco 6400 является “Nrp-b”.

    06:36:03: Vi1 PPP: Treating connection as a callout
    06:36:03: Vi1 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load]
    06:36:03: Vi1 PPP: No remote authentication for call-out
    06:36:03: Vi1 LCP: O CONFREQ [Closed] id 1 len 10
    06:36:03: Vi1 LCP:    MagicNumber 0x03013D43 (0x050603013D43)
    06:36:03: Vi1 LCP: I CONFACK [REQsent] id 1 len 10
    06:36:03: Vi1 LCP:    MagicNumber 0x03013D43 (0x050603013D43)
    06:36:05: Vi1 LCP: I CONFREQ [ACKrcvd] id 2 len 15
    06:36:05: Vi1 LCP:    AuthProto CHAP (0x0305C22305)
    06:36:05: Vi1 LCP:    MagicNumber 0x65E315E5 (0x050665E315E5)
    06:36:05: Vi1 LCP: O CONFACK [ACKrcvd] id 2 len 15
    06:36:05: Vi1 LCP:    AuthProto CHAP (0x0305C22305)
    06:36:05: Vi1 LCP:    MagicNumber 0x65E315E5 (0x050665E315E5)
    06:36:05: Vi1 LCP: State is Open
    06:36:05: Vi1 PPP: Phase is AUTHENTICATING, by the peer [0 sess, 1 load]
    06:36:05: Vi1 CHAP: I CHALLENGE id 9 len 26 from "nrp-b"
    06:36:05: Vi1 CHAP: Using alternate hostname client1
    06:36:05: Vi1 CHAP: Username nrp-b not found
    06:36:05: Vi1 CHAP: Using default password
    06:36:05: Vi1 CHAP: O RESPONSE id 9 len 28 from "client1"
    06:36:05: Vi1 CHAP: I SUCCESS id 9 len 4
    06:36:05: Vi1 PPP: Phase is FORWARDING [0 sess, 1 load]
    06:36:05: Vi1 PPP: Phase is AUTHENTICATING [0 sess, 1 load]
    06:36:05: Vi1 PPP: Phase is UP [0 sess, 1 load]
    06:36:05: Vi1 IPCP: O CONFREQ [Closed] id 1 len 10
    06:36:05: Vi1 IPCP:    Address 0.0.0.0 (0x030600000000)
    06:36:05: Vi1 CDPCP: O CONFREQ [Closed] id 1 len 4
    06:36:05: Vi1 IPCP: I CONFREQ [REQsent] id 1 len 10
    06:36:05: Vi1 IPCP:    Address 8.8.8.1 (0x030608080801)
    06:36:05: Vi1 IPCP:    Address 8.8.8.1 (0x030608080801)
    06:36:05: Vi1 IPCP:    Address 9.9.9.2 (0x030609090902)
    06:36:05: Vi1 IPCP: O CONFREQ [ACKsent] id 2 len 10
    06:36:05: Vi1 IPCP:    Address 9.9.9.2 (0x030609090902)
    06:36:05: Vi1 LCP: I PROTREJ [Open] id 3 len 10 protocol CDPCP (0x820701010004)
    06:36:05: Vi1 CDPCP: State is Closed
    06:36:05: Vi1 IPCP: I CONFACK [ACKsent] id 2 len 10
    06:36:05: Vi1 IPCP:    Address 9.9.9.2 (0x030609090902)
    06:36:05: Vi1 IPCP: State is Open
    06:36:05: Di1 IPCP: Install negotiated IP interface address 9.9.9.2
    06:36:05: Di1 IPCP: Install route to 8.8.8.1
    06:36:06: %LINEPROTO-5-UPDOWN: Line protocol on
    Interface Virtual-Access1, changed state to up

Отладьте сервер PPPoE

Для отладки Cisco 6400 (сервер PPPoE) используйте ту же восходящую процедуру, которая используется для CISCO ADSL WIC (клиент). Разница в физическом уровне DSL, когда необходимо проверить DSLAM.

  1. Физический уровень DSL:

    Для проверки физического уровня DSL необходимо просмотреть статистику DSL в DSLAM. Для Cisco DSLAMs выполните команду show dsl interface.

  2. Уровень ATM:

    На стороне Cisco 6400 можно также выполнить команду debug atm packet. Включите Cisco 6400 для определенного PVC.

    debug atm packet interface atm 0/0/0.182 vc 1/82
    

    Выходные данные должны быть аналогичны следующим данным: в полях типа, SAP, CTL и OUI должен отображаться входящий пакет ATM AAL5SNAP:

    4d04h: ATM0/0/0.182(I):
    VCD:0x3 VPI:0x1 VCI:0x52 Type:0x900 SAP:AAAA CTL:03 OUI:0080C2 TYPE:0007 Length:0x30
    4d04h: 0000 0001 96A4 84AC 0050 7359 35B7 8864 1100 0001 000E C021 0A2E 000C 65E3
    4d04h: 15E5 0000 0000

    Примечание: При использовании этой команды исходящие пакеты не видны из-за способа их обработки.

  3. Уровень Ethernet:

    Команды "show" и средства отладки VPDN, используемые Cisco ADSL WIC, могут быть использованы Cisco 6400 для просмотра установки PPPoE.

    # debug vpdn pppoe-events (debug pppoe events)
    4d04h: IN PADI from PPPoE tunnel
    
    4d04h: OUT PADO from PPPoE tunnel
    
    4d04h: IN PADR from PPPoE tunnel
    
    4d04h: PPPoE: Create session
    4d04h: PPPoE: VPN session created.
    
    4d04h: OUT PADS from PPPoE tunnel
    
    # show vpdn
    %No active L2TP tunnels
    %No active L2F tunnels
    
    PPPoE Tunnel and Session Information Total tunnels 1 sessions 1
    
    PPPoE Tunnel Information
    
    Session count: 1
    
    PPPoE Session Information
    SID        RemMAC          LocMAC       Intf    VASt   OIntf        VC
    1       0001.96a4.84ac  0050.7359.35b7  Vi4     UP     AT0/0/0 1    82
    
    # show vpdn session all
    
    nrp-b# show vpdn session all
    %No active L2TP tunnels
    %No active L2F tunnels
    
    PPPoE Session Information Total tunnels 1 sessions 1
    
    session id: 1
    local MAC address: 0050.7359.35b7, remote MAC address: 0001.96a4.84ac
    virtual access interface: Vi4, outgoing interface: AT0/0/0, vc: 1/82
        30 packets sent, 28 received, 422 bytes sent, 395 received
    

    Другие команды отладки:

    • debug vpdn pppoe-data (debug pppoe data)

    • pppoe-errors debug vpdn (ошибки debug pppoe)

    • пакеты pppoe debug vpdn (пакеты debug pppoe)

  4. Уровень PPP:

    Это - выходные данные отладки PPP от Cisco 6400, который соответствует более ранней отладке от CISCO ADSL WIC:

    debug ppp negotiation and debug ppp authentication
    4d04h: Vi2 PPP: Treating connection as a dedicated line
    4d04h: Vi2 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load]
    4d04h: Vi2 LCP: O CONFREQ [Closed] id 1 len 15
    4d04h: Vi2 LCP:    AuthProto CHAP (0x0305C22305)
    4d04h: Vi2 LCP:    MagicNumber 0x65F62814 (0x050665F62814)
    4d04h: Vi2 LCP: I CONFREQ [REQsent] id 1 len 10
    4d04h: Vi2 LCP:    MagicNumber 0x03144FF9 (0x050603144FF9)
    4d04h: Vi2 LCP: O CONFACK [REQsent] id 1 len 10
    4d04h: Vi2 LCP:    MagicNumber 0x03144FF9 (0x050603144FF9)
    4d04h: Vi3 LCP: I ECHOREQ [Open] id 60 len 8 magic 0xA60C0000
    4d04h: Vi3 LCP: O ECHOREP [Open] id 60 len 8 magic 0x51A0BEF6
    4d04h: Vi2 LCP: TIMEout: State ACKsent
    4d04h: Vi2 LCP: O CONFREQ [ACKsent] id 2 len 15
    4d04h: Vi2 LCP:    AuthProto CHAP (0x0305C22305)
    4d04h: Vi2 LCP:    MagicNumber 0x65F62814 (0x050665F62814)
    4d04h: Vi2 LCP: I CONFACK [ACKsent] id 2 len 15
    4d04h: Vi2 LCP:    AuthProto CHAP (0x0305C22305)
    4d04h: Vi2 LCP:    MagicNumber 0x65F62814 (0x050665F62814)
    4d04h: Vi2 LCP: State is Open
    4d04h: Vi2 PPP: Phase is AUTHENTICATING, by this end [0 sess, 1 load]
    4d04h: Vi2 CHAP: O CHALLENGE id 10 len 26 from "nrp-b"
    4d04h: Vi2 CHAP: I RESPONSE id 10 len 28 from "client1"
    4d04h: Vi2 PPP: Phase is FORWARDING [0 sess, 1 load]
    4d04h: Vi2 PPP: Phase is AUTHENTICATING [0 sess, 1 load]
    4d04h: Vi2 CHAP: O SUCCESS id 10 len 4
    4d04h: Vi2 PPP: Phase is UP [0 sess, 1 load]
    4d04h: Vi2 IPCP: O CONFREQ [Closed] id 1 len 10
    4d04h: Vi2 IPCP:    Address 8.8.8.1 (0x030608080801)
    4d04h: Vi2 IPCP: I CONFREQ [REQsent] id 1 len 10
    4d04h: Vi2 IPCP:    Address 0.0.0.0 (0x030600000000)
    4d04h: Vi2 IPCP: Pool returned 9.9.9.2
    4d04h: Vi2 IPCP: O CONFNAK [REQsent] id 1 len 10
    4d04h: Vi2 IPCP:    Address 9.9.9.2 (0x030609090902)
    4d04h: Vi2 CDPCP: I CONFREQ [Not negotiated] id 1 len 4
    4d04h: Vi2 LCP: O PROTREJ [Open] id 3 len 10 protocol CDPCP (0x820701010004)
    4d04h: Vi2 IPCP: I CONFACK [REQsent] id 1 len 10
    4d04h: Vi2 IPCP:    Address 8.8.8.1 (0x030608080801)
    4d04h: Vi2 IPCP: I CONFREQ [ACKrcvd] id 2 len 10
    4d04h: Vi2 IPCP:    Address 9.9.9.2 (0x030609090902)
    4d04h: Vi2 IPCP: O CONFACK [ACKrcvd] id 2 len 10
    4d04h: Vi2 IPCP:    Address 9.9.9.2 (0x030609090902)
    4d04h: Vi2 IPCP: State is Open
    4d04h: Vi2 IPCP: Install route to 9.9.9.2
    4d04h: %LINEPROTO-5-UPDOWN: Line protocol on Interface
    Virtual-Access2, changed state to up

Дополнительные сведения


Document ID: 12964