Технологии LRE и xDSL : Поддержка асимметричных цифровых абонентских линий (ADSL)

Настройка и устранение неполадок маршратизатора Cisco 1700, используя Ethernet WIC, как PPPoE клиент с NAT

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (12 ноября 2015) | Отзыв


Содержание


Введение

В этом документе показано как настроить Cisco 1700, используя Ethernet WAN Interface Card (WIC-1ENET), чтобы работал как Point-to-Point Protocol over Ethernet (PPPoE) клиент с Network Address Translation (NAT).

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Cisco Выпуск ПО IOS� 12.1 (3) XT1 или позже поддерживать WIC-1ENET Cisco 1700.

  • Для этого примера конфигурации Universal Access Concentrator-Node Route Processor Cisco 6400 (nrp UAC) выполнял Cisco IOS Software Release 12.1 (3) DC1.

Для поддержки PPPoE, вы должны иметь набор функциональных возможностей ADSL+PLUS. Набор функций только для ADSL не поддерживает PPPoE для Cisco 1700.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. в Условные обозначения технических терминов Cisco.

Теоретические сведения

WIC-1ENET является 10BASE-T картой, разработанной для Маршрутизаторов серии Cisco 1700. WIC-1ENET предоставляет второй Интерфейс Ethernet для Cisco 1700, который помогает использовать широкие функциональные возможности программного обеспечения Cisco IOS с любой Цифровой абонентской линией (DSL) или Кабельным модемом.

Свойство PPPoE клиента позволяет перенести функциональные возможности PPPoE на маршрутизатор. Множественные PC могут быть установлены позади Интерфейса Fast Ethernet Cisco 1700 и, прежде чем их трафик будет передан Сеансу PPPoE, это может быть зашифровано, фильтровано, и т.д., и NAT может работать. Рабочий PPPoE на маршрутизаторе устраняет необходимость использования программного обеспечения PPPoE-клиента на PC.

Требования к процессору

Revision B5 Микропроцессора MPC 860 требуется. Этот процессор во всех сериях маршрутизаторов Cisco 1700 выпущенных после 21-го ноября 1999 г. Серийные номера Cisco 1700 начиная с JAB0347XXXX были произведены с микропроцессором Revision B5 Модели MPC860.

Код даты встроен в серийный номер. Формат является LLLYYWWSSSS, где:

  • LLL является местоположением, в котором был создан модуль.

  • YY является годом, что модуль был создан (1997=01, 1998=02, 1999=03, 2000=04).

  • WW является рабочей неделей года, что был создан модуль.

  • SSSS является серийным номером.

Информация о версии процессора показывается при загрузке. Можно также проверить версию процессора путем запуска команды Show version в приглашении Router#.

Требования к памяти

Для выполнения Образов IOS Cisco 1700, которые поддерживают Cisco WIC-1ENET маршрутизатор должен иметь минимальное количество флэш-памяти и DRAM. Для получения дополнительной информации на требованиях к памяти для каждого образа, сошлитесь на Комментарии к выпуску для Маршрутизаторов серии Cisco 1700 для Cisco IOS Release 12.1 (3) XT1.

Ограничения WIC-1ENET и неподдерживаемые характеристики

  • WIC-1ENET не поддерживается в платформах кроме Cisco 1700.

  • Только соединение RJ-45 витой пары поддерживается; нет никакой поддержки интерфейса устройств подключения (AUI) или интерфейса BNC.

  • Никакое автоматическое согласование (автоматическое считывание) между полудуплексными и полнодуплексными режимами.

  • В то время как хост находится в ROMMON, WIC-1ENET не может использоваться для загрузки файла TFTP.

  • WIC-1ENET не распознан Cisco 1700, когда это находится в РЕЖИМЕ ROMMON.

  • Текущее программное обеспечение Cisco IOS поддерживает WIC-1ENET только в Слоте 0 Cisco 1700.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

PPPoE-клиент настроен на Cisco 1700 с командами виртуальной частной коммутируемой сети (VPDN). (Команды VPDN не необходимы для программного обеспечения Cisco IOS версии 12.2(13)T или позже.) Удостоверяются, что вы настраиваете эти команды сначала.

Примечание: Для получения информации об изменении размера максимального размера передаваемого блока данных (MTU) обратитесь к Устранению проблем Максимального размера передаваемого блока данных в Возможности внешнего подключения по телефонной линии PPPoE.

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/12956/wic_1enet.gif

Конфигурации

Эти конфигурации используются в данном документе:

Cisco 1700
! 
vpdn enable 
no vpdn logging
! 
vpdn-group pppoe 
�request-dialin�� 

!--- The PPPoE client requests to establish�� 
!--- a session with the aggregation unit (6400 NRP).
!--- These VPDN commands are not needed with 
!--- Cisco IOS Software Release 12.2(13)T or later.

��protocol pppoe 
! 
int Dialer1
 ip address negotiated
 encapsulation ppp
 ip mtu 1492

!--- The Ethernet MTU is 1500 by default 
!--- (1492 + PPPoE headers = 1500).

 ip nat outside
 dialer pool 1

!--- This ties to interface Ethernet0.

 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname <username>
ppp chap password <password>
!

!--- The ISP instructs you regarding 
!--- the type of authentication to use.
!--- To change from PPP Challenge Handshake Authentication 
!--- Protocol(CHAP) to PPP Password Authentication Protocol (PAP),
!--- replace these three lines:
!--- ppp authentication chap callin
!--- ppp chap hostname 
!--- ppp chap password 
!--- with these two lines:
!--- ppp authentication pap callin.

ppp pap sent-username <username> password <password>�

!
dialer-list 1 protocol ip permit
!

!--- This is the internal Ethernet network.

interface FastEthernet0
 ip address 10.0.0.1 255.255.255.0
 ip nat inside
!
interface Ethernet0
 pppoe enable
 pppoe-client dial-pool-number 1

!--- The PPPoE client code ties into a dialer 
!--- interface upon which a virtual-access 
!--- interface is cloned.

!

!--- For NAT, you overload on the 
!--- Dialer1 interface and add a default route
!--- out of the Dialer1 interface because
!--- the IP address can change.


ip nat inside source list 1 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 dialer1
no ip http server
!
dialer-list 1 protocol ip permit
access-list 1 permit 10.0.0.0 0.0.0.255

!--- This is for NAT.

!

Cisco 6400
*** local ppp user 

!--- Or, you can use AAA.

username <username> password <password>

!--- Begin with the VPDN commands. 
!--- Notice that you are binding the PPPoE here to 
!--- a virtual-template instead of on the ATM interface. 
!--- You cannot (at this time) use more than one 
!--- virtual-template (or VPDN group) for PPPoE� 
!--- beginning with the VPDN commands.

vpdn enable 
no vpdn logging 
! 
vpdn-group pppoe 
�accept-dialin 

!--- This is PPPoE server mode.

�protocol pppoe 
�virtual-template 1 
! 
! 
interface ATM0/0/0 
�no ip address 
�no atm ilmi-keepalive 
�hold-queue 500 in 

!--- The binding to the virtual-template 
!--- interface is configured in the VPDN group.

! 
interface ATM0/0/0.182 point-to-point 
�pvc 1/82 
��encapsulation aal5snap

!--- You need the command on the server side. 

� protocol pppoe 
�! 
! 

!--- Virtual-template is used instead of dialer interface. 

! 
interface Virtual-Template1 
�ip unnumbered Loopback10 
�ip mtu 1492 
�peer default ip address pool ippool 
�ppp authentication chap 
! 
! 
interface Loopback10 
�ip address 8.8.8.1 255.255.255.0 
! 
ip local pool ippool 9.9.9.1 9.9.9.5

Проверка.

В настоящее время для этой конфигурации нет процедуры проверки.

Отладка клиента PPPoE

В этом разделе описывается процесс устранения неполадок конфигурации.

Для отладки Cisco 1700 (PPPoE-клиент) необходимо рассмотреть стек протоколов.

  • Уровень 4 - уровень PPP

  • Уровень 3 - Уровень Ethernet

  • Уровень 2 - уровень ATM

  • Уровень 1 - физический уровень DSL

Вы могли устранить неполадки начала в нижней части. Так как DSL и уровни ATM происходят в DSL Customer Premises Equipment (CPE), необходимо устранить неполадки только Ethernet и уровней PPP для Cisco 1700, как показано ниже.

Уровень Ethernet

Завершенные Фреймы Ethernet находятся в пакетах Протокола доступа к подсети (SNAP) Уровня адаптации ATM 5 (AAL5). Нет никакой команды Пакета Ethernet отладки, но необходимо выполнить некоторые отладки VPDN (отладки PPPoE для программного обеспечения Cisco IOS версии 12.2(13)T или позже) для наблюдения кадров PPPoE.

Для ссылки Фрейм Ethernet, который является кадром PPPoE, содержит один из двух Ethertype:

  • 0x8863 Ethertype = пакет управления PPPoE (обрабатывает сеанс PPPoE)

  • 0x8864 Ethertype = пакет данных PPPoE (содержит пакеты PPP)

Одно важное замечание - это то, что в PPPoE существуют два сеанса: сеанс PPPoE который протокол layer two tunneling VPDN (встреча L2TP)-type, и сеанс PPP. Так, для установления PPPoE существует Фаза установления сеанса PPPoE и этап установления сеанса PPP.

Завершение обычно включает фазу завершения PPP и фазу завершения PPPoE.

Установка фазы PPPoE состоит из определения MAC-адресов PPPoE-клиента и сервера и присвоения идентификатора сеанса. После этого завершено, нормальное установление ppp происходит точно так же, как любой другой PPP - подключение.

Для отладки можно использовать отладки PPPoE VPDN (отладки PPPoE для программного обеспечения Cisco IOS версии 12.2(13)T или позже), чтобы определить, успешен ли этап установки связи PPPoE.

# debug vpdn pppoe-events (debug pppoe events)

06:17:58: Sending PADI: vc=1/1

!--- A broadcast Ethernet frame (in this case, encapsulated in ATM) 
!--- requests a PPPoE server, "Are there any PPPoE servers out there?" 


06:18:00:  PPPOE: we've got our pado and the pado timer went off 

!--- This is a unicast reply from a PPPoE server (very similar to 
!--- a DHCP offer).


06:18:00: OUT PADR from PPPoE tunnel

!--- This is a unicast reply accepting the offer.


06:18:00: IN PADS from PPPoE tunnel

!--- This is a confirmation that completes the establishment.

Установление соединения PPP теперь начинается, как в любой другой инициации PPP. После того, как Сеанс PPPoE установлен, можно выполнить команды show vpdn для получения статуса.

# show vpdn (show pppoe session)
%No active L2TP tunnels 
%No active L2F tunnels 

PPPoE Tunnel and Session Information Total tunnels 1 sessions 1

PPPoE Tunnel Information

Session count: 1

PPPoE Session Information
SID        RemMAC          LocMAC       Intf    VASt   OIntf    VC 
1       0050.7359.35b7  0001.96a4.84ac  Vi1     UP     AT0    1    1

Можно получить сведения о количестве пакетов с помощью show vpdn session все (show pppoe session все) команда.

show vpdn session all (show pppoe session all)
%No active L2TP tunnels
%No active L2F tunnels

PPPoE Session Information Total tunnels 1 sessions 1

session id: 1
local MAC address: 0001.96a4.84ac, remote MAC address: 0050.7359.35b7 
virtual access interface: Vi1, outgoing interface: AT0, vc: 1/1 
    1656 packets sent, 1655 received, 24516 bytes sent, 24486 received

Другие команды отладки:

  • debug vpdn pppoe-data (debug pppoe data)

  • ошибки PPPoE отладки (ошибки debug pppoe)

  • пакеты pppoe отладки (пакеты debug pppoe)

Уровень PPP

После того, как Сеанс PPPoE был установлен, отладки PPP совпадают с для любого другого установления соединения PPP.

Применяются те же команды "debug ppp negotiation" и "debug ppp authentication". Пример выходных данных:

Примечание: В этой выборке имя хоста является "client1", и название удаленного Cisco 6400 является "Nrp-b".

06:36:03: Vi1 PPP: Treating connection as a callout
06:36:03: Vi1 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load]
06:36:03: Vi1 PPP: No remote authentication for call-out
06:36:03: Vi1 LCP: O CONFREQ [Closed] id 1 len 10
06:36:03: Vi1 LCP:��� MagicNumber 0x03013D43 (0x050603013D43) 
06:36:03: Vi1 LCP: I CONFACK [REQsent] id 1 len 10
06:36:03: Vi1 LCP:��� MagicNumber 0x03013D43 (0x050603013D43) 
06:36:05: Vi1 LCP: I CONFREQ [ACKrcvd] id 2 len 15
06:36:05: Vi1 LCP:� ��AuthProto CHAP (0x0305C22305)
06:36:05: Vi1 LCP:��� MagicNumber 0x65E315E5 (0x050665E315E5) 
06:36:05: Vi1 LCP: O CONFACK [ACKrcvd] id 2 len 15
06:36:05: Vi1 LCP:��� AuthProto CHAP (0x0305C22305)
06:36:05: Vi1 LCP:��� MagicNumber 0x65E315E5 (0x050665E315E5) 
06:36:05: Vi1 LCP: State is Open
06:36:05: Vi1 PPP: Phase is AUTHENTICATING, by the peer [0 sess, 1 load]
06:36:05: Vi1 CHAP: I CHALLENGE id 9 len 26 from "nrp-b" 
06:36:05: Vi1 CHAP: Using alternate hostname client1
06:36:05: Vi1 CHAP: Username nrp-b not found
06:36:05: Vi1 CHAP: Using default password
06:36:05: Vi1 CHAP: O RESPONSE id 9 len 28 from "client1"
06:36:05: Vi1 CHAP: I SUCCESS id 9 len 4
06:36:05: Vi1 PPP: Phase is FORWARDING [0 sess, 1 load]
06:36:05: Vi1 PPP: Phase is AUTHENTICATING [0 sess, 1 load]
06:36:05: Vi1 PPP: Phase is UP [0 sess, 1 load]
06:36:05: Vi1 IPCP: O CONFREQ [Closed] id 1 len 10
06:36:05: Vi1 IPCP:��� Address 0.0.0.0 (0x030600000000)
06:36:05: Vi1 CDPCP: O CONFREQ [Closed] id 1 len 4
06:36:05: Vi1 IPCP: I CONFREQ [REQsent] id 1 len 10
06:36:05: Vi1 IPCP:��� Address 8.8.8.1 (0x030608080801)
06:36:05: Vi1 IPCP:��� Address 8.8.8.1 (0x030608080801)
06:36:05: Vi1 IPCP:��� Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 IPCP: O CONFREQ [ACKsent] id 2 len 10
06:36:05: Vi1 IPCP:� ��Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 LCP: I PROTREJ [Open] id 3 len 10 protocol CDPCP (0x820701010004) 
06:36:05: Vi1 CDPCP: State is Closed
06:36:05: Vi1 IPCP: I CONFACK [ACKsent] id 2 len 10
06:36:05: Vi1 IPCP:��� Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 IPCP: State is Open
06:36:05: Di1 IPCP: Install negotiated IP interface address 9.9.9.2
06:36:05: Di1 IPCP: Install route to 8.8.8.1
06:36:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed 
 state to up

Отладка сервера PPPoE

Для отладки Cisco 6400 (сервер PPPoE) можно использовать ту же восходящую процедуру, используемую для Cisco 1700 (PPPoE-клиент).

  • Уровень 4 - уровень PPP

  • Уровень 3 - Уровень Ethernet

  • Уровень 2 - уровень ATM

  • Уровень 1 - физический уровень DSL

Различие - то, что теперь вы устраняете неполадки уровня DSL на множителе доступа к линии цифровой подписки (DSLAM) и уровня ATM на Cisco 6400, как показано ниже.

Физический уровень DSL

Для проверки физического уровня DSL необходимо просмотреть статистику DSL в DSLAM. Для Cisco DSLAMs может использоваться команда show dsl interface.

Уровень ATM

На стороне Cisco 6400 можно также использовать команду debug atm packet и включить Cisco 6400 для определенного PVC.

debug atm packet interface atm 0/0/0.182 vc 1/82 

Необходимо видеть выходные данные, подобные придерживающемуся, с тем же Type, SAP, CTL и полями OUI, показывая, что входящий пакет ATM является AAL5 SNAP.

4d04h: ATM0/0/0.182(I):
VCD:0x3 VPI:0x1 VCI:0x52 Type:0x900 SAP:AAAA CTL:03 OUI:0080C2 TYPE:0007 Length:0x30
4d04h: 0000 0001 96A4 84AC 0050 7359 35B7 8864 1100 0001 000E C021 0A2E 000C 65E3
4d04h: 15E5 0000 0000

Примечание: Вы не видите исходящие пакеты с этой командой из-за способа, которым обработаны пакеты.

Уровень Ethernet

Та же VPDN показывает, и команды отладки, используемые на Cisco 1700, могут использоваться на Cisco 6400 для рассмотрения установления соединения PPPoE.

# debug vpdn pppoe-events (debug pppoe events)

4d04h: IN PADI from PPPoE tunnel

4d04h: OUT PADO from PPPoE tunnel

4d04h: IN PADR from PPPoE tunnel

4d04h: PPPoE: Create session
4d04h: PPPoE: VPN session created.

4d04h: OUT PADS from PPPoE tunnel


# show vpdn (show pppoe session)
%No active L2TP tunnels
%No active L2F tunnels

PPPoE Tunnel and Session Information Total tunnels 1 sessions 1

PPPoE Tunnel Information

Session count: 1
PPPoE Session Information
SID        RemMAC          LocMAC       Intf    VASt   OIntf    VC
1       0001.96a4.84ac  0050.7359.35b7  Vi4     UP     AT0/0/0 1   82


nrp-b# 
show vpdn session all (show pppoe session all)
%No active L2TP tunnels
%No active L2F tunnels

PPPoE Session Information Total tunnels 1 sessions 1
 
session id: 1
local MAC address: 0050.7359.35b7, remote MAC address: 0001.96a4.84ac
virtual access interface: Vi4, outgoing interface: AT0/0/0, vc: 1/82
    30 packets sent, 28 received, 422 bytes sent, 395 received

Это другие команды отладки:

  • debug vpdn pppoe-data (debug pppoe data)

  • ошибки PPPoE отладки (данные debug pppoe)

  • пакеты pppoe отладки (пакеты debug pppoe)

Уровень PPP

Это - выходные данные отладки PPP от Cisco 6400, который соответствует более ранней отладке от Cisco 1700:

debug ppp negotiation and debug ppp authentication

4d04h: Vi2 PPP: Treating connection as a dedicated line 
4d04h: Vi2 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load] 
4d04h: Vi2 LCP: O CONFREQ [Closed] id 1 len 15 
4d04h: Vi2 LCP:��� AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:��� MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: I CONFREQ [REQsent] id 1 len 10 
4d04h: Vi2 LCP:��� MagicNumber 0x03144FF9 (0x050603144FF9) 
4d04h: Vi2 LCP: O CONFACK [REQsent] id 1 len 10 
4d04h: Vi2 LCP:� ��MagicNumber 0x03144FF9 (0x050603144FF9) 
4d04h: Vi3 LCP: I ECHOREQ [Open] id 60 len 8 magic 0xA60C0000 
4d04h: Vi3 LCP: O ECHOREP [Open] id 60 len 8 magic 0x51A0BEF6 
4d04h: Vi2 LCP: TIMEout: State ACKsent 
4d04h: Vi2 LCP: O CONFREQ [ACKsent] id 2 len 15 
4d04h: Vi2 LCP:��� AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:��� MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: I CONFACK [ACKsent] id 2 len 15 
4d04h: Vi2 LCP:��� AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:��� MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: State is Open 
4d04h: Vi2 PPP: Phase is AUTHENTICATING, by this end [0 sess, 1 load] 
4d04h: Vi2 CHAP: O CHALLENGE id 10 len 26 from "nrp-b" 
4d04h: Vi2 CHAP: I RESPONSE id 10 len 28 from "client1" 
4d04h: Vi2 PPP: Phase is FORWARDING [0 sess, 1 load] 
4d04h: Vi2 PPP: Phase is AUTHENTICATING [0 sess, 1 load] 
4d04h: Vi2 CHAP: O SUCCESS id 10 len 4 
4d04h: Vi2 PPP: Phase is UP [0 sess, 1 load] 
4d04h: Vi2 IPCP: O CONFREQ [Closed] id 1 len 10 
4d04h: Vi2 IPCP:��� Address 8.8.8.1 (0x030608080801) 
4d04h: Vi2 IPCP: I CONFREQ [REQsent] id 1 len 10 
4d04h: Vi2 IPCP:��� Address 0.0.0.0 (0x030600000000) 
4d04h: Vi2 IPCP: Pool returned 9.9.9.2 
4d04h: Vi2 IPCP: O CONFNAK [REQsent] id 1 len 10 
4d04h: Vi2 IPCP: ���Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 CDPCP: I CONFREQ [Not negotiated] id 1 len 4 
4d04h: Vi2 LCP: O PROTREJ [Open] id 3 len 10 protocol CDPCP (0x820701010004) 
4d04h: Vi2 IPCP: I CONFACK [REQsent] id 1 len 10 
4d04h: Vi2 IPCP:��� Address 8.8.8.1 (0x030608080801) 
4d04h: Vi2 IPCP: I CONFREQ [ACKrcvd] id 2 len 10 
4d04h: Vi2 IPCP:��� Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 IPCP: O CONFACK [ACKrcvd] id 2 len 10 
4d04h: Vi2 IPCP:��� Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 IPCP: State is Open 
4d04h: Vi2 IPCP: Install route to 9.9.9.2 
4d04h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed 
 state to up

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 12956