Технологии LRE и xDSL : Поддержка асимметричных цифровых абонентских линий (ADSL)

Пример конфигураций для широкополосного агрегирования Cisco 7200

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (9 ноября 2015) | Отзыв


Содержание


Введение

Этот документ содержит общее описание компонентов цифровой абонентской линии (DSL) и их взаимодействия в базовой реализации DSL. Примеры конфигурации в этом документе показывают наиболее распространенные виды сетей DSL, используемых в настоящее время. Можно использовать эти конфигурации в качестве общего образца при внедрении агрегирования широкополосных каналов. Однако не следует считать эти конфигурации типовым решением на все случаи. У каждого заказчика и в каждой задаче существуют различные требования, и одни и те же цели проекта могут достигаться разными способами.

В то время как конфигурации в этом документе максимально завершены, документ дает только существенные линии. Документ предполагает, что пользователь имеет основное понимание конфигурации устройства Сisco и опускает многие линии основной команды. Используйте эти конфигурации только в качестве стартовой точки для разработки собственной реализации.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Завершение сеанса PPPoA: xDSL на 7200

Схема сети

В данном разделе используются следующие настройки сети:

7200_bdaggreg1.gif

Конфигурации

Данный пример описывает, как подключить Cisco 677 или другой DSL Customer Premises Equipment (CPE), Cisco 7200 через PPP over ATM (PPPoA). Конфигурация включает Cisco Lightstream 1010 (LS1010) коммутатор ATM, который является дополнительным компонентом. Результатами является то же при прямом соединении умножителя доступа DSL (DSLAM) с Cisco 7200.

В данном примере вы устанавливаете сеанс PPP на Cisco 677 и оконечный на Cisco 7200. После завершения сеанса традиционный IP передает трафик Network Service Provider (NSP) или к Интернету.

CPE имеет конфигурацию для выполнения Переадресации/Port Технологии NAT (PAT). CPE также внедряет DHCP server для присвоения IP-адресов на Станции Ethernet.

В этом разделе используются следующие конфигурации:

Конфигурация ПК для PPPoA
  1. IP-адресация Набора для автоматического получения IP-адреса.
  2. WINS набора для использования DHCP для разрешения WINS.
  3. Гарантируйте, что не установлен никакой шлюз по умолчанию.

Примечание: Если DHCP не может передать эту информацию, необходимо установить доменное имя.

Конфигурация CPE Cisco для PPPoA
cbos> enable
Password:

cbos# set nat enable
NAT is now enabled
You must use "write" then reboot for changes to take effect.

cbos# set ppp wan0-0 login 
User name for wan0-0 has been set to testcpe.

cbos# set ppp wan0-0 password 
Password for wan0-0 has been set to cisco.

cbos# set ppp wan0-0 ipcp 0.0.0.0
PPP wan0-0 IPCP Address set to 0.0.0.0

cbos# set int wan0-0 close
cbos# set int wan0-0 vpi 1

cbos# set int wan0-0 vci 32

cbos# set int wan0-0 open

cbos# set int eth0 address 172.22.10.254
eth0 ip address changed from 10.0.0.1 to 172.22.10.254

cbos# set int eth0 netmask 255.255.255.0
eth0 netmask changed from 255.255.255.0 to 255.255.255.0

cbos# set dhcp server enable
DHCP Server enabled

cbos# set dhcp server pool 0 ip 172.22.10.0
Pool 0 IP parameter is now 172.22.10.0

cbos# set dhcp server pool 0 netmask 255.255.255.0
Pool 0 netmask parameter is now 255.255.255.0

cbos# set dhcp server pool 0 gateway 172.22.10.254
Pool 0 gateway parameter is now 172.22.10.254

cbos# set password exec 
Exec Password Change Successful! 

cbos# set password enable 
Enable Password Change Successful! 

cbos# write
NVRAM written.

Конфигурация Cisco DSLam для PPPoA
hostname 6260
! Subtending Port - Will set as shutdown
interface atm0/2
 shutdown
slot 1 atuc-1-4dmt
!
dsl-profile fast
 dmt codeword-size downstream 16 upstream 16
 dmt bitrate maximum interleaved downstream 8032 upstream 832
!
interface atm1/1
 dsl profile fast
 atm pvc 1 32 interface atm0/1 1 35

Конфигурация Cisco LS1010 для PPPoA
interface ATM 0/1/2
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
 ATM pvp 1 interface ATM 0/0/2 1

Конфигурация Cisco 7200 для PPPoA
aaa new-model
AAA authentication ppp default local
!
!
username password 
!
!
interface ATM 2/0.1 multipoint
 no ip directed-broadcast
 PVC 1/35 
  encapsulation aal5mux ppp Virtual-Template 2
!
!
interface FastEthernet 4/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
!
interface Virtual-Template 2
 ip unnumbered FastEthernet 4/0
 no ip directed-broadcast
 peer default ip address pool <pool name>
 ppp authentication pap
!
!
ip local pool <pool name> 172.22.40.10 172.22.40.25

Мостовые соединения RFC1483: xDSL на 7200

Схема сети

В данном разделе используются следующие настройки сети:

7200_bdaggreg2.gif

Конфигурации

Данный пример описывает, как подключить Cisco 677 или другой DSL CPE, Cisco 7200 через мостовую инкапсуляцию RFC 1483 года. Эта конфигурация включает коммутатор ATM Cisco LS1010, который является дополнительным компонентом. Результатами является то же при прямом соединении DSLAM с Cisco 7200.

В данном примере вы устанавливаете соединённый мостом сеанс на Cisco 677 и оконечный на Cisco 7200. После того, как сеанс соединяет Cisco 7200, традиционному трафику проходов IP к NSP или к Интернету. DHCP server с конфигурацией в этих 7200 назначает IP-адрес на клиентскую рабочую станцию.

Эта конфигурация использует Integrated routing and bridging (IRB). Для облегчения масштабируемости и проблем безопасности с IRB рассмотрите Маршрутизированную мостовую инкапсуляцию (RBE).

В этом разделе используются следующие конфигурации:

Конфигурация ПК для RFC 1483
  1. IP-адресация Набора для автоматического получения IP-адреса.
  2. WINS набора для использования DHCP для разрешения WINS.
  3. Гарантируйте, что не установлен никакой шлюз по умолчанию.

Примечание: Если DHCP не может передать эту информацию, необходимо установить доменное имя.

Конфигурация CPE Cisco 677 для RFC 1483
cbos# set bridging rfc1483 enabled

!--- Use write, then reboot for the changes to take effect.


cbos# set bridging management enable

cbos# set int eth0 address 172.22.40.25

!--- You use this IP address for management purposes only.


cbos# set int wan0-0 close
cbos# set int wan0-0 vpi 1

cbos# set int wan0-0 vci 32

cbos# set int wan0-0 open

cbos# write
NVRAM written.

cbos# reboot

Конфигурация Cisco DSLam для RFC 1483
hostname 6260
! Subtending Port - Will set as shutdown
interface atm0/2
 shutdown
slot 1 atuc-1-4dmt
!
dsl-profile fast
 dmt codeword-size downstream 16 upstream 16
 dmt bitrate maximum interleaved downstream 8032 upstream 832
!
interface atm1/1
 dsl profile fast
 ATM PVC 1 32 interface atm0/1 1 35

Конфигурация Cisco LS1010 для RFC 1483
interface ATM 0/1/2
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
 ATM pvp 1 interface ATM 0/0/2 1

Конфигурация Cisco 7200 для RFC 1483
ip dhcp excluded-address 172.22.40.1 172.22.40.25
!
!
ip dhcp pool 0
   network 172.22.40.0 255.255.255.0
   default-router 172.22.40.9 
   dns-server  
   netbios-name-server 
!         
!
bridge irb
!
!
interface ATM 2/0
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
!
!
interface ATM 2/0.1 point-to-point
 no ip directed-broadcast
 PVC 1/35 
  encapsulation aal5snap
 bridge-group 1
!
!
interface ATM 2/0.2 point-to-point
 no ip directed-broadcast
 PVC 1/36 
  encapsulation aal5snap
 bridge-group 1!
!
interface FastEthernet 4/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
!
interface BVI 1
 ip address 172.22.40.9 255.255.255.0
 no ip directed-broadcast
!
!
bridge 1 protocol ieee
 bridge 1 route ip

RBE: xDSL на 7200

Схема сети

В данном разделе используются следующие настройки сети:

7200_bdaggreg2.gif

Конфигурации

RBE в настоящее время является выбранной конфигурацией для самых новых установок DSL. RBE обращается к безопасности и проблемам масштабирования мостового соединения в среде абонента широкополосной связи.

DHCP server с конфигурацией в этих 7200 назначает IP-адрес на клиентскую рабочую станцию.

Важно: DHCP не может работать на маршрутизаторе с ненумерованным ATM кроме тех случаев, когда вы используете Cisco Выпуск ПО IOS� 12.1 (2) T или позже.

В этом разделе используются следующие конфигурации:

Конфигурация ПК для RBE
  1. IP-адресация Набора для автоматического получения IP-адреса.
  2. WINS набора для использования DHCP для разрешения WINS.
  3. Гарантируйте, что не установлен никакой шлюз по умолчанию.

Примечание: Если DHCP не может передать эту информацию, необходимо установить доменное имя.

Конфигурация CPE Cisco для RBE
cbos# set bridging rfc1483 enabled

!--- Use write, then reboot for the changes to take effect.


cbos# set bridging management enable

cbos# set int eth0 address 172.22.40.25

!--- You use this IP address for management purposes only.


cbos# set int wan0-0 close
cbos# set int wan0-0 vpi 1

cbos# set int wan0-0 vci 32

cbos# set int wan0-0 open

cbos# write
NVRAM written.

cbos# reboot

Конфигурация Cisco DSLam для RBE
hostname 6260
! Subtending Port - Will set as shutdown
interface atm0/2
 shutdown
slot 1 atuc-1-4dmt
!
dsl-profile fast
 dmt codeword-size downstream 16 upstream 16
 dmt bitrate maximum interleaved downstream 8032 upstream 832
!
interface atm1/1
 dsl profile fast
 ATM PVC 1 32 interface atm0/1 1 35

Конфигурация Cisco LS1010 для RBE
interface ATM 0/1/2
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
 ATM pvp 1 interface ATM 0/0/2 1

Конфигурация Cisco 7200 для RBE
ip dhcp excluded-address 172.22.40.1 172.22.40.25
!
!
ip dhcp pool 0
   network 172.22.40.0 255.255.255.0
   default-router 172.22.40.9 
   dns-server  
   netbios-name-server 
!
!
interface Loopback0
 ip address 172.22.40.9 255.255.255.0
!
!
interface ATM 2/0
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
!
!
interface ATM 2/0.1 point-to-point
 ip unnumbered Loopback0
 no ip directed-broadcast
 ATM route-bridged ip
 PVC 1/35 
  encapsulation aal5snap
!
!
interface ATM 2/0.2 point-to-point
 ip unnumbered Loopback0
 no ip directed-broadcast
 ATM route-bridged ip
 PVC 1/36 
  encapsulation aal5snap
!
!
interface FastEthernet 4/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
!

PPPoE: xDSL на 7200

Схема сети

В данном разделе используются следующие настройки сети:

7200_bdaggreg3.gif

Конфигурации

PPP over Ethernet (PPPoE) расширяет сеанс PPP от маршрутизатора до конца клиент. PPP и программное обеспечение для аутентификации обычно работают на клиенте или в операционной системе или в автономном приложении. CPE действует в режиме моста для мостового соединения сеанса PPP по подключению DSL. Но CPE не может действовать как DHCP server в этом сценарии.

Конфигурации для CPE, DSLAM и коммутатора ATM совпадают с конфигурациями для RFC 1483, соединяя. Можно настроить маршрутизатор с поддержкой агрегирования Cisco 7200 для локальной проверки подлинности, как показано в примере. Или можно настроить 7200 с Проверкой подлинности RADIUS аутентификации, авторизации и учета (AAA).

В этом разделе используются следующие конфигурации:

Конфигурация ПК для PPPoE
  1. IP-адресация Набора для автоматического получения IP-адреса.
  2. WINS набора для использования DHCP для разрешения WINS.
  3. Гарантируйте, что не установлен никакой шлюз по умолчанию.

Примечание: Если DHCP не может передать эту информацию, необходимо установить доменное имя.

Примечание: Конечная станция должна быть в состоянии установить PPP - подключение к маршрутизатору. Специальное клиентское программное обеспечение для аутентификации и доступа может быть необходимым.

Конфигурация CPE Cisco 677 для PPPoE
cbos# set bridging rfc1483 enabled

!--- Use write, then reboot for the changes to take effect.


cbos# set bridging management enable

cbos# set int eth0 address 172.22.40.25

!--- You use this IP address for management purposes only.


cbos# set int wan0-0 close
cbos# set int wan0-0 vpi 1

cbos# set int wan0-0 vci 32

cbos# set int wan0-0 open

cbos# write
NVRAM written.

cbos# reboot

Конфигурация Cisco DSLam для PPPoE
hostname 6260
! Subtending Port - Will set as shutdown
interface atm0/2
 shutdown
slot 1 atuc-1-4dmt
!
dsl-profile fast
 dmt codeword-size downstream 16 upstream 16
 dmt bitrate maximum interleaved downstream 8032 upstream 832
!
interface atm1/1
 dsl profile fast
 ATM PVC 1 32 interface atm0/1 1 35

Конфигурация Cisco LS1010 для PPPoE
interface ATM 0/1/2
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
 ATM pvp 1 interface ATM 0/0/2 1

Конфигурация Cisco 7200 для PPPoE
!
username <username> password <password>
!
vpdn enable
!
vpdn-group 1
 accept-dialin
  protocol pppoe
  virtual-template 1
  pppoe limit per-mac 100
  pppoe limit per-vc 100
!
ip cef
!
interface atm2/0
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
!
!
interface ATM 2/0.1 point-to-point
 no ip directed-broadcast
 PVC 1/35 
  encapsulation aal5snap
  protocol pppoe
!
!
interface ATM 2/0.2 point-to-point
 no ip directed-broadcast
 PVC 1/36 
  encapsulation aal5snap
  protocol pppoe
!
interface Virtual-Template1
 ip unnumbered FastEthernet 4/0
 no ip directed-broadcast
 peer default ip address pool <pool name>
 ppp authentication pap
!
interface FastEthernet 4/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
ip local pool <pool name> 172.22.32.20 172.22.32.100

L2TP: XDSL до 7200 через l2tp

Схема сети

В данном разделе используются следующие настройки сети:

7200_bdaggreg4.gif

Конфигурации

Уровень Два Протокола туннелирования (L2TP) предоставляет средство завершить PPP - подключение от конечного пользователя в одном местоположении и транспортировать пакеты данных L2 к другому местоположению. L2TP разгружает большую часть функциональных возможностей протокола IP от устройства агрегации и позволяет проекты более централизованной сети. Сервер RADIUS предоставляет AAA.

Конфигурации для всех устройств кроме Cisco 7200 совпадают с конфигурациями для примера RFC 1483 года.

В этом разделе используются следующие конфигурации:

Конфигурация ПК для L2TP
  1. IP-адресация Набора для автоматического получения IP-адреса.
  2. WINS набора для использования DHCP для разрешения WINS.
  3. Гарантируйте, что не установлен никакой шлюз по умолчанию.

Примечание: Если DHCP не может передать эту информацию, необходимо установить доменное имя.

Конфигурация CPE Cisco 677 для L2TP
cbos> enable
Password:

cbos# set nat enable
NAT is now enabled
You must use "write" then reboot for changes to take effect.

cbos# set ppp wan0-0 login 
User name for wan0-0 has been set to testcpe.

cbos# set ppp wan0-0 password 
Password for wan0-0 has been set to cisco.

cbos# set ppp wan0-0 ipcp 0.0.0.0
PPP wan0-0 IPCP Address set to 0.0.0.0

cbos# set int wan0-0 close
cbos# set int wan0-0 vpi 1

cbos# set int wan0-0 vci 32

cbos# set int wan0-0 open

cbos# set int eth0 address 172.22.10.254
eth0 ip address changed from 10.0.0.1 to 172.22.10.254

cbos# set int eth0 netmask 255.255.255.0
eth0 netmask changed from 255.255.255.0 to 255.255.255.0

cbos# set dhcp server enable
DHCP Server enabled

cbos# set dhcp server pool 0 ip 172.22.10.0
Pool 0 IP parameter is now 172.22.10.0

cbos# set dhcp server pool 0 netmask 255.255.255.0
Pool 0 netmask parameter is now 255.255.255.0

cbos# set dhcp server pool 0 gateway 172.22.10.254
Pool 0 gateway parameter is now 172.22.10.254

cbos# set password exec 
Exec Password Change Successful! 

cbos# set password enable 
Enable Password Change Successful! 

cbos# write
NVRAM written.

Конфигурация Cisco DSLam для L2TP
hostname 6260
! Subtending Port - Will set as shutdown
interface atm0/2
 shutdown
slot 1 atuc-1-4dmt
!
dsl-profile fast
 dmt codeword-size downstream 16 upstream 16
 dmt bitrate maximum interleaved downstream 8032 upstream 832
!
interface atm1/1
 dsl profile fast
 ATM PVC 1 32 interface atm0/1 1 35

Конфигурация Cisco LS1010 для L2TP
interface ATM 0/1/2
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
 ATM pvp 1 interface ATM 0/0/2 1

Конфигурация LAC Cisco 7200 для L2TP
!
AAA new-model
AAA authentication login default none
AAA authentication ppp default local group radius
AAA authorization network default local group radius none
AAA accounting network default wait-start group radius
!  
vpdn-group 4
 request-dialin
  protocol l2tp
  domain cisco.com
 initiate-to ip 172.22.32.27 priority 1
 local name cisco-tunnel      
!
interface ATM 2/0
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
!
!
interface ATM 2/0.1 point-to-point
 no ip directed-broadcast
 PVC 1/35 
  encapsulation aal5mux ppp Virtual-Template1
!
!
interface ATM 2/0.2 point-to-point
 no ip directed-broadcast
 PVC 1/36 
  encapsulation aal5mux ppp Virtual-Template1
!
!
interface FastEthernet 4/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
!
interface Virtual-Template1
 ip unnumbered FastEthernet4/0
 no ip directed-broadcast
 ppp authentication pap
!
!
radius-server host 172.22.32.20 auth-port 1645 acct-port 1646
radius-server key cisco

Конфигурация LNS Cisco 7200 для L2TP
!
AAA new-model
AAA authentication login default none
AAA authentication ppp default local group radius
AAA authorization network default local group radius none
AAA accounting network default wait-start group radius
!
vpdn-group 1
 accept-dialin
  protocol any
  virtual-template 1
 terminate-from hostname cisco-tunnel
 local name tunnel-gate
!
radius-server host 172.22.32.20 auth-port 1645 acct-port 1646
radius-server key cisco

Проверка.

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 12868