Интерфейсы и модули Cisco : Модуль коммутации контента Cisco

Настройка балансировки загрузки FTP-сервера при использовании IOS SLB

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ предоставляет пример конфигурации для распределения нагрузки сервера FTP с помощью распределения нагрузки сервера Cisco IOS (SLB).

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • Супервизор семейства Catalyst 6000 Cisco Выпуск ПО IOS� 12.1 (8) E для Supervisor Engine 1 с MSFC1 (c6sup11-jsv-mz.121-8a. E)

  • Microsoft Windows 2000 / Серверы FTP IIS

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Общие сведения

Функцией SLB Cisco IOS является Cisco на основе IOS решение, которое предоставляет распределение нагрузки сервера. Эта функция позволяет вам определять виртуальный сервер, который представляет кластер реальных серверов, известных как ферма серверов. Когда клиент инициирует соединение к виртуальному серверу, IOS SLB балансировки нагрузки подключается к выбранному реальному серверу, в зависимости от настройки баланса алгоритма баланса загрузки или упредителя равновесия нагрузки.

Когда вы используете SLB IO, вы должны сконфигурировать балансировку нагрузки FTP сервера, для того чтобы работать в режиме отправки. В этом режиме виртуальный адрес известен серверам FTP. Необходимо настроить каждый из серверов FTP с адресами обратной связи для их уникального интерфейса обратной связи. Этот шаг необходим для предоставления каждой машины в сервере FTP в ферме тот же IP-адрес как виртуальный адрес. Сервер FTP может тогда непосредственно ответить клиентам с адресом обратной связи, так же, как сервер ответил бы для собственного IP-адреса. SLB IOS перенаправляет пакеты к реальному серверу на Уровне 2 в уровне управления доступом к среде (MAC). IP-адрес виртуального сервера не изменяется в режиме координации. Поэтому, реальные сервера должны быть Layer 2-смежными с IOS SLB. В противном случае промежуточные маршрутизаторы не могут направить к выбранному реальному серверу.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Используйте инструмент Command Lookup (только для зарегистрированных пользователей) для того, чтобы получить более подробную информацию о командах, использованных в этом разделе.

Схема сети

В настоящем документе используется следующая схема сети:

/image/gif/paws/12577/config_ftpserver_lb.gif

Конфигурации

В данном документе используется следующая конфигурация:

  • Настройка IOS SLB FTP Использование Catalyst 5509

Настройка IOS SLB FTP Использование Catalyst 5509
Current configuration: 
! 
version 12.1 
service timestamps debug uptime 
service timestamps log uptime 
no service password-encryption 
! 
hostname cat 
! 
boot buffersize 126968 
boot system flash slot0:c6sup11-jsv-mz.121-8a.E.bin 
! 
redundancy 
 main-cpu 
  auto-sync standard 
ip subnet-zero 
! 

!--- FTP Serverfarm configuration.
 
ip slb serverfarm FTPFARM 
 real 10.1.1.3 
  inservice 
 !  
 real 10.1.1.4 
  inservice 
! 

!--- FTP Virtual configuration. 
!--- Important: Config Loopback address on FTP Server's with Virtual address.
 
ip slb vserver FTPSERVER 
 virtual 172.17.63.241 tcp ftp service ftp 
 serverfarm FTPFARM 
 inservice 
! 
interface GigabitEthernet1/1 
 no ip address 
 shutdown 
! 
interface GigabitEthernet1/2 
 no ip address 
 shutdown 
! 
interface FastEthernet2/1 
 description "Uplink to the Default Gateway" 
 no ip address 
 switchport 
 switchport access vlan 100 
! 
interface FastEthernet2/2 
 no ip address 
 shutdown 
! 
interface FastEthernet2/3 
 description "Connection to FTP server" 
 no ip address 
 switchport 
 switchport access vlan 200 
! 
interface FastEthernet2/4 
 description "Connection to FTP server" 
 no ip address 
 switchport 
 switchport access vlan 200 
! 
interface FastEthernet2/5 
 no ip address 
 shutdown 
! 
interface FastEthernet2/48 
 no ip address 
 shutdown 
! 
interface Vlan1 
 no ip address 
 shutdown 
! 

!--- Client Side Vlan. 

interface Vlan100 
 ip address 172.17.63.240 255.255.255.192 
! 

!--- FTP Server Vlan. 
!--- Important: Configure the default gateway of the FTP Server to this address.

interface Vlan200 
 ip address 10.1.1.250 255.255.255.0 
! 
ip classless 
ip route 0.0.0.0 0.0.0.0 172.17.63.193 
no ip http server 
! 
line con 0 
line vty 0 4 
 login 
! 
end

Примечание: В дополнение к IOS SLB, модуль Content Switching также доступен для коммутаторов Cisco серии Catalyst 6500 и маршрутизаторов серии Cisco 7600 Series. Этот модуль предоставляет высокопроизводительные подключения между фермами серверов сетевых устройств на основе информационных пакетов от Уровня 4 до 7. Для получения дальнейшей информации обратитесь к модулю коммутации контента Cisco.

Проверка

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

  • show ip slb vserver — Отображает информацию о виртуальном сервере. Вот пример, который отображает состояние виртуального сервера и количество соединений:

    cat#show ip slb vserver 
    
    slb vserver    protocal   virtual                 state         conns 
    ----------------------------------------------------------------------
    FTPSERVER      TCP        172.17.63.241/32:21     OPERATIONAL    4
  • show ip slb reals — Отображает данные фермы серверов. Эта команда показывает предиктор, используемый для распределения нагрузки. Данный пример использует циклический выбор (по умолчанию). "Ни один" не появляется под NAT, потому что устройство находится в режиме координации.

    cat#show ip slb serverfarm 
    
    server farm     predictor       nat        reals        bind id 
    ----------------------------------------------------------------- 
    FTPFARM         ROUNDROBIN      none          2           0

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

caution Внимание: Выходные данные отладки являются назначенным высоким приоритетом в Процессе ЦПУ. Поэтому отладка может сделать систему неработоспособной. По этой причине использовать команды debug рекомендуется только для устранения конкретных проблем или во время сеансов по устранению проблем совместно с персоналом технической поддержки Cisco. Cisco рекомендует использовать команды отладки в течение периодов потоков более низких сетей и меньшего количества пользователей. Отладка в течение этих периодов уменьшает эффект этих команд на других пользователях в системе.

Команды для устранения неполадок

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Примечание: Обратитесь к документу Важная информация о командах отладки, прежде чем использовать команды debug.

  • debug ip slb {conns | reals | vservers | all} - показывает отладочные сообщения. Используйте любые формы этой команды, чтобы отключить отладку. Вот описание синтаксиса:

    Синтаксис Описание
    вести Отображает сообщения отладки для всех соединений, которые в настоящее время обрабатывает SLB IOS.
    vserver Отображает сообщения отладки для всех виртуальных серверов, определенных к SLB IOS.
    реальные сервера и приложения Отображает сообщения отладки для всех реальных серверов, определенных к SLB IOS.
    все Отображает все сообщения отладки для SLB IOS.

    Сеансы FTP состоят из двух соединений между Клиентом FTP и Сервером FTP, а именно, Контролем и Данными.

  • соединения debug ip slb

    Вот пример, который использует Пассивный FTP. В самых простых сроках это - то, как работает Пассивный FTP:

    • Одно соединение для начального управляющего соединения FTP, которое клиент инициирует к серверу:

      2d22h: SLB_CONN_DEBUG: TCP event= SYN_CLIENT,
       state= INIT -> SYNCLIENT 
      2d22h:  v_ip= 172.17.63.241:21 (  5), real= 10.1.1.4 
      2d22h:  client= 171.70.24.233:35006 
      2d22h: SLB_CONN_DEBUG: TCP event= SYNACK_SERVER,
       state= SYNCLIENT -> ESTAB 
      2d22h:  v_ip= 172.17.63.241:21 (  5), real= 10.1.1.4 
      2d22h:  client= 171.70.24.233:35006 
    • Другое соединение для информационного соединения ftp, которое инициируется от клиента к серверу:

      2d21h: SLB_CONN_DEBUG: TCP event= DATA_CLIENT,
       state= ESTAB -> ESTAB 
      2d21h:  v_ip= 172.17.63.241:21 (  5), real= 10.1.1.4 
      2d21h:  client= 171.70.24.233:34999 
      2d21h: SLB_CONN_DEBUG: TCP event= DATA_SERVER,
       state= ESTAB -> ESTAB 
      2d21h:  v_ip= 172.17.63.241:21 (  5), real= 10.1.1.4 
      2d21h:  client= 171.70.24.233:34999

Заметьте, что в пассивном FTP, клиент инициирует и контрольное соединение и соединение в режиме передачи данных. Пассивный режим обращается к состоянию Серверов в этом, сервер пассивно принимает оба соединения. В пассивном режиме и назначение и исходные порты являются 'эфемерными' портами (больше, чем 1023). Клиент ведет режимы, как в каждом случае клиент должен выполнить или команду passive или команду порта, для инициирования настройки соединения в режиме передачи данных. В каждом случае получатель соединения в режиме передачи данных (сервер для пассивного режима, клиент для активного режима) должен предоставить номер порта, на котором они прислушиваются к этому определенному соединению. Это не порт 20 ALWAYS для соединения в режиме передачи данных, даже в FTP активного режима. Ничто в RFC не указывает, что порты, которые будут использоваться, равняются 20 и 21, это - просто соглашение. Много серверов используют временные порты для соединения в режиме передачи данных.

% Не может включить nat сервера, потому что vserver [char] включили FTP

Это сообщение об ошибках отображено, потому что SLB IOS не поддерживает FTP в режиме NAT. Обходной путь должен использовать режим Отправки и loopback на серверах. Для получения дополнительной информации посмотрите Раздел обратной петли Режима координации.

Обратная связь в режиме диспетчера

После настройки функции Serverfarm и Vserver FTP на Catalyst 6500 необходимо настроить каждый реальный сервер с устройством возвратной петли или интерфейсом. Настройте IP-адрес виртуального сервера как IP - адрес обратной связи с маской подсети 255.0.0.0.

Route Table 
     =========================================================================== 
     Interface List 
     0x1 ........................... MS TCP Loopback interface 
     0x2 ...00 60 b0 87 dc 1a ...... AMD PCNET Family Ethernet Adapter 
     0x1000004 ...02 00 4c 4f 4f 50 ...... MS LoopBack Driver 
     =========================================================================== 
     Active Routes: 
        Network         Destination     Netmask       Gateway   Interface Metric 
        0.0.0.0         0.0.0.0         10.1.1.250    10.1.1.3      1 
        10.1.1.0        255.255.255.0   10.1.1.3      10.1.1.3      1 
        10.1.1.3        255.255.255.255 127.0.0.1     127.0.0.1     1 
        10.255.255.255  255.255.255.255 10.1.1.3      10.1.1.3      1 
        127.0.0.0       255.0.0.0       127.0.0.1     127.0.0.1     1 
        172.17.63.241   255.255.255.255 127.0.0.1     127.0.0.1     1 
        224.0.0.0       224.0.0.0       10.1.1.3      10.1.1.3      1 
        224.0.0.0       224.0.0.0       172.17.63.241 172.17.63.241 1 
        255.255.255.255 255.255.255.255 10.1.1.3      10.1.1.3      1 
     ===========================================================================

Исследуйте сетевой адрес в каждой строке таблицы, где вы видите, что появляется адрес обратной связи. Для серверов для передачи должным образом вам нужна ссылка на хорошо известный сетевой адрес многоадресной рассылки. Это находится в восьмой строке в примере, таким образом, необходимо удалить дополнительный маршрут по умолчанию. Это - то, сетевой адрес которого начинается с той же первой цифры как адрес кластера и придерживается три, обнуляет. В данном примере дополнительный маршрут находится во второй строке.

Это хорошо известные сетевые адреса многоадресной рассылки:

224.0.0.0      224.0.0.0    172.17.63.241      172.17.63.241       1

Вот автоматически установленные маршруты по умолчанию, удаленные из таблицы в примере:

0.0.0.0          0.0.0.0    172.17.63.193   172.17.63.241          1

Необходимо удалить дополнительный маршрут для разрешения соответствующего взаимодействия с виртуальным сервером SLB.


Дополнительные сведения


Document ID: 12577