Протокол IP : Протокол PPTP

Настройка PPTP через PAT для сервера Microsoft PPTP

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (9 февраля 2011) | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Двухточечный протокол туннелирования Microsoft (MS PPTP) позволяет пользователям удаленно подключаться к своей корпоративной сети по защищенному каналу через открытый Интернет. Для экономии пула внешних IP-адресов можно назначить удаленному объекту один IP-адрес. В этом случае можно позволить одновременно нескольким пользователям устанавливать соединения по протоколу PPTP с одним или разными объектами. PPTP был добавлен в Cisco Выпуск ПО IOS� 12.1 (4) T.

{\f3 Дополнительную информацию см. в разделе «NAT }–{\f3 поддержка PPTP в конфигурации с перегрузкой (преобразованием адресов портов)» Руководства по выпуску ПО Cisco IOS 12.1 T для предварительного развертывания.}

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Маршрутизаторы Cisco 3600 под управлением выпусков ПО Cisco IOS 12.1.5(9)T и 12.2.3

  • Все платформы на базе ОС Windows со встроенными стандартными клиентами PPTP

  • Расширенная версия по установке серверной части ПО MS Windows 2000 со встроенным сервером PPTP

Сведения, представленные в этом документе, были получены от устройств в специфической лабораторной среде. Все устройства, используемые в этом документе, были запущены с чистой конфигурацией (конфигурацией по умолчанию). При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Условные обозначения

Более подробную информацию о применяемых в документе обозначениях см. в описании условных обозначений, используемых в технической документации Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/12483/pptp_pat_01-new.gif

Конфигурации

Эти конфигурации используются в данном документе:

Маршрутизатор light
Current configuration : 1136 bytes 
! 
version 12.2 
service timestamps debug upti 
service timestamps log uptime 
no service password-encryption 
! 
hostname light 
! 
boot system tftp c3660-jk9o3s-mz.122-3.bin 255.255.255.255 
! 
ip subnet-zero 
! 
! 
no ip domain-lookup 
! 
ip audit notify log 
ip audit po max-events 100 
ip ssh time-out 120 
ip ssh authentication-retries 3 
! 
call rsvp-sync 
cns event-service server 
! 
! 
! 
! 
! 
fax interface-type modem 
mta receive maximum-recipients 0 
! 
controller E1 2/0 
! 
! 
! 
interface FastEthernet0/0 
ip address 10.64.10.13 255.255.255.224

!--- Defines the interface as external for NAT.

ip nat outside
duplex auto 
speed auto 
! 
interface FastEthernet0/1 
ip address 192.168.200.1 255.255.255.0 

!--- Defines the interface as internal for NAT.

ip nat inside
duplex auto 
speed auto 
! 
interface Serial1/0 
no ip address 
shutdown 
no fair-queue 
! 
interface Serial1/1 
no ip address 
shutdown 
! 
interface Serial1/2 
no ip address 
shutdown 
! 
interface Serial1/3 
no ip address 
shutdown 
! 

!--- Indicates that any packets received on the inside interface permitted
!--- by access list 101 share one public IP address (the address on Fa0/0).

ip nat inside source list 101 interface FastEthernet0/0 overload 
ip classless 
ip route 0.0.0.0 0.0.0.0 10.64.10.1 
no ip http server 
!
access-list 101 permit ip any any
!
!
dial-peer cor custom
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
end

Таблица преобразования IP NAT
light#show ip nat translations

Pro Inside global      Inside local          Outside local      Outside global
gre 10.64.10.13:50150  192.168.200.253:50150 10.64.10.21:50150  10.64.10.21:50150
gre 10.64.10.13:50151  192.168.200.254:50151 10.64.10.21:50151  10.64.10.21:50151
gre 10.64.10.13:0      192.168.200.254:0     10.64.10.21:0      10.64.10.21:0
gre 10.64.10.13:32768  192.168.200.253:32768 10.64.10.21:32768  10.64.10.21:32768
tcp 10.64.10.13:2643   192.168.200.253:2643  10.64.10.21:1723   10.64.10.21:1723
tcp 10.64.10.13:3546   192.168.200.254:3546  10.64.10.21:1723   10.64.10.21:1723

Маршрутизатор house
Building configuration...

Current configuration : 2281 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname house
!
enable password cisco
!
ip subnet-zero
!
!
!
fax interface-type modem
mta receive maximum-recipients 0
!
!
interface FastEthernet0/0
 ip address 10.64.10.21 255.255.255.224

!--- Defines the interface as external for NAT.

ip nat outside
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.50.1 255.255.255.0

!--- Defines the interface as internal for NAT.

ip nat inside
 duplex auto
 speed auto
!
!
interface FastEthernet4/0
 no ip address
 shutdown
 duplex auto
 speed auto
!

!--- Indicates that any packets received on the inside interface permitted by 
!--- access list 101 share one public IP address (the address on Fa0/0).

ip nat inside source list 101 interface FastEthernet0/0 overload

!--- Static port translation for the Microsoft PPTP server on TCP port 1723
!--- share one public IP address (the address on Fa0/0).

ip nat inside source static tcp 192.168.50.2 1723 interface FastEthernet0/0 1723
ip classless
ip route 0.0.0.0 0.0.0.0 10.64.10.1
ip http server
ip pim bidir-enable
!
access-list 101 permit ip any any
!
!
snmp-server manager
!
call rsvp-sync
!
!
mgcp profile default
!
dial-peer cor custom
!
!
line con 0
line aux 0
line vty 0 4
password cisco
login
!
!
end

Таблица преобразования IP NAT
house#show ip nat translations

Pro Inside global      Inside local       Outside local      Outside global
gre 10.64.10.21:50150  192.168.50.2:50150 10.64.10.13:50150  10.64.10.13:50150
gre 10.64.10.21:50151  192.168.50.2:50151 10.64.10.13:50151  10.64.10.13:50151
gre 10.64.10.21:0      192.168.50.2:0     10.64.10.13:0      10.64.10.13:0
gre 10.64.10.21:32768  192.168.50.2:32768 10.64.10.13:32768  10.64.10.13:32768
tcp 10.64.10.21:1723   192.168.50.2:1723  10.64.10.13:2643   10.64.10.13:2643
tcp 10.64.10.21:1723   192.168.50.2:1723  ---                ---
tcp 10.64.10.21:80     192.168.50.2:80    ---                ---
tcp 10.64.10.21:1723   192.168.50.2:1723  10.64.10.13:3546   10.64.10.13:3546

Настройка сервера MS PPTP

Для настройки сервера MS PPTP выполните следующие шаги:

  1. Перейдите в раздел Routing and Remote Access (Маршрутизация и удаленный доступ) и выберите Configure and Enable Routing and Remote Access (Настроить и включить маршрутизацию и удаленный доступ).

    /image/gif/paws/12483/pptp_pat_02.gif

  2. В мастере установки сервера маршрутизации и удаленного доступа (Routing and Remote Access Server Setup Wizard) выберите сервер сети VPN.

    /image/gif/paws/12483/pptp_pat_03.gif

  3. Определите IP-адреса во внутренней и внешней сетях для сетевой платы (NIC) сервера.

    pptp_pat_04.gif

  4. Назначьте пул IP-адресов удаленным клиентам PPTP.

    /image/gif/paws/12483/pptp_pat_05.gif

  5. Можно использовать как сервер аутентификации MS RADIUS, так и локальную аутентификацию.

    /image/gif/paws/12483/pptp_pat_06.gif

  6. Создайте локальную базу данных пользователей для локальной аутентификации.

    /image/gif/paws/12483/pptp_pat_07.gif

  7. Два клиента PPTP позади маршрутизатора Преобразования адресов портов (PAT) связаны с сервером PPTP MS.

    pptp_pat_08.gif

Проверка.

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

  • {\f3 show ip nat translations }–{\f3 показывает содержимое таблицы преобразования.}

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Ресурсы для устранения неполадок

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 12483