Технологии IBM : Коммутация соединения передачи данных (DLSw) и Data-Link Switching Plus (DLSw +)

Основные конфигурации DLSw+

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Data Link Switching (DLSw) – это протокол передачи данных между коммутаторами, который используется для передачи трафика IBM Systems Network Architecture (SNA) и IBM NetBIOS по IP-сети. Данный протокол не поддерживает полную маршрутизацию, однако обеспечивает коммутацию на уровне канала связи SNA и инкапсуляцию TCP/IP для передачи через Интернет.

Перед началом работы

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Предварительные условия

Для данного документа отсутствуют предварительные условия.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Сведения, представленные в этом документе, были получены от устройств в специфической лабораторной среде. Все устройства, используемые в этом документе, были запущены с чистой конфигурацией (конфигурацией по умолчанию). При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Общие сведения

DLSw+ является внедрением DLSw Cisco. Помимо стандарта DLSw, DLSw+ включает следующие возможности:

  • Выбор параметров передачи, включая TCP, FST (быстродействующая последовательная передача) и прямая инкапсуляция.

  • Усовершенствования масштабирования увеличиваются благодаря: группы одноранговых узлов, по требованию узлы, межсетевые экраны для проводника и изучение расположения.

  • Преобразование средства связи между локальной и удаленной LAN, а также SDLC или Ethernet.

Что такое стандарт DLSw?

Более подробное описание стандарта DLSw см. в RFC 1795 (документ RFC 1434 считается устаревшим после выпуска RFC 1795). В сводке RFC 1795 описывает протокол коммутатор-коммутатор (SSP), используемый между маршрутизаторами для установления подключений DLSw, обнаружения ресурсов, пересылки данных, обработки управления потоком и восстановления после ошибок. Он также описывает, как локально завершить подключения управления канала передачи данных (DLC) и отобразить эти подключения в канале DLSw.

В случае локального отключения DLC-соединений, DLSw устраняет следующие неполадки:

  • Время ожидания DLC

  • Подтверждения DLC по WAN

  • Управление потоком и загруженностью

  • Управление широковещанием поисковых пакетов

  • Максимальное значение счетчика переходов мостового соединения "источник-маршрут"

Примечание: Усовершенствования к RFC 1795 могут быть найдены в RFC 2166. Те усовершенствования обращаются к проблемам масштабирования в DLSw и разъяснениях к RFC 1795. RFC 2166, однако, не делает устаревшего 1795 и должен использоваться в сочетании с 1795.

Примеры конфигураций

Конфигурации, изображенные здесь, являются частичными конфигурациями; они изображают только часть конфигурации, требуемой для поддержки DLSw+ и ни одного из IP или другой поддержки протокола. Поскольку DLSw+ зависит от TCP/IP (за исключением ситуаций, когда используется FST или direct), предполагается, что IP-сеть уже включена и работает.

1. Token Ring — Token Ring по WAN

/image/gif/paws/12411/ringwan.gif

Router A

!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.1 255.255.255.0
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning

 
!--- Allows the router to forward single route explorer frames.

Router B

!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 0 tcp 150.150.1.1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.2 255.255.255.0
!
interface TokenRing0
 ip address 150.150.20.2 255.255.255.0
 ring-speed 16
 source-bridge 2 1 2000
 source-bridge spanning

 
!--- Allows the router to forward single route explorer frames.

В данном примере мы используем одно виртуальное кольцо (номер 2000) для легкого установления взаимосвязи между этими двумя группами. Поле маршрутной информации (RIF), однако, завершено в маршрутизаторе DLSw+. Можно выбрать другой номер виртуального кольца для каждого маршрутизатора. Будьте осторожны при выборе номера кольца; необходимо придерживаться тех же правил, которые применяются к мостовому соединению исходного маршрута. В настоящее время Cisco только поддерживает одно виртуальное кольцо на маршрутизатор.

Команда dlsw local-peer используется для определения собственного IP-адреса DLSw+ для локального маршрутизатора. В приведенном выше примере используется IP-адрес интерфейса обратной связи, поэтому DLSw+ не приходится полагаться на работу реального физического интерфейса.

Команда dlsw remote-peer определяет IP-адрес удаленного маршрутизатора. Цифра 0, следующая за ключевым словом удаленного сайта, это номер кругового списка. Обычно, если вы хотите полностью объединенная сеть, используйте количество 0. Номер кругового списка используется для управления затоплением проверочных фреймов, позволяя сети быть сегментированным (см. пример два для демонстрации списка рингтонов).

2. Соединение Token Ring - Token Ring со списком колец

/image/gif/paws/12411/ringlist.gif

Router A

!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.1 255.255.255.0
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2000
 source-bridge spanning 

 
!--- Allows the router to forward single route explorer frames.

Router B
!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 1 tcp 150.150.1.1
dlsw ring-list 1 rings 1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.2 255.255.255.0
!
interface TokenRing0
 ip address 150.150.20.2 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning 

 
!--- Allows the router to forward single route explorer frames.

!
interface TokenRing1
ip address 150.150.30.1 255.255.255.0
ring-speed 16
source-bridge 2 1 2000
source bridge spanning 


!--- Allows the router to forward single route explorer frames.

В данном примере все рабочие станции на Вызове 3 могут только установить сеансы со станциями на Вызове 1, но не Вызове 2, и наоборот. Станции на кольце 1 все еще имеют связь со станциями на кольце 2, так как они присоединены локально к маршрутизатору B.

Это означает, что не будет никакого широковещательного сообщения от Вызова 2, который будет отправлен Маршрутизатору A. Использование выражений dlsw ring-list, port-list, и bgroup-list полезно при управлении широковещательным трафиком в WAN.

3. Token Ring — Ethernet по WAN

/image/gif/paws/12411/ringether.gif

В этом примере устройства располагаются на носителях смешанного типа, поэтому необходимо перераспределить биты MAC-адреса хоста, прежде чем он будет закодирован на дополнительном устройстве, инициирующем тестовый пакет-анализатор. См. также Понимание и Устранение проблем Source-Route Translational Bridging.

Router A

!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.1 255.255.255.0
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning 

!--- Allows the router to forward single route explorer frames.


В этом примере станция сегмента Ethernet имеет возможность взаимодействовать со станциями сегмента Token Ring. Маршрутизатор DLSw+ отвечает за преобразование из формата Ethernet в формат Token Ring. Команда dlsw bridge-group используется для связывания сегмента Ethernet с процессом DLSw+ таким же образом, как инструкция исходного моста связывает сегмент Token Ring с DLSw+ через виртуальную группу одновременного вызова. Нет необходимости настраивать SRT/LB, кроме случая, когда имеется интерфейс Token Ring на маршрутизаторе B, и при этом требуется связь между станциями на основе этого Token Ring и Ethernet. Посмотрите пример 6.

Примечание:  группа колец исходного моста на маршрутизаторе B не нужна.

Router B
!
dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 0 tcp 150.150.1.1
dlsw bridge-group 1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.2 255.255.255.0
!
interface Ethernet0
 ip address 150.150.30.1 255.255.255.0
 bridge-group 1
!
bridge 1 protocol dec
!

4. Канал Ethernet-Ethernet через глобальную сеть (WAN)

/image/gif/paws/12411/etherwan.gif

Router A
!
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
dlsw bridge-group 1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.1 255.255.255.0
!
interface Ethernet0
 ip address 150.150.30.1 255.255.255.0
 bridge-group 1
!
bridge 1 protocol dec
!
Router B
!
dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 0 tcp 150.150.1.1
dlsw bridge-group 1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.2 255.255.255.0
!
interface Ethernet0
 ip address 150.150.40.1 255.255.255.0
 bridge-group 1
!
bridge 1 protocol dec

Примечание: группа колец исходного моста на каждом маршрутизаторе не нужна.

5. Token Ring - Ethernet в одном маршрутизаторе

/image/gif/paws/12411/tokenether.gif

Чтобы соединить станции между Ethernet и Token Ring, которые являются локальными сетями для маршрутизатора, необходимо использовать SR/TLB (трансляционное мостовое соединение). Локальный DLSw между Ethernet и Token Ring не поддерживается.

Router A

source-bridge ring-group 2000
source-bridge transparent 2000 1000 1 1

interface Ethernet0
 ip address 150.150.40.1 255.255.255.0
 bridge-group 1
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning

!--- Allows the router to forward single route explorer frames.

!
bridge 1 protocol ieee

Для команды, source-bridge transparent 2000 1000 1 1, мы имеем:

  • 2000 – номер виртуального кольца, сконфигурированный при помощи source-bridge ring-group 2000.

  • 1000 номер псевдокольца, данный домену ethernet.

  • 1 – этот номер моста, ведущего к домену с прозрачным мостовым соединением.

  • 1 – это номер прозрачной группы мостов, которую нужно связать в домен с маршрутизацией от источника.

Примечание: IP-адреса на интерфейсах не требуются для SRT/LB.

6. SR/TLB и DLSw+

srtlb.gif

Router A
source-bridge ring-group 2000
source-bridge transparent 2000 1000 1 1
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
dlsw bridge-group 1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Ethernet0
 ip address 150.150.40.1 255.255.255.0
 bridge-group 1
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning

!--- Allows the router to forward single route explorer frames.

!
bridge 1 protocol dec
Router B
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 0 tcp 150.150.1.1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface TokenRing0
 ip address 150.150.11.1  255.255.255.0
 ring-speed 16
 source-bridge 2 1 2000
 source-bridge spanning 

!--- Allows the router to forward single route explorer frames.

В представленном выше примере конфигурированы DLSw и SRT/LB. Когда станции на Token Ring должны говорить со станциями на Ethernet на том же маршрутизатор, маршрутизаторе A, SRT/LB только требуется. Если единственное требование для станций Ethernet на маршрутизаторе A – связь со станциями Token Ring на маршрутизаторе B, то dlsw bridge-group 1 позаботится об этом.

7. Token Ring — SDLC по WAN

/image/gif/paws/12411/tokensdlc.gif

Router A
!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.1 255.255.255.0
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning

!--- Allows the router to forward single route explorer frames.


Router B

dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 0 tcp 150.150.1.1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.2 255.255.255.0
!
interface Serial 1
 no ip address
 encapsulation sdlc
 no keepalive
 clockrate 9600
 sdlc role primary

 !--- Assumes SDLC station role secondary for the controller.

 sdlc vmac 4000.9999.0100 

 
!--- Virtual MAC address given to the controller which will 
 !--- have sdlc address (01) appended to it.

 sdlc address 01          

 
!--- SDLC address, obtained from controller configuration.

 sdlc xid 01 05D20001     

 
 !--- 01 is the SDLC address and IDBLK/IDNUM should match that 
 !--- in SMN on the host.

 sdlc partner 4000.1020.1000 01 

 
 !--- 4000.1020.1000 is the MAC address of the host
 !--- and 01 is the SDLC address.
 
 sdlc dlsw 1
!

Примечание: Подключение канала DLSw будет между 4000.9999.0101 и 4000.1020.1000. Кроме того, вышеупомянутый пример принимает контроллер PU2.0. Другие типы PU см. в руководстве по устранению неполадок в DLSw SDLC.

Вышеупомянутые примеры конфигурации являются некоторыми сценариями общей сети. С DLSw+ можно сделать значительно больше, но эти конфигурации обеспечивают некоторые основные функции. Следует иметь в виду, что DLSw+ является улучшенным RSRB с дополнительной возможностью совместимости с другими маршрутизаторами, которые соответствуют RFC 1795 и 2166.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 12411