Протокол IP : Serial Tunnel (STUN)

Настройка двухточечного BSTUN

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Bisync Serial Tunnel (BSTUN), который функция включает поддержке устройств, которые используют Протокол bisync. Этот протокол позволяет предприятиям транспортировать трафик BiSync (двоичная синхронная передача данных) по той же сети, которая поддерживает их Системную сетевую архитектуру (SNA) и мультипротокольный трафик, который избавляет от необходимости отдельные средства синхронной передачи двоичных данных. С Frame Relay можно использовать функцию локального подтверждения для обеспечения локального завершения сеанса на Одноранговом телефонном соединении BSTUN.

В данном примере Функция BSTUN точка-точка настроена с Локальным Подтверждением по Frame Relay. Соответствующие состояния в выходных данных команды show bstun были выделены в этом документе.

Примечание: Несмотря на то, что debug bstun packet/event и команды debug bsc packet/event не должны вызывать избыточное использование CPU, команда logging buffered используется для копирования выходных данных к файлу журнала.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения в этом документе основываются на Cisco Выпуск ПО IOS� 12.1 (5).

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/12346/bstun_p2p.gif

Конфигурации

Эти конфигурации используются в данном документе:

Blutch
Building configuration 
!
version 12.1
service timestamps debug datetime msec
!
hostname Blutch 
!
! 
bstun peer-name 100.1.1.1
bstun protocol-group 72 bsc-local-ack
!
! 
interface Loopback0
ip address 100.1.1.1 255.0.0.0
!
interface Serial0/0
ip address 10.1.1.1 255.0.0.0
encapsulation frame-relay
no ip mroute-cache
frame-relay interface-dlci 16
frame-relay lmi-type ansi
!
interface Serial1/0
no ip address
ip directed-broadcast
encapsulation bstun
no ip mroute-cache
no keepalive
full-duplex
clockrate 9600
bstun group 72
bsc secondary
bstun route all tcp 200.2.2.2
!
!
router rip
network 10.0.0.0
network 100.0.0.0
!
end

Ньюбери
Building configuration...

version 12.1
! 
service timestamps debug datetime msec
!
hostname Newbury 
!
bstun peer-name 200.2.2.2
bstun protocol-group 72 bsc-local-ack
!
!
interface Loopback0
ip address 200.2.2.2 255.255.255.0
! 
interface Serial0
no ip address
encapsulation bstun
load-interval 30
no keepalive
full-duplex
clockrate 9600
bstun group 72
bsc primary
bstun route all tcp 100.1.1.1
!
interface Serial1
ip address 10.1.1.2 255.0.0.0
encapsulation frame-relay IETF
no ip mroute-cache
frame-relay interface-dlci 17
frame-relay lmi-type ansi
!
!
router rip
network 10.0.0.0
network 200.2.2.0
!
end

Проверка.

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

  • show bstun

  • show bsc

Blutch #show bsc
BSC local-ack on Serial1/0:
secondary state is CU_Idle.
Control units on this interface:
 
   Poll address: 40. Select address: 60 *CURRENT-CU*
   State is Initializing.
   Tx Counts: 0 frames(total). 0 frames(data). 0 bytes.
   Rx Counts: 3 frames(total). 0 frames(data). 15 bytes.
 
Total Tx Counts: 0 frames(total). 0 frames(data). 0 bytes.
Total Rx Counts: 19 frames(total). 0 frames(data). 59 bytes.

Blutch #show bstun
This peer: 100.1.1.1
 
*Serial1/0  (group 72 [bsc-local-ack])
route transport address         dlci lsap state      rx_pkts tx_pkts   drops
all   TCP       200.2.2.2                 open         1       3        0

Newbury #show bsc
BSC local-ack on Serial0:
primary state is TCU_Polled.
Control units on this interface:
 
   Poll address: 40. Select address: 60 *CURRENT-CU*
   State is Inactive.
   Tx Counts: 126 frames(total). 0 frames(data). 378 bytes.
   Rx Counts: 0 frames(total). 0 frames(data). 0 bytes.
 
Total Tx Counts: 126 frames(total). 0 frames(data). 378 bytes.
Total Rx Counts: 0 frames(total). 0 frames(data). 0 bytes.
 
Newbury #show bstun
This peer: 200.2.2.2
 
*Serial0  (group 72 [bsc-local-ack])
route transport address         dlci lsap state      rx_pkts tx_pkts   drops
all   TCP       100.1.1.1                 open          3       2        0

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Команды для устранения неполадок

Примечание: Прежде чем выполнять какие-либо команды отладки , ознакомьтесь с документом "Важные сведения о командах отладки".

  • debug bstun packet/event

  • debug bsc packet/event

Примечание: Когда вы интерпретируете эти результаты выполнения команды debug:

  • SDI (Поступление Данных, передаваемых последовательно) — Пакеты, полученные от Протокола SDLC, взаимодействует /

  • NDI: (Поступление сетевых данных) — Пакеты, извлеченные из пакета от глобальной сети (WAN).

blutch#debug bstun event
BSTUN event debugging is on

blutch#debug bstun packet
BSTUN packet debugging is on

blutch#
Aug 26 11:29:04.534: BSTUN bsc: Serial0 SDI: Data: 40520040407F7F2D
Aug 26 11:29:04.570: BSTUN bsc: Serial0 NDI: Data: 40D20037
Aug 26 11:29:04.734: BSTUN bsc: Serial0 SDI: Data: 40530040407F7F2D
Aug 26 11:29:04.770: BSTUN bsc: Serial0 NDI: Data: 40D30037
Aug 26 11:29:04.934: BSTUN bsc: Serial0 SDI: Data: 40540040407F7F2D
Aug 26 11:29:04.970: BSTUN bsc: Serial0 NDI: Data: 40D40037
Aug 26 11:29:05.134: BSTUN bsc: Serial0 SDI: Data: 40550040407F7F2D
Aug 26 11:29:05.170: BSTUN bsc: Serial0 NDI: Data: 40D50037
Aug 26 11:29:05.334: BSTUN bsc: Serial0 SDI: Data: 40560040407F7F2D
Aug 26 11:29:05.370: BSTUN bsc: Serial0 NDI: Data: 40D60037
Aug 26 11:29:05.534: BSTUN bsc: Serial0 SDI: Data: 40570040407F7F2D
Aug 26 11:29:05.570: BSTUN bsc: Serial0 NDI: Data: 40D70037
Aug 26 11:29:05.734: BSTUN bsc: Serial0 SDI: Data: 40580040407F7F2D
Aug 26 11:29:05.770: BSTUN bsc: Serial0 NDI: Data: 40D80037
Aug 26 11:29:05.934: BSTUN bsc: Serial0 SDI: Data: 40590040407F7F2D
Aug 26 11:29:05.970: BSTUN bsc: Serial0 NDI: Data: 40D90037
Aug 26 11:29:06.134: BSTUN bsc: Serial0 SDI: Data: 405A0040407F7F2D
Aug 26 11:29:06.170: BSTUN bsc: Serial0 NDI: Data: 40DA0037
Aug 26 11:29:06.334: BSTUN bsc: Serial0 SDI: Data: 405B0040407F7F2D
Aug 26 11:29:06.370: BSTUN bsc: Serial0 NDI: Data: 40DB0037


newbury#debug bstun event
BSTUN event debugging is on

newbury#debug bstun packet
BSTUN packet debugging is on

newbury#
Aug 26 11:26:24.968: BSTUN bsc: Serial0 NDI: Data: 40780040407F7F2D
Aug 26 11:26:24.992: BSTUN bsc: Serial0 SDI: Data: 40F80037
Aug 26 11:26:25.148: BSTUN bsc: Serial0 NDI: Data: 40790040407F7F2D
Aug 26 11:26:25.172: BSTUN bsc: Serial0 SDI: Data: 40F90037
Aug 26 11:26:25.348: BSTUN bsc: Serial0 NDI: Data: 407A0040407F7F2D
Aug 26 11:26:25.372: BSTUN bsc: Serial0 SDI: Data: 40FA0037
Aug 26 11:26:25.548: BSTUN bsc: Serial0 NDI: Data: 407B0040407F7F2D
Aug 26 11:26:25.572: BSTUN bsc: Serial0 SDI: Data: 40FB0037
Aug 26 11:26:25.748: BSTUN bsc: Serial0 NDI: Data: 407C0040407F7F2D
Aug 26 11:26:25.772: BSTUN bsc: Serial0 SDI: Data: 40FC0037
Aug 26 11:26:25.948: BSTUN bsc: Serial0 NDI: Data: 407D0040407F7F2D
Aug 26 11:26:25.972: BSTUN bsc: Serial0 SDI: Data: 40FD0037
Aug 26 11:26:26.148: BSTUN bsc: Serial0 NDI: Data: 407E0040407F7F2D
Aug 26 11:26:26.172: BSTUN bsc: Serial0 SDI: Data: 40FE0037
Aug 26 11:26:26.348: BSTUN bsc: Serial0 NDI: Data: 407F0040407F7F2D
Aug 26 11:26:26.372: BSTUN bsc: Serial0 SDI: Data: 40FF0037
Aug 26 11:26:26.548: BSTUN bsc: Serial0 NDI: Data: 40400040407F7F2D
Aug 26 11:26:26.572: BSTUN bsc: Serial0 SDI: Data: 40C00037
Aug 26 11:26:26.748: BSTUN bsc: Serial0 NDI: Data: 40410040407F7F2D
Aug 26 11:26:26.772: BSTUN bsc: Serial0 SDI: Data: 40C10037

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 12346