Видео и доставка контента : Маршрутизаторы кабельного доступа Cisco серии uBR900

cable-modem dhcp-proxy na на кабельных модемах Cisco

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ объясняет, как использовать команду cable-modem dhcp-proxy nat. Основная функция этой команды должна настроить пул адресов Технологии NAT с IP-адресом, предоставленным DHCP server Поставщика Intrernet.

Для получения дополнительной информации обратитесь к cable-modem dhcp-proxy в Командах CMTS IOS Кабеля.

caution Внимание.  : Знайте об идентификаторе ошибки Cisco CSCdt32356 (только зарегистрированные клиенты), который исправлен в Cisco Очереди релизов программного обеспечения IOS� 12.2 и позже. Динамический NAT с помощью команды кабельного сопряжения pool-name nat cable-modem dhcp-proxy не функционирует правильно. IP-адрес или маски подсети и шлюзы по умолчанию не назначены правильно, если вообще. После того, как команда введена, адрес, который назначен на пул NAT, не отвечает на Протокол ARP. IP NAT pool, который создан, от области кабельного модема, а не области Customer Premises Equipment (CPE), таким образом, это помещает немаршрутизуемый IP-адрес в пул NAT. Заметьте, что эта проблема происходит в Cisco IOS Software Release для нескольких кабельных модемов, особенно 12.1 (5) T. Рекомендуется, чтобы вы использовали Cisco IOS Software Release Train 12.2 на uBR924 и использовали Версии 12.2T, 12.3 и более поздние Серии для uBR905, uBR925 и модемов CVA. Для дополнительных сведений обратитесь к идентификатору ошибки Cisco CSCdt32356 (только зарегистрированные клиенты).

Примечание: Также знайте об этих факторах:

  1. Поскольку uBR904 платформы не поддерживают программное обеспечение Cisco IOS версии 12.1(1)T, не возможно настроить команду cable-modem dhcp-proxy на этой платформе.

  2. Для активации опции прокси dhcp на uBR924 обычно рекомендуется использовать программное обеспечение Cisco IOS версии 12.2 (6j).

  3. Для CVA122 команда задокументирована как кабель dhcp-proxy nat. Эта команда совпадает с командой cable-modem dhcp-proxy nat на uBR900 кабельных модемах серии.

    От CVA122 могут быть замечены эти выходные данные:

    Router(config)# interface cable 0
    
    Router(config-if)# cable?
    
    cable-modem

Предварительные условия

Требования

Для использования данного документа требуется знание следующих тем:

  • Основное понимание Трансляции сетевых адресов и почему это используется

  • DOCSIS 1.0 протокола

  • Линейный интерфейс Программной команды Cisco IOS

Используемые компоненты

Эта таблица показывает Cisco IOS Software Release, которые поддерживают эту команду для каждой платформы кабельного модема Cisco:

Выпуск, который представил команду cable-modem dhcp-proxy Платформа
12.1 (1) T uBR924
12.1 (3) XL uBR905
12.2 (2) XA uBR925
12.1 (5) XU1 CVA122

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Динамический NAT по сравнению со статическим NAT

С динамическим NAT трансляции не существуют в Таблице преобразования сетевых адресов (NAT), пока маршрутизатор не получает трафик, который требует трансляции. Динамические преобразования характеризуются временем ожидания, после которого они удаляются из таблицы преобразований. Со статическим NAT, однако, трансляции существуют в Таблице преобразования сетевых адресов (NAT), как только вы настраиваете команду статической трансляции сетевых адресов, и они остаются в таблице преобразования, пока вы не удаляете команду статической трансляции сетевых адресов или команды.

Самый простой способ решить, что вам настроили динамический NAT в кабельном модеме, путем поиска этой команды в конфигурации кабельного модема:

ip nat inside source list 100 interface cable-modem0 overload

Путем обращения источника NAT к списку доступа вы динамично создаете Таблицу преобразования сетевых адресов (NAT). Команда cable-modem dhcp-proxy nat использует эту динамическую Характеристику NAT.

Конфигурация Использование Команды cable-modem dhcp-proxy nat

При использовании команды cable-modem dhcp-proxy nat адрес, используемый для пула NAT, автоматически выделен от DHCP server оператора кабельной связи.

При использовании этой опции включайте эти команды конфигурации NAT:

  • внутренний интерфейс ip nat — Использование для настройки Интерфейса Ethernet как “внутреннего” интерфейса.

  • внешний интерфейс ip nat — Использование для настройки кабельного сопряжения как “внешнего” интерфейса.

  • перегрузка — Задает эту опцию с командой глобальной кофигурации IP NAT, потому что пул NAT, созданный командой cable-modem dhcp-proxy nat, содержит только один IP-адрес.

После настройки маршрутизатора с командой cable-modem dhcp-proxy nat перезагрузите маршрутизатор. Во время процесса инициализации DOCSIS маршрутизатор передает запрос клиента DHCP для получения IP-адреса для кабельного сопряжения. Маршрутизатор тогда передает прокси - запрос DHCP к DHCP server с помощью MAC-адреса Интерфейса Ethernet. DHCP server отвечает со вторым IP-адресом, что маршрутизатор назначает на динамично настроенный Интерфейс обратной связи, который указывает на динамично настроенный пул NAT только одного адреса.

Посмотрите выходные данные конфигурации в этом документе для получения информации, которая автоматически добавлена к конфигурации после того, как обработан DHCP.

Для настройки NAT так, чтобы это создало пул динамично выполните эти команды на маршрутизаторе. Помните, что для настройки NAT маршрутизатор должен быть в режиме маршрутизации.

Router# config t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)# interface ethernet 0

Router(config-if)# ip address 192.168.1.1 255.255.255.0

!--- Assign an IP address to interface Ethernet 0.

Router(config-if)# no bridge-group 59

!--- Remove bridging so that you can configure for routing.

Router(config-if)# no bridge-group 59 spanning

!--- Remove bridging spanning.

Router(config-if)# ip nat inside

!--- Enable NAT inside for the Ethernet interface.

Router(config-if)# exit

Router(config)#

Router(config)# interface cable 0

Router(config-if)# no bridge-group 59

!--- Remove bridging so that you can configure for routing.

Router(config-if)# no bridge-group 59 spanning

!--- Remove bridging spanning.

Router(config-if)# no cable compliant bridge

!--- Remove bridging so that you can configure for routing.

Router(config-if)# ip nat outside

!--- Enable NAT outside for the cable interface.

Router(config-if)# cable-modem dhcp-proxy nat TEST_POOL

!--- Define dhcp-proxy nat for the TEST_POOL pool.

Router(config-if)# exit

Router(config)#

Router(config)# ip routing

!--- Enable routing.

Router(config)# ip nat inside source list 1 pool TEST_POOL overload

!--- Configure dynamic NAT.

Router(config)# access-list 1 permit 192.168.1.0 0.0.0.255

!--- Define interesting traffic for NAT.

Конфигурация похожа на это:

router# show run

Building configuration...
Current configuration : 953 bytes
!
version 12.2
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router
!
logging rate-limit console 10 except errors
!
ip subnet-zero
no ip finger
!
ip audit notify log
ip audit PO max-events 100
no ip dhcp-client network-discovery
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 no ip mroute-cache
!
interface cable-modem0
 ip nat outside
 no ip mroute-cache
 no cable-modem compliant bridge
 cable-modem dhcp-proxy nat TEST_POOL
!
ip nat inside source list 1 pool TEST_POOL overload
ip classless
no ip http server
no ip http cable-monitor
!
access-list 1 permit 192.168.1.0 0.0.0.255
snmp-server packetsize 4096
snmp-server manager
!
voice-port 0
 input gain -2
 output attenuation 0
!
voice-port 1
 input gain -2
 output attenuation 0
!
!
line con 0
 transport input none
line vty 0 4
 login
!
end

router#

Полужирные команды - те, вы ввели; другие - настройки по умолчанию. Заметьте, что пул NAT еще не был создан на этом этапе. Кабельный модем должен быть повторно загружен, или кабельное сопряжение должно быть перезагружено путем запуска закрывающей команды, придерживавшейся командой no shut.

router# reload

Proceed with reload? [confirm]
133.CABLEMODEM.CISCO: 00:06:16: %SYS-5-RELOAD: Reload requested
System Bootstrap, Version 12.0(6r)T3, RELEASE SOFTWARE (fc1)
Copyright (c) 1999 by Cisco Systems, Inc.
UBR924 platform with 16384 Kbytes of main memory
program load complete, entry point: 0x80010000, size: 0x398070
Self decompressing the image : #################################
################################################################
################################################################
################################################################
################################################################
################################################################
########################################################## [OK]

!--- Output suppressed.

Press RETURN to get started!

Примечание: В выходных данных конфигурации обработана информация, которая автоматически добавлена к конфигурации после DHCP, обращен внимание с комментариями.

В этом документе uBR7114 и uBR924 используются в качестве примеров. Cisco IOS Software Release, установленные на них, 12.1 (5) EC1 и 12.1 (3a) T4, соответственно. Следующие данные показывают подключение и используемые IP-адреса.

Рис. 1: Схема используется в конфигурации с помощью команды cable dhcp-proxy nat

/image/gif/paws/12176/cable_dhcp_proxy1.gif

uBR924 — Конфигурация Пула адресов NAT с IP-адресом, предоставленным DHCP server Поставщика услуг
router# show run

Building configuration...
Current configuration : 1273 bytes
!
! Last configuration change at 13:12:52 - Tue Feb 29 2000
!
version 12.2
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router
!
logging rate-limit console 10 except errors
!
clock timezone - -8
ip subnet-zero
no ip finger
!
ip audit notify log
ip audit PO max-events 100
no ip dhcp-client network-discovery
!
!
interface Loopback0
 ip address 111.111.111.8 255.255.255.255

!--- Lookback interface added automatically by DHCP configuration.

!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 no ip mroute-cache
!
interface cable-modem0
 ip nat outside
 no ip mroute-cache
 no cable-modem compliant bridge
 cable-modem dhcp-proxy nat TEST_POOL
 cable-modem boot admin 2
 cable-modem boot oper 5
 cable-modem downstream saved channel 525000000 37 1
!
ip nat pool TEST_POOL 111.111.111.8 111.111.111.8 netmask 255.255.255.0

!--- NAT pool added automatically by DHCP configuration.

ip nat inside source list 1 pool TEST_POOL overload
ip classless
no ip http server
no ip http cable-monitor
!
access-list 1 permit 192.168.1.0 0.0.0.255
snmp-server packetsize 4096
snmp-server manager
!
voice-port 0
 input gain -2
 output attenuation 0
!
voice-port 1
 input gain -2
 output attenuation 0
!
!
line con 0
 transport input none
line vty 0 4
 login
!
end

Проверка конфигурации

В этом разделе описывается использовать выходные данные команды show для подтверждения конфигурации кабельного модема.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Выполните команду show arp для показа записей в таблице ARP.

router# show arp

Protocol  Address         Age (min) Hardware Addr   Type   Interface
Internet  111.111.111.111      56   0002.b9ff.8c1c  ARPA   cable-modem0
Internet  10.4.1.1             59   0002.b9ff.8c1c  ARPA   cable-modem0

!--- IP address of the interface cable 1/0
!--- of the cable modem termination system (CMTS).

Internet  192.168.1.1           -   0030.1976.771a  ARPA   Ethernet0
Internet  192.168.1.5          34   00a0.243c.eff5  ARPA   Ethernet0

!--- IP address of the PC behind the cable modem.

Internet  10.4.1.114            -   0030.1976.771b  ARPA   cable-modem0

ПК позади кабельного модема имеет IP-адрес 192.168.1.5 статически настроенный. Очень просто, однако, сделать кабельный модем DHCP server, который динамично назначает IP-адрес на его хосты LAN; используйте эту конфигурацию:

ip dhcp excluded-address 192.168.1.1 
ip dhcp pool pool name


   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1

Протестировать тот NAT работает, выполните команду ping от ПК, связанного позади кабельного модема, чтобы попытаться достигнуть кабельного сопряжения.

При рассмотрении Таблицы преобразования сетевых адресов (NAT) вы видите успешные преобразования.

router# show ip nat translations

Pro  Inside global      Inside local       Outside local    Outside global
icmp 111.111.111.8:512  192.168.1.5:512    10.4.1.114:512   10.4.1.114:512

Для получения дополнительной информации обратитесь к cable-modem dhcp-proxy в Командах CMTS IOS Кабеля.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 12176