Коммутация LAN : Протокол ISL

Настройка транка ISL между коммутаторами серии Catalyst 2948G-L3 и Catalyst 2900/3500XL или 2970

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (7 октября 2015) | Отзыв


Содержание


Введение

Этот документ обсуждает, как настроить транк Протокола ISL между 2948G-L3 Cisco Catalyst и Catalyst 2900/3500XL или коммутаторами серии 2970. Когда вы соединяете Catalyst 2948G-L3 к коммутатору, последовательность действий та же, что и при соединении маршрутизатора к коммутатору. Пример конфигурации в этом документе использует Catalyst 2948G-L3 в качестве маршрутизатора и использует Catalyst 3500XL в качестве Уровня 2 (L2) коммутатор. Можно заменить Catalyst 2900XL или 2970 для 3500XL, в целях этого документа.

Для использования понятия VLAN на Catalyst 2948G-L3 необходимо использовать мостовые группы. Каждая группа мостовой передачи считается отдельной VLAN. Эти группы мостов соответствуют номеру VLAN соответствующего коммутатора.

Предварительные условия

Требования

Прежде чем вы будете делать попытку этой конфигурации, будете гарантировать соединение перекрестного кабеля между 2900/3500XL или 2970 и 2948G-L3. Как правило, вы используете прямой кабель между маршрутизатором и коммутатором; но с Catalyst 2948G-L3, вы используете перекрестный кабель для соединения с другим коммутатором. Это - тот же перекрестный кабель, который вы использовали бы для соединения коммутатор-коммутатор.

Для использования данного документа требуется знание следующих тем:

Используемые компоненты

Сведения, содержащиеся в этом документе, касаются следующих версий программного обеспечения:

  • Cisco выпуск ПО IOS� 12.0 (25) W5 (27) для Уровня 3 (L3) коммутатор/Маршрутизатор (CAT2948G-IN-M)

  • Программное обеспечение Cisco IOS версии 12.0(5)WC9 (C3500XL-C3H2S-M) (fc1)

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Настройка

Этот раздел предоставляет сведения для настройки функций, описанных в этом документе.

Примечание: Для обнаружения дополнительных сведений о командах в этом документе используйте Средство поиска команд Command Lookup Tool (только зарегистрированные клиенты).

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/12019/25.gif

Если вы хотите, чтобы все три PC были в состоянии пропинговать друг друга и иметь шлюз по умолчанию, то необходимо использовать мостовое соединение с Integrated routing and bridging (IRB).

Catalyst 2948G-L3 является устройством L3 в этом сценарии. Так как оно является устройством L3, оно не может иметь два интерфейса L3 в одной и той же подсети. Именно поэтому необходимо использовать мостовые группы на интерфейсах и связать их с виртуальным интерфейсом моста (BVI), BVI 2.

IP-адрес BVI 2 является шлюзом по умолчанию для всех PC и устройств в VLAN 2 или группе мостов 2.

Конфигурации

Эти конфигурации используются в данном документе:

2948G-L3
Building configuration...

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 2948G-L3
!
!
ip subnet-zero
bridge irb
!
!
!
interface FastEthernet1

!--- This interface is the ISL trunk to the switch.

 no ip address
 no ip directed-broadcast
!
interface FastEthernet1.1
 encapsulation isl 1        
 no ip redirects
 no ip directed-broadcast
 bridge-group 1

!--- Use bridge-group 1 for the trunk subinterface.
!--- You can not use an IP address here because of the subnet
!--- overlap that would occur due to BVI 1, which is in the
!--- same subnet.

!
interface FastEthernet1.2
 encapsulation isl 2
 no ip redirects
 no ip directed-broadcast
 bridge-group 2             
!
interface FastEthernet2
 no ip address
 no ip directed-broadcast
 bridge-group 2

!--- This port belongs to VLAN 2.

!
interface FastEthernet3
 no ip address
 no ip directed-broadcast
 bridge-group 2

!--- This port belongs to VLAN 2.

!
interface FastEthernet4
 no ip address
 no ip directed-broadcast
 bridge-group 1

!--- This port belongs to VLAN 1.

!
interface BVI1
 ip address 10.1.1.1 255.255.0.0

!--- This is the IP address of BVI 1.

 no ip directed-broadcast
 no ip route-cache cef
!
interface BVI2

!--- This is the IP address of BVI 2.

 ip address 10.2.2.2 255.255.0.0
 no ip directed-broadcast
 no ip route-cache cef
!
ip classless
!
bridge 1 protocol ieee

!--- Choose IEEE as the Spanning Tree Protocol.

 bridge 1 route ip

!--- Allow routing to occur for IP.

bridge 2 protocol ieee
 bridge 2 route ip
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

2900/3500XL или 2970

!--- First, add VLAN 2 to the VLAN database for a 2900/3500XL
!--- switch:

3500XL# vlan database

3500XL(vlan)# vlan 2

VLAN 2 added:
    Name: VLAN0002

3500XL(vlan)# exit

APPLY completed.
Exiting....
3500XL#

!--- The Catalyst 2970 gives you the option to configure VLANs
!--- from the VLAN database or from global configuration mode:

2970# configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

2970(config)# vlan 2

2970(config-vlan)# end

2970#

!--- The switchport configurations on the Catalyst 2900/3500XL
!--- and on the 2970 are identical, for the purposes of this
!--- document. Remember that the Catalyst 2970 has 10/100/1000
!--- ports (1000Base-T), so the interfaces in this output
!--- would instead be labeled Gigabit Ethernet 0/1, 0/2,
!--- and so forth.

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3500XL
!
interface FastEthernet0/1
 switchport mode trunk

!--- This port is an ISL trunk.

!
interface FastEthernet0/2
 switchport access vlan 2

!--- This port is in VLAN 2.

!
interface FastEthernet0/3

!--- This port is in the default VLAN 1.

!
interface FastEthernet0/4
!
!
interface VLAN1
 ip address 10.1.1.100 255.255.0.0

!--- This is the IP address of the management interface.

 no ip directed-broadcast
 no ip route-cache
!
snmp-server engineID local 000000090200000AF484CC80
snmp-server community public RO
!
line con 0
 exec-timeout 0 0
 transport input none
 stopbits 1
line vty 0 4
 login
line vty 5 15
 login
!
end

Проверка.

В этом разделе описана проверка работоспособности существующей конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • show interface fa0/1 switchport — Проверяет статус транка на 2900/3500XL или 2970 и видит, какие VLAN активны.

    3500XL# show interface fa0/1 switchport
    
    Name: Fa0/1
    Switchport: Enabled
    Administrative mode: trunk
    Operational Mode: trunk
    Administrative Trunking Encapsulation: isl
    Operational Trunking Encapsulation: isl
    Negotiation of Trunking: Disabled
    Access Mode VLAN: 0 ((Inactive))
    Trunking Native Mode VLAN: 1 (default)
    Trunking VLANs Enabled: ALL
    Trunking VLANs Active: 1,2
    Pruning VLANs Enabled: 2-1001
    
    Priority for untagged frames: 0
    Override vlan tag priority: FALSE
    Voice VLAN: none
    Appliance trust: none
    Self Loopback: No
    3500XL#
  • show vlan Убедитесь, что порты 2900/3500XL или 2970 присвоены правильной виртуальной локальной сети.

    3500XL# show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/3, Fa0/4, Fa0/5, Fa0/6,
                                                    Fa0/7, Fa0/8, Fa0/9, Fa0/10,
                                                    Fa0/11, Fa0/12, Fa0/13, Fa0/14,
                                                    Fa0/15, Fa0/16, Fa0/17, Fa0/18,
                                                    Fa0/19, Fa0/20, Fa0/21, Fa0/22,
                                                    Fa0/23, Fa0/24, Gi0/1, Gi0/2
    2    VLAN0002                         active    Fa0/2
    1002 fddi-default                     active
    1003 token-ring-default               active
    1004 fddinet-default                  active
    1005 trnet-default                    active
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        0      0
    2    enet  100002     1500  -      -      -        -    -        0      0
    1002 fddi  101002     1500  -      -      -        -    -        0      0
    1003 tr    101003     1500  -      -      -        -    -        0      0
    1004 fdnet 101004     1500  -      -      -        ieee -        0      0
    1005 trnet 101005     1500  -      -      -        ibm  -        0      0
    3500XL#
  • show interface bvi 1 — Проверяет, что интерфейсами BVI 2948G-L3 и протоколом линии связи является оба up на 2948G-L3.

    2948G-L3# show interface bvi 1
    
    BVI1 is up, line protocol is up
      Hardware is BVI, address is 0001.c75c.680a (bia 0000.0000.0000)
      Internet address is 10.1.1.1/16
      MTU 1500 bytes, BW 10000 Kbit, DLY 5000 usec, rely 255/255, load 1/255
      Encapsulation ARPA, loopback not set
      ARP type: ARPA, ARP Timeout 04:00:00
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue 0/0 (size/max)
    2948G-L3#
  • show bridge 1 — Проверяет, что соединяют 1, передает. Кроме того, можно проверить, включен ли Spanning Tree Protocol , а пересылка осуществляется командой show spanning-tree.

    2948G-L3# show bridge 1
    
    Total of 300 station blocks, 299 free
    Codes: P - permanent, S - self
    
    Bridge Group 1:
    
        Address       Action   Interface
    00ee.1e9f.50c0   forward   Fa1.1
    
    2948G-L3#

Устранение неполадок

Этот раздел предоставляет советы и пример выходных данных, чтобы помочь устранять неполадки конфигурации.

  • Убедитесь, что вы можете посылать эхо-запросы другому устройству.

  • Убедитесь, что ПК могут посылать пакеты проверки связи (ping) на ПК в других сетях VLAN.

  • Гарантируйте, что шлюз по умолчанию корректен. По этому сценарию шлюз по умолчанию является соответствующим BVIs на 2948G-L3.

2948G-L3# ping 10.1.1.100

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.100, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/6/12 ms

2948G-L3# show arp

Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  10.2.2.2                -   0030.40d6.4008  ARPA   BVI2
Internet  10.1.1.1                -   0030.40d6.400a  ARPA   BVI1
Internet  10.1.1.100              1   00ee.1e9f.50c0  ARPA   BVI1
2948G-L3#

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 12019