Глобальная сеть (WAN) : T1/E1 и T3/E3

Объединение каналов NxE1 с многоканальным интерфейсом

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (19 декабря 2015) | Отзыв


Содержание


Введение

Приведенный в этом документе пример конфигурации показывает, как можно связать соединения NxE1 (с формированием кадров G.704 или без него) посредством многоканального интерфейса. Многоканальный интерфейс представлен в Cisco Выпуск ПО IOS� 12.0 (3) T для распределенного Многоканального протокола "точка-точка" (PPP) на Многоцелевом интерфейсном процессоре (VIP) Маршрутизатора Cisco 7500 - основанные Интерфейсы T1 или E1 (см. раздел "Дополнительных сведений" этого документа). Многоканальный интерфейс поддерживается для основанных не на VIP-интерфейсах T1/E1 (и прочих WAN) интерфейсах начиная с версии Cisco IOS Software Release 12.0 (4) T.

Предварительные условия

Требования

Так как многоканальный PPP увеличивает загрузку ЦПУ, рекомендуется следующее:

  1. Проверьте текущую среднюю загрузку ЦПУ прежде, чем добавлять многоканальные интерфейсы или подключения E1 к многоканальному интерфейсу.

  2. По возможности используйте распределенный многоканальный PPP на Cisco 7500 на основе VIP-платформы. См. документацию по нововведениям в Cisco IOS Software Release 12.0 (3) T для получения дополнительной информации об ограничениях и предварительных условиях распределенного многоканального PPP (см. раздел Дополнительные сведения этого документа).

  3. По возможности исключите фрагментацию Multilink PPP.

Примечание: Это увеличивает задержку по многоканальному соединению.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • Маршрутизатор Cisco 7505, оборудованный VIP2-50 и PA-MC-8E1, на котором выполняется Cisco IOS Software Release 12.1 (11a).

  • Маршрутизатор Cisco 7206, оборудованный PA-MC-8E1, на котором выполняется Cisco IOS Software Release 12.1 (11).

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Более подробную информацию о применяемых в документе обозначениях см. в описании условных обозначений, используемых в технической документации Cisco.

Теоретические сведения

Многоканальный PPP, стандартизированный в RFC 1990, подобен способам балансировки нагрузки , в которых пакеты передаются через отдельные соединения при кольцевом способе обслуживания. Однако многоканальный PPP добавляет три важных функции.

  • Так как многоканальный PPP работает над уровнем соединения, он заставляет связку NxT1/E1 выглядеть как одно логическое соединение с точки зрения протоколов верхнего уровня в маршрутизаторе. Поэтому только один сетевой адрес должен быть настроен для всей связки NxT1/E1.

  • Многоканальный PPP отслеживает упорядочение пакетов и буферизует поступившие раньше времени пакеты . При этом многоканальный PPP сохраняет порядок следования пакетов через всю связку NxT1/E1.

  • Можно включить фрагментацию пакетов и разделить большие пакеты данных на меньшие фрагменты пакета, которые индивидуально передаются по соединению. При многих обстоятельствах фрагментация может увеличить эффективность канала NxT1/E1.

Многоканальный PPP также предлагает значительные возможности по управлению каналами. Если отдельное соединение отказывает, томногоканальный PPP может автоматически обнаружить сбой и удалить отказавшее соединение из связки. Пока хотя бы одно соединение в связке работает, логический интерфейс, который представляет связку , работоспособен. С использованием сигналов поддержки активности многоканальный PPP может обнаружить, когда ранее отказавшее соединение восстанавливается, а затем повторно включить такое соединение в связку. Дополнительно, когда требуется больший объем пропускной способности , можно добавить больше соединений к связке при настройке их в качестве участника связки. Не требуется изменение конфигурации на сетевом уровне, например новая адресация. Когда вы рассматриваете использование новейших сервисов маршрутизации, это также существенный фактор. Например, можно настроить определенное качество обслуживания один раз для связки в целом, а не для каждого соединения в связке.

Компромисс с точки зрения увеличения функциональности состоит в том, что многоканальный PPP требует большей мощности ЦПУ, чем решения по балансировке нагрузки. Пакетное переупорядочение, повторная сборка фрагментов и сам многоканальный протокол PPP увеличивают загрузку ЦПУ.

Настройка

В данном разделе содержится информация о настройке функций, описанных в этом документе.

Примечание: Для поиска дополнительных сведений о командах в данном документе используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В настоящем документе используется следующая схема сети.

http://www.cisco.com/c/dam/en/us/support/docs/wan/t1-e1-t3-e3/11044-ppp-11044.gif

Конфигурации

Эти конфигурации используются в данном документе.

Каналы E1 с формированием кадров G.704

Cisco 7505
version 12.1 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname diana 
! 
enable password <password> 
! 
username bob password 0 mlppp 

!--- This is an optional Challenge Handshake Authentication Protocol 
!--- (CHAP) secret shared with the remote router. 

! 
! 
! 
ip subnet-zero 
ip cef distributed 

!--- This command is mandatory for distributed Multilink PPP. 

! 
no ip domain-lookup 
! 
! 
controller E1 1/0/0 
�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.
 
! 
controller E1 1/0/1 
�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.

! 
controller E1 1/0/2 
�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.

! 
controller E1 1/0/3 
�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.

! 
controller E1 1/0/4 
�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.

! 
controller E1 1/0/5 
�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.

! 
controller E1 1/0/6 
�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group.

! 
controller E1 1/0/7 
�channel-group 0 timeslots 1-31 


!--- You must assign all timeslots to one channel-group.

! 
interface Multilink1 
�ip address 10.10.10.1 255.255.255.0 
�no cdp enable 
�ppp multilink 
�no ppp multilink fragmentation 
�
!--- This command is optional to reduce CPU load. 

�multilink-group 1 
! 
interface Serial1/0/0:0 
�no ip address 
�ip route-cache distributed 

!--- This command is default and mandatory for distributed Multilink PPP. 

encapsulation ppp 
�tx-queue-limit 26 
no fair-queue 
�
!--- This command is mandatory to enable first-in, first-out (FIFO)  
!--- queueing on the Serial interface.  

ppp authentication chap 

!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial1/0/1:0 
�no ip address 
�ip route-cache distributed 
�
!--- This command is default and mandatory for distributed Multilink PPP. 

�encapsulation ppp 
�tx-queue-limit 26 
no fair-queue 
�
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 
�
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

ppp multilink 
�multilink-group 1 
! 
interface Serial1/0/2:0 
�no ip address 
�ip route-cache distributed 

!--- This command is default and mandatory for distributed Multilink PPP. 
 
encapsulation ppp 
�tx-queue-limit 26 
no fair-queue 
�
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 

!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial1/0/3:0 
�no ip address 
�ip route-cache distributed 
�
!--- This command is default and mandatory for distributed Multilink PPP. 

encapsulation ppp 
�tx-queue-limit 26 
no fair-queue 
�
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 
�
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial1/0/4:0 
�no ip address 
�ip route-cache distributed 
�
!--- This command is default and mandatory for distributed Multilink PPP. 

encapsulation ppp 
�tx-queue-limit 26 
no fair-queue 
�
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 
�
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial1/0/5:0 
�no ip address 
�ip route-cache distributed 
�
!--- This command is default and mandatory for distributed Multilink PPP. 

encapsulation ppp 
�tx-queue-limit 26 
no fair-queue 
�
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 
�
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial1/0/6:0 
�no ip address 
�ip route-cache distributed 

!--- This command is default and mandatory for distributed Multilink PPP. 

�encapsulation ppp 
�tx-queue-limit 26 
no fair-queue 
�
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 

!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial1/0/7:0 
�no ip address 
�ip route-cache distributed 
�
!--- This command is default and mandatory for distributed Multilink PPP. 

�encapsulation ppp 
�tx-queue-limit 26 
no fair-queue 
�
!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 
�
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Ethernet1/1/0 
�ip address 10.10.20.1 255.255.255.0 
�no cdp enable 
! 
ip classless 
ip route 10.10.30.0 255.255.255.0 10.10.10.2 
no ip http server 
! 
! 
line con 0 
�exec-timeout 0 0 
line aux 0 
line vty 0 4 
�exec-timeout 0 0 
�password <password> 
�login 
! 
end 

Cisco 7206
version 12.1 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname bob 
! 
enable password <password> 
! 
username diana password 0 mlppp 

!--- An optional CHAP secret shared with the remote router. 

! 
! 
! 
ip subnet-zero 
! 
! 
controller E1 3/0 
�clock source internal 
�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/1 
�clock source internal 

�!--- This command is only required when you provide master clock 
!--- to the remote router.
 
�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/2 
�clock source internal 

�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/3 
�clock source internal 

�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/4 
�clock source internal 

�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/5 
�clock source internal 
�
�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/6 
�clock source internal 
�
�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
controller E1 3/7 
�clock source internal 
�
�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 timeslots 1-31 

!--- You must assign all timeslots to one channel-group. 

! 
! 
! 
! 
! 
interface Multilink1 
�ip address 10.10.10.2 255.255.255.0 
�ppp multilink 
�no ppp multilink fragmentation 
�
!--- This command is optional to reduce CPU load.
 
�multilink-group 1 
! 
interface FastEthernet0/0 
�ip address 10.10.30.1 255.255.255.0 
�no ip route-cache 
�no ip mroute-cache 
�half-duplex 
�no cdp enable 
! 
interface Serial3/0:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 

!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/1:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 
�
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/2:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 
�
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/3:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 
�
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/4:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 
�
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/5:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 
�
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/6:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 

!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/7:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp authentication chap 
�
!--- This is an optional command needed for when you 
!--- interface to a non-Cisco router.   

�ppp multilink 
�multilink-group 1 
! 
ip classless 
ip route 10.10.20.0. 255.255.255.0 10.10.10.1 
no ip http server 
! 
! 
line con 0 
�exec-timeout 0 0 
line aux 0 
line vty 0 4 
�exec-timeout 0 0 
�password <password> 
�login 
! 
end 

Каналы E1 без формирования кадров G.704

Cisco 7505
version 12.1 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname diana 
! 
enable password <password> 
! 
! 
! 
! 
! 
ip subnet-zero 
ip cef distributed 

!--- This command is mandatory for distributed Multilink PPP. 

no ip domain-lookup 
! 
! 
controller E1 0/1/0 
�channel-group 0 unframed 
! 
controller E1 0/1/1 
�channel-group 0 unframed 
! 
controller E1 0/1/2 
�channel-group 0 unframed 
! 
controller E1 0/1/3 
�channel-group 0 unframed 
! 
controller E1 0/1/4 
�channel-group 0 unframed 
! 
controller E1 0/1/5 
�channel-group 0 unframed 
! 
controller E1 0/1/6 
�channel-group 0 unframed 
! 
controller E1 0/1/7 
�channel-group 0 unframed 
! 
! 
! 
interface Multilink1 
�ip address 10.10.10.1 255.255.255.0 
�no cdp enable 
�ppp multilink 
�no ppp multilink fragmentation 
�
!--- This is an optional command to reduce CPU load. 

�multilink-group 1 
! 
interface Serial0/1/0:0 
�no ip address 
�ip route-cache distributed 

�!--- This command is default and mandatory for distributed Multilink PPP. 

�encapsulation ppp 
�tx-queue-limit 26 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Serial0/1/1:0 
�no ip address 
�ip route-cache distributed 

�!--- This command is default and mandatory for distributed Multilink PPP. 

�encapsulation ppp 
�tx-queue-limit 26 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Serial0/1/2:0 
�no ip address 
�ip route-cache distributed 
�
�!--- This command is default and mandatory for distributed Multilink PPP. 

�encapsulation ppp 
�tx-queue-limit 26 
�no fair-queue

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  
 
�ppp multilink 
�multilink-group 1 
! 
interface Serial0/1/3:0 
�no ip address 
�ip route-cache distributed 
�
�!--- This command is default and mandatory for distributed Multilink PPP. 

�encapsulation ppp 
�tx-queue-limit 26 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Serial0/1/4:0 
�no ip address 
�ip route-cache distributed 
�
�!--- This command is default and mandatory for distributed Multilink PPP. 

�encapsulation ppp 
�tx-queue-limit 26 
�no fair-queue

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  
 
�ppp multilink 
�multilink-group 1 
! 
interface Serial0/1/5:0 
�no ip address 
�ip route-cache distributed 

�!--- This command is default and mandatory for distributed Multilink PPP. 

�encapsulation ppp 
�tx-queue-limit 26 
�no fair-queue

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  
 
�ppp multilink 
�multilink-group 1 
! 
interface Serial0/1/6:0 
�no ip address 
�ip route-cache distributed 

�!--- This command is default and mandatory for distributed Multilink PPP. 

�encapsulation ppp 
�tx-queue-limit 26 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Serial0/1/7:0 
�no ip address 
�ip route-cache distributed 

�!--- This command is default and mandatory for distributed Multilink PPP. 

�encapsulation ppp 
�tx-queue-limit 26 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Ethernet1/1/0 
�ip address 10.10.20.1 255.255.255.0 
�no cdp enable 
! 
ip classless 
ip route 10.10.30.0 255.255.255.0 10.10.10.2 
no ip http server 
! 
! 
line con 0 
�exec-timeout 0 0 
line aux 0 
line vty 0 4 
�exec-timeout 0 0 
�password <password> 
�login 
! 
end 

Cisco 7206
version 12.1 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname bob 
! 
enable password <password> 
! 
! 
! 
! 
! 
ip subnet-zero 

! 
controller E1 3/0 
�clock source internal 

�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 unframed 
! 
controller E1 3/1 
�clock source internal 
�
�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 unframed 
! 
controller E1 3/2 
�clock source internal 
�
�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 unframed 
! 
controller E1 3/3 
�clock source internal 
�
�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 unframed 
! 
controller E1 3/4 
�clock source internal 

�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 unframed 
! 
controller E1 3/5 
�clock source internal 
�
�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 unframed 
! 
controller E1 3/6 
�clock source internal 
�
�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 unframed 
! 
controller E1 3/7 
�clock source internal 
�
�!--- This command is only required when you provide master clock 
!--- to the remote router.

�channel-group 0 unframed 
! 
! 
! 
! 
! 
interface Multilink1 
�ip address 10.10.10.2 255.255.255.0 
�ppp multilink 
�no ppp multilink fragmentation 

�!--- This is an optional command to reduce CPU load. 

�multilink-group 1 
! 
interface FastEthernet0/0 
�ip address 10.10.30.1 255.255.255.0 
�no ip route-cache 
�no ip mroute-cache 
�half-duplex 
�no cdp enable 
! 
interface Serial3/0:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/1:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/2:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/3:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/4:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/5:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/6:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
interface Serial3/7:0 
�no ip address 
�encapsulation ppp 
�no fair-queue 

!--- This command is mandatory to enable FIFO queueing on 
!--- the Serial interface.  

�ppp multilink 
�multilink-group 1 
! 
ip classless 
ip route 10.10.20.0 255.255.255.0 10.10.10.1 
no ip http server 
! 
! 
line con 0 
�exec-timeout 0 0 
line aux 0 
line vty 0 4 
�exec-timeout 0 0 
�password <password> 
�login 
! 
end 

Проверка

Этот раздел предоставляет сведения, которые можно использовать для проверки правильной работы конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • show ppp multilink Показывает все многоканальные связки вместе со всеми участниками многоканальной связки.

  • show interfaces multilink — Показывает статус многоканального соединения.

  • show interfaces serial Показывает статус каждого участника многоканальной связки.

  • show controllers e1 — Показывает статус каждого канала E1.

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Процедура устранения неполадок

Эта процедура относится к обеим конфигурациям.

  1. Проверьте статус многоканального интерфейса командой show interface multilink:

    • Если многоканальный интерфейс не работает, то проверьте статус всех участников многоканальной связки командой show ppp multilink.

    • Если многоканальный протокол отключен, то проверьте протокол управления сетью (NCP) и сообщения многоканальных PPP (MLP) при помощи команд debug ppp multilink events и debug ppp negotiation.

  2. Если участник Multilink неактивен, проверьте статус последовательного интерфейса командой show serial interface:

    • Если последовательный интерфейс не работает, проверьте статус соответствующего канала E1 командой show controller e1.

    • Если протокол последовательной линии не работает, проверьте протокол управления каналом (LCP) и сообщения CHAP командами debug ppp authenticaion и debug ppp negotiation.

Команды для устранения неполадок

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Примечание: Обратитесь к документу Важная информация о командах отладки, прежде чем использовать команды debug.

  • show ppp multilink Показывает все многоканальные связки вместе со всеми участниками многоканальной связки.

  • show interfaces multilink — Показывает статус многоканального соединения.

  • show interfaces serial Показывает статус каждого участника многоканальной связки.

  • show controllers e1 — Показывает статус каждого канала E1.

  • debug ppp negotiation — Показывает весь LCP и сообщения согласования NCP.

  • debug ppp authenticaion — (Дополнительно) Показывает все сообщения аутентификации CHAP.

  • debug ppp multilink events — Показывает все события связки MLP.

Эти выходные данные показывают команды устранения неполадок на Cisco 7505 для первого примера конфигурации.

Все восемь каналов E1 активны:

diana#show ppp multilink 

Multilink1, bundle name is bob 
� Bundle up for 00:05:35 
� Bundle is Distributed 
� 0 lost fragments, 0 reordered, 0 unassigned 
� 0 discarded, 0 lost received, 3/255 load 
� 0x1226 received sequence, 0x1226 sent sequence 
� Member links: 8 active, 0 inactive (max not set, min not set) 
��� Serial1/0/0:0, since 00:05:35, no frags rcvd 
��� Serial1/0/1:0, since 00:05:35, no frags rcvd 
��� Serial1/0/2:0, since 00:05:35, no frags rcvd 
��� Serial1/0/3:0, since 00:05:35, no frags rcvd 
��� Serial1/0/4:0, since 00:05:35, no frags rcvd 
��� Serial1/0/5:0, since 00:05:35, no frags rcvd 
��� Serial1/0/6:0, since 00:05:35, no frags rcvd 
��� Serial1/0/7:0, since 00:05:35, no frags rcvd 

diana#show interface multilink 1 
Multilink1 is up, line protocol is up 
� Hardware is multilink group interface 
� Internet address is 10.10.10.1/24 
� MTU 1500 bytes, BW 15872 Kbit, DLY 100000 usec, 
���� reliability 255/255, txload 3/255, rxload 3/255 
� Encapsulation PPP, loopback not set 
� Keepalive set (10 sec) 
� DTR is pulsed for 2 seconds on reset 
� LCP Open, multilink Open 
� Open: IPCP 
� Last input 00:00:00, output never, output hang never 
� Last clearing of "show interface" counters 00:06:39 
� Input queue: 1/75/0/0 (size/max/drops/flushes); Total output drops: 0 
� Queueing strategy: fifo 
� Output queue :0/40 (size/max) 
� 5 minute input rate 241000 bits/sec, 28 packets/sec 
� 5 minute output rate 241000 bits/sec, 28 packets/sec 
���� 6525 packets input, 9810620 bytes, 0 no buffer 
���� Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
���� 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
���� 6526 packets output, 9796112 bytes, 0 underruns 
���� 0 output errors, 0 collisions, 0 interface resets 
���� 0 output buffer failures, 0 output buffers swapped out 
���� 0 carrier transitions � 

В этих выходных данных отключен контроллер E1 3/0 на Cisco 7206, что заставляет выключаться контроллер E1 1/0/0 и последовательный контроллер 1/0/0:0 на Cisco 7505:

diana# 
*Nov 23 12:52:54.167: %CONTROLLER-5-UPDOWN: 
Controller E1 1/0/0, changed state to down 
*Nov 23 12:52:56.171: %LINK-3-UPDOWN: 
Interface Serial1/0/0:0, changed state to down 
*Nov 23 12:52:57.171: %LINEPROTO-5-UPDOWN: 
Line protocol on Interface Serial1/0/0:0, changed state to down 

diana#show ppp multilink
Multilink1, bundle name is bob 
� Bundle up for 00:06:52 
� Bundle is Distributed 
� 0 lost fragments, 0 reordered, 0 unassigned 
� 0 discarded, 0 lost received, 1/255 load 
� 0x269C received sequence, 0x269B sent sequence 
� Member links: 7 active, 1 inactive (max not set, min not set) 
��� Serial1/0/1:0, since 00:06:52, no frags rcvd 
��� Serial1/0/2:0, since 00:06:52, no frags rcvd 
��� Serial1/0/3:0, since 00:06:52, no frags rcvd 
��� Serial1/0/4:0, since 00:06:52, no frags rcvd 
��� Serial1/0/5:0, since 00:06:52, no frags rcvd 
��� Serial1/0/6:0, since 00:06:52, no frags rcvd 
��� Serial1/0/7:0, since 00:06:52, no frags rcvd 
��� Serial1/0/0:0 (inactive) 

diana#show interface multilink 1 
Multilink1 is up, line protocol is up 
� Hardware is multilink group interface 
� Internet address is 10.10.10.1/24 
� MTU 1500 bytes, BW 13888 Kbit, DLY 100000 usec, 
���� reliability 255/255, txload 6/255, rxload 6/255 
� Encapsulation PPP, loopback not set 
� Keepalive set (10 sec) 
� DTR is pulsed for 2 seconds on reset 
� LCP Open, multilink Open 
� Open: IPCP 
� Last input 00:00:00, output never, output hang never 
� Last clearing of "show interface" counters 00:07:47 
� Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
� Queueing strategy: fifo 
� Output queue :0/40 (size/max) 
� 5 minute input rate 367000 bits/sec, 40 packets/sec 
� 5 minute output rate 367000 bits/sec, 40 packets/sec 
���� 10899 packets input, 16389116 bytes, 0 no buffer 
���� Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
���� 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
���� 10901 packets output, 16367362 bytes, 0 underruns 
���� 0 output errors, 0 collisions, 0 interface resets 
���� 0 output buffer failures, 0 output buffers swapped out 
���� 0 carrier transitions 

diana#show interface serial 1/0/0:0 
Serial1/0/0:0 is down, line protocol is down 
� Hardware is Multichannel E1 
� MTU 1500 bytes, BW 1984 Kbit, DLY 20000 usec, 
���� reliability 255/255, txload 41/255, rxload 41/255 
� Encapsulation PPP, crc 16, Data non-inverted 
� Keepalive set (10 sec) 
� LCP Closed, multilink Closed 
� Closed: CDPCP 
� Last input 00:00:15, output 00:00:17, output hang never 
� Last clearing of "show interface" counters 00:07:42 
� Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
� Queueing strategy: fifo 
� Output queue :0/40 (size/max) 
� 5 minute input rate 323000 bits/sec, 35 packets/sec 
� 5 minute output rate 324000 bits/sec, 35 packets/sec 
���� 9811 packets input, 14623345 bytes, 0 no buffer 
���� Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
���� 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
���� 9809 packets output, 14680161 bytes, 0 underruns 
���� 0 output errors, 0 collisions, 1 interface resets 
���� 0 output buffer failures, 0 output buffers swapped out 
���� 2 carrier transitions alarm present 
� Timeslot(s) Used:1-31, subrate: 64Kb/s, transmit delay is 0 flags 
� Transmit queue length 26 

diana#show controller e1 
E1 1/0/0 is down. 
� Applique type is Channelized E1 - balanced 
� Transmitter is sending remote alarm. 
� Receiver is getting AIS. 
� Framing is CRC4, Line Code is HDB3, Clock Source is Line. 
� International Bit: 1, National Bits: 11111 
� Data in current interval (465 seconds elapsed): 
���� 1 Line Code Violations, 1 Path Code Violations 
���� 0 Slip Secs, 0 Fr Loss Secs, 1 Line Err Secs, 0 Degraded Mins 
���� 0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 19 Unavail Secs 
... 

diana#debug ppp negotiation 
�PPP protocol negotiation debugging is on 

diana#debug ppp authentication 
PPP authentication debugging is on 

diana#debug ppp multilink events 
Multilink events debugging is on 

В этих выходных данных контроллер E1 3/0 на Cisco 7206 включен снова.

diana# 
*Nov 23 12:53:40.167: %CONTROLLER-5-UPDOWN: 
Controller E1 1/0/0, changed state to up 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP: I CONFREQ [Closed] id 34 len 26 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:��� AuthProto CHAP (0x0305C22305) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:��� MagicNumber 0x10193C10 (0x050610193C10) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:��� MRRU 1524 (0x110405F4) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:��� EndpointDisc 1 Local (0x130701646F6469) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP: Lower layer not up, Fast Starting 
*Nov 23 12:53:42.071: Se1/0/0:0 PPP: Treating connection as a dedicated line 
*Nov 23 12:53:42.071: Se1/0/0:0 PPP: Phase is ESTABLISHING, Active Open 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP: O CONFREQ [Closed] id 2 len 27 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:��� AuthProto CHAP (0x0305C22305) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:��� MagicNumber 0x80248196 (0x050680248196) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:��� MRRU 1524 (0x110405F4) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP:��� EndpointDisc 1 Local (0x1308016469616E61) 
*Nov 23 12:53:42.071: Se1/0/0:0 LCP: O CONFACK [REQsent] id 34 len 26 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:��� AuthProto CHAP (0x0305C22305) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:��� MagicNumber 0x10193C10 (0x050610193C10) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:��� MRRU 1524 (0x110405F4) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:��� EndpointDisc 1 Local (0x130701646F6469) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP: I CONFACK [ACKsent] id 2 len 27 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:��� AuthProto CHAP (0x0305C22305) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:��� MagicNumber 0x80248196 (0x050680248196) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:��� MRRU 1524 (0x110405F4) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP:��� EndpointDisc 1 Local (0x1308016469616E61) 
*Nov 23 12:53:42.075: Se1/0/0:0 LCP: State is Open 
*Nov 23 12:53:42.079: Se1/0/0:0 PPP: Phase is AUTHENTICATING, by both 
*Nov 23 12:53:42.079: Se1/0/0:0 CHAP: O CHALLENGE id 2 len 26 from "diana" 
*Nov 23 12:53:42.079: Se1/0/0:0 CHAP: I CHALLENGE id 4 len 25 from "bob" 
*Nov 23 12:53:42.079: Se1/0/0:0 CHAP: O RESPONSE id 4 len 26 from "diana" 
*Nov 23 12:53:42.079: %LINK-3-UPDOWN: Interface Serial1/0/0:0, changed state to up 
*Nov 23 12:53:42.083: Se1/0/0:0 CHAP: I RESPONSE id 2 len 25 from "bob" 
*Nov 23 12:53:42.083: Se1/0/0:0 CHAP: I SUCCESS id 4 len 4 
*Nov 23 12:53:42.083: Se1/0/0:0 CHAP: O SUCCESS id 2 len 4 
*Nov 23 12:53:42.087: Se1/0/0:0 MLP: Request add link to bundle 
*Nov 23 12:53:42.087: Se1/0/0:0 PPP: Phase is VIRTUALIZED 
*Nov 23 12:53:42.087: Se1/0/0:0 MLP: Adding link to bundle 
*Nov 23 12:53:42.087: Mu1 MLP: Added link Se1/0/0:0 to bundle bob 
*Nov 23 12:53:43.087: %LINEPROTO-5-UPDOWN: 
Line protocol on Interface Serial1/0/0:0, changed state to up 

diana#show ppp multilink
Multilink1, bundle name is bob 
� Bundle up for 00:07:46 
� Bundle is Distributed 
� 0 lost fragments, 0 reordered, 0 unassigned 
� 0 discarded, 0 lost received, 7/255 load 
� 0x35BF received sequence, 0x35BE sent sequence 
� Member links: 8 active, 0 inactive (max not set, min not set) 
��� Serial1/0/1:0, since 00:07:46, no frags rcvd 
��� Serial1/0/2:0, since 00:07:46, no frags rcvd 
��� Serial1/0/3:0, since 00:07:46, no frags rcvd 
��� Serial1/0/4:0, since 00:07:46, no frags rcvd 
��� Serial1/0/5:0, since 00:07:46, no frags rcvd 
��� Serial1/0/6:0, since 00:07:46, no frags rcvd 
��� Serial1/0/7:0, since 00:07:46, no frags rcvd 
��� Serial1/0/0:0, since 00:00:13, no frags rcvd 

diana#show interface multilink 1 
Multilink1 is up, line protocol is up 
� Hardware is multilink group interface 
� Internet address is 10.10.10.1/24 
� MTU 1500 bytes, BW 15872 Kbit, DLY 100000 usec, 
���� reliability 255/255, txload 7/255, rxload 7/255 
� Encapsulation PPP, loopback not set 
� Keepalive set (10 sec) 
� DTR is pulsed for 2 seconds on reset 
� LCP Open, multilink Open 
� Open: IPCP 
� Last input 00:00:00, output never, output hang never 
� Last clearing of "show interface" counters 00:08:32 
� Input queue: 1/75/0/0 (size/max/drops/flushes); Total output drops: 0 
� Queueing strategy: fifo 
� Output queue :0/40 (size/max) 
� 5 minute input rate 443000 bits/sec, 49 packets/sec 
� 5 minute output rate 443000 bits/sec, 49 packets/sec 
���� 14098 packets input, 21200412 bytes, 0 no buffer 
���� Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
���� 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
���� 14099 packets output, 21170758 bytes, 0 underruns 
���� 0 output errors, 0 collisions, 0 interface resets 
���� 0 output buffer failures, 0 output buffers swapped out 
���� 0 carrier transitions 

diana#show interface serial 1/0/0:0 
Serial1/0/0:0 is up, line protocol is up 
� Hardware is Multichannel E1 
� MTU 1500 bytes, BW 1984 Kbit, DLY 20000 usec, 
���� reliability 255/255, txload 32/255, rxload 32/255 
� Encapsulation PPP, crc 16, Data non-inverted 
� Keepalive set (10 sec) 
� LCP Open, multilink Open 
� Last input 00:00:02, output 00:00:02, output hang never 
� Last clearing of "show interface" counters 00:08:39 
� Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
� Queueing strategy: fifo 
� Output queue :0/40 (size/max) 
� 5 minute input rate 253000 bits/sec, 24 packets/sec 
� 5 minute output rate 254000 bits/sec, 24 packets/sec 
���� 9821 packets input, 14623552 bytes, 0 no buffer 
���� Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
���� 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
���� 9819 packets output, 14680370 bytes, 0 underruns 
���� 0 output errors, 0 collisions, 1 interface resets 
���� 0 output buffer failures, 0 output buffers swapped out 
���� 3 carrier transitions no alarm present 
� Timeslot(s) Used:1-31, subrate: 64Kb/s, transmit delay is 0 flags 
� Transmit queue length 26 

diana#show controller e1 
E1 1/0/0 is up. 
� Applique type is Channelized E1 - balanced 
� No alarms detected. 
� Framing is CRC4, Line Code is HDB3, Clock Source is Line. 
� International Bit: 1, National Bits: 11111 
� Data in current interval (519 seconds elapsed): 
���� 1 Line Code Violations, 1 Path Code Violations 
���� 0 Slip Secs, 0 Fr Loss Secs, 1 Line Err Secs, 0 Degraded Mins 
���� 0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 37 Unavail Secs 
... 

Дополнительные сведения


Document ID: 11044