Коммутаторы : Коммутаторы Cisco Catalyst серии 6500

Настройка IP-адреса управления на коммутаторах Catalyst 4500/4000, 5500/5000, 6500/6000 и коммутаторах Catalyst с фиксированной конфигурацией

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (22 сентября 2010) | Английский (20 октября 2015) | Отзыв


Интерактивно этот документ предлагает анализ конкретного устройства Cisco.


Содержание


Введение

Этот документ описывает, как настроить управление IP-адресами на Catalyst 4500/4000, 5500/5000, и 6500/6000 коммутаторы серии, которые выполняют операционную систему Catalyst (CatOS) и Cisco программное обеспечение IOS�. В этом документе также рассматриваются коммутаторы Catalyst с фиксированной конфигурацией, работающие под управлением только программного обеспечения Cisco IOS, а также коммутаторы серий 2900/3500XL, 2940, 2950, 2955, 2970, 3550 и 3750. IP-адрес необходим, если требуется управлять коммутатором с удаленной станции, поддерживающей управление по протоколу TCP/IP. Коммутатору, управление которым будет осуществляться с терминала VT100 через консольный порт, необязательно иметь IP-адрес.

Предварительные условия

Требования

Cisco рекомендует ознакомиться с информацией, содержащейся в данном разделе.

Коммутаторы Catalyst 4500/4000, 5500/5000, 6500/6000, работающие только под управлением CatOS, — это коммутаторы уровня 2. Коммутаторы серии Catalyst 2900/3500XLs, 2940, 2950, 2955 и 2970 с фиксированной конфигурацией являются также коммутаторами L2. Протокол TCP/IP на коммутаторе уровня 2 предназначен только для целей управления. Данные, которые передаются через коммутатор, могут иметь адреса уровня 2, например IP, Internetwork Packet Exchange (IPX), AppleTalk и т.п. Однако, для определения источника трафика и портов, которые будут принимать данные, коммутатор использует только MAC-адрес данных. Коммутаторы уровня 2 игнорируют адреса уровня 3, когда пересылают данные.

Коммутаторы Catalyst серий 6500/6000, 4500/4000 и 3550/3750 под управлением программного обеспечения Cisco IOS являются коммутируемыми маршрутизаторами или коммутаторами уровня 3 и могут использовать для управления любой интерфейс. Интерфейс управления можно настроить любым из перечисленных ниже способов:

  • В качестве логического интерфейса, такого как интерфейс замыкания на себя

  • В качестве порта доступа уровня 2 во VLAN управления

  • В качестве интерфейса уровня 3 с использованием IP-адреса

    Примечание: Это - тот же путь, которым вы настраиваете интерфейс на любом маршрутизаторе Cisco.

Коммутаторы Catalyst, которые рассматриваются в этом документе, имеют следующие интерфейсы управления:

  • Коммутаторы Catalyst серий 5500/5000 и 6500/6000 с модулями Supervisor Engine, работающие под управлением CatOS, имеют 2 настраиваемых IP-интерфейса управления:

    • Внутриполосный интерфейс (sc0)

    • Интерфейс протокола SLIP (Serial Line Internet Protocol — sl0)

  • Коммутаторы Catalyst 4500/4000 с модулями Supervisor Engine, работающие под управлением CatOS, имеют 3 настраиваемых IP-интерфейса управления. Дополнительный интерфейс называется интерфейсом управления Ethernet (me1).

  • Коммутаторы Catalyst уровня 2 с фиксированной конфигурацией, работающие под управлением программного обеспечения Cisco IOS, имеют только один настраиваемый IP-интерфейс управления — по умолчанию это интерфейсная VLAN 1.

  • Для коммутаторов уровня 2 может одновременно существовать только одна активная интерфейсная VLAN. Она называется VLAN управления (в IOS) или интерфейсом sc0 (в CatOS). Основная функция этого интерфейса — управление (Telnet, SNMP и т.п.). В случае использования коммутатора уровня 3 можно настроить несколько VLAN и выполнять маршрутизацию между ними. Коммутатор уровня 3 может обрабатывать несколько IP-адресов, поэтому для такого коммутатора нет специальной VLAN управления.

  • Коммутаторы Catalyst серий 3550/3750, работающие под управлением программного обеспечения Cisco IOS, могут использовать для управления любой интерфейс.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Интерфейсы управления Catalyst 4500/4000, 5500/5000 и 6500/6000

Интерфейс sc0 — это внутренний интерфейс управления, подключенный к коммутационной матрице. Интерфейс sc0 принимает участие во всех операциях обычного порта коммутатора, включая:

  • Протокол STP (Spanning Tree Protocol)

  • Протокол CDP (Cisco Discovery Protocol)

  • Принадлежность к сети VLAN

Интерфейсы me1 и sl0 являются внеполосными интерфейсами управления, которые не подключены к коммутационной матрице и не реализуют ни одной из данных функций.

При настройке IP-адреса, маски подсети и широковещательного адреса (и, на интерфейсе sc0, принадлежности к VLAN) для интерфейсов sc0 или me1 можно осуществлять доступ к коммутатору по протоколам Telnet или SNMP (Simple Network Management Protocol). При настройке интерфейса SLIP (sl0) можно создать двухточечное подключение к коммутатору через консольный порт с рабочей станции.

При наличии вывода команды show interface с устройства Cisco можно использовать утилиту Output Interpreter (только длязарегистрированных пользователей) для просмотра потенциальных неполадок и исправлений.

Интерфейс sc0 не имеет внешнего порта для прямого подключения. Данный интерфейс существует в качестве логического интерфейса внутри коммутатора и доступен через любые физические порты коммутатора. Это показано на следующем рисунке:

/image/gif/paws/10594/8a.gif

Фактически, me1 — это физический порт Ethernet в модуле Supervisor Engine на коммутаторах Catalyst серий 4500/4000. Этот интерфейс используется только для управления сетью и не поддерживает коммутацию сети.

/image/gif/paws/10594/8d.gif

Интерфейс sl0 использует консольный порт RS232 в качестве физического интерфейса. Sl0 не может использоваться в качестве консоли VT100, пока находится в режиме SLIP. На следующем рисунке показано подключение SLIP к интерфейсу sl0:

8b.gif

Настройка интерфейса sc0 на коммутаторах Catalyst 4500/4000, 5500/5000 и 6500/6000 под управлением CatOS

В данном разделе описана настройка IP-адреса на внутриполосном интерфейсе sc0.

  1. Подключите терминал к консольным портам коммутаторов.

    Подробные сведения о подключении к консольным портам коммутаторов Catalyst см. в статье Подключение терминала к консольному порту на коммутаторах Catalyst.

  2. Введите команду show interface в командной строке коммутатора, чтобы узнать состояние интерфейсов управления по умолчанию.

    Switch-A> (enable) show interface
    sl0: flags=51<DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0
    sc0: flags=63<UP,BROADCAST,RUNNING>        
            vlan 1 inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    me1: flags=62<DOWN,BROADCAST,RUNNING>
            inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    
    !--- Catalyst 5500/5000 and 6500/6000 series switches 
    !--- do not display the me1 interface in the output.
    
    Switch-A> (enable)
  3. Введите команду set interface sc0 172.16.84.17 255.255.255.0 172.16.84.255, чтобы настроить IP-адрес для интерфейса sc0.

    В сообщении, которое возвращает коммутатор, указаны измененные параметры.

    Примечание: При запуске команды set interface sc0 вы не можете ввести широковещательный адрес без маски подсети IP-адреса.

    Switch-A> (enable) set interface sc0 172.16.84.17 255.255.255.0 172.16.84.255 
    Interface sc0 IP address, netmask, and broadcast set. 
    Switch-A> (enable)

    Введите команду show interface для просмотра изменений.

    Switch-A> (enable) show interface 
    sl0: flags=51<DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0 
    sc0: flags=63<UP,BROADCAST,RUNNING> 
            vlan 1 inet 172.16.84.17 netmask 255.255.255.0 broadcast 172.16.84.255
    me1: flags=62<DOWN,BROADCAST,RUNNING>
            inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    Switch-A> (enable)

    Если ввести только IP-адрес после команды set interface sc0 172.16.84.17, то маска и широковещательный адрес по умолчанию для данного класса адресов настраиваются автоматически. Например:

    Switch-A> (enable) set interface sc0 172.16.84.17 
    
    !--- Notice that neither the mask nor the broadcast address is specified.
    
    Interface sc0 IP address and netmask set. 
    Switch-A> (enable) 
    Switch-A> (enable) show interface 
    sl0: flags=51<DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0 
    sc0: flags=63<UP,BROADCAST,RUNNING>
            vlan 1 inet 172.16.84.17 netmask 255.255.0.0 broadcast 172.16.255.255 
    
    !--- Notice that the switch took the default mask 
    !--- and the broadcast address of class B.
    
    me1: flags=62<DOWN,BROADCAST,RUNNING>
            inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    Switch-A> (enable)

    Если ввести IP-адрес и маску подсети после команды set interface sc0, то широковещательный адрес для данной подсети настраивается автоматически.

  4. Чтобы изменить VLAN на интерфейсе sc0, введите команду set interface sc0 номер_VLAN, в которой указан номер VLAN.

    Примечание: По умолчанию интерфейс sc0 принадлежит VLAN 1.

    Чтобы задать принадлежность интерфейса sc0 к сети VLAN 2, введите следующую команду:

    Switch-A> (enable) set interface sc0 2 
    
    
    Interface sc0 vlan set. 
    Switch-A> (enable)

    Примечание: Убедитесь, что у вас есть настроенная VLAN 2 на коммутаторе перед выдачей этой команды. Вопросы настройки VLAN на коммутаторах Catalyst выходят за рамки этого документа. Дополнительные сведения см. в документе Создание VLAN Ethernet на коммутаторах Catalyst.

    Введите команду show interface для просмотра изменений.

    Switch-A> (enable) show interface
    sl0: flags=51<DOWN,POINTOPOINT,RUNNING> 
            slip 0.0.0.0 dest 0.0.0.0 
    sc0: flags=63<UP,BROADCAST,RUNNING>
    vlan 2 inet 172.16.84.17 netmask 255.255.255.0 broadcast 172.16.84.255
    me1: flags=62<DOWN,BROADCAST,RUNNING>
            inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    
    Switch-A> (enable)
  5. Введите команду show ip route.

    Примечание: Чтобы получить возможность управлять коммутатором через маршрутизатор, необходимо настроить шлюз по умолчанию. Коммутатор не участвует в IP-маршрутизации. Поэтому коммутатор не имеет сведений о топологии сети уровня 3.

    Выполняя команду show ip route, обратите внимание, что шлюзу для подсети sc0 назначен его собственный адрес.

    Switch-A> (enable) show ip route 
    Fragmentation   Redirect   Unreachable 
    -------------   --------   ----------- 
    enabled         enabled    enabled 
    
    Destination      Gateway          RouteMask    Flags    Use       Interface 
    ---------------  ---------------  ----------   -----    --------  --------- 
    172.16.84.0   172.16.84.17         0xffffff00   U        395         sc0 
    default          default          0xff000000   UH       0           sl0 
    Switch-A> (enable)
  6. Выполните команду set ip route 0.0.0.0 172.16.84.1 или set ip route default 172.16.84.1 для установки маршрута по умолчанию.

    Второй IP-адрес относится к напрямую подключенному маршрутизатору, который будет обеспечивать путь по остальной сети. Этот IP-адрес должен входить в ту же подсеть IP, что и коммутатор. Можно определить не более трех IP-шлюзов по умолчанию. Чтобы сделать шлюз основным, используйте ключевое слово primary в команде set ip route. Если вы не определили основной шлюз по умолчанию, то основным шлюзом будет первый настроенный шлюз. Если назначено несколько основных шлюзов, то основным шлюзом по умолчанию становится шлюз, настроенный последним.

    • Switch-A> (enable) set ip route 0.0.0.0 172.16.84.1 
      Route added. 
      Switch-A> (enable)

    или

    • Switch-A> (enable) set ip route default 172.16.84.1
      Route added. 
      Switch-A> (enable)

    Введите команду show ip route для просмотра изменений.

    Switch-A> (enable) show ip route 
    Fragmentation   Redirect   Unreachable
    -------------   --------   -----------
    enabled         enabled    enabled 
    
    The primary gateway: 172.16.84.1
    Destination      Gateway          RouteMask    Flags   Use       Interface
    ---------------  ---------------  ----------   -----   --------  ---------
    default        172.16.84.1          0x0        UG      0           sc0
    172.16.84.0      172.16.84.17     0xffffff00   U       525         sc0
    default          default          0xff000000   UH      0           sl0
    Switch-A> (enable)
  7. Чтобы удалить маршруты из таблицы маршрутизации, введите команду clear ip route all.

    Примечание: Если вы связаны с коммутатором через Telnet от другой подсети, вы теряете соединение при очистке маршрутов. Соединение с коммутатором нельзя будет восстановить до тех пор, пока другой пользователь не введет заново адрес шлюза на подключенной консоли, ПК или терминале, расположенных в той же подсети, что и коммутатор.

    Switch-A> (enable) clear ip route all
    All routes deleted.
    Switch-A> (enable)

    Можно удалить единственный маршрут, если был указан только этот маршрут. Введите команду clear ip route 0.0.0.0 172.16.84.1.

Настройка интерфейса SLIP (sl0) на коммутаторах Catalyst 4500/4000, 5500/5000 и 6500/6000 под управлением CatOS

Вы можете использовать соединение SLIP над sl0 для того чтобы контролировать или управлять переключателем отдаленно с прибором TCP/IP-capable где никакой другой путь к переключателю за исключением через порта консоли.

Сетевой администратор может с удаленного ПК устанавливать связь с коммутаторами, расположенными в любой точке мира, и управлять ими с помощью протоколов SNMP или Telnet через интерфейс SLIP. Через интерфейс sl0 можно также загружать системное программное обеспечение при помощи протокола TFTP. Без интерфейса SLIP консольный порт можно использовать только для доступа к терминалу VT100 (TTY) или для передачи файлов Kermit. Дополнительные сведения о настройке подключения удаленного доступа к коммутатору Catalyst см. в документе Подключение модема к консольному порту на коммутаторах Catalyst.

На приведенном ниже рисунке показан пример управления коммутатором с удаленного терминала при помощи интерфейса sl0. Иногда такой тип управления называют «внеполосным управлением». «Внеполосное» означает, что управляющий терминал обращается к устройству с использованием пути, не содержащего сеть, к которой подключен коммутатор.

/image/gif/paws/10594/8c.gif

Если вы настроили и активировали интерфейс sl0 с напрямую подключенного терминала консоли, то консольное соединение будет потеряно. Если используемый терминал поддерживает SLIP, установите сеанс SLIP с коммутатором. Затем деактивируйте соединение SLIP, чтобы установить прямую связь с консолью. Если SLIP активирован, но терминал не поддерживает SLIP, необходимо установить соединение Telnet с коммутатором и деактивировать sl0 или включить и отключить коммутатор, чтобы восстановить доступ к консольному порту.

Примечание: Пока у вас нет терминала, который может выполнить SLIP, и вы знаете, как использовать его, только выполнить эти шаги от Telnet - подключения до коммутатора.

  1. Установите соединение Telnet с коммутатором.

  2. Введите команду set interface sl0 1.1.1.1 1.1.1.2 в командной строке, чтобы задать SLIP-адрес коммутатора и IP-адрес назначения.

    Например:

    Switch-A> (enable) set interface sl0 1.1.1.1 1.1.1.2
    Interface sl0 slip and destination address set.
    Switch-A> (enable)
  3. Введите команду slip attach в командной строке, чтобы включить режим SLIP.

    Например:

    Switch-A> (enable) slip attach
    Console Port now running SLIP.
    Switch-A> (enable)
  4. Введите команду slip detach команду в командной строке для деактивации режима SLIP.

    Например:

    Switch-A> (enable) slip detach
    SLIP detached on Console port.
    Switch-A> (enable)

Настройка интерфейса управления Ethernet (me1) на коммутаторах Catalyst 4500/4000 под управлением CatOS

Данный раздел содержит описание настройки IP-адреса для интерфейса me1 на коммутаторах Catalyst серий 4500/4000. Пакеты, принятые интерфейсом me1, не смогут достигнуть коммутационной матрицы, и доступ к интерфейсу me1 возможен только через порт Ethernet модуля Supervisor Engine.

Другая особенность интерфейса me1 заключается в том, что, когда коммутатор находится в режиме ROM monitor (ROMmon), единственным активным интерфейсом является me1. Можно либо загрузиться по сети через me1, либо обновить программное обеспечение Cisco IOS через me1, когда коммутатор находится в режиме ROMmon. Однако необходимо сделать это непосредственно на порту консоли. Этот интерфейс можно использовать при восстановлении коммутаторов Catalyst серий 4500/4000 после повреждения или утраты образа программного обеспечения или после сбоя обновления. Соответствующие сведения можно найти в разделе Восстановление коммутаторов Catalyst 4000, Catalyst 2948G, Catalyst 2980G и Catalyst 4912G документа Восстановление коммутаторов Catalyst, работающих под управлением CatOS, после сбоев во время первоначальной загрузки.

IP-адрес для интерфейса me1 настраивается так же, как и для интерфейса sc0. Единственное отличие состоит в том, что интерфейс me1 нельзя подсоединить к какой-либо VLAN, поскольку он не достигает коммутационной матрицы, как интерфейс sc0.

Чтобы настроить IP-адрес для интерфейса me1, выполните следующие действия:

  1. Подключите терминал к консольному порту коммутатора.

  2. Введите команду show interface в командной строке коммутатора, чтобы узнать состояние интерфейса me1 по умолчанию.

    Например:

    Switch-A> (enable) show interface
    sl0: flags=51<DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0
    sc0: flags=63<UP,BROADCAST,RUNNING>
            vlan 1 inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    me1: flags=62<DOWN,BROADCAST,RUNNING>
            inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    
    Switch-A> (enable)
  3. Введите команду set interface me1 10.1.1.2 255.255.255.0 10.1.1.255, чтобы настроить IР-адрес для интерфейса me1.

    В сообщении, которое возвращает коммутатор, указаны измененные параметры.

    Примечание: Необходимо ввести сетевую маску для того, чтобы сконфигурировать адрес широковещательной рассылки.

    Switch-A> (enable) set interface me1 10.1.1.2 255.255.255.0 10.1.1.255
    Interface me1 IP address, netmask, and broadcast set.
    Switch-A> (enable)

    Введите команду show interface для просмотра внесенных изменений.

    Switch-A> (enable) show interface
    sl0: flags=50 <DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0
    sc0: flags=63 <UP,BROADCAST,RUNNING>
            vlan 1 inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    me1: flags=63 <UP,BROADCAST,RUNNING>
            inet 10.1.1.2 netmask 255.255.255.0 broadcast 10.1.1.255
    Switch-A> (enable)

    Если ввести только IP-адрес после команды set interface me1 10.1.1.2, то маска и широковещательный адрес по умолчанию для используемого вами класса адресов настраиваются автоматически. Например:

    Switch-A> (enable) set interface me1 10.1.1.2 
    
    !--- Notice that neither the mask nor the broadcast address is specified.
    
    Interface sc0 IP address and netmask set. 
    Switch-A> (enable)
    
    Switch-A> (enable) show interface
    sl0: flags=50 <DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0
    sc0: flags=63 <UP,BROADCAST,RUNNING>
            vlan 1 inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    
    me1: flags=63 <UP,BROADCAST,RUNNING>
            inet 10.1.1.2 netmask 255.0.0.0 broadcast 10.255.255.255
    
    !--- Notice that the switch took the 
    !--- default mask and the broadcast address of class A.
    
    Switch-A> (enable)

    Примечание: Обычно, интерфейс me1 настроен, чтобы быть в другой подсети, чем интерфейс sc0, который позволяет обоим интерфейсам оставаться. Оба интерфейса можно настроить в одной и той же подсети или с использованием одного IP-адреса, но в этом случае интерфейс sc0 будет отключен. В данном случае интерфейс me1 всегда имеет приоритет. Например, если вы уже настроили интерфейс sc0 с IP-адресом 172.16.84.17 255.255.255.0 и пытаетесь настроить интерфейс me1 в той же подсети (172.16.84.18 255.255.255.0), то получите следующие сообщения:

    Switch-A> (enable) set interface me1 172.16.84.18 255.255.255.0 172.16.80.255
    This command places me1 and sc0 into the same ip subnet. 
    The sc0 interface will be automatically configured down if necessary to resolve 
    the conflict.
    Do you want to continue (y/n) [n]?y
    Interface me1 IP address, netmask, and broadcast set.
    Interface sc0 administratively down due to conflict.
    Console> (enable)
    
    !--- Check the configuration.
    
    Switch-A> (enable) show interface
    sl0: flags=50 <DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0
    sc0: flags=62 <DOWN,BROADCAST,RUNNING>
            vlan 1 inet 172.16.84.17 netmask 255.255.255.0 broadcast 172.16.84.255
    me1: flags=63 <UP,BROADCAST,RUNNING>
            inet 172.16.84.18 netmask 255.255.255.0 broadcast 172.16.84.255
    Switch-A> (enable) 
  4. Если в шаге 3 вы заметили, что интерфейс me1 в нерабочем состоянии, введите следующую команду, чтобы перевести интерфейс в рабочее состояние вручную:

    Switch-A> (enable) set interface me1 up
    Interface me1 administratively up.
    Switch-A> (enable)
  5. Введите команду show ip route.

    Примечание: Если вы хотите быть в состоянии управлять коммутатором через маршрутизатор, необходимо настроить шлюз по умолчанию, потому что коммутатор не участвует в IP-маршрутизации. Поэтому коммутатор не имеет сведений о топологии сети уровня 3.

    Выполняя команду show ip route, обратите внимание, что шлюзу для подсети me1 назначен его собственный адрес.

    Switch-A> (enable) show ip route 
    Fragmentation   Redirect   Unreachable 
    -------------   --------   ----------- 
    enabled         enabled    enabled 
    
    Destination      Gateway          RouteMask    Flags    Use       Interface 
    ---------------  ---------------  ----------   -----    --------  --------- 
    10.1.1.0         10.1.1.2         0xffffff00   U       0           me1
    Switch-A> (enable)
  6. Выполните команду set ip route 0.0.0.0 10.1.1.3 или set ip route default 10.1.1.3 для установки маршрута по умолчанию.

    Второй IP-адрес относится к напрямую подключенному маршрутизатору, который будет обеспечивать путь по остальной сети. Этот IP-адрес должен входить в ту же подсеть IP, что и коммутатор.

    • Switch-A> (enable)set ip route 0.0.0.0 10.1.1.3
      Route added. 
      Switch-A> (enable)

    или

    • Switch-A> (enable) set ip route default 10.1.1.3
      Route added. 
      Switch-A> (enable)

    Введите команду show ip route для просмотра изменений.

    Switch-A> (enable) show ip route
    Fragmentation   Redirect   Unreachable
    -------------   --------   -----------
    enabled         enabled    enabled 
    
    The primary gateway: 10.1.1.3
    Destination      Gateway          RouteMask    Flags   Use       Interface
    ---------------  ---------------  ----------   -----   --------  ---------
    default          10.1.1.3         0x0          UG      0           me1
    10.1.1.0         10.1.1.2         0xffffff00   U       1           me1
    Switch-A> (enable)
    
    

    Примечание: Если sc0 и me1 находятся в других подсетях, можно настроить несколька шлюзов по умолчанию. Однако основным шлюзом станет шлюз, настроенный первым. Если это не намеченный вами шлюз, необходимо вставить ключевое слово primary в конце команды, чтобы изменить основной шлюз по умолчанию. Например, 172.16.84.1 будет основным шлюзом в случае, когда выполняются оба следующих условия:

    • Имеется интерфейс sc0 с IP-адресом 172.16.84.17 255.255.255.0, для которого первым настроен шлюз по умолчанию 172.16.84.1.

    • Настроен интерфейс me1 с IP-адресом 10.1.1.2 255.255.255.0 и шлюзом по умолчанию 10.1.1.3.

    Чтобы задать в качестве основного шлюза 10.1.1.3, можно выполнить следующие команды:

    Switch-A> (enable) show ip route
    Fragmentation   Redirect   Unreachable
    -------------   --------   -----------
    enabled         enabled    enabled 
    
    The primary gateway: 172.16.80.1
    Destination      Gateway          RouteMask    Flags   Use       Interface
    ---------------  ---------------  ----------   -----   --------  ---------
    default          10.1.1.3         0x0          G       0           me1
    default          172.16.84.1      0x0          UG      11          sc0
    172.16.80.0      172.16.84.17     0xffffff00   U       38          sc0
    10.1.1.0         10.1.1.2         0xffffff00   U       4           me1
    
    !--- Notice that 172.16.84.1 is the primary default gateway.
    
    Switch-A> (enable) 
    
    !--- Change the primary default gateway to 10.1.1.3.
    
    Switch-A> (enable) set ip route default 10.1.1.3 primary
    Primary route changed
    Switch-A> (enable)
    
    !--- This message displays when the primary gateway is changed:
    
    %SYS-5-RTE_DEFGATEFROM:Default Gateway switching from 172.16.80.1
    %SYS-5-RTE_DEFGATETO:Default Gateway switching to 10.1.1.3
    
    !--- Verify the change.
    
    Switch-A> (enable) show ip route
    Fragmentation   Redirect   Unreachable
    -------------   --------   -----------
    enabled         enabled    enabled 
    
    The primary gateway: 10.1.1.3
    Destination      Gateway          RouteMask    Flags   Use       Interface
    ---------------  ---------------  ----------   -----   --------  ---------
    default          10.1.1.3         0x0          UG      0         me1
    default          172.16.84.1      0x0          G       11        sc0
    172.16.80.0      172.16.84.17     0xffffff00   U       38        sc0
    10.1.1.0         10.1.1.2         0xffffff00   U       4         me1
    
    !--- Notice that now the primary default gateway is 10.1.1.3.
    
    
  7. Чтобы удалить маршруты из таблицы маршрутизации, введите команду clear ip route all.

    Примечание: Если вы связаны с коммутатором через Telnet от другой подсети, ваше соединение потеряно при очистке маршрутов. Соединение с коммутатором нельзя будет восстановить до тех пор, пока другой пользователь не введет заново адрес шлюза на подключенной консоли, ПК или терминале, расположенных в той же подсети, что и коммутатор.

    Switch-A> (enable) clear ip route all
    All routes deleted.
    Switch-A> (enable)

    Можно удалить единственный маршрут, если был указан только этот маршрут. Введите команду clear ip route 0.0.0.0 10.1.1.3.

Настройка интерфейса управления на коммутаторах Catalyst серий 4500/4000 под управлением программного обеспечения Cisco IOS

На коммутаторах Catalyst 4500/4000 с модулем Supervisor Engine III/IV, работающих под управлением программного обеспечения Cisco IOS, для управления можно использовать любой маршрутизируемый интерфейс. Существует три варианта настройки этого интерфейса.

Примечание: Управление портами Ethernet (маркировал 10/100 MGT) на Supervisor Engine III (WS-X4014) или Supervisor Engine IV (WS-X4515) используется в Режиме ROMmon только для восстановления образа программного обеспечения коммутатора, который отсутствует или поврежденный. Этот порт не активен во время обычной работы коммутатора, и его нельзя использовать в качестве интерфейса управления.

Вариант 1 — настройка интерфейса замыкания на себя для управления коммутатором. У интерфейса замыкания на себя есть несколько преимуществ. Это виртуальный интерфейс, который всегда работает. Пакеты, которые передаются на интерфейс замыкания на себя, перенаправляются обратно коммутатору или маршрутизатору уровня 3 и обрабатываются локально. IP-пакеты, направленные на интерфейс возвратной петли, но не предназначенные для него, отбрасываются. Следовательно, интерфейс замыкания на себя также служит нулевым интерфейсом. Интерфейс замыкания на себя используется в качестве идентификатора маршрутизатора для протокола OSPF (Open Shortest Path First) и т.п. В следующем примере используется нулевой интерфейс замыкания на себя:

Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface loopback 0
Switch(config-if)#ip address 10.1.1.1 255.255.255.255

!--- The loopback interface should have a 32-bit subnet mask, which means that
!--- the 10.1.1.1 address is the only destination address in this subnet.

Switch(config-if)#end
Switch#

Также необходимо настроить протокол маршрутизации для распределения подсети, которой назначен адрес замыкания на себя, или создания статического маршрута.

Вариант 2 — настроить интерфейс в качестве маршрутизируемого интерфейса L3 с IP-адресом. Все интерфейсы на коммутаторах Catalyst 4500/4000, работающих под управлением программного обеспечения Cisco IOS, по умолчанию являются интерфейсами уровня 2. Следовательно, любой интерфейс, подключенный к остальной части сети, необходимо настроить как маршрутизируемый интерфейс уровня 3. Введите команду no switchport и настройте нужный IP-адрес. Пример приведен ниже. Все интерфейсы включены по умолчанию, поэтому выполнять команду no shutdown не нужно. В данном примере используется Fast Ethernet 5/30:

Switch(config)#interface fastethernet 5/30 
Switch(config-if)#no switchport
Switch(config-if)#ip address 11.1.1.1 255.0.0.0

Если ввести команду show running-config interface fastethernet 5/30, вывод будет содержать следующие данные:

Building configuration... 
Current configuration : 80 bytes 
! 
interface FastEthernet5/30
no switchport
ip address 11.1.1.1 255.0.0.0
end

Вариант 3 — настройка интерфейса уровня 2 в качестве компонента определенной VLAN. Введите команды switchport mode access и switchport access vlan идентификатор_VLAN и используйте соответствующий коммутируемый виртуальный интерфейс (SVI) с IP-адресом.

Примечание: Необходимо понять различие между VLAN управления, которая используется для администрирования коммутатора и VLAN для передачи данных, которые используются для передачи трафика L2. VLAN управления — это интерфейс SVI, который вы создаете при помощи глобальной команды interface vlan идентификатор_VLAN. Не путайте эту команду с командами, которые используются для создания VLAN передачи данных, предназначенных для передачи трафика уровня 2. На коммутаторах Catalyst серий 6500/6000 под управлением программного обеспечения Cisco IOS можно настроить VLAN передачи данных из базы данных VLAN или выполнить глобальную команду vlan идентификатор_VLAN.

Выполните следующие действия:

  1. Введите следующие команды:

    Switch(config)#interface vlan 1 
    Switch(config-if)#ip address 10.1.1.1 255.0.0.0 
    Switch(config-if)#no shut
    

    Примечание: Данный пример использует VLAN 1 в качестве VLAN управления. VLAN 1 по умолчанию содержится в базе данных VLAN.

  2. Введите команду switchport mode access для нужного физического интерфейса, если вам требуется подтверждение, что данный интерфейс является портом коммутатора доступа.

    По умолчанию все интерфейсы являются интерфейсами уровня 2 и портами коммутатора доступа в сети VLAN 1. Если вы планируете использовать VLAN 1 в качестве VLAN управления, то настройка интерфейса не требуется. Но если вам нужно подтверждение в конфигурации, что интерфейс действительно является портом коммутатора доступа, необходимо использовать команду switchport mode access.

    Данный пример использует Fast Ethernet 5/32:

    Switch(config)#interface fastethernet 5/32
    Switch(config-if)#switchport mode access
    

    Если ввести команду show run interface fastethernet 5/32, вывод будет содержать следующие данные:

    Switch#show run interface fastethernet 5/32
    Building configuration...
    
    Current configuration : 84 bytes
    !
    interface FastEthernet5/32
    switchport mode access
    no snmp trap link-status
    end
  3. Если нужно изменить интерфейс управления с используемой по умолчанию VLAN 1 на другую VLAN, введите команду interface vlan идентификатор_VLAN, чтобы создать новый интерфейс SVI.

    Затем необходимо выполнить команду switchport access vlan идентификатор_VLAN, чтобы настроить интерфейс уровня 2 в качестве компонента новой VLAN. Этот процесс продемонстрирован на примере:

    Switch(config)#interface vlan 2
    Switch(config-if)#ip address 20.1.1.1 255.0.0.0
    Switch(config-if)#no shut
    
    !--- Configure an interface to access the new management VLAN.
    
    Switch(config)#interface fastethernet 5/32 
    Switch(config-if)#switchport mode access
    Switch(config-if)#switch access vlan 2
    

    Если ввести команду show run interface fastethernet 5/32, вывод будет содержать следующие данные:

    Building configuration... 
    Current configuration : 110 bytes
    !
    interface FastEthernet5/32 
     switchport access vlan 2 
     switchport mode access
    end

    Чтобы коммутатор осуществлял доступ к удаленным сетям, требуется любой из следующих компонентов:

    • Шлюз по умолчанию, заданный для маршрутизатора следующего участка пути, который напрямую подключен к коммутатору

    • Настроенный протокол динамической маршрутизации

    Если IP-маршрутизация не используется, введите команду ip default-gateway IP-адрес, чтобы настроить IP-адрес маршрутизатора, выступающего в роли шлюза. Чтобы настроить динамическую маршрутизацию, выполните команду router routing_protocol. Для просмотра состояния таблицы маршрутизации введите команду show ip route.

Настройка интерфейса управления на коммутаторах Catalyst серий 6500/6000 под управлением программного обеспечения Cisco IOS

На коммутаторах Catalyst серий 6500/6000, работающих под управлением программного обеспечения Cisco IOS, для управления можно использовать любой маршрутизируемый интерфейс. Существует три варианта настройки этого интерфейса.

Вариант 1 — настройка интерфейса замыкания на себя для управления коммутатором. У интерфейса замыкания на себя есть несколько преимуществ. Это виртуальный интерфейс, который всегда работает. Пакеты, которые передаются на интерфейс замыкания на себя, перенаправляются обратно коммутатору или маршрутизатору уровня 3 и обрабатываются локально. IP-пакеты, направленные на интерфейс возвратной петли, но не предназначенные для него, отбрасываются. Следовательно, интерфейс замыкания на себя также служит нулевым интерфейсом. Интерфейс возвратной петли используется в качестве идентификатора маршрутизатора для протокола OSPF и т.п. В следующем примере используется нулевой интерфейс замыкания на себя:

Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface loopback 0
Switch(config-if)#ip address 10.1.1.1 255.255.255.255

!--- The loopback interface should have a 32-bit subnet mask, which means that
!--- the 10.1.1.1 address is the only destination address in this subnet.

Switch(config-if)#end
Switch#

Также необходимо настроить протокол маршрутизации для распределения подсети, которой назначен адрес замыкания на себя, или создания статического маршрута.

Вариант 2 — настроить интерфейс в качестве маршрутизируемого интерфейса L3 с IP-адресом. Все интерфейсы на коммутаторах Catalyst 6500/6000, работающих под управлением программного обеспечения Cisco IOS, по умолчанию являются интерфейсами уровня 3. Все интерфейсы включены по умолчанию, поэтому выполнять команду no shutdown не нужно. В данном примере используется Fast Ethernet 5/30:

Switch(config)#interface fastethernet 5/30 
Switch(config-if)#ip address 11.1.1.1 255.0.0.0

Если ввести команду show running-config interface fastethernet 5/30, вывод будет содержать следующие данные:

Building configuration... 
Current configuration : 80 bytes 
! 
interface FastEthernet5/30
no switchport
ip address 11.1.1.1 255.0.0.0 
end

Вариант 3 — настройка интерфейса уровня 2 в качестве компонента определенной VLAN. Введите команды switchport mode access и switchport access vlan идентификатор_VLAN и используйте соответствующий интерфейс SVI с IP-адресом.

Примечание: Необходимо понять различие между VLAN управления, которая используется для администрирования коммутатора и VLAN для передачи данных, которые используются для передачи трафика L2. VLAN управления — это интерфейс SVI, который вы создаете при помощи глобальной команды interface vlan идентификатор_VLAN. Не путайте эту команду с командами, которые используются для создания VLAN передачи данных, предназначенных для передачи трафика уровня 2. На коммутаторах Catalyst серий 6500/6000 под управлением программного обеспечения Cisco IOS можно настроить VLAN передачи данных из базы данных VLAN или выполнить глобальную команду vlan идентификатор_VLAN.

Выполните следующие действия:

  1. Введите следующие команды:

    Switch(config)#interface vlan 1
    
    !--- Interface VLAN 1 is an SVI.
    
    Switch(config-if)#ip address 10.1.1.1 255.0.0.0 
    Switch(config-if)#no shut
    

    Примечание: Данный пример использует VLAN 1 в качестве VLAN управления. VLAN 1 по умолчанию содержится в базе данных VLAN.

  2. Введите команду switchport mode access для нужного физического интерфейса, чтобы настроить его в качестве интерфейса уровня 2 во VLAN 1 по умолчанию.

    Примечание: По умолчанию все интерфейсы являются интерфейсами L3.

    Данный пример использует Fast Ethernet 5/32:

    Switch(config)#interface fastethernet 5/32
    Switch(config-if)#switchport mode access
    

    Если ввести команду show run interface fastethernet 5/32, вывод будет содержать следующие данные:

    Switch#show run interface fastethernet 5/32
    Building configuration...
    Current configuration : 84 bytes
    !
    interface FastEthernet5/32
     switchport mode access
     no snmp trap link-status
    end
  3. Если нужно изменить интерфейс управления с используемой по умолчанию VLAN 1 на другую VLAN, введите команду interface vlan идентификатор_VLAN, чтобы создать новый интерфейс SVI.

    Затем необходимо выполнить команду switchport access vlan идентификатор_VLAN, чтобы настроить интерфейс уровня 2 в качестве компонента новой VLAN. Этот процесс продемонстрирован на примере:

    Switch(config)#interface vlan 2
    Switch(config-if)#ip address 20.1.1.1 255.0.0.0
    Switch(config-if)#no shut
    
    !--- Configure an interface to access the new management VLAN.
    
    Switch(config)#interface fastethernet 5/32 
    Switch(config-if)#switchport mode access
    Switch(config-if)#switch access vlan 2
    

    Если ввести команду show run interface fastethernet 5/32, вывод будет содержать следующие данные:

    Building configuration... 
    Current configuration : 110 bytes
    !
    interface FastEthernet5/32 
     switchport access vlan 2 
     switchport mode access
    end

    Чтобы коммутатор осуществлял доступ к удаленным сетям, требуется любой из следующих компонентов:

    • Шлюз по умолчанию, заданный для маршрутизатора следующего участка пути, который напрямую подключен к коммутатору

    • Настроенный протокол динамической маршрутизации

    Если IP-маршрутизация не используется, введите команду ip default-gateway IP-адрес, чтобы настроить IP-адрес маршрутизатора, выступающего в роли шлюза. Чтобы настроить динамическую маршрутизацию, выполните команду router routing_protocol. Для просмотра состояния таблицы маршрутизации введите команду show ip route.

Настройка интерфейса управления на коммутаторах Catalyst уровня 2 с фиксированной конфигурацией

Коммутаторы Catalyst уровня 2 с фиксированной конфигурацией работают на программном обеспечении Cisco IOS, но поддерживают только возможности уровня 2. Эти коммутаторы могут иметь одновременно лишь один активный интерфейс управления. Интерфейс управления по умолчанию — VLAN 1. На этих коммутаторах нельзя удалить VLAN 1. Однако можно создать другой интерфейс VLAN для управления, что продемонстрировано на примерах в этом разделе.

Примечание: Необходимо понять различие между VLAN управления, которая используется для администрирования коммутатора и VLAN, которые используются для передачи трафика L2. VLAN управления — это интерфейс SVI, который вы создаете при помощи глобальной команды interface vlan идентификатор_VLAN. Не путайте эту команду с командами, которые используются для создания VLAN передачи данных, предназначенных для передачи трафика уровня 2. На коммутаторах серии XL можно создавать только VLAN передачи данных при помощи команды vlan database. В программном обеспечении Cisco IOS версии 12.1(9)EA1 и выше на коммутаторах модели 2950 (и во всех версиях программного обеспечения на коммутаторах моделей 2940, 2955 и 2970) предусмотрена дополнительная возможность настройки VLAN передачи данных. Эта возможность реализуется при помощи глобальной команды vlan идентификатор_VLAN.

В приведенных ниже примерах используется Fast Ethernet 0/1 в качестве порта коммутатора доступа и компонента VLAN управления. Чтобы установить интерфейс в качестве компонента VLAN 1, не требуется никакой настройки, поскольку все интерфейсы по умолчанию являются портами коммутатора доступа во VLAN 1.

Первый пример:

Switch(config)#interface vlan 1
Switch(config-if)#ip address 10.1.1.1 255.0.0.0
Switch(config-if)#end
Switch#

Switch#show run interface vlan 1 
Building configuration...
Current configuration: 
! 
interface VLAN1 
 ip address 10.1.1.1 255.0.0.0 
 no ip directed-broadcast 
 no ip route-cache 
end

Switch#show run interface fastethernet 0/1
Building configuration...
 
Current configuration:
!
interface FastEthernet0/1

!--- All interfaces are access switch ports in VLAN 1 by default.

end
 
Switch#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
VLAN1                      10.1.1.1        YES manual up                    up  
    
FastEthernet0/1            unassigned      YES unset  up                    up

Не забудьте, что нельзя удалить интерфейс управления VLAN 1. Если нужно изменить интерфейс управления с используемой по умолчанию VLAN 1 на другую VLAN, введите команду interface vlan идентификатор_VLAN, чтобы создать новый интерфейс SVI. Затем необходимо выполнить команду switchport access vlan идентификатор_VLAN, чтобы настроить интерфейс уровня 2 в качестве компонента новой VLAN. Этот процесс продемонстрирован на примере:

Примечание: Интерфейс управления может быть в закрытом нерабочем состоянии после повторной загрузки, если интерфейс управления не является членом LAN 1 и если вы настроили какую-либо из этих команд на коммутаторе:

  • ip ftp source-interface vlan идентификатор_VLAN

  • ip tftp source-interface vlan идентификатор_VLAN

  • ip telnet source-interface vlan идентификатор_VLAN

    Настройте интерфейс управления в качестве компонента VLAN 1. В качестве альтернативного решения данной проблемы можно удалить эти команды из конфигурации или обновить программное обеспечение коммутатора до новейшего образа.

Примечание: На коммутаторах серии XL можно использовать дополнительную команду управления под новым SVI для автоматического завершения VLAN 1, и передайте IP-адрес новой VLAN.

Switch(config)#interface vlan 2
Switch(config-if)#ip address 20.1.1.1 255.0.0.0
Switch(config-if)#no shut

!--- Configure an interface to access the new management VLAN.

Switch(config)#interface fastethernet 0/1
Switch(config-if)#switchport access vlan 2
Switch(config-if)#end

Switch#

При запуске команды show run interface fastethernet 0/1 эти выходные данные теперь отображаются:

Switch#show run interface fastethernet 0/1
Building configuration...
Current configuration : 85 bytes
!
interface FastEthernet 0/1
 switchport access vlan 2
 switchport mode access
end
Switch#

Чтобы коммутатор осуществлял доступ к удаленным сетям, необходим шлюз по умолчанию, настроенный для маршрутизатора следующего участка пути, который напрямую подключен к коммутатору. Чтобы настроить IP-адрес маршрутизатора, выступающего в роли шлюза, введите команду ip default-gateway IP-адрес.

Настройка интерфейса управления на коммутаторах серий 3550 и 3750

На коммутаторах Catalyst серий 3550 и 3750, работающих под управлением программного обеспечения Cisco IOS, для управления можно использовать любой маршрутизируемый интерфейс. Существует три варианта настройки этого интерфейса.

Вариант 1 — настройка интерфейса замыкания на себя для управления коммутатором. У интерфейса замыкания на себя есть несколько преимуществ. Это виртуальный интерфейс, который всегда работает. Пакеты, которые передаются на интерфейс замыкания на себя, перенаправляются обратно коммутатору или маршрутизатору уровня 3 и обрабатываются локально. IP-пакеты, направленные на интерфейс возвратной петли, но не предназначенные для него, отбрасываются. Следовательно, интерфейс замыкания на себя также служит нулевым интерфейсом. Интерфейс возвратной петли используется в качестве идентификатора маршрутизатора для протокола OSPF и т.п. В следующем примере используется нулевой интерфейс замыкания на себя:

Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface loopback 0
Switch(config-if)#ip address 10.1.1.1 255.255.255.255

!--- The loopback interface should have a 32-bit subnet mask, which means that
!--- the 10.1.1.1 address is the only destination address in this subnet.

Switch(config-if)#end
Switch#

Также необходимо настроить протокол маршрутизации для распределения подсети, которой назначен адрес замыкания на себя, или создания статического маршрута.

Вариант 2 — настроить интерфейс в качестве маршрутизируемого интерфейса L3 с IP-адресом. Все интерфейсы на коммутаторах Catalyst 3550 и 3750, работающих под управлением программного обеспечения Cisco IOS, по умолчанию являются интерфейсами уровня 2. Чтобы настроить интерфейс уровня 2 в качестве интерфейса уровня 3, введите команду no switchport и затем настройте IP-адрес. Все интерфейсы включены по умолчанию, поэтому выполнять команду no shutdown не нужно. В данном примере используется Fast Ethernet 2/0/1 на коммутаторе Catalyst 3750:

Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface fastethernet 2/0/1
Switch(config-if)#no switchport
Switch(config-if)#ip address 11.1.1.1 255.0.0.0
Switch(config-if)#end
Switch#

Если ввести команду show running-config interface fastethernet 2/0/1, вывод будет содержать следующие данные:

Switch#show running-config interface fastethernet 2/0/1
Building configuration...
Current configuration : 81 bytes
!
interface FastEthernet2/0/1
 no switchport
 ip address 11.1.1.1 255.0.0.0
end
Switch#

Вариант 3 — настройка интерфейса уровня 2 в качестве компонента определенной VLAN. Введите команды switchport mode access и switchport access vlan идентификатор_VLAN и используйте соответствующий интерфейс SVI с IP-адресом.

Выполните следующие действия:

  1. Введите следующие команды:

    Switch(config)#interface vlan 1
    
    !--- Interface VLAN 1 is an SVI.
    
    Switch(config-if)#ip address 10.1.1.1 255.0.0.0 
    Switch(config-if)#no shut
    

    Примечание: Данный пример использует VLAN 1 в качестве VLAN управления. VLAN 1 по умолчанию содержится в базе данных VLAN.

  2. Введите команду switchport mode access для нужного физического интерфейса, если вам требуется подтверждение, что данный интерфейс является портом коммутатора доступа.

    По умолчанию все интерфейсы являются интерфейсами уровня 2 и портами коммутатора доступа в сети VLAN 1. Если вы планируете использовать VLAN 1 в качестве VLAN управления, то настройка интерфейса не требуется. Но если вам нужно подтверждение в конфигурации, что интерфейс действительно является портом коммутатора доступа, необходимо использовать команду switchport mode access.

    В данном примере используется Fast Ethernet 2/0/1:

    Switch(config)#interface fastethernet 2/0/1
    Switch(config-if)#switchport mode access
    Switch(config-if)#end
    

    Если ввести команду show run interface fastethernet 2/0/1, вывод будет содержать следующие данные:

    Switch#show run interface fastethernet 2/0/1
    Building configuration...
    Current configuration : 59 bytes
    !
    interface FastEthernet2/0/1
     switchport mode access
    end
    Switch#
  3. Если нужно изменить интерфейс управления с используемой по умолчанию VLAN 1 на другую VLAN, введите команду interface vlan идентификатор_VLAN, чтобы создать новый интерфейс SVI.

    Затем необходимо выполнить команду switchport access vlan идентификатор_VLAN, чтобы настроить интерфейс уровня 2 в качестве компонента новой VLAN. Этот процесс продемонстрирован на примере:

    Switch(config)#interface vlan 2
    Switch(config-if)#ip address 20.1.1.1 255.0.0.0
    Switch(config-if)#no shut
    
    !--- Configure an interface to access the new management VLAN.
    
    Switch(config)#interface fastethernet 2/0/1
    Switch(config-if)#switchport access vlan 2
    Switch(config-if)#end
    Switch#

    Если ввести команду show run interface fastethernet 2/0/1, вывод будет содержать следующие данные:

    Switch#show run interface fastethernet 2/0/1
    Building configuration...
    Current configuration : 85 bytes
    !
    interface FastEthernet2/0/1
     switchport access vlan 2
     switchport mode access
    end
    Switch#

    Чтобы коммутатор осуществлял доступ к удаленным сетям, требуется любой из следующих компонентов:

    • Шлюз по умолчанию, заданный для маршрутизатора следующего участка пути, который напрямую подключен к коммутатору

    • Настроенный протокол динамической маршрутизации

    Если IP-маршрутизация не используется, введите команду ip default-gateway IP-адрес, чтобы настроить IP-адрес маршрутизатора, выступающего в роли шлюза.

    Если вы планируете настроить динамическую маршрутизацию, учтите, что по умолчанию IP-маршрутизация отключена. Чтобы включить IP-маршрутизацию, необходимо выполнить глобальную команду ip routing. Протокол RIP (Routing Information Protocol) — это единственный динамический протокол маршрутизации, который поддерживается при использовании стандартного многоуровневого образа программного обеспечения (Standard Multilayer Software Image — SMI). Расширенный образ многоуровневого программного обеспечения (Enhanced Multilayer Software Image — EMI) требуется для протоколов IGRP (Interior Gateway Routing Protocol), EIGRP (Enhanced IGRP), OSPF и BGP (Border Gateway Protocol). Чтобы настроить динамическую маршрутизацию, выполните команду router routing_protocol. Для просмотра состояния таблицы маршрутизации введите команду show ip route.


Дополнительные сведения


Document ID: 10594