Коммутаторы : Коммутаторы Cisco Catalyst серии 6500

Формирование и Поиск неисправностей IP MLS на Катализаторе 6500/6000 Выключатели с MSFC

17 октября 2015 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (19 сентября 2015) | Отзыв


Содержание


Введение

Этот документ является путеводителем при подтверждении и как прочитать Многослойное Переключение (MLS) команды на Катализаторе 6500/6000. Документ содержит очень краткий обзор того, что MLS, и также дает примеры того, как использовать MLS. Основанный на этих примерах, этот документ показывает, как проверить операцию MLS и обеспечивает краткие советы поиска неисправностей для формирования MLS.

Этот документ применяет только к Катализатору 6500/6000 серийный выключатель, оборудованный следующими аппаратными средствами:

  • 1 А бегущего катализатора наблюдателя Энджина OS (CatOS) программное обеспечение

  • Стратегическая карта особенности (PFC)

  • Многослойная карта особенности выключателя (MSFC)

Примечание: Этот документ не действителен при использовании любой другой конфигурации аппаратных средств, такой как наблюдатель Энджин 2 или Многослойный модуль выключателя (MSM). Это также не действительно когда бегущая Cisco программное обеспечение IOS� и на наблюдателе Энджине 1 А и на MSFC.

Для подобной информации относительно поиска неисправностей unicast направление на Катализаторе 6500/6000 серийный выключатель с наблюдателем Энджином 2 и управление программным обеспечением CatOS, относитесь для Поиска неисправностей Направления IP Unicast, Включающего CEF на Катализаторе 6500/6000 Серийные Выключатели с наблюдателем Энджином 2 и Управляющего Системным программным обеспечением CatOS.

Для более полного описания терминологии MLS и операции, посмотрите секцию Соответствующей информации.

Перед началом

Соглашения

Для получения дополнительной информации о соглашениях документа посмотрите Cisco Технические Соглашения Подсказок.

Предпосылки

Нет никаких определенных предпосылок для этого документа.

Используемые компоненты

Информация в этом документе основана на версиях программного и аппаратного обеспечения ниже.

  • Катализатор 6500/6000 с MSFC

Информация в этом документе была создана из устройств в определенной окружающей среде лаборатории. Все устройства, используемые в этом документе, начали с очищенного (неплатеж) конфигурацию. Если ваша сеть жива, удостоверьтесь, что вы понимаете потенциальное воздействие любой команды.

Обзор MLS на MSFC

MSFC является вторым двигателем направления поколения для Катализатора 6500/6000 серийный выключатель, который может маршрут 15 миллионов пакетов в секунду. MSFC только работает с наблюдателем Энджинесом, которые имеют PFC. MSFC выполняет внутренний MLS с PFC, который действует подобный Карте Особенности NetFlow (NFFC) на Катализаторе 5000. Этот внутренний MLS не видим и просто ограничен выключателем: у вас нет ничего для формирования, чтобы заставить его работать, и это поддерживает короткие пути аппаратных средств для IP, IPX и передачи IP. Конфигурация MSFC подобна конфигурации RSM или RSFC, использующего интерфейсы VLAN. Можно получить доступ к нему сессия использования 15 (для MSFC на наблюдателе Энджине в месте 1) или сессия 16 (для MSFC на наблюдателе Энджине в месте 2).

Принцип подобен Многослойному Протоколу Переключения (MLSP) на Катализаторе 5000. Первый пакет разбит MSFC, и PFC создает короткий путь, который используется всеми последующими пакетами того же самого потока. В отличие от MLSP на Катализаторе 5000, который требует связи IP между MLS-SE и MLS-RP, MLS на Катализаторе 6500/6000 работы связью между MSFC и PFC по последовательному каналу (SCP).

PFC не может быть MLS-SE для окружающей среды Катализатора 5000 мл; однако, MSFC может быть MLS-RP для других 5000 Катализатора в сети. В этом случае необходимо формировать MSFC использование той же самой mls команды IP армированного пластика, как вы были бы для любого маршрутизатора Cisco IOS, используемого в качестве RP MLS.

/image/gif/paws/10566/mls.gif

Пример 1: направление MSFC между двумя VLANs

MLS на Катализаторе 6500/6000 для unicast IP является штепселем и игрой. Вы не должны формировать его. Ниже типовая конфигурация, где укротителем является Катализатор 6500/6000, который имеет MSFC, названный укротителем-msfc. Направление между VLAN 11 и 12 формируется на MSFC без единственной команды, связанной с MLS. Следует иметь в виду, что у наблюдателя Энджина не будет MLS-определенной конфигурации.

tamer-msfc#wr t 
Building configuration... 

Current configuration: 
! 
version 12.1 
no service pad 
service timestamps debug uptime 
service timestamps log uptime 
no service password-encryption 
! 
hostname tamer-msfc 
! 
boot system flash bootflash:c6msfc-ds-mz.121-1.E2.bin 
! 
ip subnet-zero 
ip cef 
! 
interface Vlan11 
 ip address 11.1.1.2 255.255.255.0 
! 
interface Vlan12 
 ip address 12.1.1.2 255.255.255.0 
! 
router eigrp 1 
 network 11.0.0.0 
 network 12.0.0.0 
 no auto-summary 
! 
ip classless 
no ip http server 
! 
! 
line con 0 
 transport input none 
line vty 0 4 
 login 
! 
end

Чтение шоу mls Записи и Основная Проверка

Ниже продукция, которую необходимо получить при издании шоу mls команда на наблюдателе Энджине.

tamer (enable) show mls 
Total packets switched = 8      

!--- Number of packet shortcuted by MLS.

Total Active MLS entries = 0      

!--- Number of flows currently existing.

MSFC 11.1.1.2 (Module 15) entries = 0 
IP Multilayer switching aging time = 256 seconds 
IP Multilayer switching fast aging time = 0 seconds, packet threshold = 0 
IP Current flow mask is Destination flow 
Active IP MLS entries = 0 
Netflow Data Export version: 7 
Netflow Data Export disabled 
Netflow Data Export port/host is not configured. 
Total packets exported = 0 

IP MSFC ID      Module XTAG MAC               Vlans 
--------------- ------ ---- ----------------- ---------------- 
11.1.1.2        15     1    00-d0-d3-9c-9e-3c 12,11      

!--- MSFC recognized by the switch.

Шоу mls продукция команды должно всегда иметь IP MSFC ID. Когда вы выпускаете шоу mls команда, проверяете следующее, если вы не видите IP MSFC ID:

  • MSFC в порядке (не всунутый способ ROMmon, например).

  • MLS все еще позволен на MSFC.

Можно проверить это путем издания следующих команд на MSFC:

tamer-msfc#show mls status 
MLS global configuration status: 
global mls ip:                     enabled     

!--- Should be enabled for unicast IP.

global mls ipx:                    enabled 
global mls ip multicast:           disabled 
current ip flowmask for unicast:   destination only 
current ipx flowmask for unicast:  destination only 

Путем издания шоу mls команда статуса, можно определить, позволен ли MLS для IP, IPX и передачи IP. Эти опции должны всегда активироваться по умолчанию; однако, они могут быть искалечены путем издания следующей команды в способе конфигурации:

no mls ip

Никакая mls IP команда не должна только использоваться для отладки целей. Команда также доступна как скрытая команда в глобальном способе конфигурации. Можно также отключить MLS на за - основание интерфейса VLAN, не выпуская mls IP команду в интерфейсном способе конфигурации

Примечание: не выпускайте шоу mls команда армированного пластика на MSFC. Эта продукция команды указывает, что отключен MLS. Однако шоу mls командует продукцией, выпущенной на наблюдателе Энджине выше обозначенного, что MLS работал правильно. Это несоответствие происходит, потому что шоу mls команда армированного пластика должно использоваться при выполнении MLS-армированного-пластика вместе с Катализатором 5000 выключателей.

tamer-msfc#show mls rp 
ip multilayer switching is globally disabled 
ipx multilayer switching is globally disabled 
ipx mls inbound acl override is globally disabled 
mls id is 00d0.d39c.9e04 
mls ip address 0.0.0.0 
mls ip flow mask is unknown 
mls ipx flow mask is unknown 
number of domains configured for mls 0

Пакет кандидата является пакетом, который может потенциально начать установку короткого пути MLS. Его Мак адрес назначения равен Мак адресу маршрутизатора, управляющего MLS. В этом случае Мак адрес MSFC является 00-d0-d3-9c-9e-3c (замеченный путем издания шоу mls команда). Чтобы проверить, что выключатель знает, что этим Мак адресом является Мак адрес маршрутизатора, выпустите выставочный кулак mac_address команда, как показано ниже.

tamer (enable) show cam 00-d0-d3-9c-9e-3c 
* = Static Entry. + = Permanent Entry. # = System Entry. R = Router Entry. 
X = Port Security Entry 
VLAN  Dest MAC/Route Des    [CoS]  Destination Ports or VCs / [Protocol Type] 
----  ------------------    -----  ------------------------------------------- 
11    00-d0-d3-9c-9e-3c R#          15/1 
12    00-d0-d3-9c-9e-3c R#          15/1 
Total Matching CAM Entries Displayed = 2

Эта продукция подтверждает, что выключатель знает, что этот Мак адрес является входом маршрутизатора, связанным с портом 15/1 (порт MSFC в месте 1).

Когда вы выпускаете шоу команды mls на наблюдателе выключателя Энджине, выпускаете следующую команду, если вы все еще не видите MSFC:

tamer (enable) show mls rlog l2 
SWLOG at 815d0c50: magic 1008, size 51200, cur 815d4170, end 815dd460 
Current time is: 08/08/00,17:13:25 

118 08/08/00,17:13:16:(RouterConfig)Router_cfg: router_add_MAC_to_earl 00-d0-d3-
9c-9e-3c  added for mod 15/1 Vlan 12 Earl AL =0 
117 08/08/00,17:13:16:(RouterConfig)Router_Cfg: Process add mls entry for mod 15
/1 vlan 12, i/f 1, proto 0, LC 3 
116 08/08/00,17:13:16:(RouterConfig)Router_cfg: router_add_MAC_to_earl 00-d0-d3-
9c-9e-3c  added for mod 15/1 Vlan 11 Earl AL =0 
115 08/08/00,17:13:16:(RouterConfig)Router_Cfg: Process add mls entry for mod 15
/1 vlan 11, i/f 1, proto 0, LC 3

Эта команда показывает вам сообщения, которые выключатель получает от MSFC, и что добавлены записи маршрутизатора.

Чтение шоу mls Столы Продукции

Выпустите шоу mls команда входа для просмотра полного стола MLS со всеми короткими путями. Продукция ниже показывает все полученные потоки.

tamer (enable) show mls entry 
Destination-IP  Source-IP       Prot  DstPrt SrcPrt Destination-MAC   Vlan EDst 
--------------- --------------- ----- ------ ------ ----------------- ---- ---- 
MSFC 11.1.1.2 (Module 15): 
10.68.5.1       -               -     -      -      00-d0-00-3f-a3-ff 8    ARPA 
12.1.1.1        -               -     -      -      00-00-0c-8c-70-88 12   ARPA 
11.1.1.1        -               -     -      -      00-00-0c-09-50-66 11   ARPA 
ESrc DPort  SPort  Stat-Pkts  Stat-Bytes  Uptime   Age 
---- ------ ------ ---------- ----------- -------- -------- 
ARPA 1/3    7/3    4          400         00:00:02 00:00:02 
ARPA 7/4    7/3    4          400         00:00:08 00:00:08 
ARPA 7/3    7/4    9          900         00:00:08 00:00:08 


Destination-IPX           Destination-MAC   Vlan EDst ESrc  Port  Stat-Pkts  
------------------------- ----------------- ---- ---- ---- ----- ---------- 
Stat-Bytes  Uptime   Age 
----------- -------- -------- 

MSFC 11.1.1.2 (Module 15): 

Total entries displayed: 2 
tamer (enable)

Примечание: Один поток создан за место назначения. Звон от 12.1.1.1 до 11.1.1.1 создаст два потока (один для каждого направления), как обозначено последними двумя линиями в продукции, показанной выше.

Следующее является некоторыми описаниями информации, которая найдена в столе:

  • Место назначения IP, источник, IP, Протестант, DstPrt и SrcPrt являются областями, раньше создавало короткие пути. В этом случае, место назначения только текут, используется. Только IP-адрес назначения потока припрятался про запас. Это может быть изменено путем изменения flowmask, который описан позже в этом документе.

  • MAC назначения является Мак адрес, который будет использоваться для переписывания места назначения MAC пакета. Исходный Мак адрес переписан с Мак адресом MSFC.

  • VLAN указывает на место назначения, VLAN должен был достигнуть того IP-адреса. Например, если пакет нужно послать на стволе, VLAN назначения важен.

  • DPort и Спорт являются местом назначения и исходным портом потока.

  • Статистика-Pkts и Байты статистики дают вам статистику по числу пакетов, которые использовали этот короткий путь начиная с создания потока.

  • Продолжительность работы является временем, так как был создан поток.

  • Возраст является затраченным временем, так как в последний раз использовался поток.

Измените поток на источник назначения. Шоу mls показы продукции команды входа и исходный IP-адрес и IP-адрес назначения прячет про запас. Различный поток для каждого исходного IP-адреса, общающегося к тому же самому IP-адресу назначения, теперь создан, как показано ниже.

tamer (enable) set mls flow destination-source 
Configured IP flowmask is set to destination-source flow. 
Warning: Configuring more specific flow mask may increase the number of MLS 
 entries dramatically. 
tamer (enable) 2000 Aug 09 17:05:12 %MLS-5-FLOWMASKCHANGE:IP flowmask changed 
 from DEST to DEST-SRC 

tamer (enable) show mls entry 
Destination-IP  Source-IP       Prot  DstPrt SrcPrt Destination-MAC   Vlan EDst 
--------------- --------------- ----- ------ ------ ----------------- ---- ---- 
MSFC 11.1.1.2 (Module 15): 
11.1.1.1        12.1.1.1        -     -      -      00-00-0c-09-50-66 11   ARPA 
11.1.1.1        10.68.5.1       -     -      -      00-00-0c-09-50-66 11   ARPA 
10.68.5.1       11.1.1.1        -     -      -      00-d0-00-3f-a3-ff 8    ARPA 
12.1.1.1        11.1.1.1        -     -      -      00-00-0c-8c-70-88 12   ARPA 
MSFC 0.0.0.0 (Module 16): 

ESrc DPort  Sport  Stat-Pkts  Stat-Bytes  Uptime   Age 
---- ------ ------ ---------- ----------- -------- -------- 
ARPA 7/3    7/4    4          400         00:00:02 00:00:02 
ARPA 7/3    1/3    4          400         00:00:32 00:00:32 
ARPA 1/3    7/3    4          400         00:00:32 00:00:32 
ARPA 7/4    7/3    4          400         00:00:02 00:00:02 


Destination-IPX           Destination-MAC   Vlan EDst ESrc  Port  
------------------------- ----------------- ---- ---- ---- ----- ---------- 
Stat-Pkts  Stat-Bytes  Uptime   Age 
----------- -------- -------- 

MSFC 11.1.1.2 (Module 15): 
MSFC 0.0.0.0 (Module 16): 


Total entries displayed: 4
tamer (enable)

Третий выбор установлен MLS в полный поток. Выступите некоторые свистят и сессии TELNET, чтобы видеть, как различные потоки созданы для каждого порта TCP. Ниже то, как стол MLS должен заботиться о создании, некоторые свистят и сессии TELNET. Используя полный поток, число потоков создало увеличения очень быстро. Информация о порте TCP припряталась про запас и появляется в столе MLS.

tamer (enable) set mls flow full 
Configured IP flowmask is set to full flow. 
Warning: Configuring more specific flow mask may increase the number of MLS 
 entries dramatically. 
Tamer (enable) 2000 Aug 09 17:30:01 %MLS-5-FLOWMASKCHANGE:IP flowmask changed
 from DEST to FULL 

tamer (enable) 
tamer (enable) show mls entry 
Destination-IP  Source-IP       Prot  DstPrt SrcPrt Destination-MAC   Vlan EDst 
--------------- --------------- ----- ------ ------ ----------------- ---- ---- 
MSFC 11.1.1.2 (Module 15): 
12.1.1.1        11.1.1.1        ICMP  -      -      00-00-0c-8c-70-88 12   ARPA 
11.1.1.1        12.1.1.1        TCP   11001  Telnet 00-00-0c-09-50-66 11   ARPA 
12.1.1.1        11.1.1.1        TCP*  Telnet 11001  00-00-0c-8c-70-88 12   ARPA 
11.1.1.1        10.68.5.1       TCP   11002  Telnet 00-00-0c-09-50-66 11   ARPA 
10.68.5.1       11.1.1.1        ICMP  -      -      00-d0-00-3f-a3-ff 8    ARPA 
10.68.5.1       11.1.1.1        TCP*  Telnet 11002  00-d0-00-3f-a3-ff 8    ARPA 
11.1.1.1        10.68.5.1       ICMP  -      -      00-00-0c-09-50-66 11   ARPA 
11.1.1.1        12.1.1.1        ICMP  -      -      00-00-0c-09-50-66 11   ARPA 

ESrc DPort  Sport  Stat-Pkts  Stat-Bytes  Uptime   Age 
---- ------ ------ ---------- ----------- -------- -------- 
ARPA 7/4    7/3    4          400         00:00:30 00:00:30 
ARPA 7/3    7/4    16         688         00:00:26 00:00:24 
ARPA 7/4    7/3    18         757         00:00:26 00:00:24 
ARPA 7/3    1/3    61         4968        00:00:16 00:00:06 
ARPA 1/3    7/3    4          400         00:00:33 00:00:33 
ARPA 1/3    7/3    69         2845        00:00:17 00:00:06 
ARPA 7/3    1/3    4          400         00:00:33 00:00:33 
ARPA 7/3    7/4    4          400         00:00:32 00:00:31 

  
Destination-IPX           Destination-MAC   Vlan EDst ESrc  Port  Stat-Pkts  
------------------------- ----------------- ---- ---- ---- ----- ---------- 
Stat-Bytes  Uptime   Age 
----------- -------- -------- 

MSFC 11.1.1.2 (Module 15): 

Total entries displayed: 8

Примечания

  • В живой сети число созданных потоков может быть до нескольких тысяч. Выпустите шоу mls IP входа [destination|source] команда для показа определенного потока вместо того, чтобы показать полный стол потока, как показано ниже.

    tamer (enable) show mls entry ip destination 12.1.1.1 
    
    Destination-IP  Source-IP       Prot  DstPrt SrcPrt Destination-MAC   Vlan EDst 
    --------------- --------------- ----- ------ ------ ----------------- ---- ---- 
    
    MSFC 11.1.1.2 (Module 15): 
    12.1.1.1        -               -     -      -      00-00-0c-8c-70-88 12   ARPA 
    
    
    ESrc DPort  Sport  Stat-Pkts  Stat-Bytes  Uptime   Age 
    ---- ------ ------ ---------- ----------- -------- -------- 
    ARPA 7/4    7/3    4          400         00:00:30 00:00:30 
    
  • Можно проверить, что статистические данные для потока путем издания команды показывают mls статистику, как показано ниже.

    tamer (enable) show mls statistics entry ip 15 
                                      Last    Used 
    Destination IP  Source IP       Prot DstPrt SrcPrt Stat-Pkts  Stat-Bytes 
    --------------- --------------- ---- ------ ------ ---------- --------------- 
    MSFC 11.1.1.2 (Module 15): 
    12.1.1.1        11.1.1.1        ICMP -      -      9          900 
    11.1.1.1        10.68.5.1       TCP  11005  Telnet 20         913 
    11.1.1.1        10.68.5.1       TCP  11004  Telnet 0          0 
    10.68.5.1       11.1.1.1        ICMP -      -      4          400 
    10.68.5.1       12.1.1.1        ICMP -      -      9          900 
    12.1.1.1        10.68.5.1       ICMP -      -      4          400 
    11.1.1.1        10.68.5.1       ICMP -      -      4          400 
    11.1.1.1        12.1.1.1        ICMP -      -      9          900

Поиск неисправностей определенной связи

Если у вас есть проблема возможности соединения к определенному IP-адресу или между двумя определенными хозяевами, попробуйте следующий для поиска неисправностей:

  • Выпустите шоу mls IP входа [destination|source] команда, чтобы видеть, был ли создан поток.

  • Выпустите шоу mls вход статистики [source|destination] команда несколько раз подряд, чтобы видеть, увеличиваются ли прилавки статистики-pakts для того короткого пути.

  • Проверьте соответствующий поток.

Например, для сессии FTP большого файла между сервером TFTP 12.1.1.1 и клиентом TFTP 11.1.1.1, необходимо проверить следующие два потока:

  • Один с местом назначения 12.1.1.1, который должен быть поражен только признанием TFTP (маленький пакет) (источник потока 12.1.1.1, если бы поток источника назначения использовал).

  • Один с местом назначения 11.1.1.1, который должен быть поражен большим количеством больших пакетов (фактическая передача файлов) (источник потока 11.1.1.1, если поток источника назначения используется).

    Это - пример TFTP между 12.1.1.1. и 11.1.1.1 из файла приблизительно 7.6 МБ. Следующее является столом статистики MLS перед началом TFTP:

    tamer (enable) show mls statistics entry 
                                      Last    Used 
    Destination IP  Source IP       Prot DstPrt SrcPrt Stat-Pkts  Stat-Bytes 
    --------------- --------------- ---- ------ ------ ---------- --------------- 
    MSFC 11.1.1.2 (Module 15): 
    12.1.1.1        11.1.1.1        ICMP -      -      4          400 
    11.1.1.1        12.1.1.1        ICMP -      -      4          400 
    12.1.1.1        11.1.1.1        TCP  11000  Telnet 20         894
    

TFTP только что начался. Два дополнительных потока, созданные для движения TFTP (порт UDP 69), показывают ниже.

tamer (enable) show mls statistics entry 
                                  Last    Used 
Destination IP  Source IP       Prot DstPrt SrcPrt Stat-Pkts  Stat-Bytes 
--------------- --------------- ---- ------ ------ ---------- --------------- 
MSFC 11.1.1.2 (Module 15): 
12.1.1.1        11.1.1.1        ICMP -      -      4          400 
12.1.1.1        11.1.1.1        UDP  69     50532  343        10997 
11.1.1.1        12.1.1.1        ICMP -      -      4          400 
11.1.1.1        12.1.1.1        UDP  50532  69     343        186592 
12.1.1.1        11.1.1.1        TCP  11000  Telnet 20         894

TFTP переходят только что законченный. Примерно 8.1 МБ переданы от сервера до клиента в 14,903 пакетах, который создает средний размер 544 байтов за пакет. В другом направлении та же самая сумма пакетов получена со средним размером 476,949 разделенных 14,904, который делает 33 байта.

Tamer (enable) show mls statistics entry 
                                  Last    Used 
Destination IP  Source IP       Prot DstPrt SrcPrt Stat-Pkts  Stat-Bytes 
--------------- --------------- ---- ------ ------ ---------- --------------- 
MSFC 11.1.1.2 (Module 15): 
12.1.1.1        11.1.1.1        ICMP -      -      4          400 
12.1.1.1        11.1.1.1        UDP  69     50532  14904      476949 
11.1.1.1        12.1.1.1        ICMP -      -      4          400 
11.1.1.1        12.1.1.1        UDP  50532  69     14903      8107224 
12.1.1.1        11.1.1.1        TCP  11000  Telnet 20         894

Эти столы должны дать вам общее представление о том, на что должен быть похожим ваш транспортный образец.

Пример 2: два MSFCs в том же самом шасси, формируемом для HSRP

Ниже бегущая конфигурация двух MSFCs, формируемых для HSRP и продукции выставочной команды резерва. MSFC в месте 15 активен для VLAN 12, и MSFC в месте 16 активен для VLAN 11.

Место 15 Место 16
tamer-msfc#wr t 
Building configuration... 

Current configuration: 
! 
version 12.1 
no service pad 
service timestamps debug uptime 
service timestamps log uptime 
no service password-encryption 
! 
hostname tamer-msfc 
! 
boot system flash bootflash:
  c6msfc-ds-mz.121-1.E2.bin 
! 
ip subnet-zero 
ip cef 
! 
! 
! 
! 
interface Vlan1 
 ip address 10.200.11.120 255.255.252.0 
! 
interface Vlan8 
 ip address 10.68.5.2 255.255.252.0 
! 
interface Vlan11 
 ip address 11.1.1.2 255.255.255.0 
 no ip redirects 
 standby 11 preempt 
 standby 11 ip 11.1.1.3 
! 
interface Vlan12 
 ip address 12.1.1.2 255.255.255.0 
 no ip redirects 
 standby 12 priority 105 preempt 
 standby 12 ip 12.1.1.3 
! 
router eigrp 1 
 network 10.0.0.0 
 network 11.0.0.0 
 network 12.0.0.0 
 no auto-summary 
! 
ip classless 
! 
line con 0 
 transport input none 
line vty 0 4 
 login 
! 
end
tamer-msfc-2#wr t 
Building configuration... 

Current configuration: 
! 
version 12.1 
no service pad 
service timestamps debug uptime 
service timestamps log uptime 
no service password-encryption 
! 
hostname tamer-msfc-2 
! 
boot system flash
  bootflash:c6msfc-jsv-mz.121-2.E.bin 
! 
ip subnet-zero 
!
! 
! 
! 
interface Vlan1 
 ip address 10.200.11.121 255.255.252.0 
! 
interface Vlan8 
 ip address 10.68.5.4 255.255.252.0 
! 
interface Vlan11 
 ip address 11.1.1.4 255.255.255.0 
 no ip redirects 
 standby 11 priority 105 preempt 
 standby 11 ip 11.1.1.3 
! 
interface Vlan12 
 ip address 12.1.1.4 255.255.255.0 
 no ip redirects 
 standby 12 preempt 
 standby 12 ip 12.1.1.3 
! 
router eigrp 1 
 network 10.0.0.0 
 network 11.0.0.0 
 network 12.0.0.0 
 no auto-summary 
! 
ip classless!  
! 
line con 0 
 transport input none 
line vty 0 4 
 login 
! 
end


tamer-msfc>show standby 
Vlan11 - Group 11 
  Local state is Standby, priority 100,
    may preempt 
  Hellotime 3 holdtime 10 
  Next hello sent in 00:00:00.814 
  Hot standby IP address is 11.1.1.3 configured 
  Active router is 11.1.1.4 expires in 00:00:09 
  Standby router is local 
  Standby virtual MAC address is 0000.0c07.ac0b 
  4 state changes, last state change 00:06:36 
Vlan12 - Group 12 
  Local state is Active, priority 105,
    may preempt 
  Hellotime 3 holdtime 10 
  Next hello sent in 00:00:02.380 
  Hot standby IP address is 12.1.1.3 configured 
  Active router is local 
  Standby router is 12.1.1.4 expires in 00:00:09 
  Standby virtual MAC address is 0000.0c07.ac0c 
  2 state changes, last state change 00:12:22
tamer-msfc-2#show standby 
Vlan11 - Group 11 
  Local state is Active, priority 105,
    may preempt 
  Hellotime 3 holdtime 10 
  Next hello sent in 00:00:02.846 
  Hot standby IP address is 11.1.1.3 configured 
  Active router is local 
  Standby router is 11.1.1.2 expires in 00:00:08 
  Standby virtual MAC address is 0000.0c07.ac0b 
  2 state changes, last state change 00:07:02 
Vlan12 - Group 12 
  Local state is Standby, priority 100,
    may preempt 
  Hellotime 3 holdtime 10 
  Next hello sent in 00:00:02.518 
  Hot standby IP address is 12.1.1.3 configured 
  Active router is 12.1.1.2 expires in 00:00:07,
   priority 105 
  Standby router is local 
  Standby virtual MAC address is 0000.0c07.ac0c 
  4 state changes, last state change 00:04:08

Вся информация в предыдущем примере все еще действительна. Для подтверждения, что изменилось после формирования HSRP рассмотрите продукцию команд MLS ниже.

Издание шоу mls Команды

tamer (enable) show mls 
Total packets switched = 29894 
Total Active MLS entries = 0 
  MSFC 11.1.1.2 (Module 15) entries = 0 
  MSFC 10.200.11.121 (Module 16) entries = 0 
IP Multilayer switching aging time = 256 seconds 
IP Multilayer switching fast aging time = 0 seconds, packet threshold = 0 
IP Current flow mask is Full flow 
Active IP MLS entries = 0 
Netflow Data Export version: 7 
Netflow Data Export disabled 
Netflow Data Export port/host is not configured. 
Total packets exported = 0 
IP MSFC ID      Module XTAG MAC               Vlans 
--------------- ------ ---- ----------------- ---------------- 
11.1.1.2        15     1    00-d0-d3-9c-9e-3c 12,11,8,1 
                            00-00-0c-07-ac-0c 12 

10.200.11.121   16     2    00-d0-bc-f0-07-b0 1,8,11,12 
                            00-00-0c-07-ac-0b 11 
  

IPX Multilayer switching aging time = 256 seconds 
IPX flow mask is Destination flow 
IPX max hop is 15 
Active IPX MLS entries = 0 

IPX MSFC ID     Module XTAG MAC               Vlans 
--------------- ------ ---- ----------------- ---------------- 
11.1.1.2        15     1    -                 - 

10.200.11.121   16     2    -                 -
  • Существует теперь два маршрутизатора MLS, замеченные PFC.

  • Для каждого замеченного маршрутизатора Мак адрес, используемый группой HSRP, является 00-00-0c-07-ac-xx. Этими Мак адресами являются действительные Мак адреса, используемые HSRP. Вы только видите Мак адрес группы 11, связанной с маршрутизатором, который активен для той группы (место 15 для VLAN 12 и места 16 для VLAN 11). Это означает, что в дополнение к пакетам с Мак адресом назначения, являющимся Мак адресом MSFC, пакеты кандидата также рассматривают, которые являются пакетами с местом назначения MAC, являющийся адресом HSRP.

  • Как заявлено в первом примере, также необходимо видеть эти HSRP адрес в Слое 2 стола CAM, указывающие на MSFC.

tamer (enable) show cam 00-00-0c-07-ac-0c 
* = Static Entry. + = Permanent Entry. # = System Entry. R = Router Entry. 
X = Port Security Entry 

VLAN  Dest MAC/Route Des    [COs]  Destination Ports or VCS / [Protocol Type] 
----  ------------------    -----  ------------------------------------------- 
12    00-00-0c-07-ac-0c R#          15/1 
Total Matching CAM Entries Displayed = 1 
tamer (enable) 

tamer (enable) show cam 00-00-0c-07-ac-0b 
* = Static Entry. + = Permanent Entry. # = System Entry. R = Router Entry. 
X = Port Security Entry 

VLAN  Dest MAC/Route Des    [COs]  Destination Ports or VCS / [Protocol Type] 
----  ------------------    -----  ------------------------------------------- 
11    00-00-0c-07-ac-0b R#          16/1 
Total Matching CAM Entries Displayed = 1 
tamer (enable)

Издание шоу mls Команды входа

tamer (enable) show mls entry
Destination-IP  Source-IP       Prot  DstPrt SrcPrt Destination-MAC   Vlan EDst 
--------------- --------------- ----- ------ ------ ----------------- ---- ---- 
MSFC 11.1.1.2 (Module 15): 
11.1.1.1        12.1.1.1        ICMP  -      -      00-00-0c-09-50-66 11   ARPA 
MSFC 10.200.11.121 (Module 16): 
12.1.1.1        11.1.1.1        ICMP  -      -      00-10-7b-3b-af-3b 12   ARPA 

ESrc DPort  Sport  Stat-Pkts  Stat-Bytes  Uptime   Age 
---- ------ ------ ---------- ----------- -------- -------- 
ARPA 7/3    7/4    4          400         00:00:03 00:00:03 
ARPA 7/4    7/3    4          400         00:00:04 00:00:03 


Destination-IPX           Destination-MAC   Vlan EDst ESrc  Port  Stat-Pkts  
------------------------- ----------------- ---- ---- ---- ----- ---------- 
Stat-Bytes  Uptime   Age 
----------- -------- -------- 

MSFC 11.1.1.2 (Module 15): 
MSFC 10.200.11.121 (Module 16):

  • Существует теперь два более легких стола: один для потоков, созданных первым MSFC, и один для потоков, создан вторым MSFC.

  • Путем свистения между 11.1.1.1 и 12.1.1.1, которые являются двумя PCs, формируемым с адресом HSRP как их ворота по умолчанию, пакеты от 12.1.1.1 до 11.1.1.1 прибытий в VLAN 12 на выключателе были shortcuted MSFC в месте 15 (поскольку это - активный маршрутизатор HSRP для VLAN 12), и короткий путь для места назначения 11.1.1.1 создан MSFC в месте 15. Короткие пути для пакетов от 11.1.1.1 до 12.1.1.1 были созданы на другом конце MSFC в месте 16.

Поиск неисправностей подсказок

Создание потоков

Если поток не был создан, используйте следующие советы поиска неисправностей:

  • Наблюдатель Энджин видит MSFC со всеми ожидаемыми Мак адресами при издании шоу mls команда?

    • Если да, пойдите в следующий шаг.

    • Если не, удостоверьтесь, что MSFC не застревает в способе ROMmon. Проверьте, что MLS позволен на MSFC путем издания mls статуса шоу команды.

  • Мак адрес подарка MSFC при издании выставочной команды кулака? Это обнаруживается как вход кулака маршрутизатора (R#)?

  • Проверьте, что вы не формировали особенность на MSFC, который отключает MLS.

    • Проверьте особенности, которые могут повлиять на MLS путем рассмотрения информации о версии для версии программного обеспечения, которой вы управляете.

    • Примеры ограничений показывают в столе ниже.

      Ограничения команды маршрутизатора IP

      Команда Поведение
      ясный IP маршрут Очищает все записи тайника MLS для всех выключателей, выполняющих Слой 3 переключения для этого MSFC.
      IP направление Никакая форма не производит чистку всех записей тайника MLS и отключает IP MLS на этом MSFC.
      IP безопасность (все формы этой команды) Отключает IP MLS в интерфейсе.
      IP tcp связи сжатия Отключает IP MLS в интерфейсе.
      IP tcp сжатие заголовка Отключает IP MLS в интерфейсе.

  • Проверьте предоставление возможности списка доступа, который просит обработку программного обеспечения вместо того, чтобы быть обработанным короткими путями аппаратных средств. Отошлите к Обработке Аппаратного и программного обеспечения IOS ACLs для получения дополнительной информации.

Если вы прошли все подсказки, упомянутые выше, и все еще имеете проблемы, проверяете, что MSFC все еще поражается большим количеством пакетов.

  • Что-то может заставлять записи очищаться непрерывно. Некоторые возможные причины чистки стола потока могут включать следующее:

    • Колебание маршрута или любой Слой 3 нестабильности.

    • Тайник ARP изменяется на MSFC.

    • Flowmask изменился на наблюдателе Энджине.

    • Место назначения VLAN удалено.

    • Интерфейс VLAN является закрытием на MSFC.

  • Некоторые другие причины отправления программного обеспечения (пакет, поражающий MSFC) вместо коротких путей аппаратных средств, могут включать следующее:

    • Пакет с выбором IP установлен.

    • Пакет с TTL, меньше чем или равным 1.

    • Пакет, который должен быть фрагментирован.

  • У вас может быть до 128 K потока, однако, алгоритм хеширования используется. При превышении 32 потоков K можно начать иметь столкновение мешанины, которое вызовет пакеты, разбиваемые программным обеспечением.

    • Способ избежать иметь слишком много потоков состоит в том, чтобы формировать быстрое старение для потока MLS.

  • Помните, что у вас может только быть MLS для IP, IPX и Передачи IP. Если у вас будут другие типы движения (например, AppleTalk), то они будут программным обеспечением, разбитым, и могут вызвать пики CPU на MSFC или чрезмерном пакете, совершающем нападки на MSFC.

  • Как определено, IP MLS и IPX MLS позволены по умолчанию, однако, передачу IP, которую MLS не позволен по умолчанию. При использовании передачи IP удостоверьтесь, что позволили MLS для передачи, как определено в гиде конфигурации.

Примечание: Уведомление об изменении топологии (TCN) Дерева Охвата или колебание портами на Катализаторе 6500/6000 серийный выключатель не заставят стол потока MLS быть очищенным, как имел место для MLS на Катализаторе 5000 выключателей.

Бухгалтерский учет IP исключает движение MLS

В Cisco Катализатор 6500 рядов Многократное переключение слоя (MLS) развернуто таким способом, которым, как только установлен поток, движение непосредственно переключено в (переключенном в аппаратные средства) PFC и не обработано MSFC, следовательно отсутствие непрерывного бухгалтерского учета. Только новые или переключенные в процесс (переключенные в программное обеспечение) потоки зарегистрированы бухгалтерским учетом IP, когда позволено, и даже тогда только, пока вход не введен в базу данных. Таким образом предыдущее предупреждающее сообщение обычно показывается при предоставлении возможности IP, считающего на такой платформе.

6500(config)#int fa8/40
6500(config-if)#ip accounting
Accounting will exclude mls traffic when mls is enabled.

Бухгалтерский учет NetFlow является предпочтительным методом. Обратитесь к Формированию NetFlow для получения дополнительной информации относительно к NetFlow.

Неспособный формировать интерфейсно-полный Flowmask

C6500#mls flow ip interface-full
%  Unable to configure flow mask for ip protocol: interface-full. Reset
to the default flow mask type: none

Выпустите шоу из fie flowmask, деталь командуют и проверяют, позволен ли NAT и использует Полную маску Потока Intf.

C6500#show fm fie flowmask detail

!--- Part of the output not shown

Primary Flowmasks registered by Features
----------------------------+------------------------+------------------
---
          Feature                   Flowmask             Flowmask Status
----------------------------+------------------------+------------------
---
 IP_ACCESS_INGRESS               Intf Full Flow		Disabled/Unused
 IP_ACCESS_EGRESS                Intf Full Flow		Disabled/Unused
 NAT_INGRESS                     Intf Full Flow            Enabled
 NAT_EGRESS                      Intf Full Flow            Enabled

!--- Remaining part of the output not shown

Если NAT использует Полную маску Потока Intf и когда вы пытаетесь формировать интерфейсно-полное для Netflow, существует проблема, поскольку существует конфликт flowmask. Если вы хотите использовать статистику Netflow, можно попытаться использовать интерфейсный источник назначения (mls поток IP команда интерфейсного источника назначения), который не находится в противоречии с использованием маски Netflow.

NDE предполагает, что все потоки созданы с той же самой маской потока. Из-за этого ограничения, NDE не может быть позволен с определенными особенностями, которые требуют противоречивых масок потока. Одним конкретным случаем является ускоренный аппаратными средствами NAT. NDE и ускоренный аппаратными средствами NAT являются взаимоисключающими.

Если какое-либо из этих событий имеет место, NDE терпит неудачу:

  • Ускоренный аппаратными средствами NAT позволен.

  • Две или больше особенности с противоречивыми масками потока формировались на выключателе.

С другой стороны, как только NDE успешно формируется, NAT не может формироваться для работы в аппаратных средствах, и две различных особенности с противоречивыми требованиями маски потока не могут формироваться на выключателе.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Соответствующая информация


Document ID: 10566