Многопротокольная коммутация по меткам (MPLS) : Механизм MPLS over ATM

MPLS VPN через ATM: с использованием протокола BGP или RIP на стороне клиента

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Когда Протокол BGP или Протокол RIP присутствуют на клиентских узлах сети, этот документ предоставляет пример конфигурации VPN Многопротокольной коммутации по меткам (MPLS) по ATM.

Функция Виртуальной частной сети (VPN), когда используется с MPLS, позволяет нескольким узлам прозрачно соединять через сеть поставщика услуг. Одна сеть поставщика услуг может поддерживать несколько различных IP-сетей VPN. Любая из этих сетей для пользователей является частной сетью, отделенной от других сетей. В пределах сети VPN с каждого узла могут быть переданы IP-пакеты на другой узел этой же сети.

Каждая сеть VPN связана с одним или более коммутируемым или пересылаемым экземпляром (VRF). VRF состоит из таблицы IP-маршрутизации, полученной Таблицы Cisco Expressorwarding (CEF) и набора интерфейсов, который использует эту таблицу пересылки.

Маршрутизатор поддерживает отдельную маршрутизацию и таблицу CEF для каждого VRF. Это не позволяет информации передаваться вне VPN, но это позволяет той же подсети использоваться в нескольких VPN без проблем дублирования IP-адресов.

Маршрутизатор, который использует BGP, распределяет информацию о Маршрутизации VPN с расширенными сообществами (группа узлов) BGP.

Для получения дополнительной информации о распространении обновлений через VPN, посмотрите эти ссылки:

Предварительные условия

Версии аппаратного и программного обеспечения

Эти буквы представляют различные типы маршрутизаторов и используемых коммутаторов:

  • P : Центральный маршрутизатор поставщика

  • PE - маршрутизатор на стороне поставщика

  • CE – маршрутизатор на границе клиента

  • C : Клиентский маршрутизатор

Мы разработали и протестировали конфигурацию с этими версиями программного и аппаратного обеспечения:

  • Граничные маршрутизаторы провайдеров:

    • Программное обеспечение: Cisco Выпуск ПО IOS� 12.1 (3) T. Релиз 12.0 (5) T включает MPLS VPN.

    • Оборудование – Любой маршрутизатор Cisco серии 3600 или выше, например Cisco 3660 или 7206.

  • Граничные маршрутизаторы клиентов: Используйте любой маршрутизатор, который в состоянии обмениваться сведениями о маршрутизации с его Периферийным маршрутизатором.

  • P-маршрутизаторы и коммутаторы: Функция интеграции MPLS VPN находится только на краю сети MPLS, так используйте любой Коммутатор с поддержкой MPLS. В примере конфигурации облако MPLS составлено из 8540 MSR и LightStream 1010. При использовании LightStream 1010, мы рекомендуем использовать версию программного обеспечения WA4.8d или выше. Можно также использовать другие коммутаторы ATM, такие как Cisco BPX 8650 или MGX 8850 в базовой сети ATM.

Условные обозначения

Эта схема показывает типичную конфигурацию, которая иллюстрирует эти условные обозначения:

/image/gif/paws/10468/mpls_bgp_rip1.gif

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Общие сведения

Описание

Мы установили стандартную магистраль ATM MPLS с областью Протокола OSPF 0 как Протокол IGP. Мы настроили две других VPN с этой магистралью. Первое из этого использования RIP как его абонентская граница к границе поставщика (CE-PE) протокол маршрутизации и другой BGP использования как его протокол маршрутизации PE-CE.

На маршрутизаторах CE настроены различные возвратные петли и статические маршруты для имитации присутствия других маршрутизаторов и сетей.

Процедура Configure

Примечание: Это является обязательным для использования BGP в качестве IGP VPN между Периферийными маршрутизаторами. Это вызвано тем, что использование расширенных сообществ (группа узлов) BGP является единственным способом транспортировать сведения о маршрутизации для VPN между Периферийными маршрутизаторами.

Схема сети

/image/gif/paws/10468/mpls_bgp_rip2.gif

Первая часть процедуры настройки

Эта процедура настройки конфигурации также описывается в документации Cisco IOS ("Виртуальные частные сети MPLS").

Убедитесь, что режим ip cef включен. При использовании Маршрутизатор Cisco 7500, гарантируете, что включен распределенный ip cef. На PE, как только MPLS был установлен, выполняют эти действия:

  1. Создайте один VRF для каждой VPN, связанной с командой ip vrf <VPN routing/forwarding instance name>:

    1. Укажите правильный отличительный признак маршрута, который используется для данной виртуальной частной сети (VPN). Это используется для расширения IP-адреса так, чтобы можно было определить VPN, которой он принадлежит.

      rd <VPN route distinguisher>
      
    2. Задайте свойства импорта и экспорта для расширенных сообществ BGP. Они используются для фильтрации процесса экспорта и импорта.

      route-target [export|import|both] <target VPN extended community>
      
  2. Настройте сведения о переадресации для соответствующих интерфейсов с этой командой:

    ip vrf forwarding <table name>
    

    Примечание: Не забудьте устанавливать IP-адрес после того, как вы сделаете это.

  3. Зависящий от протокола маршрутизации PE-CE, который вы используете, необходимо теперь сделать один или больше из них:

    • Настройте статические маршруты:

      ip route vrf vrf-name prefix mask [next-hop-address] [interface {interface-number}]
      
    • Настройте RIP с этой командой:

      address-family ipv4 vrf <VPN routing/forwarding instance name>
      

      Выполнив эти действия, введите обычные команды настройки конфигурации RIP.

      Примечание: Применимо только к интерфейсам продвижения для текущего VRF.

      Примечание: Необходимо преобразовать правильные данные BGP в данные RIP. Когда вы делаете это, не забудьте также задавать метрику, которая используется.

    • Задайте сведения о соседях BGP.

    • Настройте OSPF с новой командой IOS:

      router ospf <process ID> vrf <VPN routing/forwarding instance name>.
      

      Примечание: Применимо только к интерфейсам продвижения для текущего VRF.

      Примечание: Необходимо преобразовать правильные данные BGP в данные OSPF. Когда вы делаете это, не забудьте также задавать метрику, которая используется.

      Примечание: Как только вы приписываете процесс OSPF VRF, этот номер процесса всегда используется для этого определенного VRF. Этот параметр применяется, даже если он не указан в командной строке.

Вторая часть процедуры настройки

Настройка BGP между PE маршрутизаторами. Существует несколько способов настроить BGP; один путь состоит в том, чтобы использовать рефлектор маршрута или методы конфедерации. Метод, используемый здесь – непосредственная конфигурация соседнего устройства – является самым простым и наименее масштабируемым.

  1. Объявите различных соседей.

  2. Введите name> маршрутизации/экземпляра VRF <VPN VRF ipv4 address-family для каждого подарка VPN в этом Периферийном маршрутизаторе. Выполните один или больше этих шагов по мере необходимости:

    • Перераспределите данные статической маршрутизации.

    • Перераспределение данных RIP-маршрутизации.

    • Перераспределение данных OSPF-маршрутизации.

    • Активируйте BGP в близости к Маршрутизаторам CE.

  3. Введите режим ввода адресов типа vpnv4 и выполните один из них:

    • Активируйте соседей.

    • Укажите необходимость использования расширенного сообщества. Данное действие является обязательным.

Конфигурации

В Конфигурации Alcalzaba линии, определенные для VPN 101, показывают полужирным, определенные для VPN 102 курсивом, и определенных для обоих показывают и в полужирном и в курсив.

Alcazaba
!
ip vrf vrf101
 rd 1:101
 route-target export 1:101
 route-target import 1:101
!
ip vrf vrf102
 rd 1:102
 route-target export 1:102
 route-target import 1:102
!
ip cef
!
interface Loopback0
 ip address 223.0.0.3 255.255.255.255
!
interface Ethernet1/0
 ip vrf forwarding vrf102
 ip address 10.200.10.3 255.255.252.0

!
interface Ethernet1/1
 ip vrf forwarding vrf101
 ip address 150.150.0.1 255.255.255.0
!
interface ATM3/0
 no ip address
 no ip mroute-cache
 no atm ilmi-keepalive
 pvc qsaal 0/5 qsaal
 pvc ilmi 0/16 ilmi
 !
!
interface ATM3/0.1 tag-switching
 ip address 10.0.0.17 255.255.255.252
 tag-switching atm vpi 2-4
 tag-switching ip
!
interface ATM4/0
 no ip address
 no atm ilmi-keepalive
!
interface ATM4/0.1 tag-switching
 ip address 10.0.0.13 255.255.255.252
 tag-switching atm vpi 2-4
 tag-switching ip 
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
 network 223.0.0.3 0.0.0.0 area 0
!
router rip
 version 2
 !
 address-family ipv4 vrf vrf101
 version 2
 redistribute bgp 1 metric 0
 network 150.150.0.0
 no auto-summary
 exit-address-family
!
router bgp 1
 no synchronization
 neighbor 125.2.2.2 remote-as 1
 neighbor 125.2.2.2 update-source Loopback0
 
neighbor 223.0.0.21 remote-as 1

 
neighbor 223.0.0.21 update-source Loopback0

 no auto-summary
 !
 address-family ipv4 vrf vrf102
 redistribute connected
 neighbor 10.200.10.14 remote-as 158
 neighbor 10.200.10.14 activate
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family ipv4 vrf vrf101
 redistribute rip
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 125.2.2.2 activate
 neighbor 125.2.2.2 send-community extended

 neighbor 223.0.0.21 activate
 neighbor 223.0.0.21 send-community extended

 no auto-summary
 exit-address-family
!


Kozel
!
ip vrf vrf101
 rd 1:101
 route-target export 1:101
 route-target import 1:101
!
ip vrf vrf102
 rd 1:102
 route-target export 1:102
 route-target import 1:102
!
ip cef
!
interface Loopback0
 ip address 223.0.0.21 255.255.255.255
!
interface Ethernet1/1
 ip vrf forwarding vrf101
 ip address 200.200.0.1 255.255.255.0
!
interface Ethernet1/2
 ip vrf forwarding vrf102
 ip address 201.201.201.1 255.255.255.252
!
interface ATM4/0
 no ip address
 no atm scrambling cell-payload
 no atm ilmi-keepalive
 pvc qsaal 0/5 qsaal     
 pvc ilmi 0/16 ilmi
!
interface ATM4/0.1 tag-switching
 ip address 10.0.0.6 255.255.255.252
 tag-switching atm vpi 2-4
 tag-switching ip
!
router ospf 1
 log-adjacency-changes
 network 10.0.0.0 0.0.0.255 area 0
 network 223.0.0.21 0.0.0.0 area 0
!
router rip
 version 2
 !
 address-family ipv4 vrf vrf101
 version 2
 redistribute bgp 1 metric 1
 network 200.200.0.0
 no auto-summary
 exit-address-family
!
router bgp 1
 no synchronization
 neighbor 125.2.2.2 remote-as 1
 neighbor 125.2.2.2 update-source Loopback0
 neighbor 223.0.0.3 remote-as 1
 neighbor 223.0.0.3 update-source Loopback0
 no auto-summary
 !
 address-family ipv4 vrf vrf102
 redistribute connected
 redistribute static
 neighbor 201.201.201.2 remote-as 69
 neighbor 201.201.201.2 activate
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family ipv4 vrf vrf101
 redistribute rip
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 125.2.2.2 activate
 neighbor 125.2.2.2 send-community extended
 neighbor 223.0.0.3 activate
 neighbor 223.0.0.3 send-community extended
 no auto-summary
 exit-address-family
!

Medina
Current configuration:
!
ip vrf vrf101
 rd 1:101
 route-target export 1:101
 route-target import 1:101
ip cef
!
interface Loopback1
 ip vrf forwarding vrf101
 ip address 11.2.2.2 255.255.255.252
!
interface ATM2/0
 no ip address
 no atm ilmi-keepalive
!
interface ATM2/0.66 tag-switching
 ip address 125.1.4.2 255.255.255.252
 tag-switching ip
!
interface Ethernet1/1
 ip vrf forwarding vrf101
 ip address 11.3.3.1 255.255.255.252
!
router ospf 1
 
 network 125.1.4.0 0.0.0.3 area 0
 network 125.2.2.2 0.0.0.0 area 0
!
router rip
 version 2
 network 11.0.0.0
 !
 address-family ipv4 vrf vrf101
 version 2
 redistribute bgp 1 metric 1
 network 11.0.0.0
 no auto-summary
 exit-address-family
!
router bgp 1
 no synchronization
 neighbor 223.0.0.3 remote-as 1
 neighbor 223.0.0.3 update-source Loopback0
 neighbor 223.0.0.21 remote-as 1
 neighbor 223.0.0.21 update-source Loopback0
 !
 address-family ipv4 vrf vrf101
 redistribute connected
 redistribute static
 redistribute rip
 default-information originate
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 223.0.0.3 activate
 neighbor 223.0.0.3 send-community extended
 neighbor 223.0.0.21 activate
 neighbor 223.0.0.21 send-community extended
 exit-address-family
!

Быстрый
Current configuration:


!
interface Loopback0
 ip address 223.0.0.12 255.255.255.255
!         
interface Loopback2
 ip address 7.7.7.7 255.255.255.0
!
interface FastEthernet0/1
 ip address 150.150.0.2 255.255.255.0
 duplex auto
 speed auto
!
router rip
 version 2
 redistribute static
 network 7.0.0.0
 network 10.0.0.0
 network 150.150.0.0
 no auto-summary
!
ip route 158.0.0.0 255.0.0.0 Null
!

Damme
!
interface Loopback1
 ip address 6.6.6.6 255.0.0.0
!
interface FastEthernet0/0
 ip address 10.200.10.14 255.255.252.0
 duplex auto
 speed autoa
!
router bgp 158
 no synchronization
 network 6.0.0.0
 network 10.200.0.0 mask 255.255.252.0
 neighbor 10.200.10.3 remote-as 1
 no auto-summary
!

Pivrnec
Current configuration:
!
interface Loopback0
 ip address 223.0.0.22 255.255.255.255
!
interface Loopback1
 ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/1
 ip address 200.200.0.2 255.255.255.0
 duplex auto
 speed auto
!
router rip
 version 2
 redistribute static
 network 6.0.0.0
 network 200.200.0.0
 no auto-summary
!
ip route 69.0.0.0 255.0.0.0 Null0
!

Guilder
!
interface Loopback2
 ip address 150.150.0.1 255.255.0.0
!
interface Ethernet0/2
 ip address 201.201.201.2 255.255.255.252
!
router bgp 69
 no synchronization
 network 7.7.7.0 mask 255.255.0.0
 network 150.150.0.0
 network 201.201.201.0 mask 255.255.255.252
 redistribute connected
 neighbor 201.201.201.1 remote-as 1
 no auto-summary
!

Purkmister
Current configuration:
!
interface Loopback0
 ip address 11.5.5.5 255.255.255.252
!
interface FastEthernet0/1
 ip address 11.3.3.2 255.255.255.252
 duplex auto
 speed auto
!
router rip
 version 2
 network 11.0.0.0
!

Команды "show"

Специальные команды маршрутизации

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

  • show ip rip database vrf

  • show ip bgp vpnv4 vrf

  • команда "show ip route vrf"

  • show ip route

На Периферийном маршрутизаторе метод маршрутизации PE-CE (такой как RIP, BGP или статичный) и Обновления BGP PE-PE указывает на таблицу маршрутизации, которая используется для определенного VRF. Можно отобразить информацию о RIP для определенного VRF:

Alcazaba#show ip rip database vrf vrf101
 0.0.0.0/0 auto-summary  
 0.0.0.0/0
 [2] via 150.150.0.2, 00:00:12, Ethernet1/1
 6.0.0.0/8 auto-summary
 6.6.6.6/32 redistributed
 [1] via 223.0.0.21,
 7.0.0.0/8 auto-summary
 7.7.7.0/24
 [1] via 150.150.0.2, 00:00:12, Ethernet1/1 
 10.0.0.0/8 auto-summary
 10.0.0.0/8 redistributed
 [1] via 125.2.2.2,
 10.0.0.0/16
 [1] via 150.150.0.2, 00:00:12, Ethernet1/1 
 10.200.8.0/22
 [1] via 150.150.0.2, 00:00:12, Ethernet1/1 
 11.0.0.0/8 auto-summary
 11.0.0.4/30 redistributed
 [1] via 125.2.2.2,
 11.1.1.0/30 redistributed
 [1] via 125.2.2.2,
 11.3.3.0/30 redistributed
 [1] via 125.2.2.2,
 11.5.5.4/30 redistributed
 [1] via 125.2.2.2,
 69.0.0.0/8 auto-summary
 69.0.0.0/8 redistributed
 [1] via 223.0.0.21,
 150.150.0.0/16 auto-summary
 150.150.0.0/24 directly connected, Ethernet1/1
 158.0.0.0/8
 [1] via 150.150.0.2, 00:00:17, Ethernet1/1
 200.200.0.0/24 auto-summary 
 200.200.0.0/24 redistributed 
 [1] via 223.0.0.21,  

Можно также отобразить информацию BGP для определенного VRF с командой show ip bgp vpnv4 vrf. Результаты PE-PE из внутреннего BGP (IBGP) обозначены буквой "i".

Alcazaba#show ip bgp vpnv4 vrf vrf101 
   BGP table version is 46, local router ID is 223.0.0.3 
   Status codes: s suppressed, d damped, h history, * valid, best, i - internal    
   Origin codes: i - IGP, e - EGP, ? - incomplete 
 
 Network Next Hop Metric LocPrf Weight Path 
   Route Distinguisher: 1:101 (default for vrf vrf101) 
   *i6.6.6.6/32 223.0.0.21 1 100 0 ? 
   * 7.7.7.0/24 150.150.0.2 1 32768 ? 
   * 10.0.0.0/16 150.150.0.2 1 32768 ? 
   * 10.200.8.0/22 150.150.0.2 1 32768 ? 
   *i11.2.2.0/30 125.2.2.2 0 100 0 ? 
   *i11.3.3.0/30 125.2.2.2 0 100 0 ? 
   *i11.5.5.4/30 125.2.2.2 1 100 0 ? 
   *i69.0.0.0 223.0.0.21 1 100 0 ? 
   * 150.150.0.0/24 0.0.0.0 0 32768 ? 
   * 158.0.0.0/8 150.150.0.2 1 32768 ? 
   *i200.200.0.0 223.0.0.21 0 100 0 ?  

Kozel#show ip bgp vpnv4 vrf vrf102
BGP table version is 48, local router ID is 223.0.0.21
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
 
   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 1:102 (default for vrf vrf102)
* i6.0.0.0          223.0.0.3                0    100      0 158 i
*>i                 223.0.0.3                0    100      0 158 i
*> 7.7.0.0/16       201.201.201.2            0             0 69 ?
*  10.200.8.0/22    201.201.201.2            0             0 69 ?
* i                 223.0.0.3                0    100      0 ?
*>i                 223.0.0.3                0    100      0 ?
*> 102.102.0.0/16   201.201.201.2            0             0 69 ?
*> 150.150.0.0      201.201.201.2            0             0 69 i
*  201.201.201.0/30 201.201.201.2            0             0 69 i
*>                  0.0.0.0                  0         32768 ?

Глобальную таблицу маршрутизации для VRF можно проверить на маршрутизаторах PE и CE. Они совпадают. Для Периферийного маршрутизатора необходимо задать VRF с командой show ip route vrf.

Alcazaba#show ip route vrf vrf101
   Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP   
   D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
   E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
   i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area    
   * - candidate default, U - per-user static route, o - ODR
   P - periodic downloaded static route
    Gateway of last resort is not set
   B 69.0.0.0/8 [200/1] via 223.0.0.21, 00:11:03
   B 200.200.0.0/24 [200/0] via 223.0.0.21, 00:11:03
    6.0.0.0/32 is subnetted, 1 subnets
   B 6.6.6.6 [200/1] via 223.0.0.21, 00:11:03 
    7.0.0.0/24 is subnetted, 1 subnets
   R 7.7.7.0 [120/1] via 150.150.0.2, 00:00:05, Ethernet1/1 
    10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
   R 10.0.0.0/16 [120/1] via 150.150.0.2, 00:00:05, Ethernet1/1 
   R 10.200.8.0/22 [120/1] via 150.150.0.2, 00:00:05, Ethernet1/1 
    11.0.0.0/30 is subnetted, 3 subnets
   B 11.3.3.0 [200/0] via 125.2.2.2, 00:07:05
   B 11.2.2.0 [200/0] via 125.2.2.2, 00:07:05
   B 11.5.5.4 [200/1] via 125.2.2.2, 00:07:05
    150.150.0.0/24 is subnetted, 1 subnets
   C 150.150.0.0 is directly connected, Ethernet1/1
   R 158.0.0.0/8 [120/1] via 150.150.0.2, 00:00:06, Ethernet1/1

Для Pivrnec это - стандартная таблица маршрутизации, так используйте команду show ip route:

Pivrnec#show ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP  
  D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
  N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
  E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
  i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area  
  * - candidate default, U - per-user static route, o - ODR 
  P - periodic downloaded static route Gateway of last resort is not  set S 69.0.0.0/8 is directly connected, Null0 
  223.0.0.0/32 is subnetted, 1 subnets 
 C 223.0.0.22 is directly connected, Loopback0 
 C 200.200.0.0/24 is directly connected, FastEthernet0/1 
  6.0.0.0/32 is subnetted, 1 subnets 
 C 6.6.6.6 is directly connected, Loopback1 
  7.0.0.0/24 is subnetted, 1 subnets 
 R 7.7.7.0 [120/1] via 200.200.0.1, 00:00:23, FastEthernet0/1 
  10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks 
 R 10.0.0.0/16 [120/1] via 200.200.0.1, 00:00:23, FastEthernet0/1 
 R 10.200.8.0/22 [120/1] via 200.200.0.1, 00:00:24, FastEthernet0/1 
  11.0.0.0/30 is subnetted, 3 subnets 
 R 11.3.3.0 [120/1] via 200.200.0.1, 00:00:24, FastEthernet0/1 
 R 11.2.2.0 [120/1] via 200.200.0.1, 00:00:25, FastEthernet0/1 
 R 11.5.5.4 [120/1] via 200.200.0.1, 00:00:25, FastEthernet0/1 
  150.150.0.0/24 is subnetted, 1 subnets 
 R 150.150.0.0 [120/1] via 200.200.0.1, 00:00:25, FastEthernet0/1 
 R 158.0.0.0/8 [120/1] via 200.200.0.1, 00:00:25, FastEthernet0/1 

Метки MPLS

Проверьте стек меток, используемый для какого-то конкретного маршрута:

 Alcazaba#show tag-switching forwarding-table vrf vrf101 11.5.5.5 detail    
   Local Outgoing Prefix Bytes tag Outgoing Next Hop
   tag tag or VC or Tunnel Id switched interface
   None 2/91 11.5.5.4/30 0 AT4/0.1 point2point
    MAC/Encaps=4/12, MTU=4466, Tag Stack{2/91(vcd=69) 37} 
    00458847 0004500000025000

Можно также использовать обычные команды для просмотра выделений метки и отношений VPI/VCI здесь.

Совмещенные адреса

Тот же адрес может использоваться в других VPN без интерференции с другими. Данный пример показывает, что адрес 6.6.6.6 подключен дважды: к Pivrnec в VPN 101 и к Damme в VPN 102. Мы можем проверить это с эхо-запросом на одном узле и debug ip icmp на другом узле.

Guilder#ping 6.6.6.6
   Type escape sequence to abort.
   Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
   !!!!!
   Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms

Damme#debug ip icmp
   ICMP packet debugging is on
   6d22h: ICMP: echo reply sent, src 6.6.6.6, dst 201.201.201.2
   6d22h: ICMP: echo reply sent, src 6.6.6.6, dst 201.201.201.2
   6d22h: ICMP: echo reply sent, src 6.6.6.6, dst 201.201.201.2
   6d22h: ICMP: echo reply sent, src 6.6.6.6, dst 201.201.201.2
   6d22h: ICMP: echo reply sent, src 6.6.6.6, dst 201.201.201.2

Пример результата отладки

Пример выходных данных, который использует одинаковую конфигурацию, доступен здесь.


Дополнительные сведения


Document ID: 10468