Интерфейсы и модули Cisco : Модуль коммутации контента Cisco

Пример настройки RHI на модуле переключения содержимого

21 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ предоставляет пример конфигурации для инжекции состояния маршрута (RHI) на модуле коммутации контента Cisco (CSM).

RHI позволяет CSM объявлять доступность виртуального IP (VIP) адрес всюду по сети. Несколько устройства CSM с идентичными адресами VIP и сервисами могут существовать всюду по сети. Если сервисы больше не доступны на других устройствах, один CSM может отвергнуть сервисы распределения нагрузки сервера (SLB) по другим устройствам. Один CSM также может предоставить сервисы, потому что это логически ближе к системам клиента, чем другие устройства SLB. CSM объявляет адрес VIP как маршрут хоста.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения в этом документе основываются на исполняемой версии CSM 3.x или 4. x .

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Поиск дополнительной информации о командах в данном документе можно выполнить с помощью средства "Command Lookup" (Поиск команд) (только для зарегистрированных клиентов).

Схема сети

В настоящем документе используется следующая схема сети:

/image/gif/paws/60043/rhi_csm.jpg

Конфигурации

Эти конфигурации используются в данном документе:

  • Catalyst A

  • Catalyst B

Catalyst A
hostname Catalyst A
!
module ContentSwitchingModule 4 
!
 vlan 10 server
  ip address 10.1.10.97 255.255.254.0
!
 vlan 20 client
  ip address 10.1.20.1 255.255.255.0
  gateway 10.1.20.2
!
 probe LINUXPING icmp


!--- This probe is to verify that the servers are alive. This could be any 
!--- type of probe.

!
 serverfarm MYLINUX
  nat server
  no nat client
  real 10.1.10.3
   inservice
  real 10.1.10.4
   inservice
  probe LINUXPING
!
 vserver RHITEST
  virtual 192.168.1.1 any
  vlan 20


!--- The VLAN is important. When the VIP address is not part of the subnet
!--- of any VLAN configured on the CSM, the VLAN is used to tell the CSM on 
!--- which VLAN the traffic is coming in. This allows the CSM to set the 
!--- next-hop correctly when configuring the static route on the MSFC.

  serverfarm MYLINUX
advertise active



!--- The advertise command tells the CSM to create the static route.
!--- If you specify the active option, the static route is created only 
!--- if the vserver is operational.

  inservice
!    
interface Vlan20
 ip address 10.1.20.2 255.255.255.0
 no ip proxy-arp
!
interface Vlan30
 ip address 10.1.30.97 255.255.254.0
 no ip proxy-arp
!
router ospf 1


!--- In this example, OSPF is used to advertise the VIP through the network.
!--- You can use any IGP however.

 log-adjacency-changes
 redistribute static metric 10 subnets


!--- Since the CSM creates a static route on the MSFC, you simply need to 
!--- redistribute static routes to advertise the VIP.

 network 10.1.0.0 0.0.255.255 area 1
!

Конфигурация Catalyst B идентична Catalyst A. IP-адресация немного отличается, потому что Catalyst B находится в другой области сети. Адрес VIP является тем же как бы то ни было. Метрика перераспределенных статических маршрутов была также изменена так, чтобы Catalyst A был предпочтительным путем к VIP, и Catalyst B является решением по резервированию.

Catalyst B
hostname Catalyst B
!
module ContentSwitchingModule 4 
!
 vlan 10 server
  ip address 10.2.10.97 255.255.254.0
!
 vlan 20 client
  ip address 10.2.20.1 255.255.255.0
  gateway 10.2.20.2
!
 probe LINUXPING icmp
!
 serverfarm MYLINUX
  nat server
  no nat client
  predictor hash address source
  real 10.2.10.3
   inservice
  real 10.2.10.4
   inservice
  probe LINUXPING
!
 vserver RHITEST
  virtual 192.168.1.1 any
  vlan 20
  serverfarm MYLINUX
  advertise active
  inservice
!    
interface Vlan20
 ip address 10.2.20.2 255.255.255.0
 no ip proxy-arp
!
interface Vlan30
 ip address 10.2.30.97 255.255.254.0
 no ip redirects
 no ip proxy-arp
!
router ospf 1
 log-adjacency-changes
 redistribute static metric 20 subnets
 network 10.2.0.0 0.0.255.255 area 2
!

Проверка

В этом разделе содержатся сведения, которые помогают убедиться в надлежащей работе конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • статичный show ip route — Выполняет эту команду для просмотра статических маршрутов, созданных CSM для каждого vserver, настроенного с командой advertise. Если вы не видите маршрутов, удостоверьтесь, что vserver в рабочем состоянии и что существует VLAN, заданная под vserver.

    SwitchA#show ip route static 
         192.168.1.0/32 is subnetted, 1 subnets
    S       192.168.1.1 [1/0] via 10.1.20.1, Vlan20
    SwitchA#
  • покажите mod csm X vserver подробность name NAME

    SwitchB#sho mod csm 4 vservers name rhitest
    
    vserver         type  prot virtual                  vlan state        conns
    ---------------------------------------------------------------------------
    RHITEST         SLB   any  192.168.1.1/32:0         20   OPERATIONAL  0       
    SwitchA#show mod csm 4 probe name linuxping detail
    probe           type    port  interval retries failed  open   receive
    ---------------------------------------------------------------------
    LINUXPING       icmp          120      3       300            10     
     real                  vserver         serverfarm      policy          status
     ------------------------------------------------------------------------------
     10.1.10.4:0        RHITEST         MYLINUX         (default)       OPERABLE
     10.1.10.3:0        RHITEST         MYLINUX         (default)       OPERABLE
  • покажите mod csm X тестовых подробностей name NAME

  • show ip ospf database самопроисходит — Выполняют эту команду, чтобы проверить, что OSPF объявляет адрес VIP.

    SwitchA#sho ip ospf database self-originate 
    
                OSPF Router with ID (10.1.30.97) (Process ID 1)
    
                    Router Link States (Area 1)
    
    Link ID         ADV Router      Age         Seq#       Checksum Link count
    10.1.30.97      10.1.30.97      5           0x80000001 0x00B9BE 2
    
                    Type-5 AS External Link States
    
    Link ID         ADV Router      Age         Seq#       Checksum Tag
    192.168.1.1     10.1.30.97      5           0x80000001 0x00CCC7 0
  • show ip route x. x . x . x

  • экстерн show ip ospf database x. x . x . x

    lsd#sho ip ospf database external 192.168.1.1
    
                OSPF Router with ID (200.200.200.200) (Process ID 1)
    
    
                    Type-5 AS External Link States
    
      Routing Bit Set on this LSA
      LS age: 39
      Options: (No TOS-capability, DC)
      LS Type: AS External Link
      Link State ID: 192.168.1.1 (External Network Number )
      Advertising Router: 10.1.20.97
      LS Seq Number: 80000001
      Checksum: 0x8310
      Length: 36
      Network Mask: /32
            Metric Type: 2 (Larger than any link state path)
            TOS: 0 
            Metric: 20 
            Forward Address: 10.2.20.1
            External Route Tag: 0
    
      Routing Bit Set on this LSA
      LS age: 89
      Options: (No TOS-capability, DC)
      LS Type: AS External Link
      Link State ID: 192.168.1.1 (External Network Number )
      Advertising Router: 10.1.30.97
      LS Seq Number: 80000001
      Checksum: 0xCCC7
      Length: 36
      Network Mask: /32
            Metric Type: 2 (Larger than any link state path)
            TOS: 0 
            Metric: 10 
            Forward Address: 10.1.20.1
            External Route Tag: 0

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.


Дополнительные сведения


Document ID: 60043