Широкополосные кабельные сети : Управление кабельной системой и сервисы

Настройка завершения сеанса PPPoE для uBR7100 CMTS с использованием туннелирования L2TP

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ предоставляет пример конфигурации завершения Протокола PPPoE в широкополосной кабельной сети с помощью Системы терминирования кабельных модемов (CMTS) Cisco uBR7100 в качестве Концентратора локального доступа (LAC). В этом документе Сеанс PPPoE инициируется Маршрутизатором Cisco 1600 как PPPoE-клиент и передает трафик PPP через безопасный уровень Два Протокола туннелирования (L2TP) туннельное соединение к L2TP Network Server (LNS). Маршрутизатор LNS завершает туннель L2TP от Cisco CMTS и может перенаправить трафик в корпоративную сеть.

Перед началом работы

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Предварительные условия

Читатель этого документа должен быть знаком с RFC 2516, где описываются правила использования PPPoE, а также Data-over-Cable Service Interface Specifications (DOCSIS). leavingcisco.comВ настоящем документе не описано, как настраивать кабельную сеть физической полосы пропускания. Прежде, чем попытаться настроить решение PPPoE, DOCSIS - совместимые кабельные модемы должны быть онлайновыми и операционными в Режиме моста. Более подробно данные по устранению неисправностей CMS представлены в документе Устранение неисправностей кабельных модемов uBR без перехода в оперативный режим.

Используемые компоненты

Сведения, содержащиеся в данном документе, относятся к следующим версиям программного и аппаратного обеспечения.

  • Функция завершения PPPoE поддерживается только в универсальных широкополосных маршрутизаторах Cisco серий uBR7100 и uBR7246VXR.

  • Маршрутизатор Cisco CMTS должен выполнять Cisco релиз 12.2 IOS� (4) BC1a или более поздний выпуск. Кроме того, чтобы поддерживать функцию завершения подключения PPPoE, название образа программного обеспечения должно включать IP + набор функций (буквы, "я" и "s" должны появиться на название образа программного обеспечения).

  • Чтобы обеспечить поддержку терминирования PPPoE в групповых кабельных интерфейсах, необходимо использовать на маршрутизаторе Cisco CMTS выпуск Cisco IOS 12.2(8)BC2 или более поздний.

  • Клиентское ПО должно поддерживать протокол PPPoE. Если операционная система компьютера не включает такую поддержку, пользователь может использовать клиентское программное обеспечение, такое как WinPoet. Этот документ использует Cisco 1600 в качестве клиента PPPoE.

Информация в этой определенной установленной лабораторной работе основывается на версиях программного и аппаратного обеспечения ниже.

  • CMTS Cisco uBR7111 выполняет Cisco IOS Release uBR7100-ik8s-mz.122-11. BC1.

  • Маршрутизатор Cisco 1600 выполняет Cisco IOS Release Cisco 1600-sy-mz.122-11. T8.

Сведения, представленные в этом документе, были получены от устройств в специфической лабораторной среде. Все устройства, используемые в этом документе, были запущены с чистой конфигурацией (конфигурацией по умолчанию). При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Теоретические сведения

PPPoE обеспечивает возможность подключения сети с хостами к концентратору удаленного доступа при помощи простого устройства мостовой связи. Протокол PPPoE обеспечивает прямое соединение с кабельными интерфейсами. Поддержка PPPoE на кабельных сопряжениях Cisco uBR7100 и uBR7200 series маршрутизаторов позволяет Customer Premises Equipment (CPE) позади кабельного модема использовать PPP в качестве механизма, чтобы получить их IP-адреса и использовать его для всего трафика последующих данных, подобного клиенту PPP модемной связи. На сеансе модемной связи PPP заверен Сеанс PPPoE, и о IP-адресе выполняют согласование между PPPoE-клиентом и сервером, который мог быть или маршрутизатором Cisco CMTS или домашним шлюзом. В данной модели каждый хост использует собственный стек PPP. Поэтому управление доступом, выставление счетов и тип обслуживания могут быть сделаны на основе каждого пользователя, а не каждого узла. Поставщики услуг могут поддерживать и клиентов PPPoE, и хосты DHCP с одним и тем же диспетчером подключений.

PPPoE использует две различные стадии: стадия обнаружения и стадия сеанса PPP. Когда хост хочет инициировать Сеанс PPPoE, он должен сначала выполнить обнаружение, чтобы определить MAC - адрес Ethernet узла и установить PPPoE SESSION_ID. В то время как PPP определяет одноранговое взаимоотношение, обнаружение является по сути отношением клиент-сервер. В процессе обнаружения хост (клиент) обнаруживает и получает доступ к концентратору (серверу). На основании топологии сети может существовать более одного концентратора доступа, через который может связываться хост. Этап обнаружения позволяет главному узлу обнаружить все концентраторы доступа и затем выбрать один из них. Если обнаружение завершается успешно, то хост и выбранный концентратор доступа получают данные, которые они будут использовать для установления через Ethernet соединения "точка-точка". С начала сеанса PPPoE данные PPP посылаются как в любой другой инкапсуляции PPP.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

В данном документе используется сеть, изображенная на следующей схеме.

/image/gif/paws/43241/pppoe_ubr7200.gif

Конфигурации

В данном документе используются следующие конфигурации.

Маршрутизатор Cisco 1600 (PPPoE-клиент)
PPPoE_client#show running-config 
Building configuration...

Current configuration : 1099 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname PPPoE_client
!
no logging console
enable password cisco
!

username LAC password 0 cisco


!--- Cmts-user name/password sent to LNS to create the L2TP tunnel. 


username LNS password 0 cisco


!--- Lns-user name/password used by LNS to authenticate tunnel creation. 


username user@surf.org


!--- Specifies a username and password for each user to be granted PPPoE access.

!--- This can be configured on the RADIUS authentication servers.


ip subnet-zero
no ip domain lookup
ip domain name surf.org
!
vpdn enable
!
vpdn-group 1
 request-dialin
  protocol pppoe
!
!
!
!
interface Ethernet0
 no ip address
 pppoe enable
 pppoe-client dial-pool-number 1
!
interface Virtual-Template1
 no ip address
 ip mtu 1492
 no peer default ip address
!
interface Serial0
 no ip address
 shutdown
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
interface Dialer1
 mtu 1492
 ip address negotiated
 ip nat outside
 encapsulation ppp
 dialer pool 1
 ppp chap hostname user@surf.org
 ppp chap password 0 cisco
!
ip nat inside source list 1 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
!
!
access-list 1 permit any
!
!
line con 0
line vty 0 4
 password cisco
 login
!
end

CMTS Cisco uBR7100 (LAC)
LAC#show running-config 
Building configuration...

Current configuration : 2442 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname "LAC"
!
no logging console
enable password cisco
!

!--- Cmts-user name/password sent to LNS to create the L2TP tunnel. 


username LAC password 0 cisco


!--- Lns-user name/password used by LNS to authenticate tunnel creation.

username LNS password 0 cisco


!--- Specifies a username and password for each user to be granted PPPoE access.

!--- This can be configured on the RADIUS authentication servers.

username user@surf.org

no cable qos permission create
no cable qos permission update
cable qos permission modems
cable time-server
!
cable config-file platinum.cm
 service-class 1 max-upstream 128
 service-class 1 guaranteed-upstream 10
 service-class 1 max-downstream 10000
 service-class 1 max-burst 1600
 cpe max 10
 timestamp
!
ip subnet-zero
!
!
no ip domain lookup
!
ip dhcp pool pppoe
   network 10.1.4.0 255.255.255.0
   bootfile platinum.cm
   next-server 10.1.4.1
   default-router 10.1.4.1
   option 7 ip 10.1.4.1
   option 4 ip 10.1.4.1
   option 2 hex ffff.8f80
   lease 7 0 10
!
ip dhcp pool pppoe_clients
   network 172.16.29.0 255.255.255.224
   next-server 172.16.29.1
   default-router 172.16.29.1
   domain-name surf.org
   lease 7 0 10
!

!--- Enables Virtual Private Dial-Up Networking (VPDN). 

vpdn enable

vpdn logging


!--- VPDN group 1 configures the router to accept PPPoE connections.
!--- Specifies the virtual template used for the virtual interfaces that are created 
!--- for each PPPoE session. 


!
vpdn-group 1
 accept-dialin
  protocol pppoe
  virtual-template 1


!--- VPDN group 2 configures the group to be used for the L2TP tunnel to the LNS. 
!--- PPPoE sessions will be initiated from clients using the domain surf.org.


vpdn-group 2
 request-dialin
  protocol l2tp
  domain surf.org
 initiate-to ip 1.1.1.8
 local name LAC


!--- Disables authentication for creation of L2TP tunnel. 


 no l2tp tunnel authentication
!
!
!
!
interface FastEthernet0/0
 ip address 2.2.2.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 1.1.1.6 255.255.255.0
 ip broadcast-address 1.1.1.255
 no ip route-cache
 no ip mroute-cache
 duplex auto
 speed 10
!
interface Cable1/0
 ip address 172.16.29.1 255.255.255.224 secondary
 ip address 10.1.4.1 255.255.255.0
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable downstream frequency 471000000
 cable downstream channel-id 0
 no cable downstream rf-shutdown
 cable downstream rf-power 51
 cable upstream 0 frequency 32000000
 cable upstream 0 power-level 0
 no cable upstream 0 shutdown
 cable dhcp-giaddr policy 


!--- pppoe enable must be configured on the cable 
!--- interface accepting PPPoE sessions.
!--- This is not necessary on subinterfaces. 

 pppoe enable
!
interface Virtual-Template1
 ip unnumbered FastEthernet0/1
 ip mtu 1492

ppp authentication chap
!

ip classless
no ip http server
!
!
cdp run
!
snmp-server community private RW
snmp-server enable traps tty
alias exec scm show cable modem
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
line vty 5 15
 login
!
end

Cisco 2500 (LNS)
hostname "LNS"
!
!

!--- Lns-user name/password for the LNS itself. 


username LNS password 0 cisco


!--- Cmts-user name/password for the Cisco CMTS. 


username LAC password 0 cisco


!--- Username and password for the PPPoE client. 
!--- This can be configured on the RADIUS authentication servers.


username user@surf.org password 0 cisco
! 
vpdn enable 
!

!--- Creates a VPDN group and starts VPDN group configuration mode.

vpdn-group 1
accept-dialin


!--- Configures VPDN group for L2TP protocol so that it 
!--- can access the PPPoE server.


protocol l2tp


!--- Specifies the virtual-template number to be used when 
!--- configuring a PPPoE session. 


virtual-template 1


!--- This group terminates L2TP tunnels from the specified CMTS hostname.


terminate-from hostname LAC 


!--- This is the local hostname of the LNS.


local name LNS


!--- Disables authentication for creation of L2TP tunnel. 


no l2tp tunnel authentication
!
!
!
interface Virtual-Template1
ip unnumbered FastEthernet0/1
ip mtu 1492


!--- Surf is used as the pool name, and  
!--- the router will use an address from the 100-net.
 

!--- If a test cannot be found, it will search for the pool with the name default.


peer default ip address pool surf
ppp authentication chap
!
ip local pool surf 100.0.0.1 100.0.0.10

Проверка.

В данном разделе содержатся сведения о проверке работы конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Процедуры

Чтобы проверить назначение IP-адреса из адресного пула локальной системы именования (LNS), выполните следующие шаги.

  1. Выполните команду show ip local pool от LNS. Проверьте выходные данные command.

    LNS#show ip local pool 
    
     Pool                    Begin              End                   Free     In use 
     surf                    100.0.0.1          100.0.0.10             9         1 
    
  2. Для определения успешного вызывающего абонента выполните команду show caller ip от LNS.

    LNS#show caller ip 
    
      Line           User                        IP Address      Local Number    Remote Number   <-> 
      Vi29           user@surf.org               100.0.0.1            -                -          in
  3. Для проверки сеанса VPDN на LNS введите команду show vpdn session.

    LNS#show vpdn session 
    
    L2TP Session Information Total tunnels 1 sessions 1 
    
    LocID RemID TunID Intf          Username                  State    Last Chg  Fastswitch 
    30    299   23629 Vi29          user@surf.org             est      00:16:03  enabled 
    
    %No active L2F tunnels 
    
    %No active PPTP tunnels 
    
    %No active PPPoE tunnels 
    

Используйте шаги ниже для подтверждения количества виртуального интерфейса, которое используется PPPoE-клиентом.

  1. Выполните команду show vpdn session от LAC. Проверьте выходные данные command.

    LAC# show vpdn session
    L2TP Session Information Total tunnels 1 sessions 1 
    LocID RemID TunID    Intf       Username                 State      Last Chg  Fastswitch 
    299   30    26280    Vi1        user@surf.org            est        00:31:19  enabled 
    
    %No active L2F tunnels 
    
    %No active PPTP tunnels 
    
    PPPoE Session Information Total tunnels 1 sessions 1 
    
    PPPoE Session Information 
    SID       RemMAC              LocMAC           Intf     VASt    OIntf  VLAN/VP/VC 
    1         0030.9413.0556      0008.a328.831c   Vi1       UP     Ca1/0
    
  2. Для отображения пользователей, зарегистрированный в Cisco CMTS при помощи PPPoE, выполните команду show interface cable modem.

    LAC#show interface cable 1/0 modem 0 
    SID Priv bits     Type       State          IP address        method            MAC address 
    1 00                 modem    up             10.1.4.2          dhcp            0010.9526.2f57 
    2 00                 modem    up             10.1.4.3          dhcp            0007.0e03.a7e5 
    2 00                 host   unknown          172.16.29.2       static          0007.0e03.a7e4 
    3 00                 modem    up             10.1.4.4          dhcp            0007.0e02.c893 
    3 00                 host   unknown                            pppoe           0030.9413.0556 
    4 00                 modem    up             10.1.4.5          dhcp            0007.0e03.5075 
  3. Чтобы отобразить текущие домены VPDN, выполните команду show vpdn domain.

    LAC#show vpdn domain 
    Tunnel VPDN Group 
    ------ ---------- 
    domain:surf.org2 (L2TP) 
    

Устранение неполадок

Процедура устранения неполадок

Используйте инструкции ниже для устранения проблем конфигурации.

  1. Проверьте концентратор доступа LAC, чтобы просмотреть состояние интерфейсов с помощью команды show ip interface brief.

    Если каким-либо из интерфейсов является down, проверьте физический кабель и удостоверьтесь, что интерфейсы не административно выключены.

    LAC#show ip interface brief 
    Interface                 IP-Address        OK?     Method         Status        Protocol 
    FastEthernet0/0            2.2.2.2          YES     NVRAM            up             up 
    
    FastEthernet0/1            1.1.1.6          YES     NVRAM            up             up 
    
    Cable1/0                   10.1.4.1         YES     NVRAM            up             up 
    
    Virtual-Access1            1.1.1.6          YES     TFTP             up             up 
    
    Virtual-Template1          1.1.1.6          YES     unset           down           down 
    
    
  2. Проверьте интерфейс на PPPoE_client, чтобы проверить, что интерфейс номеронабирателя является up и имеет IP-адрес от пула LNS.

    PPPoE_client#show ip interface brief  
    Interface                  IP-Address      OK? Method       Status                Protocol 
    Dialer1                    100.0.0.1         YES BOOTP        up                    up 
    
    Ethernet0                  unassigned        YES NVRAM        up                    up 
    
    Serial0                    unassigned        YES NVRAM        up                    up 
    
    Serial1                    unassigned        YES NVRAM        up                    up 
    
    Virtual-Access1            unassigned        YES unset        up                    up 
  3. Убедитесь, что можно проверить доступность LNS от клиента PPPoE.

    PPPoE_client#ping 1.1.1.8 
    
    Type escape sequence to abort. 
    Sending 5, 100-byte ICMP Echos to 1.1.1.8, timeout is 2 seconds: 
    !!!!!  Success rate is 100 percent (5/5), round-trip min/avg/max = 12/12/16 ms 
    
  4. Если при инициировании L2TP возникнут неполадки, попробуйте использовать команду lcp renegotiation on-mismatch, настроенную на сервере LNS в группе VPDN.

    LNS#config t 
    Enter configuration commands, one per line.  End with CNTL/Z. 
    LNS(config)#vpdn-group 1 
    LNS(config-vpdn)#lcp renegotiation on-mismatch 

    Примечание: Протокол управления каналом (LCP) Прокси LAC, когда запускается PPP. Когда LNS начинает просмотр переадресованного PPP, то при обнаружении LCP, не согласованного с клиентом, он подает запрос. Команда lcp renegotiation on-mismatch вынуждает LNS выполнить повторное согласование LCP с клиентом. Не все клиенты выполнят повторное согласование протокола LCP, но некоторые все же выполнят это.

Команды для устранения неполадок

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Примечание: Прежде чем применять команды отладки, ознакомьтесь с разделом "Важные сведения о командах отладки".

  • debug ppp negotiation — Дающий эту команду на LNS позволяет вам просматривать транзакции согласования PPP для определения проблемы или этапа, когда ошибка происходит, и разработайте разрешение. Однако считается обязательным понимать выходные данные согласования отладки ppp. Понимание выходных данных команды debug ppp negotiation дает всеобъемлющий способ интерпретации и поиска неполадок PPP.

  • 12x-ошибки-пакета debug vpdn — Iissuing, эта команда отображает L2F и ошибки протокола L2TP, которые предотвращают установку туннеля или нормальную работу

  • debug vpdn 12x-packet events – Выполнение этой команды на LNS приводит к отображению событий L2TP, которые являются частью процесса установления или закрытия туннеля.

  • debug vpdn packet [контроль | данные] [подробность] - дающий эту команду на LNS или LAC отображает определяемую протоколом информацию о заголовке пакета, такую как порядковые номера если подарок, флаги и длина.

  • debug vpdn event [протокол | flowcontrol] — Дающий эту команду на LNS или LAC отображает ошибку VPN и основных событиях в протоколе L2TP и ошибках связался с управлением потоками, где окно приема удаленного узла настроено для значения, больше, чем ноль.

  • debug ppp {парень | pap} — Выполняющий эту команду отображает Протокол аутентификации по квитированию вызова (CHAP) и Протокол аутентификации пароля (PAP), который встроен в PPP.

  • debug ip udp - при выполнении данной команды на LNS выполняется проверка выходных данных на наличие пакетов, принимаемых от хоста PPPoE.

  • debug aaa per-user - Эта команда, выданная с сервера LNS, показывает, какие атрибуты применяются к каждому пользователю при прохождении им аутентификации.

  • debug radius Выдача этой команды отображает информацию привязанный когда пользовательская используемая аутентификация сервер RADIUS.

Вопросы и ответы

Вопрос. . CMTS Cisco поддерживает Переадресацию PPPoE?

О. Нет. Маршрутизаторы Cisco CMTS не поддерживают Переадресацию PPPoE, которая получает пакеты PPPoE от входящего интерфейса и вперед их на исходящем интерфейсе. Маршрутизаторы Cisco uBR7100 Series действительно автоматически передают трафик PPPoE, когда настроено для режима моста MxU (который поддерживается только на Cisco IOS Release 12.1 EC), однако, это - последствие конфигурации мостов и не из-за любой поддержки PPPoE. Для обеспечения ясности Переадресация PPPoE не поддерживается ни на каком CMTS Cisco.

Вопрос. . У меня могут быть PPPoE-клиенты и обычные клиенты Протокола DHCP (динамического конфигурирования узла) в то же время на том же заводе DOCSIS?

Ответ. Да. Функция завершения PPPoE поддерживает одновременное использование клиентов PPPoE и клиентов DHCP позади тех же CM. Абоненты могут использовать PPPoE для начальной регистрации в кабельной сети, а затем использовать DHCP, чтобы их компьютеры и другие узлы получили IP-адреса для доступа к сети.

Вопрос. . Существует ли поддержка PPPoE как для NPE-300, так и для NPE-400 на платформах Cisco uBR7200VXR CMTS?

Ответ. Да. Однако процессор NPE-300 был снят с производства 15 августа 2001 года.

Вопрос. . Поддерживается ли PPPoE на платформе Cisco uBR10k CMTS?

О. Нет. Функция завершения сеанса PPPoE поддерживается только на маршрутизаторах Cisco серии uBR7100 и маршрутизаторе Cisco uBR7246VXR под управлением Cisco IOS выпуска 12.2(4)BC1a и выше. Данная функция не поддерживается на маршрутизаторе Cisco uBR10012.

Вопрос. . Сколько Сеансов PPPoE я могу работать на платформе Cisco CMTS?

О. Платформа uBR наследует предел IDB, равный 10000, из платформы cisco 7200, которая поддерживает как 4000 сеансов PPPoE с NPE-225 и NPE-300, так и 8000 сеансов PPPoE с NPE-400. Платформа uBR7100, у которой нет модульных NPE, поддерживает сеансы 4000 PPPoE. Это теоретические пределы. Необходимо иметь в виду, что максимальное число активных одновременных PPPoE сеанса будет меньше (в зависимости от объема памяти платы процессора, типа используемой платы кабельного интерфейса, полосы пропускания для каждого пользователя и конфигурация маршрутизации).

Вопрос. . Какой выпуск Cisco IOS завершение подключения PPPoE поддерживается в Серии EC?

О. Функция завершения подключения PPPoE не поддерживается ни на каком маршрутизаторе Cisco CMTS при использовании Cisco IOS Release 12.1 EC.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 43241