Протокол IP : Протокол IS-IS

Настройка IS-IS в IPv6

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

В данном документе приводится пример конфигурации протокола обмена между промежуточными системами (IS-IS) для IP-протокола версии 6 (IPv6). В данном документе также рассматриваются способы проверки и устранения неисправностей конфигурации.

Предварительные условия

Требования

Прежде чем использовать эту конфигурацию, убедитесь, что выполняются следующие требования:

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • 12.2 (13) T с Расширенным (enterprise) набором функций

  • Платформа Cisco 7200

Сведения, представленные в этом документе, были получены от устройств в специфической лабораторной среде. Все устройства, используемые в этом документе, были запущены с чистой конфигурацией (конфигурацией по умолчанию). При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. в Условные обозначения технических терминов Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

В данном документе используется сеть, изображенная на следующей схеме.

/image/gif/paws/40262/ipv6_sample_config.gif

Конфигурации

В данном документе используются следующие конфигурации.

c7200-1
c7200-1# show run

ipv6 unicast-routing 
! Enable the forwarding of IPv6 unicast datagrams
!
interface Loopback0
 no ip address
 ipv6 address 2000:1::1/96
 circuit-type level-2-only
 address-family ipv6 unicast
!

!--- If the sole purpose of the loopback is a router ID, 
!--- a /128 is preferred. 
!--- A /96 is used here to advertise this route through IS-IS.
!--- Last two commands for getting advertised in the LSP


 ipv6 router isis alpha

!--- Enables IS-IS on the interface for area "alpha."

!
interface FastEthernet3/0
 ip address 172.16.88.51 255.255.255.224
 duplex half
 ipv6 address 1000:1:1:1:1:1:1:1/112
 ipv6 router isis alpha
!
router isis alpha

!--- Enables the IS-IS routing process for area "alpha."

 net 49.1111.2220.3330.4440.00

!--- Defines the area addresses for the IS-IS area and the system ID
!--- of the router. 49.1111 is the area id SysID is 2220.3330.4440.

!
end

c7200-2
c7200-2# show run
ipv6 unicast-routing
!
interface Loopback0                                                  
 no ip address
 ipv6 address 3000:1::1/96
 ipv6 router isis alpha
!
interface FastEthernet0/0
 ip address 172.16.88.50 255.255.255.224
 duplex auto
 speed auto
 ipv6 address 1000:1:1:1:1:1:1:2/112
 ipv6 router isis alpha
!
 router isis alpha
 net 49.1111.2222.3333.4444.00
 !
end

Проверка.

В данном разделе содержатся сведения о проверке работы конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • команда show clns interface используется для перечисления сведений об интерфейсе, связанных с сетевой службой без предварительного соединения (CLNS)

    c7200-1# show clns int fa3/0 
    FastEthernet3/0 is up, line protocol is up 
      Checksums enabled, MTU 1497, Encapsulation SAP 
      ERPDUs enabled, min. interval 10 msec. 
      CLNS fast switching enabled 
      CLNS SSE switching disabled 
    
      DEC compatibility mode OFF for this interface 
      Next ESH/ISH in 43 seconds 
      Routing Protocol: IS-IS 
        Circuit Type: level-1-2 
        Interface number 0x0, local circuit ID 0x1 
        Level-1 Metric: 10, Priority: 64, Circuit ID: c7200-1.01      
        Number of active level-1 adjacencies: 1 
        Level-2 Metric: 10, Priority: 64, Circuit ID: c7200-1.01      
        Number of active level-2 adjacencies: 1 
        Next IS-IS LAN Level-1 Hello in 1 seconds 
        Next IS-IS LAN Level-2 Hello in 1 seconds
  • show clns neighbors - Используемый для показа состояния соседей CLNS.

    c7200-1# show clns neighbors
    System Id      Interface   SNPA                     State  Holdtime  Type Protocol 
    c7200-2        Fa3/0       0004.281e.e008           Up      25        L1L2 IS-IS
  • show ipv6 route - проверка наличия маршрута в IPv6.

    c7200-1# show ipv6 route 
         IPv6 Routing Table - 7 entries 
         Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
                U - Per-user Static route 
                I1 - ISIS L1, I2 - ISIS L2, IA - ISIS      interarea 
         L   1000:1:1:1:1:1:1:1/128 [0/0] 
              via ::, FastEthernet3/0 
         C   1000:1:1:1:1:1:1:0/112 [0/0] 
              via ::, FastEthernet3/0 
         L   2000:1::1/128 [0/0] 
              via ::, Loopback0 
         C   2000:1::/96 [0/0] 
              via ::, Loopback0 
         I1  3000:1::/96 [115/20] 
              via FE80::204:28FF:FE1E:E008, FastEthernet3/0 
         L   FE80::/10 [0/0] 
              via ::, Null0 
         L   FF00::/8 [0/0] 
              via ::, Null0
    
    c7200-1# show ipv6 route 3000:1::1 
         IPv6 Routing Table - 7 entries 
         Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
                U - Per-user Static route 
                I1 - ISIS L1, I2 - ISIS L2, IA - ISIS      interarea 
         I1  3000:1::/96 [115/20] 
              via FE80::204:28FF:FE1E:E008, FastEthernet3/0 
  • show isis database detail - данная команда применяется для отображения сведений базы данных IS-IS.

    c7200-1# show isis database detail
    IS-IS Level-1 Link State Database: 
         LSPID                      LSP Seq Num  LSP Checksum  LSP Holdtime           ATT/P/OL 
         c7200-1.00-00       * 0x000000DB        0xC383        1103                   0/0/0 
           Area Address: 49.1111 
           NLPID:        0x8E 
           Hostname: c7200-1 
           IPv6 Address: 2000:1::1 
           Metric: 10         IPv6 1000:1:1:1:1:1:1:0/112      
           Metric: 10         IPv6 2000:1::/96      
           Metric: 10         IS c7200-1.01      
         c7200-1.01-00       * 0x000000D8        0x5C9A        1078                   0/0/0 
           Metric: 0          IS      c7200-1.00 
           Metric: 0          IS      c7200-2.00 
         c7200-2.00-00         0x000000DD        0x0219        757                    0/0/0 
           Area Address: 49.1111 
           NLPID:        0x8E 
           Hostname: c7200-2 
           IPv6 Address: 3000:1::1 
           Metric: 10         IPv6 1000:1:1:1:1:1:1:0/112      
           Metric: 10         IPv6 3000:1::/96      
           Metric: 10         IS c7200-1.01      
         IS-IS Level-2 Link State Database: 
         LSPID                      LSP Seq Num  LSP Checksum  LSP Holdtime           ATT/P/OL 
         c7200-1.00-00       * 0x000000DC        0x2569        893                    0/0/0 
           Area Address: 49.1111 
           NLPID:        0x8E 
           Hostname: c7200-1 
           IPv6 Address: 2000:1::1 
           Metric: 10         IS c7200-1.01      
           Metric: 10         IPv6 1000:1:1:1:1:1:1:0/112      
           Metric: 10         IPv6 2000:1::/96      
           Metric: 20         IPv6 3000:1::/96      
         c7200-1.01-00       * 0x000000D9        0xE994        773                    0/0/0 
           Metric: 0          IS      c7200-1.00 
           Metric: 0          IS      c7200-2.00 
         c7200-2.00-00         0x000000DF        0x88E8        937                    0/0/0 
           Area Address: 49.1111 
           NLPID:        0x8E 
           Hostname: c7200-2 
           IPv6 Address: 3000:1::1 
           Metric: 10         IS c7200-1.01      
           Metric: 10         IPv6 1000:1:1:1:1:1:1:0/112      
           Metric: 20         IPv6 2000:1::/96      
           Metric: 10         IPv6 3000:1::/96
  • ping – определяет, является ли удаленный главный компьютер активным или неактивным, а также двустороннюю задержку при взаимодействии с главным компьютером.

    7200-2# ping 1000:1:1:1:1:1:1:1
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 1000:1:1:1:1:1:1:1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms 

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

  • debug isis adj-packets - используется для показа пакетов приветствий (IIH) IS-IS, идущих через соседей CLNS.

Процедура устранения неполадок

Ниже приводятся сведения об устранении проблем для этой конфигурации. Если протокол IPv6 IS-IS работает неверно, выполняйте следующие инструкции для устранения неполадок конфигурации.

  1. Отправьте эхо-запрос к соседнему узлу и убедитесь, что проверка доступности работает. В случае неудачного эхо-теста, проверьте, что адреса входят в одну подсеть, а также проверьте уровень 1 и 2. Полезно иметь IPv4 address на каждом интерфейсе. Проверьте функционирование команд проверки связи IPv4 ping, что позволит исключить все проблемы первого и второго уровней.

  2. Проверьте, чтобы видеть, корректна ли конфигурация. Обратитесь к примерам конфигураций в разделе "Конфигурации" данного документа. Если конфигурация окажется правильной, введите команду debug clns adj-packets.

    Можно наблюдать IIH-пакеты, идущие в обоих направлениях, как показано в следующем примере результата команды debug:

    Примечание: Перед запуском команд отладки в рабочей сети ознакомьтесь с "Важной информацией о командах отладки".

    c7200-1# debug isis adj-packets 
    IS-IS Adjacency related packets debugging is on 
    
    5d23h: ISIS-Adj: Sending L1 LAN IIH on FastEthernet3/0, length 1497 
    5d23h: ISIS-Adj: Sending L2 LAN IIH on Loopback0, length 1514n 
    5d23h: ISIS-Adj: Sending L2 LAN IIH on FastEthernet3/0, length 1497 
    5d23h: ISIS-Adj: Rec L1 IIH from 0004.281e.e008 (FastEthernet3/0), cir type L1L2,
     cir id 2220.3330.4440.01, length 1497
  3. Если Ipv6 neighbor IS-IS не связывает, проверьте для двойного идентификатора системы.

Для получения дополнительной информации при настройке IS-IS по IPv6, обратитесь к Библиотеке конфигураций IPv6 Cisco IOS.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 40262