Технологии коммутируемого доступа в сеть : "Технология ISDN, CAS"

Использование терминального адаптера ADTRAN с маршрутизаторами Cisco

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Адаптеры терминала ISDN ADTRAN (TA) могут использоваться для обеспечения подключения интерфейса (BRI) маршрутизаторам без интерфейсов BRI. TA (связанный с последовательным портом) завершает вызов BRI и передает данные к маршрутизатору как поток синхронных данных.

Этот документ выделяет как к ADTRAN TA ISU™ для работы с маршрутизаторами Cisco. Мы рекомендуем сослаться на документацию по продукту на leavingcisco.comвебе - узлы/URL ADTRAN до перехода.

Предварительные условия

Требования

Проверьте, что цепь с интерфейсом BRI работает правильно. Можно хотеть использовать канал на маршрутизаторе с портом BRI для тестирования канала до развертывания его в этой конфигурации. Также проверьте и протестируйте одноранговое устройство, чтобы гарантировать, что оно функционирует должным образом.

Для некоторых приложений ISU ADTRAN должен поддержать синхронный Протокол PPP (MPPP). ISU, которые поддерживают синхронный MP, включают ISU Express (Номера изделия 1200.081L5, 1200.081L6, и 1202.081 L6), ISU 2x64 (1200.051L1 и 1200.051L2), и второе поколение ISU 128 (1202.029L2 и 1202.029L3.)

Для использования MPPP на маршрутизаторе Cisco версия программного обеспечения ISU должна быть актуальной. Список минимальных редакций ПО представлен продуктом в таблице ниже:

Модуль Шифр изделия Версия программного обеспечения
ISU 128 1202.029 E.00
ISU 2x64 1200.051 D.00 или G.00
L6 ISU Express 1200.081L6 K.28
L6 ISU Express 1202.081L6 D.43

Примечание: Так как требования могут изменить, проверить требования микропрограммы с Использованием ISU ADTRAN С маршрутизаторами Cisco leavingcisco.com.

Используемые компоненты

Сведения, содержащиеся в данном документе, относятся к следующим версиям программного и аппаратного обеспечения.

  • Маршрутизатор с синхронным последовательным интерфейсом. Последовательный интерфейс может быть встроен или на WIC/Сетевом модуле.

  • Нет никакого Cisco ограничений ПО IOS� для этой конфигурации.

Сведения, представленные в этом документе, были получены от устройств в специфической лабораторной среде. Все устройства, используемые в этом документе, были запущены с чистой конфигурацией (конфигурацией по умолчанию). При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Метод набора номера

Существует три метода, которые могут использоваться для инициирования набора TA:

  • Набор номера по протоколам V.25 или V.25bis

  • Вызов номера Готовности терминала данных (DTR)

  • Набор номера с клавиатуры

Набор номера по протоколам V.25 или V.25bis

Использование этого метода, маршрутизатор передает номер телефона к TA. Этот метод позволяет маршрутизатору размещать и получать вызовы ISDN. Для активации V.25/V.25bis вызов номера, необходимо настроить команду dialer in-band на интерфейсе маршрутизатора. Например: :

interface Serial0
   ip address 172.25.254.97 255.255.255.252
   encapsulation ppp
   dialer in-band
   dialer idle-timeout 300
   dialer map ip 172.25.254.98 name Remote broadcast 5551212&5551213
   ppp authentication chap
   dialer-group 1

Необходимо настроить ISU для вызова номера V.25bis и MPPP.

Когда маршрутизатор получает представляющий интерес трафик, он повышает DTR и Request To Send (RTS), который заставляет TA инициировать набор на первом B-канале. Однако маршрутизатор не просит, чтобы TA инициировал второе соединение B-канала. В этом случае ADTRAN должен быть запрограммирован, чтобы набрать второй B-канал или передать второе количество в той же строке номеронабирателя. Интерфейс последовательного маршрутизатора является Интерфейсом точка-точка и понятия не имеет о количестве B-каналов, настроенных на ADTRAN.

Не настраивайте команду ppp multilink на маршрутизаторе, так как TA фактически обрабатывает многоканальное соединение, в то время как маршрутизатор должен только обработать синхронный поток от TA.

Примечание: Использование карт несколько номеронабирателея (как мы были бы на интерфейсах BRI) не помогает для этой многоканальной проблемы.

Метод набора DTR

Использование этого метода, маршрутизатор может только разместить вызовы в один определенный номер телефона, это не может получить входящие вызовы. С этим методом номер (а) телефона удаленного сайта должен быть сохранен в памяти о TA. Когда TA видит, что DTR идет высоко, это набирает номер, который сохранен в TA. Это требует команды dialer dtr под последовательным интерфейсом. Например: :

Пример:

interface Serial0
   ip address 172.25.254.97 255.255.255.252
   encapsulation ppp
   dialer dtr
   dialer idle-timeout 300
   ppp authentication chap

ADTRAN должен быть настроен для Набора DTR, протокола PPP, и т.д., и программировать телефонный номер адресата.

Оба B-канала набраны ADTRAN.

Набор номера с клавиатуры

Некоторые TA имеют клавиатуры на них для учета интерактивного набора номера непосредственно от TA. С этим методом пользователь должен ввести количество для вызова номера в клавиатуре Та каждый раз, когда соединение должно быть сделано. Этот метод прежде всего используется для тестирования для подтверждения подключения. Требуемую конфигурацию маршрутизатора показывают ниже:

interface Serial0
   ip address 172.25.254.97 255.255.255.252
   encapsulation ppp
   dialer in-band
   dialer idle-timeout 300
   dialer map ip 172.25.254.98 name Remote broadcast
   ppp authentication chap

Кабельное подключение

Для соединения последовательного порта маршрутизатора к TA используют кабель DTE V.35 (с последовательным портом DB-60 или умным сериалом на одной стороне). Придерживающаяся схема показывает типовой кабель:

adtran_ta1.gif

Если TA только имеет порт RS-232, то вы также требуете V.35 к RS-232 (DB-25) Кабель в дополнение к кабелю, показанному выше. Поочередно, можно использовать всего один DB-60-to-DB-25 Кабель RS-232.

Обратитесь к разделам Каталога продуктов по Кабелям последовательного порта для получения дополнительной информации о кабельном подключении.

Пример конфигурации с использованием V.25bis

Этот раздел показывает пример конфигурации с помощью V.25bis.

/image/gif/paws/28080/adtran_ta2.gif

Конфигурация ADTRAN ISU

Этот раздел включает некоторые советы относительно настройки ISU ADTRAN. Однако консультируйтесь с Вебом - узлы/URL ADTRAN leavingcisco.com прежде, чем настроить TA, поскольку функциональность, возможно, изменились функции и параметры конфигурации.

  1. Подключите ADTRAN TA с ПК. Этот шаг необходим так, чтобы можно было обратиться к TA и настроить различные параметры до сцепления его до маршрутизатора.

    Подключите адаптер RJ-45-DB-9 отметил "Терминал" к связи (COM) порт ПК. Из RJ-45 выхода адаптера, подключите плоский смотанный RJ-45-- RJ-45 кабель (шифр CAB-500RJ= ), поставляющийся с каждым маршрутизатором Cisco для консольных соединений. Вы также требуете RJ-45 к отмеченному "МОДЕМУ" адаптера DB-25 (CAB-25AS-MMOD номера изделия) для соединения витого кабеля с портом DB-25 маркированный RS-232 в конце ADTRAN.

  2. Введите AT! V (или, если связано с портом RS366/Maintenance, используйте! V) получить главное меню. Затем нажмите Ctrl+C для ввода меню конфигурации.

    Необходимо видеть меню, подобное тому ниже (это может варьироваться в зависимости от модели TA):

     Ctl-V STATUS   Ctl-T TEST   Ctl-C CONFIG   Ctl-D DIAL   Ctl-X EXIT
                             ISU 128 Configuration Menu
    
     1) Netw. options = Dial Line           17) RTS Options = 1 ms delay
     2) Switch Protocl = National ISDN1     18) CTS Options = Forced CTS
     3) Call type = Data 64Kbps             19) CD Options = Normal
     4) SPID 1 = 51255511110101             20) DTR Options = Idle when Off
     5) SPID 2 = 51255511120101             21) DSR Options = OFF Idle+Test
     6) LDN 1 = 5551111                     22) Transmit Clock = Normal
     7) LDN 2 = 5551112                     23) Protocol = PPP asyn-sync
     8) Dial options = V.25                 24) Method = Multilink
     9) V.25 = V.25 HDLC FLAGS              25) Quick setup
    10) Auto answer = Enabled
    11) Answer tone = No Answer tone
    12) Connect Timout = 30 sec (def)
    13) Call Screening = Answer any
    14) DTE options = Synchronous
    15) Bit Rate = 128000
    16) Connector Type = RS-232
    ____________________________________________________________________________
    
    Select =                                    Enter SELECT    Esc NO CHANGE
    ____________________________________________________________________________
    
     Ctl-V STATUS   Ctl-T TEST   Ctl-C CONFIG   Ctl-D DIAL   Ctl-X EXIT
  3. Используйте соответствующее количество для ввода режима конфигурации для различных атрибутов.

    Придерживающиеся атрибуты (как минимум) должны быть настроены:

    • Протокол коммутаторов: тип коммутатора задан Telco (телефонная компания).

    • Тип вызова: Задайте или данные на 56 К или на 64 К (в зависимости от типа канала).

    • SPID1, SPID2, LDN1, LDN2: Если применимо назначьте SPID и LDN, предоставленные Telco (телефонная компания).

    • Опции Dial: V.25.

    • V.25: HDLC V.25 (при использовании синхронного последовательного порта) или АСИНКС V.25 (при использовании асинхронный последовательный).

    • Параметры DTE: Синхронный (при использовании синхронного последовательного порта) или Асинхронный (при использовании асинхронный последовательный).

    • Битовая скорость: 128000 (или 112000 для вызовов на 56 К).

    • Протокол: asyn-синхронизование PPP.

    • Метод: многоканальный.

    Мы рекомендуем обратиться к Таблице данных ISU / Руководства на вебе - узлы/URL ADTRAN leavingcisco.com для возможных вариантов для каждого параметра. Пример, показанный выше, должен работать для большинства ситуаций.

Конфигурация и тестирование маршрутизатора

Используйте следующую процедуру, чтобы настроить и протестировать маршрутизатор.

  1. Подключите V.35 или Кабель DTE RS-232 к порту последовательного маршрутизатора. Обратитесь к Кабельному подключению раздела для получения дополнительной информации о типах кабеля, которые необходимо использовать.

  2. Используйте покажите контроллер последовательный x (который указывает на тип кабеля, маршрутизатор связан с) проверить, что кабель на стороне маршрутизатора является DTE. Например: :

    Router#show controller serial 1
    HD unit 1, idb = 0xCF6E8, driver structure at 0xD4A30
    buffer size 1524  HD unit 1, RS-232 DTE cable
    cpb = 0xE3, eda = 0x940, cda = 0x800
    ...
    ...

    Необходимо также проверить, что параметр типа разъема на ADTRAN (опция 16 в приведенном выше примере) совпадает с используемым кабельным подключением.

  3. Настройте маршрутизатор следующим образом:

    username peer password 0 cisco
    !
    interface Serial1 
    ip address 192.168.180.2 255.255.255.0 
    encapsulation ppp 
    dialer in-band
     
    !--- Enable V.25bis dialing. 
    
    dialer map ip 192.168.180.22 name peer 5551111&5551112
     
    !--- Dialer map for the peer. 
    !--- Note the multiple numbers separated by "&"
     
    dialer-group 1 
    pulse-time 1 
    ppp authentication chap
    !
    ip classless
    ip route 192.168.180.22 255.255.255.255 Serial1
    dialer-list 1 protocol ip permit

    Примечание: Для TA для внедрения обоих каналов необходимо сохранить второе количество в ADTRAN или использование [phonenumber1] и [phonenumber2] в (рекомендуемой) инструкции схемы набора номеров Cisco. Последовательный интерфейс является всего одним интерфейсом точка-точка, так наличие карт несколько номеронабирателея не влияет на многоканальные соединения.

    ADTRAN набирает первый номер, выполняет согласование и подтверждает подлинность, и затем сразу набирает второе. Заметьте, что команда ppp multilink не настроена на маршрутизаторе, начиная с многоканальных маркеров TA

    Примечание: Если вы хотите использовать последовательный интерфейс в асинхронном режиме, используйте команду physical-layer async под конфигурацией последовательного интерфейса. Однако некоторые аппаратные средства последовательного интерфейса не поддерживают асинхронное соединение. Для соединения модема с этим интерфейсом обратитесь к документуНастройка подключения к внешней службе с использованием модема на порту AUX. В этом документе предполагается использование порта AUX. Однако конфигурации подобны.

  4. Инициируйте эхо-запрос к удаленному маршрутизатору. Маршрутизатор передает строки номеронабирателя к TA, который тогда инициирует соединение ISDN. Как только соединение ISDN произошло, маршрутизаторы выполняют согласование о PPP и и аутентификация происходит. Должна существовать возможность передать трафик в это время.

Проверка.

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Команды для устранения неполадок

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Примечание: Прежде чем применять команды отладки, ознакомьтесь с разделом "Важные сведения о командах отладки".

  • debug dialer - Для показа информации об отладке о пакетах получил на номеронабирателе способный интерфейс. Когда Технология DDR включена на интерфейсе, информация относительно причины любого вызова (названный причиной внешнего доступа по телефонной линии) также отображена. Для получения дополнительной информации см. описание команды "debug dialer" в документации по командам отладки.

  • debug interface serial - Использование отладка последовательная интерфейсная команда EXEC для отображения информацию на ошибке последовательного подключения. Для получения дополнительной информации посмотрите информацию о debug interface serial в документации Команд отладки.

  • команда "debug ppp negotiation" отображает сведения об объеме трафика и обмене по протоколу соединения "точка-точка" (PPP) в процессе согласования компонентов PPP, включая протокол управления каналом (LCP), аутентификацию и протокол управления сетью (NCP). В успешных переговорах PPP сначала выясняется состояние LCP, затем проводится аутентификация и наконец выполняется согласование NCP. Для получения дополнительной информации о чтении выходных данных debug ppp negotiation см. документ, Понимая Выходные данные debug ppp negotiation.

  • debug ppp authentication – отображает сообщения протокола аутентификации PPP, включая обмен пакетами протокола аутентификации с предварительным согласованием вызова (CHAP) и обмена протоколами аутентификации по паролю (PAP). Дополнительные сведения см. в следующем документе: Устранение неисправностей аутентификации PPP (CHAP или PAP).

Выходные данные отладки

Активируйте debug dialer и debug ppp negotiation, затем инициируйте эхо-запрос к узлу. Маршрутизатор должен выполнить попытку набора номера. Как только ISDN - подключение является установленным согласованием PPP, должен начаться. Следующие выходные данные отладки показывают успешный вызов.

Router#show debug
Dial on demand:  Dial on demand events debugging is on
PPP:  
  PPP authentication debugging is on  
  PPP protocol negotiation debugging is on
Router#ping 192.168.180.22
  Type escape sequence to abort.
   Sending 5, 100-byte ICMP Echos to 192.168.180.22, timeout is 2 seconds:
 Serial1: Dialing cause ip (s=192.168.180.2,d=192.168.180.22)

!--- Dialing cause is ping to 192.168.180.22.

   Serial1: Attempting to dial 5551111&5551112
   
!--- Call is dialed out using Serial1 
   !---(which is connected to the ADTRAN).
   !--- Remember that ADTRAN handles the ISDN L1-L3, so ISDN messages
   !--- will not be visible on the router.

   Se1 UNKNOWN(0x00FF): LCP not open, discarding packet.
   Se1 UNKNOWN(0x00FF): LCP not open, discarding packet
   Se1 LCP: I CONFREQ [Closed] id 49 len 15

!--- PPP Negotiation begins.

   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x65FF6351 (0x050665FF6351)
   Se1 LCP: Lower layer not up, discarding packet
   %LINK-3-UPDOWN: Interface Serial1, changed state to up.
   Se1 PPP: Treating connection as a callout
   Se1 PPP: Phase is ESTABLISHING, Active Open
   Se1 LCP: O CONFREQ [Closed] id 47 len 15
   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x048333B0 (0x0506048333B0)
   Se1 LCP: I CONFACK [REQsent] id 48 len 15
   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x048333B0 (0x0506048333B0)
   Se1 LCP: I CONFREQ [ACKrcvd] id 50 len 15
   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x65FF6351 (0x050665FF6351)
   Se1 LCP: O CONFACK [ACKrcvd] id 50 len 15
   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x65FF6351 (0x050665FF6351)
   Se1 LCP: State is Open
   Se1 PPP: Phase is AUTHENTICATING, by both
   Se1 CHAP: O CHALLENGE id 11 len 42 from "Router"
   Se1 CH.AP: I CHALLENGE id 11 len 30 from "peer"
   Se1 CHAP: O RESPONSE id 11 len 42 from "Router"
   Se1 CHAP: I SUCCESS id 11 len 4
   Se1 CHAP: I RESPONSE id 11 len 30 from "peer"
   Se1 CHAP: O SUCCESS id 11 len 4 
   
!--- Authentication is successful.

   Se1 PPP: Phase is UP
   Se1 IPCP: O CONFREQ [Closed] id 16 len 10
   Se1 IPCP: Address 192.168.180.2 (0x0306CF12B402)
   Se1 IPCP: I CONFREQ [REQsent] id 1 len 10
   Se1 IPCP: Address 192.168.180.22 (0x0306CF12B416)
   Se1 IPCP: O CONFACK [REQsent] id 1 len 10
   Se1 IPCP: Address 192.168.180.22 (0x0306CF12B416)
   %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1, 
   changed state to up
   Se1 IPCP: TIMEout: Time 0x476F808 State ACKsent
   Se1 IPCP: O CONFREQ [ACKsent] id 17 len 10
   Se1 IPCP: Address 192.168.180.2 (0x0306CF12B402)
   Se1 IPCP: I CONFACK [ACKsent] id 17 len 10
   Se1 IPCP: Address 192.168.180.2 (0x0306CF12B402)
   Se1 IPCP: State is Open
   Se1 IPCP: Install route to 192.168.180.22
   dialer Protocol up for Se1

Примечание: Для получения дополнительной информации о чтении выходных данных debug ppp negotiation, см. документ, Понимая Выходные данные debug ppp negotiation.

Процедура устранения неполадок

Этот раздел включает некоторые общие процедуры устранения отказов. Если вы встречаетесь, проблемы при любом шаге ссылаются на техническую документацию ADTRAN для получения дополнительной информации:

  1. Проверьте, что показ на передней стороне ADTRAN читает следующим образом:

    Adtran ISU 128
    [Switch-type] Ready

    Это гарантирует, что Конфигурация ISDN, такая как типы коммутаторов, идентификаторы профиля сервиса (SPID) и Местный абонентский номер (LDN) была правильно настроена и принята Telco (телефонная компания).

  2. Инициируйте тестовое подключение к узлу с помощью клавиатуры на ADTRAN. Это может помочь гарантировать, что цепь ISDN и связанная конфигурация ISDN на TA корректны.

  3. Инициируйте эхо-запрос к узлу. Необходимо видеть следующий показ лицевой панели ADTRAN: "ВЫЗЫВАЯ [PHONENUMBER". Это указывает, что, по крайней мере, V.25bis работает правильно. Если вы не видите сообщение, попытайтесь подкачать кабели и даже TA. Это может помочь изолировать неисправные кабели и интерфейсы V.35 на TA.

  4. Активируйте debug dialer. Инициируйте эхо-запрос. Проверьте наблюдение придерживающегося в выходных данных отладки:

    Serial1: Dialing cause ip (s=192.168.180.2, d=192.168.180.22)
    Serial1: Attempting to dial 5551111&5551112

    Если вы не видите сообщение, то проблема связана с DDR. Проверьте, что конфигурация маршрутизатора как показано выше. Удостоверьтесь, что маршрутизация и определение содержательного трафика настроены также.

  5. Активируйте отладьте последовательный интерфейс, инициируйте эхо-запрос и проверьте, что TA повышает готовность набора данных (DSR).

    Только, когда маршрутизатор обнаруживает высокий DSR, будет попытка маршрутизатора выполнить согласование о PPP. Если DSR не восстанавливает работоспособность, то мы должны устранить неполадки низшего уровня, такого как ISDN, аппаратные средства и кабельное подключение.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 28080