Интерфейсы и модули Cisco : Модуль коммутации контента Cisco

Настройка прозрачного кэширования на модуле коммутации контента

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Отзыв


Содержание


Введение

Этот документ описывает, как настроить Модуль коммутатора контента (CSM) для прозрачного кэширования с Модулями контента Cisco как кэши. Прозрачный кэш находится между пользователем и сервером. CSM представлен между пользователем и кэшем. CSM интеллектуален из-за своей возможности Уровня 5 динамично проанализировать содержание и определить, кэшируемо ли это или нет. Эти рекомендации применяются:

  • Если кэшируемый, CSM балансирует нагрузку запроса к сервису cache на основе настроенного средства прогнозирования.

  • Если не кэшируемый, CSM передает его непосредственно к исходному серверу. Это избегает падения производительности, которое происходит, когда не подлежащий кэшированию объект переходит к кэшу, только для перенаправления его запроса кэшем к исходному серверу.

Существует несколько доступных методов балансирования, которые зависят от того, как вы хотите распределить данные по кэшам (например, целый URL, Строка URL, и т.д).

CSM могут быть конфигурированы списком расширений файла для отправления в кэш. Данный список называется также списком классификаторов добавочного номера (EQL). Как только вы настраиваете slb-policy CACHE-POLICY под ПРОЗРАЧНЫМ vserver, только запрашивает с расширениями файла, которые перечислены в карте список КЭШИРУЕМОГО URL - АДРЕСА, передаются кэш. Если расширения файла не будут перечислены в карте список КЭШИРУЕМОГО URL - АДРЕСА, то запрос поразит slb-policy NONCACHE-POLICY.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Catalyst 6000 Supervisor Cisco выпуск ПО IOS� 12.1 (8) EX для Supervisor Engine 1 с MSFC1 (c6sup11-dsv-mz.121-8a. EX)

  • Выпуск 2.1 (2) (c6slb-apc.2-1-2.bin) Catalyst 6000 Па CSM

  • Модуль контента Cisco 565 рабочих Выпусков 5.1.3 программного обеспечения Cisco Application and Content Networking System (ACNS)

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Настройка

В этом разделе вам предоставляют информацию по настройке функций, которые описаны в этом документе.

Схема сети

В этом документе использованы параметры данной сети:

Прозрачное кэширование на CSM

config_transp_caching_19680.gif

Конфигурации

Эти конфигурации используются в данном документе:

CSM
Building configuration...
Current configuration : 4500 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cat
!
boot buffersize 126968
enable password cisco
!
redundancy
 main-cpu
  auto-sync standard
ip subnet-zero
!
ip name-server 10.107.241.185
!

!--- CSM located in slot 3. Module is running as active
!--- cache and client side on the same CSM VLAN 100.

module ContentSwitchingModule 3
 vlan 100 client
  ip address 10.107.249.251 255.255.255.248
  gateway 10.107.249.249
!

!--- End user located in CSM VLAN 200.

 vlan 200 server
  ip address 10.107.249.251 255.255.255.248
!

!--- Probe setup to check the availability of the Content
!--- Engine default probe values. Interval is 300 seconds.

 probe CACHEPROBE tcp
!

!--- Serverfarm CACHE.
!--- Note: Issue the no nat server command.
!--- CSM needs to do a Layer 2 rewrite.
!--- Balancing predictor is hash URL.

 serverfarm CACHE
  no nat server
  no nat client
  predictor hash url
  real 10.107.249.254
   inservice
  real 10.107.249.252
   inservice
  probe CACHEPROBE
!

!--- Serverfarm OUTBOUND.
!--- Note: Use the serverfarm OUTBOUND to bypass the cache.
!--- Requests that do not match the map CACHEABLE url list
!--- will use serverfarm OUTBOUND. The NAT server has no
!--- effect, as no reals are configured.
!--- Balancing predictor forward.

 serverfarm OUTBOUND
  nat server
  no nat client
  predictor forward
!

!--- Map CACHEABLE URL.

 map CACHEABLE url

!--- Extension Qualifier List (EQL).

  match protocol http url *.pdf
  match protocol http url *.fdf
  match protocol http url *.au
  match protocol http url *.bmp
  match protocol http url *.z
  match protocol http url *.gif
  match protocol http url *.html
  match protocol http url *.js
  match protocol http url *.mocha
  match protocol http url *.jpeg
  match protocol http url *.jpg
  match protocol http url *.jpe
  match protocol http url *.jfif
  match protocol http url *.pjpeg
  match protocol http url *.pjp
  match protocol http url *.mp2
  match protocol http url *.mpa
  match protocol http url *.abs
  match protocol http url *.mpeg
  match protocol http url *.mpg
  match protocol http url *.mpe
  match protocol http url *.mpv
  match protocol http url *.vbs
  match protocol http url *.m1v
  match protocol http url *.pcx
  match protocol http url *.txt
  match protocol http url *.text
  match protocol http url *.mov
  match protocol http url *.tiff
  match protocol http url *.tar
  match protocol http url *.avi
  match protocol http url *.wav
  match protocol http url *.gz
  match protocol http url *.zip
!
 map NONCACHABLE url
  match protocol http url *
!
 policy CACHE-POLICY
  url-map CACHEABLE
  serverfarm CACHE
!
 policy NONCACHE-POLICY
  url-map NONCACHABLE
  serverfarm OUTBOUND
!

!--- Vserver TRANSPARENT.
!--- Note: Virtual IP is all zeros.
!--- Use of persistence rebalance for HTTP 1.1.
!--- Parse-lengh set to 2000 bytes.
!--- Two policies added to vserver TRANSPARENT.

 vserver TRANSPARENT
  virtual 0.0.0.0 0.0.0.0 tcp www
  serverfarm CACHE
  persistent rebalance
  parse-length 2000
  slb-policy CACHE-POLICY
  slb-policy NONCACHE-POLICY
  inservice
!

!--- Fault Tolerance group 1.
!--- Used to configure redundancy between modules 3 and 4.

 ft group 1 vlan 250
  priority 20
!

!--- CSM located in slot 4. Module is running as standby
!--- cache and client side on the same CSM VLAN 100.

module ContentSwitchingModule 4
 vlan 100 client
  ip address 10.107.249.253 255.255.255.248
  gateway 10.107.249.249
!

!--- End user located in CSM VLAN 200.
!--- Note: Module 3 and 4 VLAN IP addresses are different.

 vlan 200 server 
  ip address 10.107.249.253 255.255.255.248
!

!--- Probe setup to check availability of Content Engine.
!--- Default probe values. Interval 300 seconds.

!
 probe CACHEPROBE tcp
!

!--- Serverfarm CACHE.
!--- Note: Issue the no nat server command. CSM needs to
!--- do a Layer 2 rewrite.
!--- Balancing predictor is hash URL.

 serverfarm CACHE
  no nat server
  no nat client
  predictor hash url
  real 10.107.249.254
   inservice
  real 10.107.249.252
   inservice
  probe CACHEPROBE
!

!--- Serverfarm OUTBOUND
!--- Note: Use the serverfarm OUTBOUND to bypass the cache.
!--- Requests that do not match the CACHEABLE URL list will
!--- use serverfarm OUTBOUND. The NAT server has no effect,
!--- as no reals are configured.
!--- Balancing predictor forward.

 serverfarm OUTBOUND
  nat server
  no nat client
  predictor forward
!

!--- Map CACHEABLE URL.

 map CACHEABLE url

!--- Extension Qualifier List (EQL).

  match protocol http url *.pdf
  match protocol http url *.fdf
  match protocol http url *.au
  match protocol http url *.bmp
  match protocol http url *.z
  match protocol http url *.gif
  match protocol http url *.html
  match protocol http url *.js
  match protocol http url *.mocha
  match protocol http url *.jpeg
  match protocol http url *.jpg
  match protocol http url *.jpe
  match protocol http url *.jfif
  match protocol http url *.pjpeg
  match protocol http url *.pjp
  match protocol http url *.mp2
  match protocol http url *.mpa
  match protocol http url *.abs
  match protocol http url *.mpeg
  match protocol http url *.mpg
  match protocol http url *.mpe
  match protocol http url *.mpv
  match protocol http url *.vbs
  match protocol http url *.m1v
  match protocol http url *.pcx
  match protocol http url *.txt
  match protocol http url *.text
  match protocol http url *.mov
  match protocol http url *.tiff
  match protocol http url *.tar
  match protocol http url *.avi
  match protocol http url *.wav
  match protocol http url *.gz
  match protocol http url *.zip
!
 map NONCACHABLE url
  match protocol http url *
!
 policy CACHE-POLICY
  url-map CACHEABLE
  serverfarm CACHE
!
 policy NONCACHE-POLICY
  url-map NONCACHABLE
  serverfarm OUTBOUND
!

!--- Vserver TRANSPARENT.
!--- Note: Virtual IP is all zeros.
!--- Use of persistence rebalance for HTTP 1.1.
!--- Parse-lengh set to 2000 bytes.
!--- Two policies added to vserver TRANSPARENT.

 vserver TRANSPARENT
  virtual 0.0.0.0 0.0.0.0 tcp www
  serverfarm CACHE
  persistent rebalance
  parse-length 2000
  slb-policy CACHE-POLICY
  slb-policy NONCACHE-POLICY
  inservice
!

!--- Fault Tolerance group 1.
!--- Used to configure redundancy between modules 3 and 4.

 ft group 1 vlan 250
!
interface GigabitEthernet1/1
 no ip address
 shutdown
!
interface GigabitEthernet1/2
 no ip address
 shutdown
!

!--- CSM client side VLAN. Uplink to the Internet.

interface FastEthernet2/1
 no ip address
 switchport
 switchport access vlan 100
!
interface FastEthernet2/2
 no ip address
 shutdown
!

!--- Cache Engine connected to FE2/3 and FE2/4.
!--- CSM client side VLAN.

interface FastEthernet2/3
 no ip address
 duplex full
 speed 100
 switchport
 switchport access vlan 100
!
interface FastEthernet2/4
 no ip address
 duplex full
 speed 100
 switchport
 switchport access vlan 100
!

!--- CSM Server side VLAN. Connection to end users.

interface FastEthernet2/5
 no ip address
 switchport
 switchport access vlan 200
!

!--- MSFC VLAN 100. Content Engine and client uses this
!--- address as the default gateway.

interface Vlan100
 ip address 10.107.249.250 255.255.255.248
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.107.249.249
no ip http server
!
line con 0
line vty 0 4
password cisco
login
!
end

Модуль контента
device mode content-engine
!
hostname ce1
!
http proxy incoming 80

!--- Accept proxy requests on port 80.

!
http l4-switch enable


!--- Instructs the Content Engine to accept traffic that is
!--- directed to any destination IP.

!
ip domain-name cisco.com
!
!
interface Fastethernet 0/0
 ip address 10.107.249.254 255.255.255.248
 exit
!
interface Fastethernet 0/1
 exit
!
ip default-gateway 10.107.249.250
!
primary-interface Fastethernet 0/0
!
!
no auto-register enable
!
ip name-server 10.107.241.185
!
!
username admin password 1 bVmDmMMmZAPjY
username admin privilege 15
!
authentication login local enable primary
authentication configuration local enable primary
!
! End of ACNS configuration

Проверка.

В этом разделе содержатся сведения, которые можно использовать для подтверждения правильности работы конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Примечание: Прежде чем применять команды отладки, ознакомьтесь с разделом "Важные сведения о командах отладки".

Команды debug и show CSM

  • show module

  • show arp распечатку кэша Протокола ARP Распределения нагрузки сервера (SLB).

  • покажите ведет — Предоставляет информацию о соединении SLB.

  • покажите, что dfp — Предоставляет административную информацию Протокола DFP SLB.

  • покажите, что ft — Предоставляет информацию об Отказоустойчивости (FT) SLB.

    cat# show module csm 3 ft
    
    FT group 1, vlan 250
    This box is active
    priority 20, heartbeat 1, failover 3, preemption is off
    
    cat# show module csm 4 ft
    
    FT group 1, vlan 250
    This box is in standby state
    priority 10, heartbeat 1, failover 3, preemption is off
  • покажите, что карта — Предоставляет сведения о сопоставлении SLB.

  • show memory данные памяти SLB.

  • покажите natpools — информация о пуле NAT предоставления сведений клиенту SLB.

  • покажите, что политика — Предоставляет информацию о политике SLB.

  • покажите, что зонд — Предоставляет сведения о тесте SLB.

  • покажите, что real — Предоставляют информацию о реальном сервере SLB.

  • покажите, что serverfarm — Предоставляют данные фермы серверов SLB.

  • show static — Предоставляет данные NAT статического сервера SLB.

  • show stats — Обеспечивает статистику SLB.

  • show status сведения о статусе SLB.

  • покажите, что sticky — Предоставляет базу данных сообщений на экране SLB.

  • show tech-support SLB техническая отладочная информация.

  • show vlan сведения о виртуальной локальной сети (VLAN) SLB.

  • покажите, что vserver — Предоставляют информацию о виртуальном сервере SLB.

    show module csm 3 vservers name transparent detail
    
    TRANSPARENT, state = OPERATIONAL, v_index = 10
      virtual = 0.0.0.0/0:80, TCP, service = NONE, advertise = FALSE
      idle = 3600, replicate csrp = none, vlan = ALL
      max parse len = 2000, persist rebalance = TRUE
      conns = 0, total conns = 47
      Default policy:
        server farm = CACHE
        sticky: timer = 0, subnet = 0.0.0.0, group id = 0
      Policy           Tot Conn     Client pkts  Server pkts
      ------------------------------------------------------
      CACHE-POLICY     44           249          203
      NONCACHE-POLICY  37           111          37
      (default)        0            0            0
  • модуль CSM? — Настраивает CSM для прозрачного кэширования. Также задает местоположение CSM, который вы настраиваете.

    cat(config)# module csm ?
    
    <1-6>  slot where the CSM module resides
  • vserver proxy — Настраивает виртуальный сервер.

    cat(config-module-csm)# vserver proxy
    
    cat(config-slb-vserver)# ?
    
  • vserver дает объявление — Объявляют виртуальный IP - адрес.

  • клиент VServer — Устанавливает IP-адреса клиентов.

  • по умолчанию vserver — Устанавливает команду в свои настройки по умолчанию.

  • выход vserver — Выходит из подрежима распределения нагрузки сервера.

  • простаивающий vserver — Устанавливает счетчик простоя.

  • штатный vserver — Включает сервис для этого виртуального сервера.

  • никакой vserver — Не Инвертирует команду или устанавливает ее настройки по умолчанию.

  • длина синтаксического анализа vserver — Устанавливает максимальную длину синтаксического анализа Уровня 7.

  • персистентный vserver — Включает или отключает устойчивость соединения.

  • vserver реплицирует — Устанавливает репликацию отказоустойчивости vserver.

  • serverfarm vserver — Устанавливает ферму реального сервера.

  • политика slb vserver — Устанавливает политику распределения нагрузки сервера.

  • sticky vserver — Устанавливает таймер закрепления в памяти.

  • хэш URL vserver — Устанавливает префиксное/суффиксное соответствие для алгоритма хэширования URL.

  • действительный vserver — Настраивает виртуальный сервер.

  • кэш serverfarm — Настраивает ферму серверов.

    cat(config-module-csm)# serverfarm cache
    
    cat(config-slb-sfarm)# ?
    
  • bindid serverfarm — Связывает ID для DFP.

  • по умолчанию serverfarm — Устанавливает команду в свои настройки по умолчанию.

  • выход serverfarm — Выходит из подрежима фермы серверов SLB.

  • serverfarm failaction — Действие для принятия выхода сервера из строя.

  • nat serverfarm — Устанавливает переадресацию для SLB.

  • никакой serverfarm — Не Инвертирует команду или устанавливает ее настройки по умолчанию.

  • упреждающее устройство фермы серверов — Устанавливает предиктивный алгоритм распределения нагрузки.

  • зонд serverfarm — Настраивает для использования зонда.

  • real serverfarm — Настраивает реальный сервер.

  • vserver перенаправления serverfarm — Настраивает виртуальный сервер перенаправления SLB.

Команды показа Модуля контента

  • show statistics http savings — Сохраняет статистику от Модуля контента.

    ce1# show statistics http savings
    
                           Statistics - Savings
                         Requests           Bytes
    -----------------------------------------------
    Total:               635                2764599
    Hits:                113                254517
    Miss:                505                2483555
    Savings:            17.8 %              9.2 %

    Как вы можете видеть было 113 соответствий.

Устранение неполадок

В настоящее время нет никакой определенной доступной информации для устранения проблем этой конфигурации.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения