Технологии коммутируемого доступа в сеть : "Технология ISDN, CAS"

Настройка Data Over Voice (DoV), используя данных входящих голосовых звонков isdn и звонков в режиме телефона номиронабирателя

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ предоставляет пример конфигурации для настройки Data Over Voice (DoV) с помощью данных isdn incoming-voice и команд dialer voice-call.

Перед началом работы

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Предварительные условия

Для данного документа отсутствуют предварительные условия.

Используемые компоненты

Сведения, содержащиеся в данном документе, относятся к следующим версиям программного и аппаратного обеспечения.

  • Cisco Выпуск ПО IOS� 11.3 или позже.

  • Можно использовать любой маршрутизатор с интерфейсом ISDN. Однако, необходимо гарантировать, что DOV поддержек Telco (телефонная компания), и что там не будет никакое повреждение данных

Сведения, представленные в этом документе, были получены от устройств в специфической лабораторной среде. Все устройства, используемые в этом документе, были запущены с чистой конфигурацией (конфигурацией по умолчанию). При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Теоретические сведения

Передача голосовых данных (DOV) позволяет передавать данные по телефонной линии, используя канал ISDN. Линия ISDN может поддерживать передачу как данных, так и голоса. Два маршрутизатора, которые соединяются каналами ISDN, обычно используют передачу данных (64 Кбит/с или 56 Кбит/с). Предполагается, что голосовые вызовы будут создаваться телефоном или факсом. Голосовые вызовы также могут исходить от устройства, подключенного к аналоговому модему (например, от компьютера, совершающего модемный вызов в обычной телефонной сети [POTS]).

В некоторых обстоятельствах пользователь может быть заинтересован в соединении двух маршрутизаторов с голосовыми вызовами при помощи линий ISDN, особенно, если учитывается разница в цене между передачей данных и речи. Линии ISDN обычно оплачиваются по числу звонков с учетом всех звонков (местных, междугородних и международных).

В некоторых случаях ценообразование голосовых вызовов ниже, чем ценообразование вызовов данных. Чтобы маршрутизаторы могли общаться, используя голосовые вызовы между двумя линиями ISDN, требуется аккуратная настройка для того, чтобы маршрутизаторы понимали, что вызовы необходимо инициировать в качестве голосовых вызовов, и что входящие голосовые вызовы необходимо обрабатывать как передачу данных. С исходящей (звонящей) стороны используйте параметр "map-class" для определения вызовов как голосовых:

map-class dialer name

dialer voice-call

Этот класс схемы задает поведение и должен применяться к интерфейсам ISDN, где необходимо такое поведение. Вот пример поведения класса сопоставления на cхеме набора номеров или командах dialer string.

имя хоста названия класса сопоставления класса адресов протокола cхемы набора номеров [передавало] номер телефона

класс карты классов номера телефона строки номеронабирателя

Полный синтаксис этих двух команд см. в документации по ПО Cisco IOS.

На входящей (получающей вызов) стороне добавьте к физическому интерфейсу команду isdn incoming-voice data. Не забывайте о том, что все входящие голосовые вызовы будут обрабатываться как вызовы с данными. Если используется платформа, которая поддерживает модемные вызовы на BRI, нельзя настроить отдельный интерфейс для поддержки той или иной возможности. Определенный интерфейс мог или обработать голосовые вызовы как модемные вызовы или голосовые вызовы, как DOV звонит, но не оба.

Примечание: Возможно настроить определенный интерфейс для обработки голосовых вызовов как модемных вызовов или голосовых вызовов, как звонит DOV. Однако для этого вам потребуется настроить управление пулом ресурсов (RPM). Дополнительные сведения по RPM см. в следующем документе: Управление совокупностью ресурсов.

Необходимо помнить, что метод передачи данных вместе с голосом (DOV) недостаточно надежен. Для поддержания цифрового сквозного пути необходим вызов между двумя линиями ISDN. Оборудование, линии и другие ресурсы, что использование телефонной компании для устанавливания вызовов данных и голосовой вызов обычно является тем же. Однако они могут быть другими. Передача оцифрованного голоса протекает более гибко, чем передача данных. В случае вызовов для передачи данных по линии ISDN телефонная сеть гарантирует транспортировку битов по цифровому пути со скоростью 64 или 56 Кбит/с. Для голосовых вызовов телефонная сеть может направлять и управлять битовым потоком различными способами, не влияя на качество голосовой связи, однако при пересылке данных таким образом они будут повреждены. Таким образом, DOV не работает с некоторыми ISDN-каналами. Проверьте, что Telco (телефонная компания) может обработать вызовы DOV перед настройкой этой функции еще настройка вызова может succeeed, но будут повреждены данные tht.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

В данном документе используется сеть, изображенная на следующей схеме.

/image/gif/paws/14964/briipun.gif

Конфигурации

В данном документе используются следующие конфигурации.

Маршрутизатор 1
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router1
!
aaa new-model
aaa authentication login default local
aaa authentication login CONSOLE none
aaa authentication ppp default local
enable password somethingSecret
!
username Router2 password 0 open4me2
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
interface Ethernet0
 ip address 10.10.186.133 255.255.255.240
 no ip directed-broadcast
!
interface Serial0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI0
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 dialer string 5556700 class DOV

! --- The router will use the map-class DOV when dialing this number
! --- The map-class named DOV is defined below

 dialer load-threshold 5 outbound
 dialer-group 1
 ppp authentication chap
!
ip classless
ip route 0.0.0.0 0.0.0.0 BRI0
no ip http server
!
map-class dialer DOV

! --- map class named DOV is applied to the dialer string under 
! --- the physical interface

 dialer voice-call

! --- Outgoing call is treated as a voice call

!
dialer-list 1 protocol ip permit
!
line con 0
 login authentication CONSOLE
 transport input none
line aux 0
line vty 0 4
!
end

Маршрутизатор 2
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router2
!
aaa new-model
aaa authentication login default local
aaa authentication login CONSOLE none
aaa authentication ppp default local
enable password somethingSecret
!
username Router1 password 0 open4me2
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
interface Ethernet0
 ip address 10.8.186.134 255.255.255.240
 no ip directed-broadcast
!
interface Serial0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI0
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 dialer-group 1
 isdn switch-type basic-5ess
 isdn incoming-voice data

! --- Incoming voice calls will be treated as data calls
! --- An interface cannot accept modem calls and DOV calls without RPM

 ppp authentication chap
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.8.186.129
ip route 10.10.186.128 255.255.255.240 BRI0
no ip http server

dialer-list 1 protocol ip permit

line con 0
 login authentication CONSOLE
 transport input none
line aux 0
line vty 0 4
!
end

Проверка.

В данном разделе содержатся сведения о проверке работы конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • show isdn status- Статус должен быть:

    layer 1 = active 
    layer 2 = MULTIPLE_FRAMES_ESTABLISHED

    Если Уровень 1 не активен, то адаптер проводного соединения или порт могут быть плохими или не включенные. Если второй уровень находится в состоянии TEI_Assign, взаимодействие между маршрутизатором и коммутатором отсутствует. Обратитесь к Использованию Команды show isdn status для Устранения проблем BRI для получения дополнительной информации об устранении неисправностей соединения ISDN

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Команды для устранения неполадок

Примечание: Прежде чем применять команды отладки, ознакомьтесь с разделом "Важные сведения о командах отладки".

  • debug dialer - Для отображения информацию относительно причины любого вызова. Это было бы primarilty использоваться, чтобы определить, инициировал ли маршрутизатор вызов.

  • debug isdn q931- Для проверки ISDN - подключений как, пользователи набирают в видеть то, что происходит с вызовом ISDN (например, если соединение отбрасывается). Можно также установить пропускную способность информационного канала (который указывает, является ли вызов цифровым или голос) от этих выходных данных отладки.

  • debug ppp nego - Чтобы видеть, если подробные данные согласования PPP.

  • debug ppp chap- Проверять аутентификацию.

Выходные данные отладки

Придерживающиеся выходные данные debug isdn q931 показывают соединение вызова с помощью DOV. maui-soho-01 (клиент) набирает maui-nas-08 (сервер). Заметьте, что пропускная способность информационного канала вызовов указывает, что они - голосовые вызовы, как ожидалось. maui-nas-08 настроен для обработки входящих голосовых вызовов как вызовов данных (в противоположность модемным вызовам), и вызов связан.

maui-soho-01#ping 10.8.186.134 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.8.186.134, timeout is 2 seconds:
Aug 17 15:48:12.523: ISDN BR0: TX ->  SETUP pd = 8  callref = 0x03

! --- Setup message for outgoing call

Aug 17 15:48:12.531:         Bearer Capability i = 0x8090A2

! --- Bearer Cap indicates that the call is a Voice call(u-law)
! --- An ISDN digital call would be indicated with 0x8890 (for 64k) 
! --- or 0x8890218F (for 56k)

Aug 17 15:48:12.543:         Channel ID i = 0x83
Aug 17 15:48:12.550:         Keypad Facility i = '5556700'
Aug 17 15:48:12.908: ISDN BR0: RX <-  CALL_PROC pd = 8  callref = 0x83

Aug 17 15:48:12.916:         Channel ID i = 0x89

Aug 17 15:48:12.927:         Locking Shift to Codeset 5
Aug 17 15:48:12.931:         Codeset 5 IE 0x2A  i = 0x808001038308, 
'555-6700', 0x8001098001, '<'
Aug 17 15:48:13.130: ISDN BR0: RX <-  CONNECT pd = 8  callref = 0x83

! --- maui-nas-08 has accepted the call and responded with the 
! --- CONNECT message

Aug 17 15:48:13.142:         Locking Shift to Codeset 5
Aug 17 15:48:13.150:         Codeset 5 IE 0x2A  i = 0x808001038308, 
'555-6700', 0x8001098909, 'Connected', 0x80010B8001, '('
Aug 17 15:48:13.217: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up.
Aug 17 15:48:13.249: ISDN BR0: TX ->  CONNECT_ACK pd = 8  callref = 0x03
Aug 17 15:48:14.372: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, 
changed state to up
Aug 17 15:48:19.185: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 5556700

Придерживающаяся отладка получена из maui-nas-08 (сервер). Обратите внимание, что пропускная способность информационного канала указывает, что вызов является голосовым. NAS была сконфигурирована обращаться с входящими голосовыми вызовами как с цифровыми вызовами на этом интерфейсе.

maui-nas-08#
Aug 17 15:48:12.765: ISDN BR2/0: RX <-  SETUP pd = 8  callref = 0x13

! --- Setup message for incoming call

Aug 17 15:48:12.765:         Bearer Capability i = 0x8090A2

! --- Bearer Cap indicates that the call is a Voice call(u-law)
! --- An ISDN digital call would be indicated with 0x8890 (for 64k) 
! --- or 0x8890218F (for 56k)

Aug 17 15:48:12.765:         Channel ID i = 0x89
Aug 17 15:48:12.765:         Signal i = 0x40 - Alerting on - pattern 0 
Aug 17 15:48:12.765:         Called Party Number i = 0xC1, '5556700', 
Plan:ISDN, Type:Subscriber(local)
Aug 17 15:48:12.765:         Locking Shift to Codeset 5
Aug 17 15:48:12.765:         Codeset 5 IE 0x2A  i = 0x808001038001118001, '<'

Aug 17 15:48:12.769: ISDN BR2/0: Event: Received a DATA call from  
on B1 at 64 Kb/s

! --- The incoming voice call (on int bri 2/0) is treated as a data call
! --- This is configured (in interface config mode) using 
! --- isdn incoming-voice data

Aug 17 15:48:12.769: ISDN BR2/0: TX ->  CALL_PROC pd = 8  callref = 0x93
Aug 17 15:48:12.773:         Channel ID i = 0x89
Aug 17 15:48:12.773: %LINK-3-UPDOWN: Interface BRI2/0:1, changed state to up
Aug 17 15:48:12.773: BR2/0:1 PPP: Treating connection as a callin
Aug 17 15:48:12.773: BR2/0:1 PPP: Phase is ESTABLISHING, Passive Open
Aug 17 15:48:12.773: BR2/0:1 LCP: State is Listen
Aug 17 15:48:13.073: ISDN BR2/0: TX ->  CONNECT pd = 8  callref = 0x93

! --- The call is accepted and nas-08 responds with the CONNECT message

Aug 17 15:48:13.073:         Channel ID i = 0x89
Aug 17 15:48:13.121: ISDN BR2/0: RX <-  CONNECT_ACK pd = 8  callref = 0x13


! ---Output omitted

...

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 14964