Глобальная сеть (WAN) : Протоколы X.25

Преобразование X.25 в TCP

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

XOT (X.25 по TCP) разработан Cisco Systems и детализирован в Запросе на комментарий (RFC) 1613, для транспортировки X.25 по Интернету IP. Это позволяет отправлять пакеты X.25 по сети с протоколом управления передачей/протоколом IP (Transmission Control Protocol/Internet Protocol, TCP/IP) вместо канала со сбалансированным протоколом доступа к каналу (Link Access Procedure Balanced, LAPB). XOT является методом передавания пакетов X.25 по Интернету IP посредством инкапсуляции Пакетного уровня X.25 в пакетах TCP.

Этот документ представляет пример конфигурации, который иллюстрирует эти две трансляции:

  • Протокол TCP к трансляции X.25.

  • Преобразование X.25 в TCP.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Эта трансляция требует Расширенного (enterprise) набора функций, который только поддерживается на платформах маршрутизаторов Cisco 26xx и выше.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. в Условные обозначения технических терминов Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/14216/x25_tcptrans1.gif

Как показано здесь, встречно-параллельные ссылки используются между Маршрутизаторами 1 и 2 и между Маршрутизаторами 2 и 3.

Конфигурации

Эти конфигурации используются в данном документе:

  • Маршрутизатор 1

  • Маршрутизатор 2

  • Маршрутизатор 3

Примечание: Мы имеем усеченный придерживающиеся конфигурации для показа связанных сведений.

Маршрутизатор 1
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router1
!
interface Serial0
 description DCE connection to s1 Router2
 ip address 10.0.0.6 255.255.255.252
 no ip mroute-cache
 clockrate 56000
!
ip route 192.168.7.0 255.255.255.0 10.0.0.5                                             

Маршрутизатор 2
version 12.1
service timestamps debug datetime msec                                                  
service timestamps log datetime msec
!
hostname Router2
!
x25 routing
!
interface Loopback0
 ip address 192.168.7.1 255.255.255.0
!
interface Serial0
 description DCE connection to s1 Router3
 encapsulation x25 dce
 no ip mroute-cache
 clockrate 64000
!
interface Serial1
 description DTE connection to s0 Router1
 ip address 10.0.0.5 255.255.255.252
!
x25 route 123 interface Serial0
!
translate tcp 192.168.7.2 x25 123
translate x25 345 tcp 10.0.0.6

Маршрутизатор 3
Router3#show running-config
Building configuration...
 
Current configuration:
!
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
hostname Router3
!
ip subnet-zero
!
x25 routing
!
interface Serial1
 description DTE connection to s0 Router2
 encapsulation x25
 x25 address 123
!
x25 route 345 interface Serial1                                                         

Проверка.

Использование следующие команды для тестирования той сети работает должным образом:

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • show debug вам отобразить множество отладочной информации или выполнить определенные действия по устранению проблем.

  • telnet 192.168.7.2 — соединяется с компьютерными системами в Интернете в режиме приглашения.

  • подушка 345 — регистрирует вас на ПОДУШКЕ.

  • show x25 vc об активных коммутируемых виртуальных каналах (SVC) и постоянные виртуальные каналы (PVCs) в привилегированном режиме EXEC.

Выходные данные, показанные в тестах ниже, являются результатом ввода этих команд на устройствах, показанных в схеме сети выше. Выходные данные показывают, что сеть функционирует исправно.

Тест 1: Трансляция TCP в X.25

В этом тесте мы выполняем сеанс Telnet от Router1 до IP-адреса Router2:

  1. Telnet 192.168.7.2 от Router1.

    Примечание: Этот адрес принадлежит сети 192.168.7.0 / 24 в Router2. Этот адрес не должен быть назначен ни на какую другую систему в сети.

  2. Router2 делает Преобразование TCP в X.25 для достижения Router3. Результаты приводятся ниже.

Router2#show debug 
   TCP: 
     TCP special event debugging is on 
   X.29 PAD: 
     X25 PAD debugging is on 
   X.25: 
     X.25 special event debugging is on 
   Protocol translation: 
     Protocol Translation debugging is on 
   Router2#
 
Router1#telnet 192.168.7.2 
   Trying 192.168.7.2 ... Open 
   Trying 123...Open 
    User Access Verification 
    Password: 
   Router3>

Router2# 
   *Mar  1 01:50:28.759: TCP0: state was LISTEN -> SYNRCVD [23 -> 10.0.0.6(11007)]    
   *Mar  1 01:50:28.763: TCB00499CAC setting property TCP_TOS (11) C0094 
   *Mar  1 01:50:28.767: tcppad2: fork started 
   *Mar  1 01:50:28.767: TCP: sending SYN, seq 3338770911, ack 4026886977    
   *Mar  1 01:50:28.771: TCP2: Connection to 10.0.0.6:11007, advertising MSS 1460 
   *Mar  1 01:50:28.775: TCP2: Connection to 10.0.0.6:11007, received MSS 556, MSS is 556 
   *Mar  1 01:50:28.791: TCP2: state was SYNRCVD -> ESTAB [23 -> 10.0.0.6(11007)]    
   *Mar  1 01:50:28.803: pad_open_connection: found a valid route 
   *Mar  1 01:50:28.807: Serial0: X.25 O R1 Call (11) 8 lci 1 
   *Mar  1 01:50:28.811: From (0):  To (3): 123 
   *Mar  1 01:50:28.811: Facilities: (0) 
   *Mar  1 01:50:28.815: Call User Data (4): 0x01000000 (pad)    
   *Mar  1 01:50:28.827: Serial0: X.25 I R1 Call Confirm (5) 8 lci 1 
   *Mar  1 01:50:28.831: From (0):  To (0): 
   *Mar  1 01:50:28.835: Facilities: (0) 
   *Mar  1 01:50:28.835: PAD2: Call completed 
   *Mar  1 01:50:28.839: PAD2: Control packet received. 
   *Mar  1 01:50:28.851: PAD2: Input X29 packet type 4 (Read X.3 param) len 1 
   *Mar  1 01:50:28.855: PAD2: Output X29 packet type 0 (Parameter indication) len 45 
       1:1, 2:1, 3:2, 4:1, 5:0, 6:0, 7:4, 
       8:0, 9:0, 10:0, 11:14, 12:0, 13:0, 14:0, 15:0, 
       16:127, 17:21, 18:18, 19:0, 20:0, 21:0, 22:0, 
   *Mar  1 01:50:28.879: PAD2: Control packet received. 
   *Mar  1 01:50:28.883: PAD2: Input X29 packet type 6 (Set and Read) len 9 
       2:0, 4:1, 15:0, 7:21, 
   *Mar  1 01:50:28.887: tcppad2: Sending WILL ECHO 
   *Mar  1 01:50:28.891: PAD2: Output X29 packet type 0 (Parameter indication) len 9 
       2:0, 4:1, 15:0, 7:21,

Router2#show x25 vc
   SVC 1, State: D1, Interface: Serial0 
     Started 00:00:25, last input 00:00:22, output 00:00:22  
  Line: 2 vty 0 Location: Host: 10.0.0.6    
      connected to 123 PAD <--> X25  
  Window size input: 2, output: 2 
     Packet size input: 128, output: 128 
     PS: 5  PR: 4  ACK: 4  Remote PR: 5 RCNT: 0 RNR: no 
     P/D state timeouts: 0  timer (secs): 0 
     data bytes 57/62 packets 5/4 Resets 0/0 RNRs 0/0 REJs 0/0 INTs 0/0 
   Router2# 

Тест 2: Преобразование X.25 в TCP

В этом тесте мы начинаем сеанс компоновщик/декомпоновщика пакетов (PAD) от Router3 до адреса X.25 Router2:

  1. Сделайте ПОДУШКУ к 345 от Router3.

  2. Router2 делает Трансляцию X.25 в TCP для достижения Router1. Результаты приводятся ниже.

Router2#show debug 
   TCP: 
     TCP special event debugging is on 
   X.29 PAD: 
     X25 PAD debugging is on 
   X.25: 
     X.25 special event debugging is on 
   Protocol translation: 
     Protocol Translation debugging is on 
   Router2# 

Router3#pad 345 
   Trying 345...Open 
   Trying 10.0.0.6 ... Open 
    User Access Verification 
    Password: CCCC 
   Router1> 
      
Router2# 
   *Mar  1 01:51:31.475: Serial0: X.25 I R1 Call (12) 8 lci 1024 
   *Mar  1 01:51:31.479: From (3): 123 To (3): 345 
   *Mar  1 01:51:31.483: Facilities: (0) 
   *Mar  1 01:51:31.483: Call User Data (4): 0x01000000 (pad)    
   *Mar  1 01:51:31.487: PAD: translate call to 345 
   *Mar  1 01:51:31.491: Call User Data (4): 0x01000000 (pad)    
   *Mar  1 01:51:31.495: PAD: Creating proto translation on tty2 for vc 1024    
   *Mar  1 01:51:31.499: Serial0: X.25 O R1 Call Confirm (5) 8 lci 1024 
   *Mar  1 01:51:31.503: From (0):  To (0): 
   *Mar  1 01:51:31.503: Facilities: (0) 
   *Mar  1 01:51:31.507: PAD2: Call completed 
   *Mar  1 01:51:31.511: padtcp2: fork started 
   *Mar  1 01:51:31.515: PAD2: Output X29 packet type 4 (Read X.3 param) len 1 
   *Mar  1 01:51:31.523: TCB0049E7A4 created 
   *Mar  1 01:51:31.523: TCB0049E7A4 setting property TCP_TOS (11) 49C853    
   *Mar  1 01:51:31.527: TCB0049E7A4 bound to UNKNOWN.44034 
   *Mar  1 01:51:31.531: PAD2: Control packet received. 
   *Mar  1 01:51:31.531: TCP: sending SYN, seq 3401534831, ack 0 
   *Mar  1 01:51:31.535: TCP2: Connection to 10.0.0.6:23, advertising MSS 1460 
   *Mar  1 01:51:31.539: TCP2: state was CLOSED -> SYNSENT [44034 -> 10.0.0.6(23)]    
   *Mar  1 01:51:31.559: TCP2: state was SYNSENT -> ESTAB [44034 -> 10.0.0.6(23)]    
   *Mar  1 01:51:31.563: TCP2: Connection to 10.0.0.6:23, received MSS 1460, MSS is 1460 
   *Mar  1 01:51:31.567: TCB0049E7A4 connected to 10.0.0.6.23 
   *Mar  1 01:51:31.571: PAD2: Input X29 packet type 0 (Parameter indication) len 45 
       1:1, 2:1, 3:2, 4:1, 5:0, 6:0, 7:4, 
       8:0, 9:0, 10:0, 11:14, 12:0, 13:0, 14:0, 15:0, 
       16:127, 17:21, 18:18, 19:0, 20:0, 21:0, 22:0, 
   *Mar  1 01:51:31.583: PAD2: Setting ParamsIn, length 44 
   *Mar  1 01:51:31.587: PAD2: Output X29 packet type 6 (Set and Read) len 9 
       2:0, 4:1, 15:0, 7:21, 
   *Mar  1 01:51:31.599: PADTCP2: Telnet received WILL ECHO (1) 
   *Mar  1 01:51:31.599: PAD2: Control packet received. 
   *Mar  1 01:51:31.607: PADTCP2: Telnet received DO TTY-TYPE (24) 
   *Mar  1 01:51:31.611: PAD2: Output X29 packet type 6 (Set and Read) len 3 2:0, 
   *Mar  1 01:51:31.619: PAD2: Input 
   *Mar  1 01:51:31.619: PAD2: Control packet received.X29 packet type 0 
       (Parameter indication) len 9 2:0, 4:1, 15:0, 7:21, 
   *Mar  1 01:51:31.627: PAD2: Setting ParamsIn, length 8 
   *Mar  1 01:51:31.631: PAD2: Input X29 packet type 0 (Parameter indication) len 3 2:0, 
   *Mar  1 01:51:31.635: PAD2: Setting ParamsIn, length 2 
   *Mar  1 01:51:31.643: PADTCP2: Telnet received DONT TTY-LOCATION (23) 
   *Mar  1 01:51:31.647: PADTCP2: Telnet received DONT TTY-SPEED (32) 
   Router2#  

Router2#show x25 vc 
   SVC 1024,  State: D1,  Interface: Serial0 
     Started 00:00:10, last input 00:00:07, output 00:00:05  
  Line: 2   vty 0    Location:  Host: 123    
     123 connected to 345 PAD <--> X25  
  Window size input: 2, output: 2 
     Packet size input: 128, output: 128 
     PS: 1  PR: 6  ACK: 6  Remote PR: 1  RCNT: 0  RNR: no 
     P/D state timeouts: 0  timer (secs): 0 
     data bytes 3057/60 packets 33/6 Resets 0/0 RNRs 0/0 REJs 0/0 INTs 0/0    
   Router2# 
   Router2# 

Прежде чем вызывать команды debug, обратитесь к разделу Важные сведения о командах отладки.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 14216