Технологии коммутируемого доступа в сеть : Асинхронные подключения

Настройка внешнего телефонного соединения с использованием модуля аналогового модема NM-8AM или NM-16AM

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ показывает, как настроить подключение к внешней службе с помощью модема с сетевым модулем на основе аналогового модема NM-AM. В этом сценарии маршрутизатор с модемным модулем NM-8AM набирает Primary Rate Interface (PRI) маршрутизатора центрального узла.

Этот документ предполагает, что у вас есть хорошее понимание различных проблем, привязанных к настройкам модема. Если вы требуете дополнительных сведений об этих проблемах, см. Руководство по подключению модема с маршрутизатором.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

При разработке и тестировании этой конфигурации использовались следующие версии программного и аппаратного обеспечения:

  • Маршрутизатор Cisco 3640 с картой NM-8AM рабочий Cisco Выпуск ПО IOS� 12.1 (5) T.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

В данном документе используется сеть, изображенная на следующей схеме.

/image/gif/paws/10316/dialout-nmam.gif

Конфигурации

В данном документе используются следующие конфигурации.

Маршрутизатор 1 (Cisco 3640)
Current configuration : 1676 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router1
!
enable password ww
!
username router2 password 0 ww

!--- username for remote router (Router 2) and shared secret
!--- shared secret(used for CHAP authentication) must be the same on both sides

ip subnet-zero
!
chat-script async "" "AT" OK "ATDT\T" TIMEOUT 30 CONNECT \c

!--- chat script "async" used for the dialout connection

!
!
interface Ethernet2/0
 ip address 10.200.20.51 255.255.255.0
 half-duplex
!
interface Async104	

!--- async interface corresponding to the modem 
!--- This was determined using the show line command.

 ip address 10.10.0.2 255.255.255.252

!--- IP address of this async interface

 encapsulation ppp
 dialer in-band
 dialer wait-for-carrier-time 180
 dialer map ip 10.10.0.1 name router2 modem-script async 8214

!--- dialer map statements for the remote router 
!--- The name must match the one used by the remote router to identify itself.
!--- use modem chat script "async" for this connection

 dialer-group 1
!--- apply interesting traffic definition from dialer-list 1
 async mode dedicated

!--- Place the line into dedicated asynchronous network mode.
!--- This interface is now automatically configured for PPP connections.

 ppp authentication chap
!--- use chap authentication
!
ip classless
ip route 10.10.0.0 255.255.0.0 10.10.0.1

!--- Traffic for the 10.10.0.0/16 network uses a next hop of 10.10.0.1

ip route 10.10.0.1 255.255.255.255 Async104	

!--- the next hop for 10.10.0.1/32 (which is also the next hop for the 
!--- previous route) is interface Async104.

!
dialer-list 1 protocol ip permit

!--- All IP traffic is defined interesting.
!--- This is applied to Async104 using dialer-group 1.

!
!
line con 0
 exec-timeout 0 0
 password ww transport input none
line 33 38
line 97 103
 modem InOut transport input all
line 104		

!--- line interface configuration for Async 104

 modem InOut	

!--- allow incoming and outgoing modem calls on this line
	
 transport input all
 transport output lat pad v120 lapb-ta telnet rlogin udptn
 flowcontrol hardware
line aux 0
line vty 0 4
 password ww
 login
!
end

В этих 3600 шасси карта NM-8AM установлена в слоте 3. Что касается того, Как Асинхронные линии Пронумерованы в документе Маршрутизаторов серии Cisco 3600, мы устанавливаем, что слот 3 имеет линию 97 - 128 зарезервированных. Для определения, какой определенный асинхронный интерфейс необходимо настроить используйте команду show line для обнаружения доступных линий. В этой конфигурации обратите внимание, что только выравнивает 97-104 (8 линий) доступны в том диапазоне. Следовательно, для настройки первого модема в карте настраивают линию 97 (и интерфейс async97), в то время как последний модем является line/async104.

Проверка.

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок аналогового соединения

Выполните эти шаги для устранения проблем внешнего подключения:

  1. Проверьте настройку модема.

    Проверьте конфигурацию модема. Необходимо проверить обоих конфигурация с командной строки, соответствующая модему, а также интерфейсному асинксу.

  2. Обратный доступ по протоколу Telnet к модему и инициирует подключение к внешней службе.

    Обратный доступ по протоколу Telnet порт к модему и использование набор AT-команд, чтобы набрать и соединиться с удаленным устройством. Это может использоваться для проверки работы оборудования модема и телефонной цепи. В данном примере, так как порт модема находится на линии 104, обратный доступ по протоколу Telnet для портирования 2104 на маршрутизаторе. Дополнительную информацию об обратных сеансах Telnet см. в разделе "Установка обратного сеанса Telnet с модемом".

    router1#telnet 10.200.20.51 2104 
    Trying 10.200.20.51, 2104  ... Open
    User Access Verification
    Username: admin
    Password: 
    
    !--- Authentication performed by local router for the reverse telnet
    
    at
    OK
    atdt 81690
    
    !--- The modem dials (81690) and connects.
    !--- This takes approximately 30-45 seconds.
    
    CONNECT 31200/ARQ/V34/LAPM/V42BIS
    
    !--- Connect speed and protocols that were negotiated
    
    User Access Verification
    Username: admin
    Password:
    
    !--- Authentication performed by remote router for the incoming call
     
    router2>
    
    !--- Remote router's prompt
    
    

    Можно также применить другие команды AT для подтверждения параметров настройки модема. Обратитесь к Набору AT-команд и Сводке реестра для Сетевых модулей на основе аналогового модема для получения дополнительной информации о команде AT, доступной для модулей аналогового модема.

  3. Активируйте сценарий диалогового взаимодействия вручную и инициируйте набор.

    Используйте команду start-chat , чтобы активировать сценарий диалогового взаимодействия и инициировать набор. Команда start-chat требует, чтобы вы задали название сценария диалогового взаимодействия, который будет активирован, номер телефона, который будет набран, и интерфейс модема для вызова номера на.

  4. Проверьте, что существует маршрут к асинхронному интерфейсу.

    Используйте команду show ip route, чтобы проверить, существует ли маршрут к асинхронному интерфейсу. Если существует никакой маршрут, создайте статический маршрут. Пример:

    ip route 10.10.0.1 255.255.255.255 Async104 
  5. Генерируйте эхо-запрос, предназначенный для сети следующего перехода, заданной в шаге 4.

    Эхо-запрос для удаленного маршрутизатора, который задан с помощью сети следующего перехода от шага 4, заставляет маршрутизатор набирать удаленное устройство.

    router1#ping 10.10.0.1
    

Обратитесь к Устранению проблем Исходящих вызовов для получения дополнительной информации о том, как устранить неполадки соединения.

Распространенные ошибки

  • Проверьте, что название сценария диалогового взаимодействия идентично тому, заданному в инструкции схемы набора номеров. Также проверьте, что правильно задан номер телефона, который будет набран.

  • Проверьте, чтобы видеть, что правильно определен представляющий интерес трафик. Представляющий интерес трафик задан с командой dialer-list.

  • Гарантируйте, что определение содержательного трафика применено к асинхронному интерфейсу. Это сделано с помощью команды dialer-group, где номер группы должен совпасть с определением содержательного трафика, заданным с командой dialer-list.

  • Проверьте, что имя пользователя и пароли для аутентификации PAP/CHAP корректны.

  • Проверьте, чтобы удостовериться, что инструкция схемы набора номеров имеет корректное название, IP-адрес и номер телефона для вызова номера.

команды "debug"

Перед использованием команд debug ознакомьтесь с документом Важные сведения о командах отладки.

  • "debug dialer" - показывает отладочную информацию о пакетах, полученных на интерфейс устройства набора номера. Когда Технология DDR включена на интерфейсе, информация относительно причины любого вызова (названный причиной внешнего доступа по телефонной линии) также отображена. Для получения дополнительной информации см. описание команды "debug dialer" в документации по командам отладки.

  • debug modem – отображает активность линии модема, управление модемом и сообщения об активации процесса на маршрутизаторе.

  • debug chat – Для мониторинга выполнения сценария диалогового взаимодействия, когда инициализируется вызов асинх./ТфОП. Обратитесь к dialup-технологии: Методика поиска и устранения неисправностей для получения дополнительных сведений.

  • debug ppp negotiation - Для отображения информацию на трафике PPP и обменах при согласовании о компонентах PPP включая Протокол управления каналом (LCP), аутентификацию и Протокол управления сетью (NCP). В успешных переговорах PPP сначала выясняется состояние LCP, затем проводится аутентификация и наконец выполняется согласование NCP.

  • debug ppp authenticaion - Для показа сообщений протокола аутентификации PPP, включая Протокол аутентификации проблемы (CHAP) обмены пакетами и обмены Протокола аутентификации пароля (PAP).

Пример отладочных выходных данных

router1#show debug
General OS:
  Modem control/process activation debugging is on
Dial on demand:
  Dial on demand events debugging is on
Generic IP:
  ICMP packet debugging is on
PPP:
  PPP protocol negotiation debugging is on
Chat Scripts:
  Chat scripts activity debugging is on
router1#
router1#ping 10.10.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.0.1, timeout is 2 seconds:
*Mar  1 00:22:58.663: As104 DDR: Dialing cause ip (s=10.10.0.2, d=10.10.0.1)

!--- Dialing reason is the ping for 10.10.10.1
!--- The dialout is using Async104.

*Mar  1 00:22:58.663: As104 DDR: Attempting to dial 8214

!--- Phone number to be dialed

*Mar  1 00:22:58.663: CHAT104: Attempting async line dialer script
*Mar  1 00:22:58.663: CHAT104: Dialing using Modem script: async & System script: none

!--- Use chat script named "async"

*Mar  1 00:22:58.663: CHAT104: process started
*Mar  1 00:22:58.667: CHAT104: Asserting DTR
*Mar  1 00:22:58.667: CHAT104: Chat script async started

!--- Chat-script "async" is started.

*Mar  1 00:22:58.667: CHAT104: Sending string: AT
*Mar  1 00:22:58.667: CHAT104: Expecting string: OK
*Mar  1 00:22:58.739: CHAT104: Completed match for expect: OK
*Mar  1 00:22:58.739: CHAT104: Sending string: ATDT\T<8214>
*Mar  1 00:22:58.739: CHAT104: Expecting string: CONNECT
*Mar  1 00:22:58.751: Modem 3/7 Mcom: in modem state 'Dialing/Answering'
*Mar  1 00:23:10.775: Modem 3/7 Mcom: in modem state 'Waiting for Carrier'
*Mar  1 00:23:21.903: Modem 3/7 Mcom: in modem state 'Connected'
*Mar  1 00:23:22.323: Modem 3/7 Mcom: CONNECT at 26400/24000(Tx/Rx), V34, LAPM, V42bis,
 Originate

!--- Connect speeds, protocols and so forth, and so on negotiated for the connection
!--- Note that the modem used is 3/7 which is equivalent to line 104.
!--- Refer to How Async Lines are Numbered in Cisco 3600 Series Routers.

*Mar  1 00:23:22.375: CHAT104: Completed match for expect: CONNECT
*Mar  1 00:23:22.375: CHAT104: Sending string: \c
*Mar  1 00:23:22.375: CHAT104: Chat script async finished, status = Success

!--- Chat script is successful. Notice the Expect/Send attributes and the time elapsed.

*Mar  1 00:23:22.375: Modem 3/7 Mcom: switching to PPP mode
*Mar  1 00:23:22.379: TTY104: no timer type 1 to destroy
*Mar  1 00:23:22.379: TTY104: no timer type 0 to destroy
*Mar  1 00:23:22.379: As104 IPCP: Install route to 10.10.0.1
*Mar  1 00:23:24.379: %LINK-3-UPDOWN: Interface Async104, changed state to up
*Mar  1 00:23:24.379: As104 DDR: Dialer statechange to up
*Mar  1 00:23:24.379: As104 DDR: Dialer call has been placed
*Mar  1 00:23:24.379: As104 PPP: Treating connection as a callout

!--- PPP negotiation begins.

*Mar  1 00:23:24.379: As104 PPP: Phase is ESTABLISHING, Active Open [0 sess, 0 load]
*Mar  1 00:23:24.379: Modem 3/7 Mcom: PPP escape map: Tx map = FFFFFFFF, Rx map = 0
*Mar  1 00:23:24.379: As104 LCP: O CONFREQ [Closed] id 17 len 25
*Mar  1 00:23:24.379: As104 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 00:23:24.379: As104 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 00:23:24.379: As104 LCP:    MagicNumber 0x1090720F (0x05061090720F)
*Mar  1 00:23:24.379: As104 LCP:    PFC (0x0702)
*Mar  1 00:23:24.379: As104 LCP:    ACFC (0x0802)
*Mar  1 00:23:24.543: As104 LCP: I CONFREQ [REQsent] id 1 len 25
*Mar  1 00:23:24.543: As104 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 00:23:24.543: As104 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 00:23:24.543: As104 LCP:    MagicNumber 0x41B616FF (0x050641B616FF)
*Mar  1 00:23:24.543: As104 LCP:    PFC (0x0702)
*Mar  1 00:23:24.543: As104 LCP:    ACFC (0x0802)
*Mar  1 00:23:24.543: As104 LCP: O CONFACK [REQsent] id 1 len 25
*Mar  1 00:23:24.543: As104 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 00:23:24.543: As104 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 00:23:24.543: As104 LCP:    MagicNumber 0x41B616FF (0x050641B616FF)
*Mar  1 00:23:24.543: As104 LCP:    PFC (0x0702)
*Mar  1 00:23:24.543: As104 LCP:    ACFC (0x0802)
*Mar  1 00:23:24.555: As104 LCP: I CONFACK [ACKsent] id 17 len 25
*Mar  1 00:23:24.555: As104 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 00:23:24.555: As104 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 00:23:24.559: As104 LCP:    MagicNumber 0x1090720F (0x05061090720F)
*Mar  1 00:23:24.559: As104 LCP:    PFC (0x0702)
*Mar  1 00:23:24.559: As104 LCP:    ACFC (0x0802)
*Mar  1 00:23:24.559: As104 LCP: State is Open

!--- LCP negotiation is complete.

*Mar  1 00:23:24.559: Modem 3/7 Mcom: PPP escape map: Tx map = A0000, Rx map = 0
*Mar  1 00:23:24.559: As104 PPP: Phase is AUTHENTICATING, by both [0 sess, 0 load]

!--- Two-way PPP authentication begins.

*Mar  1 00:23:24.559: As104 CHAP: O CHALLENGE id 4 len 28 from "router1"
*Mar  1 00:23:24.691: As104 CHAP: I CHALLENGE id 1 len 28 from "router2"
*Mar  1 00:23:24.691: As104 CHAP: O RESPONSE id 1 len 28 from "router1"
*Mar  1 00:23:24.707: As104 CHAP: I RESPONSE id 4 len 28 from "router2"
*Mar  1 00:23:24.707: As104 CHAP: O SUCCESS id 4 len 4
*Mar  1 00:23:24.815: As104 CHAP: I SUCCESS id 1 len 4

!--- Incoming and outgoing CHAP authentication is successful.

*Mar  1 00:23:24.815: As104 PPP: Phase is UP [0 sess, 0 load]
*Mar  1 00:23:24.819: As104 IPCP: O CONFREQ [Closed] id 6 len 10
*Mar  1 00:23:24.819: As104 IPCP:    Address 10.10.0.2 (0x03060A0A0002)
*Mar  1 00:23:24.835: As104 IPCP: I CONFREQ [REQsent] id 1 len 10
*Mar  1 00:23:24.835: As104 IPCP:    Address 10.10.0.1 (0x03060A0A0001)
*Mar  1 00:23:24.839: As104 IPCP: O CONFACK [REQsent] id 1 len 10
*Mar  1 00:23:24.839: As104 IPCP:    Address 10.10.0.1 (0x03060A0A0001)
*Mar  1 00:23:24.931: As104 IPCP: I CONFACK [ACKsent] id 6 len 10
*Mar  1 00:23:24.931: As104 IPCP:    Address 10.10.0.2 (0x03060A0A0002)
*Mar  1 00:23:24.931: As104 IPCP: State is Open

!--- IP Control Protocol (IPCP) negotiation is complete.

*Mar  1 00:23:24.931: As104 DDR: dialer protocol up
*Mar  1 00:23:25.379: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async104,
 changed state to up

!--- Interface is up.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 10316