Технологии коммутируемого доступа в сеть : Асинхронные подключения

Дозвон по асинхронному каналу PPP из клиентов Microsoft Windows

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

В этой конфигурации Асинхронного протокола PPP удаленные абоненты с Microsoft Windows 95/98 PC используют нескольких модемов для увеличения доступной скорости доступа. Асинхронный протокол PPP может также быть настроен с другими клиентами, такими как Linux и Apple Macintosh, с соответствующим клиентским программным обеспечением PPP. Конфигурация маршрутизатора Multilink PPP не зависит от платформы ПК клиента.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения в этом документе основаны на версиях оборудования и программного обеспечения, указанных ниже.

  • Cisco AS5300 рабочая Cisco Выпуск ПО IOS� 12.07 (T).

Сведения, содержащиеся в данном документе, были получены с устройств в специальной лабораторной среде. Все устройства, описанные в данном документе, были запущены с конфигурацией по умолчанию. При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. Cisco Technical Tips Conventions.

Теоретические сведения

Протокол PPP (MPPP) позволяет устройствам передавать данные тому же назначению по множественным каналам передачи данных "точка-точка" путем реализации виртуального соединения. MPPP - подключение имеет максимальную пропускную способность, равную сумме пропускных способностей соединений компонента. MPPP может быть настроен для мультиплексных каналов, таких как ISDN и Frame Relay, или для групп асинхронных линий.

Асинхронный протокол PPP может использоваться для подключения удаленных клиентов на большей скорости, чем это доступное посредством одиночного аналогового соединения. В Асинхронном MPPP удаленный клиент использует нескольких модемов, и поэтому несколька телефонных линий, к входящему вызову к центральному маршрутизатору, и обратитесь к сети. Поскольку несколька телефонных линий являются часто более дешевыми, чем сервис Интерфейса (BRI) ISDN, Асинхронный MPPP предоставляет эффективный способ для увеличения скорости соединения для удаленных пользователей при управлении затратами. Асинхронный MPPP является также эффективным способом получить более высокие скорости доступа для удаленных областей, которые не могут быть обслужены ISDN.

Асинхронный MPPP связывает вместе отдельные модемные соединения к Серверу доступа. Программное обеспечение для PPP на каждый одноранговые фрагменты пакеты и передачи части другой стороне посредством групп аналоговых соединений. Принимающая сторона собирает пакеты из отдельных подключений и, на основе данных протокола РРР, встроенных в них, повторно собирает части в допустимые пакеты данных, таким образом предоставляя сквозному виртуальному каналу более высокую пропускную способность. Асинхронный MPPP может быть или настроен между двумя маршрутизаторами или между маршрутизатором и клиентским компьютером.

Хотя возможно использовать больше чем два модема для многоканального соединения от клиентского компьютера, издержки, которые следуют из фрагментации, и повторная сборка пакетов на ПК может инвертировать любую дополнительную полученную пропускную способность.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Поиск дополнительной информации о командах в данном документе можно выполнить с помощью средства "Command Lookup" (Поиск команд) (только для зарегистрированных клиентов).

Схема сети

В этом документе используются настройки сети, показанные на данной диаграмме:

/image/gif/paws/9553/async_multilink.gif

Конфигурация NAS

В этой конфигурации сервер AS5300 с соединением Primary Rate Interface (PRI) T1 используется в качестве Сервера доступа к сети (NAS) входящих пользовательских звонков по аналоговой линии. Поскольку на этом NAS не настроены другие контроллеры T1, данный сервер доступа используется исключительно для асинхронного модемного соединения. Эта конфигурация AS5300 использует виртуальные шаблоны для клонирования интерфейсов виртуального доступа для входящих вызовов. Многоканальная PPP-связка копирует параметры своего интерфейса с определений виртуального шаблона.

Некоторые основные команды аутентификации, авторизации и учета (AAA) включены в качестве примеров оптимальной методологии. Имена и пароли абонентов настраиваются на маршрутизаторе. IP-адреса, назначаемые вызывающим пользователям, выбираются из пула адресов.

Cisco AS5300
bobslake-nas-01#show running-config
Building configuration...

Current configuration:
!
! Last configuration change at 16:01:01 UTC Wed Jun 28 2000
! NVRAM config last updated at 15:30:28 UTC Wed Jun 28 2000 
!
version 12.0
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service tcp-small-servers
!
hostname bobslake-nas-01
!
logging buffered 10000 debugging
aaa new-model
aaa authentication login default local
aaa authentication ppp default if-needed local

!--- authenticate for PPP if not authenticated during login
!--- allows users with Terminal Window after Dial to initiate PPP!

username admin password <deleted> 
username charlie password <deleted> 
spe 1/0 1/7
 firmware location system:/ucode/mica_port_firmware
!
resource-pool disable
!
ip subnet-zero
no ip source-route
ip domain-name the.net
!
multilink virtual-template 1

!--- use virtual-template 1 for multilink connections

async-bootp dns-server 172.22.53.210
isdn switch-type primary-5ess
isdn voice-call-failure 0
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 1
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 2
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 3
 framing esf
 clock source line secondary 3
 linecode b8zs
 pri-group timeslots 1-24
!
interface Loopback0
 ip address 172.21.10.10 255.255.255.255
 no ip directed-broadcast
!
interface Loopback1
 ip address 172.21.104.254 255.255.255.0

!--- summarizes addresses in address pool 
!--- Loopback 1 is in the same subnet as the address pool 

no ip directed-broadcast
!
interface Ethernet0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Virtual-Template1
 description Template for Multilink Users
 ip unnumbered Loopback0  
 no ip directed-broadcast
 peer default ip address pool addr-pool

!--- use IP pool called addr-pool 
!--- for incoming calls
 
ppp authentication chap

!--- authenticate using Challenge Handshake Authentication Protocol (CHAP)

 ppp multilink
!

!--- configure D channel on PRI interface Serial0:23

 description Headquarters 324-1939 active PRI line
 no ip address
 no ip directed-broadcast
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 fair-queue 64 256 0
 no cdp enable
!
interface Serial1:23
 no ip address
 no ip directed-broadcast
 no logging event link-status
 no snmp trap link-status
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 fair-queue 64 256 0
 no cdp enable
!
interface Serial2:23
 no ip address
 no ip directed-broadcast
 no logging event link-status
 no snmp trap link-status
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 fair-queue 64 256 0
 no cdp enable
!
interface Serial3:23
 no ip address
 no ip directed-broadcast
 no logging event link-status
 no snmp trap link-status
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 fair-queue 64 256 0
 no cdp enable
!
interface FastEthernet0
 ip address 172.21.101.23 255.255.255.0
 no ip directed-broadcast
 duplex auto
 speed auto
!
interface Group-Async1

!--- template to control all async interface configuration 

ip unnumbered Loopback0
 no ip directed-broadcast
 encapsulation ppp

!--- use PPP encapsulation dialer in-band

 dialer-group 5
 async mode interactive
 peer default ip address pool addr-pool

!--- use IP pool called addr-pool 
!--- for incoming calls 

 no fair-queue
 no cdp enable
 ppp authentication chap callin

!--- CHAP authenticate for dialin users only 

 ppp multilink
 group-range 1 48

!--- assign modems 1-48 to the Group-Async 1 configuration template

 router eigrp 1
 network 172.21.0.0
!
ip local pool addr-pool 172.21.104.1 172.21.104.48

!--- define IP address pool range for dialin clients 

ip classless
no ip http server
!

access-list 105 permit ip any any
dialer-list 5 protocol ip list 105
!
line con 0
 exec-timeout 0 0
 transport input none
line 1 48
 autoselect during-login

!--- permits user login prompts after dialin 

 autoselect ppp

!--- automatically launch PPP on the line




 modem InOut

!--- modems can be used to dialin and dialout
!--- InOut may be replaced by Dialin 
!--- if NAS handles only incoming calls

 transport preferred none
 transport output telnet
line aux 0
line vty 0 4
 transport preferred none
 transport input telnet
 transport output telnet
!
ntp clock-period 17180374
ntp update-calendar
ntp server 172.22.255.1 prefer
end

bobslake-nas-01#

Настройка клиентов Windows 9x

Следующая процедура является кратким обзором при настройке ваших клиентов Windows 9x для MPPP. См. узел Веб-узла Microsoft leavingcisco.com, если вы испытываете затруднения.

Для настройки Microsoft Windows 9x клиенты для MPPP, удостоверьтесь, что у вас есть Набор Сетевая версия 1.3 или позже установленный.

Перейдите к узлу Веб-узла Microsoft leavingcisco.com для получения дополнительной информации и загружать последнюю версию Набора, передающего (DUN).

  1. Присоедините и настройте каждый модем отдельно.

    В панели управления Windows воспользуйтесь служебной программой “Установить новое оборудование”, чтобы добавить модемы для клиента. При возникновении проблем при добавлении модемов, свяжитесь с вашим поставщиком ПК или представителем Microsoft для Процедур поиска и устранения неисправностей. Убедитесь, что каждый модем правильно подключен и распознается операционной системой. Можно хотеть использовать эмулятор терминала, чтобы проверить, что модем работает должным образом.

  2. Создайте новое подключение удаленного доступа.

    В ОС Windows щелкните два раза пиктограмму "Мой Компьютер" и откройте окно "Удаленный доступ к сети". Затем дважды щелкните "Создать новое соединение". Следуйте этим указаниям для создания удаленного соединения с использованием основного модема. Многоканальные функции настроены позже. Проверьте соединение путем дозвона поставщику услуг.

  3. Добавьте свойства multilink к вашему модемному соединению.

    Дважды щелкните значок "Мой компьютер" и и откройте окно "Удаленный доступ к сети". Щелкните правой кнопкой мыши значок только что настроенного подключения. В появившемся меню выберите пункт "Свойства"."

    Нажмите вкладку "Multilink", выберите "Use additional devices" и нажмите кнопку "Add". Выберите дополнительный модем из раскрывающегося меню и введите номер телефона из семи цифр для сервера доступа либо используйте отображаемый номер. Не включайте код области при конфигурации дополнительного устройства, даже если это междугородный вызов. Соединение автоматически использует код области, настроенный для первого модема. Чтобы завершить настройку, дважды щелкните кнопку "ОК".

    Несколько снимков экрана для многозвенной конфигурации Windows:

    /image/gif/paws/9553/win95_mppp_1.gif

    win95_mppp_2.gif

  4. Установите модемное соединение с сервером доступа.

    Дважды щелкните мышью по иконке подключения удаленного доступа, которое было только что создано. Введите имя пользователя и пароль, настроенные на маршрутизаторе, и нажмите кнопку "Connect". При выборе значка "Удаленный доступ к сети" выполняется набор номера, установленного для модема, определенного для соединения в качестве основного. Когда будет установлено первое соединение, служба удаленного доступа в сеть набирает номер с помощью дополнительных модемов, заданных в списке Additional Devices.

    После создания всех соединений можно просмотреть сведения о состоянии канала с помощью двойного щелчка на ярлыка "Communicating Computers" (Подключенные компьютеры) в панели задач или отключить соединение. Щелкните Details, чтобы убедиться в том, что соединение использует несколько устройств. При выборе устройства в окне списка появляется кнопка Suspend или Resume. Если появляется кнопка Suspend (Приостановить), устройство используется и входит в многоканальные подключения. Нажатием на кнопку Suspend линия разъединяется и удаляется из пакетных соединений. При появлении кнопки "Resume" нажмите ее для установки этого подключения и добавьте эту линию в связку. Можно останавливать и возобновлять многоканальную передачу без потери соединения.

Проверка

В настоящее время для этой конфигурации нет процедуры проверки.

В этом разделе содержатся сведения, которые помогают убедиться в надлежащей работе конфигурации.

Некоторые команды show поддерживаются Интерпретатором выходных данных; это позволяет выполнять анализ выходных данных команды show.

  • show ppp multilink – Отобразить сведения о об активных многоканальных пучках. Эта команда служит для проверки многоканальных соединений.

  • show caller - для отображения сведений об отдельных пользователях и потребляемых ресурсах NAS. Эта команда позволяет отобразить статистику активных вызовов в больших пулах соединений, а также абсолютное время и время простоя для каждого пользователя.

  • show caller user — отображение параметров для определенного пользователя, например используемой телетайпной линии, асинхронного интерфейса (полки/слота/порта), номера канала DS0, номера модема, назначенного IP-адреса, параметров PPP и группы каналов PPP и т. д.

Для помощи в проверке и устранении проблем MPPP - подключения обратитесь к этим предложениям:

  • Гарантируйте, что префиксы, такие как использование 9 прежде, чем набрать внешнюю линию, настроены правильно на клиентском компьютере. Если это не будет настроено должным образом, то вы услышите сигнал занято, как только номер начинает набирать.

  • Создайте отдельных клиентов DUN для каждого модема и проверьте, что у вас есть полное подключение вашему поставщику услуг. Используйте каждый модем отдельно перед продолжением устранения проблем вашего многоканального соединения.

  • Используйте эмулятор терминала для соединения с модемом. Наберите номер NAS с помощью команды atdt. Например, в HyperTerminal вводят atdt 55511111. Проверьте, что модем набирает правильно и соединяется с NAS. Если модем не соединяется, устраните неполадки своего модема. Посмотрите Использование Основной leavingcisco.com документации Команд модема AT относительно узла Веб-узла Microsoft для получения дополнительной информации об устранении проблем клиентских модемов.

  • Если ваше первичное соединение соединяется должным образом, но второе подключение удаленного доступа дает сигнал занято, проверьте, что номер телефона для дополнительного модема правильно настроен в DUN. Помните, коды зоны не должны, чтобы быть добавленными к конфигурации для дополнительных устройств. См. действия настройки в Настройке Windows 9x Clients разделяют выше.

Показ образца и данные отладки

Вот, некоторые показывают и выходные данные отладки от AS5300. Части отладок удаляются для сокращения. Обратите внимание на разделы, выделенные жирным шрифтом, и комментарии в выходных данных.

Заметьте, что абонент связан на Async5 и Async6 до окончания аутентификации. Временный IP - адрес предоставлен абоненту от пула адресов. Вызов тогда виртуализирован или связан к существующему виртуальному пучку. Это происходит, потому что сервер доступа должен иметь информацию, кто является вызывающим абонентом, если они принадлежат установленной виртуальной связке. Как только вызывающее устройство привязывается к пучку, временный IP-адрес удаляется и вызывающее устройство использует IP-адрес виртуального пучка.

bobslake-nas-01#
bobslake-nas-01#show ppp multilink 

Virtual-Access1, bundle name is charlie
  0 lost fragments, 0 reordered, 0 unassigned, sequence 0x29/0x17 rcvd/sent
  0 discarded, 0 lost received, 1/255 load
  Member links: 2 (max not set, min not set)
    Async5
    Async6


!--- Note that the bundle is using Async line 5 and 6 for multilink. 

bobslake-nas-01#show caller 
                                                Active    Idle
  Line         User               Service       Time      Time
  con 0        admin              Host connect  1w4d      16:50:19  
  tty 5        charlie             Async         00:04:34  00:01:54  
  tty 6        charlie             Async         00:02:00  00:00:57  
  vty 1        admin              VTY           00:13:43  00:00:00  
  As5          charlie             PPP           00:04:25  00:00:00  
  As6          charlie             PPP           00:01:53  00:00:00  
  Vi1          charlie             PPP   Bundle  00:04:25  00:00:57  


!--- User charlie has two async lines, two tty, 
!--- and one virtual interface bundle.

bobslake-nas-01#show caller user charlie

  User: charlie, line tty 5, service Async

!--- shows hardware level settings for user charlie (first connection)

        Active time 00:04:43, Idle time 00:00:06
  Timeouts:            Absolute  Idle      Idle
                                 Session   Exec
      Limits:          -         -         00:10:00  
      Disconnect in:   -         -         -         
  TTY: Line 5, running PPP on As5

!--- user charlie is using tty 5

  DS0: (slot/unit/channel)=0/0/0  Line: Baud rate (TX/RX) is 115200/115200, 
no parity, 1 stopbits, 8 databits
  Status: Ready, Active, No Exit Banner, Async Interface Active
          HW PPP Support Active
  Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out
                Modem Callout, Modem RI is CD, 
                Line usable as async interface, Integrated Modem
  Modem State: Ready

  User: charlie, line tty 6, service Async


!--- shows hardware level settings for user charlie (second connection)

        Active time 00:02:09, Idle time 00:01:06
  Timeouts:            Absolute  Idle      Idle
                                 Session   Exec
      Limits:          -         -         00:10:00  
      Disconnect in:   -         -         -         
  TTY: Line 6, running PPP on As6

!--- user charlie is using tty 6

  DS0: (slot/unit/channel)=0/0/1
  Line: Baud rate (TX/RX) is 115200/115200, no parity, 1 stopbits, 8 databits
  Status: Ready, Active, No Exit Banner, Async Interface Active
          HW PPP Support Active
  Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out
                Modem Callout, Modem RI is CD, 
                Line usable as async interface, Integrated Modem
  Modem State: Ready

  User: charlie, line As5, service PPP

!--- PPP setting for user charlie (first connection).

        Active time 00:04:34, Idle time 00:00:00
  Timeouts:            Absolute  Idle
      Limits:          -         -         
      Disconnect in:   -         -         
  PPP: LCP Open, multilink Open, CHAP (<- AAA)

!--- MPPP state is open.

  Dialer: Connected, inbound
          Type is IN-BAND ASYNC, group Async5
  IP: Local 172.21.10.10
  Bundle: Member of charlie, last input 00:00:00
  Counts: 54 packets input, 4110 bytes, 0 no buffer
          1 input errors, 1 CRC, 0 frame, 0 overrun
          73 packets output, 4150 bytes, 0 underruns
          0 output errors, 0 collisions, 0 interface resets

!--- Packets are passing through the connection.

  User: charlie, line As6, service PPP

!--- PPP setting for user charlie (second connection).

        Active time 00:02:02, Idle time 00:00:00
  Timeouts:            Absolute  Idle
      Limits:          -         -         
      Disconnect in:   -         -         
  PPP: LCP Open, multilink Open, CHAP (<- AAA)

!--- MPPP state is Open.

  Dialer: Connected, inbound
          Type is IN-BAND ASYNC, group Async6
  IP: Local 172.21.10.10
  Bundle: Member of charlie, last input 00:00:00
  Counts: 6 packets input, 462 bytes, 0 no buffer
          1 input errors, 1 CRC, 0 frame, 0 overrun
          20 packets output, 1129 bytes, 0 underruns
          0 output errors, 0 collisions, 0 interface resets

!--- Packets are passing through the connection.

    
User: charlie, line Vi1, service PPP Bundle


!--- Bundle information for user charlie

        Active time 00:04:34, Idle time 00:00:06
  Timeouts:            Absolute  Idle
      Limits:          -         -         
      Disconnect in:   -         -         
  PPP: LCP Open, multilink Open, IPCP
  IP: Local 172.21.104.254, remote 172.21.104.2

!--- Remote IP address is obtained from IP pool.

  Counts: 50 packets input, 4034 bytes, 0 no buffer
          0 input errors, 0 CRC, 0 frame, 0 overrun
          80 packets output, 8750 bytes, 0 underruns
          0 output errors, 0 collisions, 0 interface resets

 

bobslake-nas-01#debug vtemplate
Virtual Template debugging is on
bobslake-nas-01#debug ppp multilink events 
Multilink events debugging is on
bobslake-nas-01#debug ppp negotiation 
PPP protocol negotiation debugging is on
bobslake-nas-01#debug ppp authentication 
PPP authentication debugging is on
bobslake-nas-01#debug ppp error 
PPP protocol errors debugging is on
bobslake-nas-01#debug modem
Modem control/process activation debugging is on
bobslake-nas-01#show debug
General OS:
  Modem control/process activation debugging is on
PPP:
  PPP authentication debugging is on
  PPP protocol errors debugging is on
  PPP protocol negotiation debugging is on
  Multilink events debugging is on
VTEMPLATE:
  Virtual Template debugging is on

bobslake-nas-01#
Jun 28 15:41:46.281 UTC: TTY5: DSR came up
Jun 28 15:41:46.281 UTC: tty5: Modem: IDLE->(unknown)

!--- Modem responds to first dialin connection.

Jun 28 15:41:46.281 UTC: TTY5: EXEC creation
...
Jun 28 15:41:48.537 UTC: TTY5 Autoselect cmd:  ppp negotiate
Jun 28 15:41:48.537 UTC: TTY5: EXEC creation
...
Jun 28 15:41:48.545 UTC: As5 IPCP: Install route to 172.21.104.4

!--- IP address for first link obtained from address pool.
!--- Route will be removed when link is virtualized later. 

Jun 28 15:41:50.541 UTC: As5 PPP: Treating connection as a callin
Jun 28 15:41:50.541 UTC: As5 PPP: Phase is ESTABLISHING, Passive Open
Jun 28 15:41:50.541 UTC: As5 LCP: State is Listen

!--- LCP negotiation begins.

Jun 28 15:41:51.549 UTC: As5 LCP: I CONFREQ [Listen] id 3 len 46
...
Jun 28 15:41:51.549 UTC: Unthrottle 5
Jun 28 15:41:51.549 UTC: As5 LCP: O CONFREQ [Listen] id 1 len 47
...
Jun 28 15:41:51.549 UTC: As5 LCP: O CONFREJ [Listen] id 3 len 7
...
Jun 28 15:41:53.549 UTC: As5 LCP: O CONFREQ [REQsent] id 2 len 47
Jun 28 15:41:53.549 UTC: As5 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Jun 28 15:41:53.549 UTC: As5 LCP:    AuthProto CHAP (0x0305C22305)
Jun 28 15:41:53.549 UTC: As5 LCP:    MagicNumber 0x56E3C73E (0x050656E3C73E)
Jun 28 15:41:53.549 UTC: As5 LCP:    PFC (0x0702)
Jun 28 15:41:53.549 UTC: As5 LCP:    ACFC (0x0802)
Jun 28 15:41:53.549 UTC: As5 LCP:    MRRU 1524 (0x110405F4)

!--- Max-Receive-Reconstructed-Unit:Maximum packet size 
!--- that the peer will reconstruct.
!--- Both sides must agree on the packet size (MRRU).

Jun 28 15:41:53.549 UTC: As5 LCP:    EndpointDisc 1 Local
Jun 28 15:41:53.549 UTC: As5 LCP:     (0x131201626F62736C616B652D6E61732D)
Jun 28 15:41:53.549 UTC: As5 LCP:     (0x3031)
Jun 28 15:41:53.789 UTC: As5 LCP: I CONFACK [REQsent] id 2 len 47
Jun 28 15:41:53.789 UTC: As5 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Jun 28 15:41:53.789 UTC: As5 LCP:    AuthProto CHAP (0x0305C22305)
Jun 28 15:41:53.789 UTC: As5 LCP:    MagicNumber 0x56E3C73E (0x050656E3C73E)
Jun 28 15:41:53.789 UTC: As5 LCP:    PFC (0x0702)
Jun 28 15:41:53.789 UTC: As5 LCP:    ACFC (0x0802)
Jun 28 15:41:53.789 UTC: As5 LCP:    MRRU 1524 (0x110405F4)

!--- Max-Receive-Reconstructed-Unit:Maximum packet size that 
!--- the peer will reconstruct.

Jun 28 15:41:53.789 UTC: As5 LCP:    EndpointDisc 1 Local
Jun 28 15:41:53.789 UTC: As5 LCP:     (0x131201626F62736C616B652D6E61732D)
Jun 28 15:41:53.789 UTC: As5 LCP:     (0x3031)Jun 28 15:41:54.541 UTC: 
As5 LCP: I CONFREQ [ACKrcvd] id 4 len 46
...
Jun 28 15:41:54.541 UTC: As5 LCP: O CONFREJ [ACKrcvd] id 4 len 7
...
Jun 28 15:41:54.717 UTC: As5 LCP: I CONFREQ [ACKrcvd] id 5 len 43
...
Jun 28 15:41:54.717 UTC: As5 LCP: O CONFACK [ACKrcvd] id 5 len 43
...
Jun 28 15:41:54.721 UTC: As5 LCP: State is Open

!--- LCP negotiation is complete.

Jun 28 15:41:54.721 UTC: As5 PPP: Phase is AUTHENTICATING, by this end

!--- CHAP authentication begins.

Jun 28 15:41:54.721 UTC: As5 CHAP: O CHALLENGE id 1 len 36 from "bobslake-nas-01"
Jun 28 15:41:54.909 UTC: As5 CHAP: I RESPONSE id 1 len 27 from "charlie"
Jun 28 15:41:54.909 UTC: As5 CHAP: O SUCCESS id 1 len 4

!--- CHAP authentication is successful.

Jun 28 15:41:54.909 UTC: As5 MLP: Multilink up event pending
Jun 28 15:41:54.913 UTC: As5 PPP: Phase is VIRTUALIZED

!--- Call is virtualized after authentication.

Jun 28 15:41:54.913 UTC: Vi1 VTEMPLATE: Reuse Vi1, recycle queue size 0
Jun 28 15:41:54.913 UTC: Vi1 VTEMPLATE: Hardware address 0010.7b4d.7046
Jun 28 15:41:54.913 UTC: Vi1 PPP: Phase is DOWN, Setup
Jun 28 15:41:54.913 UTC: Vi1 MLP: VP: Clone from Vtemplate 1 block=1
Jun 28 15:41:54.913 UTC: Vi1 VTEMPLATE: Has a new cloneblk vtemplate
Jun 28 15:41:54.913 UTC: Vi1 VTEMPLATE: ************* CLONE VACCESS1 ***********
Jun 28 15:41:54.913 UTC: Vi1 VTEMPLATE: Clone from Virtual-Template1

!--- Cloning from Virtual-Template.

interface Virtual-Access1
default ip address
no ip address
encap ppp
description Template for Multilink Users
ip unnumbered Loopback0
no ip directed-broadcast
no logging event link-status
no snmp trap link-status
peer default ip address pool addr-pool
ppp authentication chap
ppp multilink
ip unnum loop 1
end
Jun 28 15:41:55.005 UTC: Vi1 PPP: Treating connection as a dedicated line
Jun 28 15:41:55.005 UTC: Vi1 PPP: Phase is ESTABLISHING, Active Open
Jun 28 15:41:55.005 UTC: Vi1 LCP: O CONFREQ [Closed] id 1 len 37
...
Jun 28 15:41:55.009 UTC: Vi1 PPP: Phase is UP
Jun 28 15:41:55.009 UTC: Vi1 IPCP: O CONFREQ [Closed] id 1 len 10
Jun 28 15:41:55.009 UTC: Vi1 IPCP:    Address 172.21.104.254 (0x0306AC1568FE)
Jun 28 15:41:55.009 UTC: As5 MLP: charlie, multilink up, first link

!--- First link in multilink bundle for user charlie is up.

Jun 28 15:41:55.009 UTC: As5 IPCP: Remove route to 172.21.104.4

!--- Temporary route to first link removed since link is virtualized.

Jun 28 15:41:55.069 UTC: Vi1 IPCP: I CONFREQ [REQsent] id 1 len 40
...
Jun 28 15:41:55.069 UTC: Vi1 IPCP: Pool returned 172.21.104.2

!--- IP address for virtual bundle obtained from address pool.

Jun 28 15:41:55.069 UTC: Vi1 IPCP: O CONFREJ [REQsent] id 1 len 22
...
Jun 28 15:41:55.085 UTC: Vi1 CCP: I CONFREQ [Not negotiated] id 1 len 15
Jun 28 15:41:55.085 UTC: Vi1 CCP:    MS-PPC supported bits 0x00000001 (0x120600)
...
Jun 28 15:41:55.181 UTC: Vi1 IPCP: I CONFACK [REQsent] id 1 len 10
Jun 28 15:41:55.181 UTC: Vi1 IPCP:    Address 172.21.104.254 (0x0306AC1568FE)
Jun 28 15:41:57.009 UTC: Vi1 IPCP: TIMEout: State ACKrcvd
Jun 28 15:41:57.009 UTC: Vi1 IPCP: O CONFREQ [ACKrcvd] id 2 len 10
Jun 28 15:41:57.009 UTC: Vi1 IPCP:    Address 172.21.104.254 (0x0306AC1568FE)
Jun 28 15:41:59.009 UTC: Vi1 IPCP: TIMEout: State REQsent
Jun 28 15:41:59.009 UTC: Vi1 IPCP: O CONFREQ [REQsent] id 3 len 10
Jun 28 15:41:59.009 UTC: Vi1 IPCP:    Address 172.21.104.254 (0x0306AC1568FE)
Jun 28 15:41:59.617 UTC: Vi1 IPCP: I CONFREQ [REQsent] id 2 len 34
...
Jun 28 15:41:59.617 UTC: Vi1 IPCP: O CONFREJ [REQsent] id 2 len 16
...
Jun 28 15:41:59.633 UTC: Vi1 PPP: Replace IPCP code 2 id 3 with id 3
Jun 28 15:41:59.633 UTC: Vi1 IPCP: I CONFACK [REQsent] id 3 len 10
Jun 28 15:41:59.633 UTC: Vi1 IPCP:    Address 172.21.104.254 (0x0306AC1568FE)
Jun 28 15:41:59.777 UTC: Vi1 IPCP: I CONFREQ [ACKrcvd] id 3 len 22
...
Jun 28 15:41:59.777 UTC: Vi1 IPCP: O CONFNAK [ACKrcvd] id 3 len 22
...
Jun 28 15:41:59.937 UTC: Vi1 IPCP: I CONFREQ [ACKrcvd] id 4 len 22
Jun 28 15:41:59.937 UTC: Vi1 IPCP:    Address 172.21.104.2 
(0x0306AC156802)

!--- IP address of virtual bundle was previously obtained from 
!--- address pool.

Jun 28 15:41:59.937 UTC: Vi1 IPCP:    PrimaryDNS 172.22.53.210 (0x8106AC1635D2)
Jun 28 15:41:59.937 UTC: Vi1 IPCP:    SecondaryDNS 171.68.10.70 (0x8306AB440A46)
Jun 28 15:41:59.937 UTC: Vi1 IPCP: O CONFACK [ACKrcvd] id 4 len 22
Jun 28 15:41:59.937 UTC: Vi1 IPCP:    Address 172.21.104.2 (0x0306AC156802)
Jun 28 15:41:59.937 UTC: Vi1 IPCP:    PrimaryDNS 172.22.53.210 (0x8106AC1635D2)
Jun 28 15:41:59.937 UTC: Vi1 IPCP:    SecondaryDNS 171.68.10.70 (0x8306AB440A46)
Jun 28 15:41:59.937 UTC: Vi1 IPCP: State is Open
Jun 28 15:41:59.941 UTC: Vi1 IPCP: Install route to 172.21.104.2

!--- Add route for virtual bundle to routing table.

Jun 28 15:42:44.383 UTC: TTY51: timer type 1 expired
Jun 28 15:42:44.383 UTC: TTY51:  Exec timer (continued)

!--- Modem comes up for multilink connection.

Jun 28 15:44:20.385 UTC: TTY6: DSR came up

!--- Async 6 is used for second connection.

Jun 28 15:44:20.385 UTC: tty6: Modem: IDLE->(unknown)
Jun 28 15:44:20.385 UTC: TTY6: EXEC creation
...
Jun 28 15:44:20.529 UTC: TTY6 Autoselect cmd:  ppp negotiate
Jun 28 15:44:20.529 UTC: TTY6: EXEC creation
...Jun 28 15:44:20.661 UTC: As6 IPCP: Install route to 172.21.104.5

!--- IP address for second link is obtained from the pool.
!--- Route will be removed when link is added to the MPPP bundle.

Jun 28 15:44:22.661 UTC: As6 PPP: Treating connection as a callin
Jun 28 15:44:22.661 UTC: As6 PPP: Phase is ESTABLISHING, Passive Open

!--- LCP negotiation begins.

Jun 28 15:44:22.661 UTC: As6 LCP: State is Listen
Jun 28 15:44:23.521 UTC: As6 LCP: I CONFREQ [Listen] id 2 len 46
...
Jun 28 15:44:23.525 UTC: Unthrottle 6
Jun 28 15:44:23.525 UTC: As6 LCP: O CONFREQ [Listen] id 1 len 47
...
Jun 28 15:44:23.525 UTC: As6 LCP: O CONFREJ [Listen] id 2 len 7
Jun 28 15:44:23.525 UTC: As6 LCP:    Callback 6  (0x0D0306)
Jun 28 15:44:25.525 UTC: As6 LCP: TIMEout: State REQsent
Jun 28 15:44:25.525 UTC: As6 LCP: O CONFREQ [REQsent] id 2 len 47
...
Jun 28 15:44:25.765 UTC: As6 LCP: I CONFACK [REQsent] id 2 len 47
...
Jun 28 15:44:26.533 UTC: As6 LCP: I CONFREQ [ACKrcvd] id 3 len 46
...
Jun 28 15:44:26.533 UTC: As6 LCP: O CONFREJ [ACKrcvd] id 3 len 7
Jun 28 15:44:26.533 UTC: As6 LCP:    Callback 6  (0x0D0306)
Jun 28 15:44:26.741 UTC: As6 LCP: I CONFREQ [ACKrcvd] id 4 len 43
...
Jun 28 15:44:26.741 UTC: As6 LCP: O CONFACK [ACKrcvd] id 4 len 43
...
Jun 28 15:44:26.741 UTC: As6 LCP: State is Open

!--- LCP negotiation is complete.
!--- CHAP authentication begins.

Jun 28 15:44:26.745 UTC: As6 PPP: Phase is AUTHENTICATING, by this end
Jun 28 15:44:26.745 UTC: As6 CHAP: O CHALLENGE id 1 len 36 from "bobslake-nas-01"
Jun 28 15:44:26.981 UTC: As6 CHAP: I RESPONSE id 1 len 27 from "charlie"
Jun 28 15:44:26.981 UTC: As6 CHAP: O SUCCESS id 1 len 4

!--- CHAP authentication is successful. 

Jun 28 15:44:26.981 UTC: As6 MLP: Multilink up event pending
Jun 28 15:44:26.981 UTC: As6 PPP: Phase is VIRTUALIZED

!--- Link is virtualized.

Jun 28 15:44:26.985 UTC: As6 MLP: charlie, multilink up

!--- Multilink connection is up.

Jun 28 15:44:26.985 UTC: As6 IPCP: Remove route to 172.21.104.5

!--- Use IP address previously assigned to the bundle 
!--- (in this case, 172.21.104.2).

bobslake-nas-01#

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Команды для устранения неполадок

Некоторые команды show поддерживаются Интерпретатором выходных данных; это позволяет выполнять анализ выходных данных команды show.

Примечание: Прежде чем применять команды отладки, ознакомьтесь с разделом "Важные сведения о командах отладки".

  • debug vtemplate - Информация клонирования Показов для интерфейса виртуального доступа со времени, это клонировано от виртуального шаблона до времени, которое это снижается.

  • debug ppp multilink events - Отображает информацию о событиях, влияющих на многоканальные соединения.

  • debug ppp negotiation - вывод сведений о трафике PPP и обмене данными в процессе согласования параметров протокола управления каналом (LCP), аутентификации и протокола управления сетью (NCP). В успешных переговорах PPP сначала выясняется состояние LCP, затем проводится аутентификация и наконец выполняется согласование NCP.

  • debug ppp authenticaion - Отображает сообщения протокола аутентификации PPP, включая обмены пакетами Протокола аутентификации по квитированию вызова (CHAP) и обмены Протокола аутентификации пароля (PAP).

  • debug ppp error – отображает ошибки протокола и статистику ошибок, связанных с согласованием и функционированием PPP-соединения.

  • команда debug modem отображает операции модемной линии на сервере доступа.


Дополнительные сведения


Document ID: 9553