Широкополосные кабельные сети : Системы терминирования кабельных модемов (CMTS)

Как Загружать файл конфигурации IOS на кабельные модемы Cisco Используя CLI Cisco CMTS

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Файлы Конфигурации ПО IOS� Cisco являются текстовыми файлами, которые содержат конфигурацию, которая будет передаваться маршрутизаторам. В случае кабельных модемов Cisco отправляемая конфигурация обычно содержит списки доступа, имена хостов, строки сообществ SNMP, пароли или конфигурацию маршрутизации, отличную от стандартной конфигурации мостовых соединений. Чтобы отправить файл конфигурации Cisco IOS, необходимо внедрить это файл в файл конфигурации Data-over-Cable Service Interface Specifications (DOCSIS) , который используют кабельные модемы в TFTP-части процесса инициализации.

Существует два способа загрузить Файл конфигурации Cisco IOS к кабельным модемам Cisco.

Первым, чаще всего встречающимся способом является использование инструмента DOCSIS CPE Configurator. См. "Конфигуратор DOCSIS CPE Cisco (только для зарегистрированных клиентов)". Документ, Создающий Конфигурационные файлы DOCSIS 1.0, Использование DOCSIS-конфигуратора Cisco (только зарегистрированные клиенты) содержит подробное объяснение о том, как сделать это.

Ту же задачу можно выполнить другим способом - используя интерфейс командной строки (CLI) в среде Cisco IOS терминальной системы кабельного модема (CMTS).

В этом документе подробно описывается второй способ загрузки файла конфигурации IOS на кабельные модемы Cisco без необходимости использовать конфигуратор DOCSIS. Для этого мы используем расширенную версию конфигурации все в одном, которая позволяет CMTS Cisco быть настроенным как DHCP, ToD и Tftp server, а также настраивать файл конфигурации DOCSIS на самом CMTS.

Когда мы хотим передать файл конфигурации к кабельным модемам с помощью CLI для настройки файла конфигурации DOCSIS, мы должны добавить параметр DHCP, названный Vendor Specific Information Option DHCP, также известным как опция 43.

Основным преимуществом настройки кабельных модемов указанным способом является то, что все операции можно выполнить с помощью Cisco CMTS, что устраняет необходимость использования других серверов (например, DHCP, TFTP или ToD) и программного обеспечения (например, DOCSIS CPE Configurator Tool) для успешной пересылки конфигураций Cisco IOS кабельным модемам Cisco и их активации с помощью настраиваемой конфигурации.

Перед началом работы

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Предварительные условия

Пользователь должен обладать следующими общими знаниями:

  • Протокол DOCSIS

  • Интерфейс командной строки (CLI) Cisco IOS на маршрутизаторах семейства uBR

  • UNIX

  • Протокол динамической настройки узлов (DHCP)

Используемые компоненты

См. приведенный ниже раздел "Настройка всех компонентов с помощью одной конфигурации, включая параметр 43 для DHCP".

Вариант DHCP (вариант 43) данных, определяемых поставщиком

Параметр 43 – это параметр DHCP, используемый клиентами и серверами для обмена определяемой поставщиком информацией.

Эта опция, как правило, форматируется в стиле "Типа - Длина-Значения", где другие части информации могут быть представлены другими типами подпараметра. Значение поля "Value" определяется изготовителем конечных устройств. На рисунке 1 представлен параметр 43 в графическом виде.

Введите Длина Значение Введите Длина Значение
T1 n d1 d2 ......... T2 n D1 D2 ........

Рисунок 1 - структура Типа - Длина-Значения данных передана в Опции 43.

Чтобы загрузить конфигурационные файлы Cisco IOS для кабельных модемов Cisco, используйте два дополнительных параметра: Vendor ID и Vendor Specific Information Option (VSIF).

Подпараметр Иденификатора поставщика имеет тип 8. Трехбайтовый Organization Unique Identifier (OUI) для поставщика обычно - первые три байта MAC-адреса кабельного модема. Это значение обычно представлено шестнадцатеричным числом. Это поле должно быть 00:00:0C (в Hex) для оборудования Cisco Systems. Рисунок 2 ниже дает шестнадцатеричные числа для подпараметра Иденификатора поставщика.

Введите Длина Значение
08 03 00:00:0C

Рисунок 2 - Иденификатор поставщика Подпараметра (В Шестнадцатеричном значении)

Второй использованный подпараметр – поле сведений конкретного поставщика (VSIF). Этот подпараметр имеет тип 128, и именно любые произвольные значения определены изготовителем кабельного модема. Кабельный модем Cisco использует это поле для определения имени файла конфигурации Cisco IOS, который следует загрузить (при его наличии) в маршрутизатор.

В этом поле можно также указать произвольные команды Cisco IOS. Это поле обычно представлено десятичным числом, разделенным точками. Нотация десятичного представления с точкой является десятичным представлением букв согласно ASCII, в котором каждая буква имеет десятичное значение. Точки используются между десятичным представлением для облегчения восприятия.

В этом документе будет показано, как загрузить файл конфигурации Cisco IOS с именем ios.cf. Имя этого файла получается при преобразовании из ASCII в десятичное число с запятой.

Чтобы узнать, что являет собой преобразование ASCII в десятичное представление адреса с точкой, команда UNIX man ascii может использоваться следующим образом. Эта команда отображает несколько таблиц преобразований. Мы должны искать Десятичное число - Таблица символов.

sj-cse-494% man ascii
Reformatting page.  Wait... done

ASCII(5)           Headers, Tables, and Macros           ASCII(5)

NAME
     ASCII - map of ASCII character set
.... (skip the beginning)

 	 Decimal - Character

     |  0 NUL|  1 SOH|  2 STX|  3 ETX|  4 EOT|  5 ENQ|  6 ACK|  7 BEL|
     |  8 BS |  9 HT | 10 NL | 11 VT | 12 NP | 13 CR | 14 SO | 15 SI |
     | 16 DLE| 17 DC1| 18 DC2| 19 DC3| 20 DC4| 21 NAK| 22 SYN| 23 ETB|
     | 24 CAN| 25 EM | 26 SUB| 27 ESC| 28 FS | 29 GS | 30 RS | 31 US |
     | 32 SP | 33  ! | 34  " | 35  # | 36  $ | 37  % | 38  & | 39  ' |
     | 40  ( | 41  ) | 42  * | 43  + | 44  , | 45  - | 46  . | 47  / |
     | 48  0 | 49  1 | 50  2 | 51  3 | 52  4 | 53  5 | 54  6 | 55  7 |
     | 56  8 | 57  9 | 58  : | 59  ; | 60  < | 61  = | 62  > | 63  ? |
     | 64  @ | 65  A | 66  B | 67  C | 68  D | 69  E | 70  F | 71  G |
     | 72  H | 73  I | 74  J | 75  K | 76  L | 77  M | 78  N | 79  O |
     | 80  P | 81  Q | 82  R | 83  S | 84  T | 85  U | 86  V | 87  W |
     | 88  X | 89  Y | 90  Z | 91  [ | 92  \ | 93  ] | 94  ^ | 95  _ |
     | 96  ` | 97  a | 98  b | 99  c |100  d |101  e |102  f |103  g |
     |104  h |105  i |106  j |107  k |108  l |109  m |110  n |111  o |
     |112  p |113  q |114  r |115  s |116  t |117  u |118  v |119  w |
     |120  x |121  y |122  z |123  { |124  | |125  } |126  ~ |127 DEL|

Поэтому цифровое представление с разделителями-точками ios.cf 105.111.115.46.99.102 как показано ниже на рисунке 3.

я o s . c _________ F
105 111 115 46 99 192

Рисунок 3 - Цифровое представление с разделителями-точками ios.cf имени файла.

Так как VSIF – это формат Type-Length-Value, полное название файла ios.cf конфигурации Cisco IOS будет следующим: 128.6.105.111.115.46.99.192. Как вы можете видеть, 128.6 был добавлен к цифровому представлению с разделителями-точками ios.cf, показанного на рисунке 3. Помните, что "128" тип, и "6" длина.

128.6.105.111.115.46.99.192 – значение, введенное в поле "VSIF" на вкладке "Vendor Info" средства DOCSIS CPE Configurator версии 3.2, как показано на рис. 4 ниже.

iosconfig_option43.jpg

Рисунок 4. Поле Vendor Info в средстве конфигурации DOCSIS CPE.

Однако при выполнении этой функции в Cisco IOS с помощью параметра DHCP 43 сведения TLV должны быть выражены в шестнадцатеричных числах. В этом документе описано это шестнадцатеричное выражение.

Чтобы получить шестнадцатеричное представление символов ASCII, можно использовать команду Unix:

echo -n "ios.cf" | od -t x1 | cut -s -d' ' -f2- | tr ' ' ':'

sj-cse-494% echo -n "ios.cf" | OD -t x1 | cut -s -d' ' -f2- | tr ' ' ':'
69:6f:73:2e:63:66

Или можно использовать предыдущую команду man ascii операционной системы UNIX и найти таблицу "Hexadecimal - Character".

sj-cse-494% man ASCII
Reformatting page.  Wait... done

ASCII(5)           Headers, Tables, and Macros           ASCII(5)

NAME
     ASCII - map of ASCII character set
.... (skip the beginning)


     Hexadecimal - Character

     | 00 NUL| 01 SOH| 02 STX| 03 ETX| 04 EOT| 05 ENQ| 06 ACK| 07 BEL|
     | 08 BS | 09 HT | 0A NL | 0B VT | 0C NP | 0D CR | 0E SO | 0F SI |
     | 10 DLE| 11 DC1| 12 DC2| 13 DC3| 14 DC4| 15 NAK| 16 SYN| 17 ETB|
     | 18 CAN| 19 EM | 1A SUB| 1B ESC| 1C FS | 1D GS | 1E RS | 1F US |
     | 20 SP | 21  ! | 22  " | 23  # | 24  $ | 25  % | 26  & | 27  ' |
     | 28  ( | 29  ) | 2A  * | 2B  + | 2C  , | 2D  - | 2E  . | 2F  / |
     | 30  0 | 31  1 | 32  2 | 33  3 | 34  4 | 35  5 | 36  6 | 37  7 |
     | 38  8 | 39  9 | 3A  : | 3B  ; | 3C  < | 3D  = | 3E  > | 3F  ? |
     | 40  @ | 41  A | 42  B | 43  C | 44  D | 45  E | 46  F | 47  G |
     | 48  H | 49  I | 4A  J | 4B  K | 4C  L | 4D  M | 4E  N | 4F  O |
     | 50  P | 51  Q | 52  R | 53  S | 54  T | 55  U | 56  V | 57  W |
     | 58  X | 59  Y | 5A  Z | 5B  [ | 5C  \ | 5D  ] | 5E  ^ | 5F  _ |
     | 60  ` | 61  a | 62  b | 63  c | 64  d | 65  e | 66  f | 67  g |
     | 68  h | 69  i | 6A  j | 6B  k | 6C  l | 6D  m | 6E  n | 6F  o |
     | 70  p | 71  q | 72  r | 73  s | 74  t | 75  u | 76  v | 77  w |
     | 78  x | 79  y | 7A  z | 7B  { | 7C  | | 7D  } | 7E  ~ | 7F DEL|

На рисунке 5 ниже отображено значение поля Vendor Specific Information Field (VSIF) в дробном и шестнадцатиричном форматах.

Введите Длина Значение
Десятичный с разделительными точками 128 6 105.111.115.46.99.102
Шестнадцатеричный 80 06 69:6F:73:2E:63:66

Рис. 5 – подпараметр VSIF в десятичном представлении с точкой и в шестнадцатеричном.

Функционально законченная команда настройки config с параметром 43 DHCP

При разработке и тестировании этой конфигурации использовались следующие версии программного и аппаратного обеспечения.

  • Cisco uBR10012 под управлением 12.2(2)XF

  • Cisco CVA120 под управлением операционной системы Cisco IOS версии 12.2(2)XA

Сведения, представленные в этом документе, были получены от устройств в специфической лабораторной среде. Все устройства, используемые в этом документе, были запущены с чистой конфигурацией (конфигурацией по умолчанию). В рабочей сети необходимо изучить потенциальное воздействие всех команд Cisco IOS до их использования.

Первый шаг. Создайте файл конфигурации DOCSIS с правильной строкой параметра 43

Первый шаг в настройке конфигурации опции 43 – выяснить необходимое шестнадцатеричное значение идентификатора поставщика и необходимое шестнадцатеричное значение VSIF подопций DHCP опции 43.

Ниже в таблице сведены вместе значения, которые подробно обсуждались в разделе "Информация, относящаяся к поставщику".

Вложенный параметр идентификатора производителя (Vendor ID) Дополнительный параметр VSIF
TLV Введите Длина Значение Введите Длина Значение
Шестнадцатеричный 08 03 00:00:0C 80 06 69:6F:73:2E:63:66
Значение Тип идентификатора поставщика Длина идентификационного номера поставщика Идентификатор Cisco Тип VSIF Длина VSIF (имя файла) ios.cf

Рис. 6

Как только мы знаем, какое значение мы введем, мы должны использовать CLI CMTS Cisco для генерации всех свойств, необходимых для Файла конфигурации DOCSIS, включая параметр DHCP 43.

Для создания Файла конфигурации DOCSIS, мы должны ввести имя файла DOCSIS config-file кабеля команды global . Следующий результат показывает создание файла конфигурации DOCSIS с именем platinum.cm. Все настройки platinum.cm описаны ниже.

Note: 
!--- Comments are in blue.


cable config-file platinum.cm  
  
!---  Name of the DOCSIS config file is platinum.cm

  service-class 1 priority 2  
  
!---  The Upstream Channel priority is 2

  service-class 1 max-upstream 128 
  
!---  The Maximum upstream value is 128Kbps

  service-class 1 guaranteed-upstream 10
  
!---  The Guaranteed Upstream is 10 Kbps

  service-class 1 max-downstream 10000 
  
!---  The Maximum Downstream is 10Mbps

  service-class 1 max-burst 1600
  
!---  The Maximum Upstream Transmit burst is 1600 bytes

  cpe max 10 
  
!---  The Maximum number of CPE's is 10

  timestamp
  
!---  Enable timestamp generation

  option 43 hex 08:03:00:00:0C:80:06:69:6F:73:2E:63:66  
  
!---  Using option 43 to send the IOS Configuration file named "ios.cf" 
  !---  to cable modems.

caution Внимание.  : Команда cable config-file была введена в программном обеспечении Cisco IOS версии 12.1(2)EC1 для uBR7200 и uBR7100, а также в программном обеспечении Cisco IOS версии 12.2(1)XF1 для uBR10K.

Примечание: Будьте определенны, некоторый, что вы правильно ввели данные TLV при использовании шестнадцатеричного параметра. Неправильно введенные данные могут привести к сбросу CM, переходу в автономный режим или зависанию, тогда для продолжения работы понадобиться выключить и снова включить питание.

Второй шаг – создайте пул DHCP для настройки сервера DHCP

Как только мы создали platinum.cm файла конфигурации DOCSIS, мы должны настроить CMTS, чтобы быть DHCP server и настроить опции, необходимые для функциональных возможностей DHCP. См. "Служба DHCP Cisco IOS на CMTS", в котором описана каждая команда, используемая для создания пула DHCP. Здесь мы всего лишь резюмируем конфигурацию и дадим краткое описание.

Пул DHCP имеет следующую конфигурацию:

ip dhcp pool surf
  
!---  name of the dhcp pool. This scope is for the cable modems attached 
  !---  to interface cable 5/0/0

  network 10.1.4.0 255.255.255.0
  
!---  pool of addresses for scope from interface c5/0/0

  bootfile platinum.cm
  
!---  DOCSIS config file name associated with this pool

  next-server 10.1.4.1
  
!---  IP address of TFTP server which sends bootfile

  default-router 10.1.4.1
  
!---  default gateway for cable modems, necessary to get DOCSIS files

  option 7 ip 10.1.4.1
  
!---  Log Server DHCP option

  option 4 ip 10.1.4.1
  
!---  ToD server IP address

  option 2 hex ffff.8f80
  
!---  Time offset for ToD, in seconds, HEX, from GMT, -28,000 = PST = ffff.8f80

  lease 7 0 10
  
!---  lease 7 days 0 hours 10 minutes

  ! 

Третий шаг – сконфигурируйте CMTS в качестве сервера TFTP

Третий шаг – настроить CMTS в качестве TFTP-сервера. Для этого потребуется:

  1. Используйте команду tftp-server

  2. Сообщите TFTP-серверу местоположение файла ios.cf

Для этого можно выполнить команду "tftp-server disk0:ios.cf alias ios.cf". Обратите внимание, что эта команда помещает файл ios.cf на disk0.

tftp-server server

!--- enable the cmts to act as a tftp server

tftp-server disk0:ios.cf alias ios.cf

!--- get the IOS config file called ios.cf that is pre-downloaded to disk0
!--- this IOS  config file was built with a text editor and tftp to disk0  


Чтобы поместить файл ios.cf во флэш-память или на disk0 (для uBR10012), следует применить протокол TFTP к файлу, созданному с помощью редактора текстовых файлов. Чтобы сделать это сначала удостоверяется, что можно пропинговать tftp server, где расположена Конфигурация Cisco IOS.

Затем следует ввести глобальную команду copy tftp <device>, чтобы разместить файл в CMTS. Обычно флэш-память используется для uBR7200 или uBR7100 или uBR10K, однако, данный пример показывает, как использовать disk0 для uBR10012.

schooner#copy tftp disk0
Address or name of remote host []? 172.16.30.2
Source filename []? ios.cf
Destination filename [ios.cf]? 

Accessing tftp://172.16.30.2/ios.cf...
Loading ios.cf from 172.16.30.2 (via FastEthernet0/0/0): !
[OK - 173/4096 bytes]

173 bytes copied in 0.152 secs

Чтобы убедиться, что файл конфигурации IOS хранится на CMTS, выполните команду dir.

schooner#dir
Directory of disk0:/
    3  -rw-    11606084   Sep 17 2001 13:31:38  ubr10k-k8p6-mz.122-2.XF.bin
 2839  -rw-         173   Oct 01 2001 23:29:44  ios.cf
47890432 bytes total (36274176 bytes free)

Для просмотра команд, настроенных в файле ios.cf, можно использовать в CMTS команду more <имя файла>, как показано ниже:

schooner#more ios.cf
hostname SUCCEED
service linenumber
enable password cisco
interface ethernet 0
load 30
no shut
interface cable 0
load 30
no shut
line vty 0 4
password cisco
end

Четвертый шаг – конфигурация CMTS в качестве сервера ToD

Чтобы настроить ToD на CMTS Cisco, необходимы лишь две глобальные команды: service udp-small-servers max-servers no-limit и cable time-server. Конфигурация выглядит следующим образом:

service udp-small-servers max-servers no-limit

!---  supports a large number of modems / hosts attaching quickly

cable timeserver

!---  permits cable modems to obtain Time of Day (ToD) from uBR10012


Конфигурация для CMTS

Полная конфигурация uBR10012 приводится ниже. Все выделенные жирным шрифтом команды относятся к теме данного документа.

Schooner#show run
Building configuration...

Current configuration : 3522 bytes
!
version 12.2
no parser cache
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers max-servers no-limit
!
hostname schooner
!
logging rate-limit console all 10 except critical
enable secret 5 $1$cM7F$ryXH7z/Ly6QCnD2LQ.gZs/
!
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable timeserver
!
cable config-file platinum.cm
 service-class 1 priority 2
 service-class 1 max-upstream 128
 service-class 1 guaranteed-upstream 10
 service-class 1 max-downstream 10000
 service-class 1 max-burst 1600
 cpe max 10
 timestamp
 option 43 hex 08:03:00:00:0C:80:06:69:6F:73:2E:63:66
!
redundancy
 main-cpu
  auto-sync standard
facility-alarm intake-temperature major 49
facility-alarm intake-temperature minor 40
facility-alarm core-temperature major 53
facility-alarm core-temperature minor 45
card 1/0 1oc12pos-1
card 1/1 2cable-tccplus
card 2/0 1gigethernet-1
card 5/0 2cable-mc28
card 7/0 2cable-mc28
ip subnet-zero
no ip domain-lookup
!
ip dhcp pool surf
   network 10.1.4.0 255.255.255.0
   bootfile platinum.cm
   next-server 10.1.4.1 
   default-router 10.1.4.1 
   option 7 ip 10.1.4.1 
   option 4 ip 10.1.4.1 
   option 2 hex ffff.8f80
   lease 7 0 10
!
interface FastEthernet0/0/0
 ip address 172.16.30.50 255.255.255.192
!
interface POS1/0/0
 no ip address
 crc 32   
 pos report all
 POs flag j0 1
!
interface GigabitEthernet2/0/0
 no ip address
 negotiation auto
!
interface Cable5/0/0
 ip address 10.1.4.1 255.255.255.0
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable upstream 0 frequency 40000000
 cable upstream 0 power-level 0
 no cable upstream 0 shutdown
 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.30.1
no ip http server
!
no cdp run
snmp-server community public RO
snmp-server community private RW
snmp-server trap-source Cable5/0/0
snmp-server packetsize 2048
snmp-server enable traps cable
snmp-server host 172.16.30.8 public  cable snmp
snmp-server manager
tftp-server server
tftp-server ios.cf alias ios.cf
!
alias exec scm show cable modem
!
line con 0
line aux 0
line vty 0 4
!
end

schooner#

У других поставщиков CMTS может не быть возможности установить все эти части с помощью только их команды CMTS, тогда как она может быть выполнена полностью в Cisco IOS.

Чтобы кабельные модемы выполняли команды, указанные в файле конфигурации Cisco IOS с именем ios.cf, необходимо перезагрузить рассматриваемые кабельные модемы. Это можно сделать с помощью интерфейса командной строки CMTS, используя команду "clear cable modem <ip address/MAC address> reset".

Schooner#clear cable modem 10.1.4.4 reset

caution Внимание.  : Если вы имеете большую сеть и хотите передать другой файл конфигурации ко всем кабельным модемам на заводе, это рекомендуется для этого в фазах. Это позволит снизить воздействие тысяч кабельных модемов, которые стараются подавить остальных при выходе в сеть в одно и то же время.

Проверка конфигурации

Для проверки конфигурации очистите кабельный модем при помощи команды clear cable modem. Когда кабельный модем снова подключается к сети, Telnet к нему смотрит на конфигурацию.

Schooner#show cable modem 
MAC Address    IP Address      I/F       MAC         Prim RxPwr Timing Num  BPI
                                         State       Sid  (db)  Offset CPEs Enbld
0004.27ca.0e9b 10.1.4.6        C5/0/0/U0 online      1  *0.00   2820   0    no 
0090.9600.703d 10.1.4.2        C5/0/0/U0 online      2   -0.75  2816   0    no 
0003.e38f.f9b5 10.1.4.3        C5/0/0/U0 online      3  *0.00   2822   0    no 
0001.64ff.e4b5 10.1.4.4        C5/0/0/U0 online      4  *0.00   2812   0    no

!--- CVA120
 
0020.4086.2704 10.1.4.5        C5/0/0/U0 online      5   -0.50  2808   0    no 
0020.4086.3324 10.1.4.7        C5/0/0/U0 online      6   -0.50  2808   0    no 
0020.4079.feb4 10.1.4.8        C5/0/0/U0 online      7   0.00   2805   0    no 
0020.4085.d06a 10.1.4.9        C5/0/0/U0 online      8   -0.50  2807   0    no 

Заметьте в данном примере, что команды файла ios.cf, за которыми кабельные модемы для имения имени хоста СЛЕДУЮТ, и действительно это - имя файла, которое замечено когда мы telnet в кабельный модем.

Schooner#telnet 10.1.4.4
Trying 10.1.4.4 ... Open

SUCCEED line 1 


User Access Verification

Password: 
SUCCEED>en
Password: 
SUCCEED#

Чтобы проверить, что Файл конфигурации Cisco IOS был загружен успешно к кабельному модему, используют команду show version. Выходные данные , имеющие отношение к файлу ios.cf, выделены жирным шрифтом.

SUCCEED#show  version
Cisco Internetwork Operating System Software 
IOS (tm) 120 Software (CVA120-K8V4Y5-M), Version 12.2(2)XA, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
TAC:Home:SW:IOS:Specials for info
Copyright (c) 1986-2001 by cisco Systems, Inc.
Compiled Wed 27-Jun-01 02:02 by hwcheng
Image text-base: 0x800100A0, data-base: 0x80782844
ROM: System Bootstrap, Version 12.0(20001010:025045) [spaulsen-blue-3105 3108], DEVELOPMENT SOFTWARE
ROM: 120 Software (CVA120-K8V4Y5-M), Version 12.2(2)XA, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

SUCCEED uptime is 3 days, 3 hours, 21 minutes
System returned to ROM by reload at 05:52:09 - Sat Jan 1 2000
System restarted at 05:58:30 - Sat Oct 6 2001
System image file is "flash:cva120-k8v4y5-mz.122-2.XA.bin"
Host configuration file is "tftp://10.1.4.1/ios.cf"

cisco CVA122 CM (MPC850) processor (revision 3.r) with 32256K/1024K bytes of memory.
Processor board ID SAD043708GK
Bridging software.
1 Ethernet/IEEE 802.3 interface(s)
1 Cable Modem network interface(s)
1 Universal Serial Bus (USB) interface(s)
8192K bytes of processor board System flash (Read/Write)
7296K bytes of processor board Boot flash (Read/Write)

Configuration register is 0x2

Конфигурация CVA120 приведена ниже. Обратите внимание, что команды, выделенные полужирным шрифтом, соответствуют строкам в файле ios.cf.

SUCCEED#show run
Building configuration...

Current configuration : 1429 bytes
!
! Last configuration change at 11:22:22 - Tue Oct 9 2001
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service linenumber
service internal
!
hostname SUCCEED
!
no logging buffered
no logging buffered
logging rate-limit console 10 except errors
enable password cisco
!
clock timezone - -8
ip subnet-zero
no ip routing
no ip finger
!
interface Ethernet0
 ip address 10.1.4.11 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 load-interval 30
 bridge-group 59
 bridge-group 59 spanning-disabled
!
interface cable-modem0
 ip address docsis
 no ip route-cache
 no ip mroute-cache
 load-interval 30
 cable-modem boot admin 2
 cable-modem boot oper 5
 cable-modem downstream mode annex-b
 cable-modem Mac-timer t2 40000
 bridge-group 59
 bridge-group 59 spanning-disabled
!
interface USB0
 ip address 10.1.4.11 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 arp timeout 0
 bridge-group 59
 bridge-group 59 spanning-disabled
!
ip classless
no ip http server
no ip http cable-monitor
!
snmp-server packetsize 4096
snmp-server chassis-id 
snmp-server manager
!
voice-port 0
 input gain -2
!
voice-port 1
 input gain -2
!
mgcp modem passthrough voaal2 mode 
no mgcp timer receive-rtcp
!
mgcp profile default
!
line con 0
 transport input none
line vty 0 4
 password cisco
 login
!
end

ВАЖНОЕ ПРИМЕЧАНИЕ

Вполне вероятно, что команда option для файла конфигурации кабеля выполняется неверно, поскольку можно ожидать, что приведенные ниже команды дадут правильную конфигурацию.

option 43 instance 8 hex 00:00:0c
option 43 instance 128 ASCII ios.cf

В то время как эти команды приняты, это не генерирует корректный файл config Cisco IOS. Это НЕ ошибка! Проблема здесь состоит в том, как термин "экземпляр" интерпретировался как "подпараметр", которым это, как никогда предполагалось, не было.

Реализация "экземпляра" только разрешает повторение той же опции многократно, как тогда, когда у вас есть множественные случаи опции 43 для различных поставщиков! Например:

option 43 instance 1 hex 08:03:00:00:0C:80:07:69:6F:73:2E:63:66:67

!--- Config file cisco CM

option 43 instance 2 hex 08:03:11:22:33:80:07:69:6F:73:2E:63:66:67

!--- Some option for other CM

Обратите внимание, что 11:22:33 является случайным идентификатором производителя несуществующей компании. Любое совпадение с идентификатором реального поставщика является случайным.

Так как термин "экземпляр" должен отражать значения полей дополнительных параметров TLV (которые обязательно присутствуют), необходимо ввести значение всей строки в шестнадцатеричном формате.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 8323