Глобальная сеть (WAN) : Протокол PPP

Встречные подключения РРР

21 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ предоставляет пример конфигурации для встречно-параллельного подключения PPP. С такой конфигурацией можно убедиться, что соединение и аппаратное обеспечение работают нормально, и даже использовать маршрутизацию IP для тестирования.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • Эта конфигурация применима ко всей Cisco Выпуски ПО IOS�.

  • Сторона DCE подключена кабелем WAN DCE.

  • Сторона DТE подключена кабелем WAN DТE.

Для получения дополнительной информации о DCE глобальной сети (WAN) или кабелях DTE, обратитесь к документации Кабелей последовательного порта.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. Cisco Technical Tips Conventions.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Сведения о конфигурации

В этой конфигурации Router1 использует кабель V35-MT (ссылка Cisco является CAB-V35MT), и Router2 использует V35-кабель-FC (ссылка Cisco является CAB-V35FC). Это значит, что тактирование обеспечивается Router2. Тактовая частота 64000 битов в секунду используется путем выдачи команды clock rate 64000 под последовательными 0 интерфейсами.

Примечание: После того, как эта команда сконфигурирована, она появляется в конфигурации как тактовая частота 64000. Теперь два кабеля соединены между собой.

Интерфейсы Ethernet настраиваются с помощью использования команды no keepalive. Таким образом, необязательно подключать их к локальной сети, чтобы они были активны и работали. Использование статического маршрута на каждом маршрутизаторе позволяет пинговать IP-адрес интерфейса Ethernet маршрутизатора 2 при помощи IP-адреса интерфейса Ethernet маршрутизатора 1 (или наоборот). Конечно, это полезно в тестовой среде.

Схема сети

Данный документ основан на следующей конфигурации:

/image/gif/paws/7923/ppp_backtoback.gif

Конфигурации

Эти конфигурации используются в данном документе:

Маршрутизатор 1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router1
!
enable password cisco
!
ip subnet-zero
!
!
!
!
interface Ethernet0
 ip address 10.1.0.1 255.255.255.0
 no keepalive
!
interface Serial0
 ip address 10.0.0.1 255.255.255.0
 encapsulation ppp
!
ip classless
ip route 10.2.0.0 255.255.255.0 10.0.0.2
ip http server
!
!
line con 0
line aux 0
line vty 0 4
 no login
!
end

Router-2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router2
!
enable password cisco
!
ip subnet-zero
!
!
!
!
interface Ethernet0
 ip address 10.2.0.1 255.255.255.0
 no keepalive
!
interface Serial0
 ip address 10.0.0.2 255.255.255.0
 encapsulation ppp
 no fair-queue
 clock rate 64000
!
ip classless
ip route 10.1.0.0 255.255.255.0 10.0.0.1
ip http server
!
!
line con 0
line aux 0
line vty 0 4
 no login
!
end

Проверка

В этом разделе содержатся сведения, которые помогают убедиться в надлежащей работе конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • Отдайте команду show controllers, чтобы проверить скорость передачи данных по кабелю и частоту тактирования:

    Ниже приведен пример выходных данных для команды show controllers:

    Router1#show controllers serial 0 | i V.35
    buffer size 1524  HD unit 0, V.35 DTE cable
    Router1#
    
  • Выполните команду show interfaces serial 0, чтобы проверить, что пакеты переданы и получены (см. packets input, packets output, 5 minute input rate и 5 minute output rate. Для получения информации относительно используемой инкапсуляции, посмотрите Encapsulation PPP.

    Ниже приведен пример выходных данных для команды show interfaces serial 0:

    Router1#show interfaces serial 0
    Serial0 is up, line protocol is up
      Hardware is HD64570
      Internet address is 10.0.0.1/24
      MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation PPP, loopback not set
      Keepalive set (10 sec)
      LCP Open
      Open: IPCP, CDPCP
      Last input 00:00:00, output 00:00:00, output hang never
      Last clearing of "show interface" counters 00:07:53
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: weighted fair
      Output queue: 0/1000/64/0 (size/max total/threshold/drops)
         Conversations  0/5/256 (active/max active/max total)
         Reserved Conversations 0/0 (allocated/max allocated)
         Available Bandwidth 1158 kilobits/sec
      5 minute input rate 2000 bits/sec, 2 packets/sec
      5 minute output rate 2000 bits/sec, 2 packets/sec
         155 packets input, 55066 bytes, 0 no buffer
         Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
         168 packets output, 60037 bytes, 0 underruns
         0 output errors, 0 collisions, 0 interface resets
         0 output buffer failures, 0 output buffers swapped out
         0 carrier transitions
         DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
    Router1#
    
  • Чтобы создать пакет проверки связи на 10.2.0.2 с помощью IP-адреса 10.2.0.1, можно выполнить команду ping:

    Далее приводится вывод команды ping:

    Router1#ping
    Protocol [ip]:
    Target IP address: 10.2.0.1
    Repeat count [5]:
    Datagram size [100]:
    Timeout in seconds [2]:
    Extended commands [n]: y
    Source address or interface: 10.1.0.1
    Type of service [0]:
    Set DF bit in IP header? [no]:
    Validate reply data? [no]:
    Data pattern [0xABCD]:
    Loose, Strict, Record, Timestamp, Verbose[none]:
    Sweep range of sizes [n]:
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.2.0.1, timeout is 2 seconds: Packet sent with a source address of 10.1.0.1 !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/32 ms Router1#
    

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • show controllers - Показывает скорость передачи данных по кабелю и частоту тактирования.

  • show interfaces serial 0 — Проверяет, что пакеты переданы и получены.

  • ping — Используемый для тестирования подключения устройств.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.


Дополнительные сведения


Document ID: 7923