Коммутаторы : Cisco 6130 IP DSL Switch

Настройка интерфейса ATM Cisco 6400 ATM с RBE и DHCP

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (11 ноября 2015) | Отзыв


Содержание


Введение

Этот документ предоставляет пример конфигурации для Маршрутизатора Цифровой абонентской линии (DSL) Cisco 827, связанного с Мультиплексором доступа к цифровой абонентской линии (DSLAM) (DSLAM) Cisco 6130, который завершается на Универсальном концентраторе доступа (UAC) Cisco 6400.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Customer Premises Equipment (CPE) Cisco 827-4V с Выпуском ПО IOS� 12.1 (1) XB.

  • Выпуск ПО IOS nrp UAC Cisco 6400 12.1 (1) DC1 (внешний сервер DHCP) или 12.2 (2) B (DHCP server IOS).

  • Выпуск ПО Cisco 6400 UAC-NSP IOS 12.0 (4) дБ.

  • Выпуск ПО Cisco 6130 DSLAM-NI2 IOS 12.1(1)DA.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. в Условные обозначения технических терминов Cisco.

Общие сведения

Cisco 827 настроен с Мостовым соединением RFC1483 и Integrated routing and bridging (IRB). Cisco 827 позволяет PC на Сегменте Ethernet получать адреса из DHCP server позади этих 6400, или от 6400 DHCP server IOS. Кроме того, адрес BVI был также настроен для получения адреса и маршрута по умолчанию от DHCP server. Интерфейс асинхронного режима передачи Cisco 6400 настроен с инкапсуляцией маршрутизированного моста (RBE) и настроен для работы или с внешним сервером DHCP или с DHCP server IOS на nrp.

Для Cisco 6400 функция RBE ATM на Процессоре маршрута узла Cisco 6400 (nrp) направляет IP по соединённому мостом Трафику ethernet RFC1483 от локальной сети с мостами-заглушками. Соединённые мостом пакеты IP, полученные на ATM-интерфейсе, настроенном в режиме моста маршрута, маршрутизируются посредством IP - заголовка. Интерфейсы используют преимущества характеристик тупиковой топологии локальной сети, обычно используемой для доступа DSL, и предлагают повышение производительности и гибкость по IRB.

Кроме того, маршруты хоста для клиентов DHCP автоматически добавлены к 6400 таблицам маршрутизации, поскольку розданы IP-адреса. Когда адрес DHCP освобожден, маршруты хоста удалены из таблицы маршрутизации.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

Этот документ использует сетевую установку, показанную 1 в цифрах и 2:

Рисунок 1 – сценарий 1

/image/gif/paws/7208/fig1_7208.gif

Рисунок 2 – сценарий 2

/image/gif/paws/7208/fig2_7208.gif

Конфигурации

Эти конфигурации используются в данном документе:

  • Cisco 827

  • Cisco 6400 NRP

  • 6400 отладок (Использование RBE с внешним сервером DHCP)

  • 6400 отладок (Использование RBE с DHCP Server IOS)

Cisco 827
Current configuration: 
! 
version 12.0 
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname R1
!
ip subnet-zero 
!
bridge irb 
! 
interface Ethernet0 
 no ip address
 bridge-group 1

!--- Because the Ethernet0 is bridged to the WAN interface,
!--- PCs behind the ethernet0 can be setup as DHCP clients.
!--- They get their addresses from the DHCP server behind the 6400,
!--- or from the IOS DHCP server on the 6400.

! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive 
 pvc 4/100 
  encapsulation aal5snap 
 ! 
 bundle-enable 
 bridge-group 1 
 hold-queue 224 in 
! 
interface BVI1 
 ip address dhcp client-id Ethernet0

!--- This command tells the BVI interface to get the address
!--- from DHCP, and also to get the default route from DHCP.

! 
ip classless 

!--- Note: The default route will be inserted into
!--- the routing table automatically from the DHCP server, and
!--- no static routing statement is required.                         

no ip http server 
! 
bridge 1 protocol ieee 
 bridge 1 route ip 
! 
voice-port 1 
 timing hookflash-in 0 
! 
voice-port 2 
 timing hookflash-in 0 
! 
voice-port 3 
 timing hookflash-in 0 
! 
voice-port 4 
 timing hookflash-in 0 
!
end 

Cisco 6400 NRP
Current configuration: 
! 
version 12.1
no service pad 
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname NRP 

! 
redundancy 
 main-cpu 
 no auto-sync standard 
 no secondary console enable 
ip subnet-zero 
! 
interface Loopback1 
 ip address 198.1.1.1 255.255.255.0 
 no ip directed-broadcast

!--- This address and mask must match the intended
!--- scope and network configured on the external DHCP server.

! 
interface ATM0/0/0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no ATM ilmi-keepalive 
! 
interface ATM0/0/0.4 point-to-point

!--- The interface ATM0/0/0.4 point-to-point uses IP
!--- unnumbered Loopback1 for its IP address requirements.

 ip unnumbered Loopback1 
 ip helper-address <dhcp server ip address>
 atm route-bridged ip 
 PVC 4/100 
  encapsulation aal5snap 
 ! 
interface Ethernet0/0/1 
 no ip address 
 no ip directed-broadcast 
! 
interface Ethernet0/0/0 
 no ip directed-broadcast 
! 
interface FastEthernet0/0/0 
 no ip address 
 no ip directed-broadcast 
 full-duplex 
! 
ip classless 

!--- Note: For every DHCP client that is relayed an address,
!--- a host route will be automatically inserted in the routing 
!--- table, and no host route statement for a DHCP client is required.

end 

6400 отладок (Использование RBE с внешним сервером DHCP)
debug ip dhcp server events 

Looks for existing binding. . .

00:10:56:  find_or_create(): Look for existing binding for:
00:10:56:  find_or_create(): dhcp->chaddr = 616EF9BC
00:10:56:  find_or_create(): dhcp->hlen = 6
00:10:56:  find_or_create(): dhcp->htype = 1
00:10:56:  find_or_create: address = 124.124.124.1
00:10:56:  find_or_create(): Creating new binding with data
00:10:56:  find_or_create(): dhcp->chaddr = 616EF9BC
00:10:56:  find_or_create(): dhcp->hlen = 6
00:10:56:  find_or_create(): dhcp->htype = 1
00:10:56:  find_or_create: address = 124.124.124.1

!--- Forwards DHCP DISCOVER packet from the client to the
!--- external DHCP server.

00:10:56: DHCPD: Received DHCPDISCOVER on UNNUM-IF
00:10:56: DHCPD: Forwarding reply on un-numbered intf

!--- Forwards the DHCP OFFER packet from the external DHCP server 
!--- to the client.

00:10:56: DHCPD: Unnum: Received DHCPOFFER
00:10:56:  DHCPD: Server Address = 200.200.200.2
00:10:56:  DHCPD: Giaddr Address = 124.124.124.1
00:10:56:  find_or_create(): Look for existing binding for:
00:10:56:  find_or_create(): dhcp->chaddr = 616EF9BC
00:10:56:  find_or_create(): dhcp->hlen = 6
00:10:56:  find_or_create(): dhcp->htype = 1
00:10:56:  find_or_create: address = 124.124.124.1

!--- Forwards the DHCP REQUEST packet from the client to the external
!--- DHCP server.

00:10:56: DHCPD: Received DHCPREQUEST on UNNUM-IF
00:10:56:  DHCPD: request_on_unnumif ():Real Server = 200.200.200.2   
00:10:56: DHCPD: Forwarding reply on un-numbered intf

!--- Forwards the DHCP ACK packet from the DHCP server to the client.

00:10:56: DHCPD: Unnum: Received DHCPACK
00:10:56:  DHCPD: lease time = 86400

!--- Adds a dynamic host route to the client into the routing table.

00:10:56: DHCPD: dhcpd_lookup_route: host = 124.124.124.2
00:10:56: DHCPD: dhcpd_lookup_route: index = 126
00:10:56:  DHCPD: Adding new route to host 124.124.124.2
00:10:56: DHCPD: dhcpd_lookup_route: host = 124.124.124.2
00:10:56: DHCPD: dhcpd_lookup_route: index = 126
00:10:56: DHCPD: dhcpd_create_and_hash_route: host = 124.124.124.2
00:10:56: DHCPD: dhcpd_create_and_hash_route index = 126
00:10:56: DHCPD: dhcpd_add_route: lease = 86400 
00:10:56:  DHCPD: Server ID saved in Binding = 200.200.200.2
00:10:56:  DHCPD: Server ID saved in Route block = 200.200.200.2
00:10:56:  DHCPD: Giaddr Address = 124.124.124.1

6400 отладок (Использование RBE с DHCP Server IOS)
debug ip dhcp server events 

Assigns an address to the client from the IOS DHCP server.

23:19:09: DHCPD: assigned IP address 124.124.124.3 to 
client 0063.6973.636f.2d30.3030.302e.3063.3036.2e32.3339.342d.4256.31.
23:19:10:  DHCPD: lease time = 86400

Adds a dynamic host route to the client into the routing table.

23:19:10: DHCPD: dhcpd_lookup_route: host = 124.124.124.3
23:19:10: DHCPD: dhcpd_lookup_route: index = 127
23:19:10:  DHCPD: Adding new route to host 124.124.124.3
23:19:10: DHCPD: dhcpd_lookup_route: host = 124.124.124.3
23:19:10: DHCPD: dhcpd_lookup_route: index = 127
23:19:10: DHCPD: dhcpd_create_and_hash_route: host = 124.124.124.3
23:19:10: DHCPD: dhcpd_create_and_hash_route index = 127
23:19:10: DHCPD: dhcpd_add_route: lease = 86400

Проверка.

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 7208