Глобальная сеть (WAN) : Протокол PPP

Конфигурация подключения IP/PPP сервера доступа с выделенным PPP V.120

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ предоставляет пример конфигурации для IP/PPP наборного (телефонный) доступа сервера доступа со специализированным PPP V.120

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Cisco Выпуск ПО IOS� 11.2 или позже, для V.120 с Виртуальными асинхронными интерфейсами.

  • Программное обеспечение Cisco IOS версии 11.3 или позже, для V.120 с Virtual-template.

  • Образ Версии Cisco IOS Enterprise для настройки больше чем пяти линий VTY.

Используйте Советника по программному обеспечению (только зарегистрированные клиенты) для определения, какая функция ПО Cisco IOS устанавливает функциональность V.120 поддержки. В программном средстве выберите придерживающиеся функции: V.120 Support, Трансляция протоколов и Virtual-template для Трансляции протоколов. При требовании дополнительных характеристик выберите их как требуется.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. в Условные обозначения технических терминов Cisco.

Общие сведения

Рекомендация V.120 Международного союза телекоммуникаций сектор стандартизации телекоммуникаций (ITU-T), обеспечивает надежность передачи синхронных, асинхронных, или кусает прозрачные данные по Каналам - носителям ISDN.

Соединение V.120 может быть или в PPP или в отличном от PPP режим. Это вызвано тем, что много Терминальных адаптеров V.120 подобны модемам и поддерживают некоторые наборы AT-команд. Отличный от PPP режим может использоваться, чтобы проверить, корректна ли настройка V.120 у клиента и маршрутизатора. PPP может тогда быть настроен на той ссылке. Посмотрите Сверять V.120 в разделе отличного от PPP режим для получения дополнительной информации.

Существует два основных метода для осуществления V.120:

  • Виртуальные асинхронные интерфейсы

    Использование программного обеспечения Cisco IOS, можно настроить возможности асинхронного протокола, такие как PPP и SLIP, на линиях VTY. PPP и SLIP обычно функционируют только на асинхронных интерфейсах, не на линиях VTY. При настройке линии VTY для поддержки возможностей асинхронного протокола, вы создаете Виртуальные асинхронные интерфейсы на линиях VTY. Виртуальный асинхронный интерфейс (также известный как vty-async) создан к поддержкам вызова, которые вводят маршрутизатор через нефизический интерфейс. Например, поток асинхронного символа называет оконечным, или земля на нефизический интерфейсах. Виртуальные асинхронные интерфейсы не конфигурируемы пользователем; скорее они динамично созданы и разъединены по требованию.

  • Virtual-template

    Туннелирование поддержки внедрения Virtual-Template PPP, с помощью двухступенчатой трансляции протоколов. Когда пользователь V.120 набирает в через виртуальную абонентскую линию, маршрутизатор создает интерфейс виртуального доступа. Интерфейс виртуального доступа является временным интерфейсом, который поддерживает конфигурацию асинхронного протокола, заданную в шаблоне виртуального интерфейса. Тот интерфейс создан динамично путем клонирования Виртуального интерфейса в конфигурации. Этот интерфейс виртуального доступа освобожден, как только понижается соединение. Virtual-Template более гибок, потому что он дает больше параметров конфигурации, чем ограниченная Действительно-асинхронная реализация.

Как V.120 влияет на быстродействие маршрутизатора

Cisco не рекомендует выполнить PPP по V.120 на Micamodem, потому что обработка V.120 чрезвычайно с высокой загрузкой ЦПУ. Cisco AS5200 не может обработать много одновременно активных PPP - подключений V.120. Другие маршрутизаторы AS5xxx могут обработать более одновременно активные PPP - подключения V.120. Как альтернатива, Cisco рекомендует настроить клиентский адаптер терминала ISDN (TA), чтобы сделать "преобразование PPP синхронизования к асинксу" так, чтобы соединение вошло в сервер доступа к сети (NAS) как в PPP обычной синхронизации вместо V.120.

Однако с Модемами Nextport, новая характеристика была добавлена, для разгружения вызовов V.120 к Цифровому процессору сигналов (DSP) модема. При использовании программного обеспечения Cisco IOS версии 12.2 XB (и 12.2 (11) T и позже), возможно завершиться, V.120 обращается к DSP NextPort вместо ЦПУ. Для получения дополнительной информации посмотрите Завершающиеся Сеансы V.120 на DSP NextPort.

Зачем реализовывать PPP через V.120?

PPP по V.120 с высокой загрузкой ЦПУ. Поэтому Cisco препятствует развернутому внедрению. Однако, можно хотеть выполнить PPP по V.120 по придерживающимся причинам:

  • Вы используете терминальный адаптер (TA), который присоединен к терминальному оборудованию асинхронных данных (DTE) и не может сделать преобразования PPP синхронизования к асинксу. В этом случае необходимо использовать V.120.

  • Конфигурация по умолчанию TA является V.120, и вы неспособны реконфигурировать TA без помощи интернет-провайдера (ISP).

  • Приложение хочет иметь сеанс PPP, начинаются с диалогом терминала символьной ячейки (например, специальная проблема разового пароля и ответ), таким образом, вы не хотите сеанс чистой синхронизации PPP.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Этот раздел также описывает implementaion для vty-async и Virtual-template.

Примечание: Эти шаги предполагают, что NAS должным образом настроен для основного ISDN или доступа Асинхронного вызова, и что клиент должным образом настроен для PPP по V.120.

Виртуально-асинхронные интерфейсы (vty-async)

Для осуществления vty-async выполните эти шаги:

  1. Создайте Виртуальные асинхронные интерфейсы с помощью команды глобальной кофигурации vty-async.

  2. Настройте аутентификацию для соединения vty-async. Используйте ppp vty-async authen {парень | pap} команда.

  3. Настройте другие параметры vty-async такой как, таймеры поддержки активности, размер mtu, сжатие заголовка, и т.д., как требуется, для настройки. Обратитесь к Трансляции протоколов и Действительным Командам Асинхронного устройства для получения дополнительной информации.

  4. Настройте Автоматическое определение Инкапсуляции V.120 с помощью команды autodetect encapsulation v120 ppp. Эта команда должна быть применена к физическому интерфейсу входящего вызова (например, interface BRI 0, interface Serial 1:23). Однако, если TA V.120 вызова правильно сигнализирует V.120 в низкоуровневом поле совместимости НАСТРОЙКИ Q.931, строка "autodetect encapsulation" не необходима. К сожалению, много TA не в состоянии делать это.

  5. Отключите приглашение Имени пользователя и пароля под конфигурацией с командной строки VTY. Можно сделать это, не настраивая входа в систему и никакого пароля в режиме конфигурации с командной строки VTY. При использовании AAA, определяете список, который имеет метод ни один, и затем примените его к интерфейсу VTY. Например: :

    maui-soho-01(config)#aaa new-model
    maui-soho-01(config)#aaa authentication login NO_AUTHEN none
    maui-soho-01(config)#line vty 0 4
    maui-soho-01(config-line)#login authentication NO_AUTHEN
    
  6. Настройте команду autocommand ppp default в режиме конфигурации с командной строки VTY. Без login authentication и ppp autocommand, VTY инициирует PPP, как только входит соединение V.120. Это позволяет узлу V.120 сразу начать согласования PPP, не имея необходимость выполнять сценарий или вводить имя пользователя и пароль в окно терминала. Команда autoselect не поддерживается на VTY.

    Примечание: Так как VTY запускают рабочий PPP, как только соединение установлено, вы не будете в состоянии выполнить команду telnet на NAS для административных целей. Для обхождения этого ограничения примените команду transport input v120 на VTY, используемые для PPP - подключений V.120, и примените команду transport input telnet на используемых для административного Telnet.

Virtual-template

Для осуществления Virtual-template выполните эти шаги:

  1. Создайте и настройте шаблон виртуального интерфейса при помощи команды interface virtual-template. Настройте этот виртуальный интерфейс, как вы настроили бы обычный асинхронный последовательный интерфейс. Для этого назначьте шаблон виртуального интерфейса IP-адрес активного интерфейса (использующий команду ip unnumbered interface) и настройте адресацию, так же, как вы настроили бы его на асинхронном интерфейсе. Можно также ввести команды в режим конфигурации интерфейса, которые сжимают заголовки TCP или настраивают аутентификацию Протокола аутентификации по квитированию вызова (CHAP) для PPP. Например: :

    interface Virtual-Template1
      ip unnumbered Ethernet0
      no ip directed-broadcast
      ip tcp header-compression passive
      peer default ip address pool IPaddressPool
      ppp authentication chap
  2. Создайте Виртуальные асинхронные интерфейсы с помощью команды глобальной кофигурации vty-async.

  3. Настройте виртуальные абонентские линии для поддержки функций асинхронного протокола, на основе определения шаблона виртуального интерфейса. Можно сделать это использование vty-async virtual-template команда количества в режиме глобальной конфигурации. Например: :

    vty-async
    vty-async Virtual-Template 1
  4. Настройте Автоматическое определение Инкапсуляции V.120 с помощью команды autodetect encapsulation v120 ppp. Примените эту команду к физическому интерфейсу входящего вызова (например, interface BRI 0, interface Serial 1:23). Однако, Если TA V.120 вызова правильно сигнализирует V.120 в низкоуровневом поле совместимости НАСТРОЙКИ Q.931, строка "autodetect encapsulation" не требуется. К сожалению, много TA не в состоянии делать это.

  5. Отключите приглашение Имени пользователя и пароля под конфигурацией с командной строки VTY. Сделайте это, не настраивая входа в систему и никакого пароля в режиме конфигурации с командной строки VTY. При использовании AAA, определяете список, который имеет метод ни один, и затем примените его к интерфейсу VTY. Например: :

    maui-soho-01(config)#aaa new-model
    maui-soho-01(config)#aaa authentication login NO_AUTHEN none
    maui-soho-01(config)#line vty 0 4
    maui-soho-01(config-line)#login authentication NO_AUTHEN
    
  6. Настройте команду autocommand ppp default в режиме конфигурации с командной строки VTY. Без login authentication и ppp autocommand, PPP VTY инициирует, как только входит соединение V.120. Это позволит узлу V.120 сразу начать согласования PPP, не имея необходимость выполнять сценарий или вводить имя пользователя и пароль в окно терминала. Обратите внимание на то, что команда autoselect не поддерживается на VTY.

    Примечание: Так как VTY запускают рабочий PPP, как только соединение установлено, вы не будете в состоянии выполнить команду telnet на NAS для административных целей. Для обхождения этого ограничения примените команду transport input v120 на VTY, используемые для PPP - подключений V.120, и примените команду transport input telnet на используемых для административного Telnet.

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/6306/28a.gif

Конфигурации

В данном документе используется следующая конфигурация:

  • Cisco AS5200, который поддерживает IP наборного (телефонный) доступа или клиентов PPP для синхронного PPP ISDN (не многоканальный), асинхронного PPP и PPP V.120.

Эта конфигурация использует Виртуальные асинхронные интерфейсы (vty-async) метод, описанный выше.

V.120 (PPP) с виртуальными асинхронными интерфейсами
aaa new-model
aaa authentication login default local
aaa authentication login NOAUTH none             

!--- The aaa list NOAUTH has no authentication.
!--- This list will be applied to the vty interface.

! 
username fred password FLINTSTONE
!
ip local pool default 10.1.1.2 10.1.1.47

!--- Define local IP address pool.


vty-async                                        

!--- Configures all virtual terminal lines on a router to 
!--- support asynchronous protocol features.
!--- The vty-async parameters are required for Async V.120. 

vty-async keepalive 0       

!--- Disable PPP keepalives.

vty-async ppp authen chap pap 

!--- Async  V.120 PPP authentication methods.

!
interface Ethernet0
  ip address 10.1.1.1 255.255.255.0
!
interface serial0:23

!--- ISDN D-channel configuration for T1 0.

  no ip address
  encapsulation ppp
  isdn incoming-voice modem

!--- Analog calls are forwarded to the internal digital modem.

  ppp authentication chap pap
  dialer rotary-group 1

!--- Member of rotary group 1. 


!--- The rotary group configuration is interface Dialer 1.

  autodetect encapsulation v120 ppp  

!--- Automatic detection of encapsulation type on the specified interface. 
!--- This interface will automatically detect whether the call is normal PPP or V.120
!--- If the calling V.120 TA correctly signals V.120 in the Q.931 
!--- SETUP low-level compatibility field, autodetect encapsulation is 
!--- not needed. Unfortunately, many TAs fail to do this.   
   
!
interface Dialer1

!--- Rotary group 1 logical interface.

  description Dialer interface for sync ISDN calls
  ip unnumbered Ethernet0
  encapsulation ppp
  peer default ip address pool
  dialer-group 1
  dialer idle-timeout 300                      
  no cdp enable
  ppp authentication chap pap 
!
interface Group-Async1
  description Interface for async modem calls
  async mode dedicated                           

!--- PPP only, no exec dial-ins (or Teminal window after dial).
 
  ip unnumbered Ethernet0
  encapsulation ppp
  ip tcp header-compression
  peer default ip address pool default
  dialer-group 1
  dialer idle-timeout 300                        
  no cdp enable
  ppp authentication chap pap
!
dialer-list 1 protocol ip permit
!
line con 0
  login authentication NOAUTH
line 1 48

!--- Modems used for normal async calls.

  no exec
  modem inout
!                                                
line vty 0 45

!--- V.120 call will be terminated on vty 0 45.
!--- If your router does not support more than five vtys refer 
!--- to the Components Used section.

  login authentication NOAUTH    

!--- Use the AAA list NOAUTH (which specified no authentication) 
!--- configured previously with this method. There will be no 
!--- Username/password exec prompt. Use the no login command
!--- if this NAS does not do AAA.

  autocommand ppp default

!--- This command is ONLY required for V.120 with PPP.

  session-timeout 5 output                       

!--- Timeout of 5 minutes.

  transport input v120                           

!--- Allow only V.120 connections into these VTYs.

line vty 46 50

!--- These vtys will be used for normal telnets into the router.

  login authentication default

!--- Use AAA list "default" for vty 46-50. 
!--- This method uses local authentication (configured previously).

  exec-timeout 30
  transport input telnet

!--- Permit only incoming telnet connections to use vty 46-50.


Проверка.

В данном разделе содержатся сведения о проверке работы конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • show ip route записи таблицы IP-маршрутизации.

  • show users об активных линиях сервера сети, включая номер строки, имена соединения и расположение оконечных устройств.

Проверьте соединение V.120

Для подтверждения соединения V.120 выполните эти шаги:

  1. Используйте debug v120 и генерируйте входящий вызов V.120. Необходимо видеть эти выходные данные отладки на NAS:

    19:25:16: V120: Autodetect trying to detect V120 mode on Se0:18
    19:25:16: V120 sampled pkt:  3 bytes:  8 1 7F
    19:25:16: Se0:18-v120 started - Setting default V.120 parameters
    19:25:16: V120extablished handle = 4

    Если это сообщение не появляется, входящий вызов был, вероятно, не V.120, и следовательно маршрутизатор не обнаруживал его как таковой.

  2. Проверьте, подходит ли интерфейс vty-async. Если конфигурация использует V.120 с Virtual-template, проверьте, создан ли интерфейс виртуального доступа. В придерживающихся выходных данных console log возрос интерфейс vty-async 32:

    19:25:17: %LINK-3-UPDOWN: Interface VTY-Async32, 
    changed state to up
  3. Используйте debug ppp negotiation и debug ppp authenticaion. гарантировать, что о параметрах PPP должным образом выполняют согласование. Для получения дополнительной информации об Отладке PPP посмотрите Dialup-технологию: Методика поиска и устранения неисправностей.

  4. Выполните show ip route и show users, чтобы проверить, что должным образом установлен вызов V.120.

Следующие примеры являются выходными данными от настройки, где у нас нет Virtual-template V.120:

DSL4-5300A#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.68.0.0/32 is subnetted, 1 subnets
S       172.68.186.41 [1/0] via 172.18.120.1
     172.18.0.0/24 is subnetted, 1 subnets
S       172.18.120.0 [1/0] via 10.92.1.1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.92.1.0 is directly connected, FastEthernet0
C    192.168.1.0/24 is directly connected, Loopback0
     172.0.0.0/32 is subnetted, 1 subnets
C       172.22.53.1 is directly connected, VTY-Async32

Примечание: Вызов связан на интерфейсном VTY-Async 32, и существует маршрут клиенту.

Примечание: IP-адрес стороны NAS ссылки будет IP-адресом или ethernet или интерфейса Fast-Ethernet на NAS, при использовании параметров конфигурации Virtual-Template non. Следовательно проверьте, возрос ли интерфейс ethernet или Fast-Ethernet и может быть пропингован.

DSL4-5300A#show users
  Line          User       Host(s)              Idle     Location
*0 con 0                   idle                 00:00:00
 32 vty 0     wan-2520-5  VTY-Async32           00:01:37 Serial0:18
Interface        User      Mode                 Idle     Peer Address
  VT32         wan-2520-5 Async PPP             00:01:14 172.22.53.1

Примечание: Вызов связан на интерфейсном VTY-Async 32, и IP - адрес адресуемой точки задан.

При использовании опции Virtual-Template с V.120, show ip route и выходные данные show user появляются как это:

DSL4-5300A#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     192.168.199.0/32 is subnetted, 1 subnets
C       192.168.199.5 is directly connected, Virtual-Access1
     172.22.0.0/32 is subnetted, 1 subnets
S       172.22.186.41 [1/0] via 172.18.120.1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.20.20.0 is directly connected, Virtual-Access1
.........

Примечание: Вызов связан на интерфейсном Виртуальном доступе 1, и существует маршрут клиенту.

DSL4-5300A#show users
    Line       User       Host(s)              Idle       Location
*  0 con 0                idle                 00:00:00
  32 vty 0     wan-2520-5 Virtual-Access1      00:00:05 Serial0:18

Примечание: Вызов связан на интерфейсном Виртуальном доступе 1.

Проверьте V.120 в отличном от PPP режим

Много терминальных адаптеров V.120 подобны модемам и поддерживают некоторые наборы AT-команд. Следовательно, можно использовать отличного от PPP режим, чтобы проверить, корректна ли настройка V.120 у клиента и маршрутизатора. Вы можете тогда conffigure PPP на той ссылке. Тестирование V.120 отдельно позволяет нам устранять неполадки связанных проблем V.120, не добавляя сложность PPP.

Для тестирования соединения V.120 в отличном от PPP режим выполните эти шаги:

  1. Включите приглашение Имени пользователя и пароля под конфигурацией с командной строки VTY. Используйте команду входа в систему для включения входа в систему. Используйте пароль команда password для установки пароля линии. При использовании AAA, удаляете login authentication перечислите команду под VTY.

  2. Удалите команду autocommand ppp default в режиме конфигурации с командной строки VTY. Например: :

    maui-soho-01(config)#line vty 0 4
    maui-soho-01(config-line)#login
    maui-soho-01(config-line)#password letmein
    maui-soho-01(config-line)#no autocommand ppp default
    
  3. Включите debug v120 и инициируйте вызов от клиента. Маршрутизатор должен отобразить это:

    19:25:16: V120: Autodetect trying to detect V120 mode on Se0:18
    19:25:16: V120 sampled pkt:  3 bytes:  8 1 7F
    19:25:16: Se0:18-v120 started - Setting default V.120 parameters
    19:25:16: V120extablished handle = 4       
  4. Продолжите остаток конфигурации V.120. Выполните шаги, описанные в Настраивать разделе.

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Команды устранения неисправностей (необязательные)

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Примечание: Перед запуском команд отладки обратитесь к разделу Важные сведения о командах отладки для получения дополнительной информации.

  • debug v120 — указывает, когда обработка V.120 запущена или завершена, и интерфейс, на котором это работает.

  • команда debug ppp negotiation отображает сведения об объеме трафика и обмене данными по протоколу PPP в процессе согласования компонентов PPP, включая протокол управления каналом (LCP), аутентификацию и протокол NCP. В случае успешного согласования PPP сначала открывается состояние LCP, затем выполняется аутентификация и в заключение согласуются параметры NCP (обычно IPCP).

  • debug ppp authenticaion — отображает сообщения протокола аутентификации PPP, включая обмены пакетами CHAP и обмены Протокола аутентификации пароля (PAP).

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 6306