Технологии LRE и xDSL : Поддержка асимметричных цифровых абонентских линий (ADSL)

Руководство по настройке, поиску и устранению неполадок маршрутизатора Cisco DSL Router – Режим маршрутизации RFC1483 с одним статическим IP-адресом

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Интернет-провайдер (ISP) назначил одиночный статический открытый IP - адрес на Маршрутизатор Цифровой абонентской линии (DSL) Cisco.

Совет: Обратитесь к пошаговой Конфигурации Маршрутизации RFC1483 с Одиночным Статическим IP - адресом, если вы не знакомы с тем, как настроить устройства Сisco и хотели бы придерживаться пошаговой конфигурации.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Задачи для выполнения

  • Дизайн схема IP-адресации для частной локальной сети (LAN).

  • Вручную настройте IP-адрес и маску подсети на Интерфейсе Ethernet маршрутизатора Cisco DSL.

  • Настройте ATM-интерфейс (интерфейс асимметричной цифровой абонентской линии (ADSL)) маршрутизатора Cisco DSL с постоянной виртуальной цепью (PVC) ATM, инкапсуляцией и IP-адресом.

  • Для Технологии NAT: Настройте NAT на маршрутизаторе Cisco DSL, чтобы позволить совместно использовать статического открытого IP - адреса ATM-интерфейса.

    • Дополнительно: Пул NAT, если дополнительные IP-адреса были предоставлены интернет-провайдером.

    • Дополнительно: Статический NAT, если интернет-пользователи требуют доступа к внутренним серверам.

  • Настройте каждый ПК хоста с IP-адресом, маской подсети, шлюзом по умолчанию и сервером (ами) Системы доменных имен (DNS).

    Для Протокола DHCP (динамического конфигурирования узла): Также, если вы хотите, чтобы маршрутизатор Cisco DSL назначил динамические IP - адреса ПК - клиентов, настройте каждый ПК для получения IP-адреса и сервера (ов) DNS автоматически через DHCP.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Конфигурация

Совет: Обратитесь к пошаговой Конфигурации Маршрутизации RFC1483 с Одиночным Статическим IP - адресом, если вы не знакомы с тем, как настроить устройства Сisco и хотели бы придерживаться пошаговой конфигурации.

Маршрутизатор Cisco DSL со статическим IP - адресом и NAT

!--- Comments contain explanations and additional information.


service timestamps debug datetime msec
service timestamps log datetime msec
ip subnet-zero
!

!--- For DHCP:

ip dhcp excluded-address <ip address of ethernet0>
ip dhcp pool <dhcp pool name>
 network <ip network address of ethernet0> <subnet mask>
 default-router <ip address of ethernet0>
 dns-server <ip address of dns server>
!
interface ethernet0
 no shut
 ip address <ip address> <subnet mask>
 ip nat inside
 no ip directed-broadcast
!
interface atm0
 no shut
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
!
interface atm0.1 point-to-point
 ip address <ip address> <subnet mask>

!--- For NAT:

 ip nat outside
 pvc <vpi/vci>
  encapsulation aal5snap
 
!--- Common PVC values supported by ISPs are 0/35 or 8/35.
 !--- Confirm your PVC values with your ISP.

 !
!

!--- For NAT:

ip nat inside source list 1 interface atm0.1 overload

!--- If you have a pool (a range) of public IP addresses provided 
!--- by your ISP, you can use a NAT Pool. Replace 
!--- ip nat inside source list 1 interface atm0.1 overload

 
 

!--- with these two configuration statements:
!--- ip nat inside source list 1 pool <nat pool name> overload
!--- ip nat pool <nat pool name> <first ip address> <last ip address> 
!---  netmask <subnet mask>




!--- If Internet users require access to an internal server, you can 
!--- add this static NAT configuration statement:
!--- ip nat inside source static tcp <inside ip address of server> {80 or 25} 
!--- <outside well-known ip address of server> {80 or 25} extendable
!--- Note: TCP port 80 (HTTP/web) and TCP port 25 (SMTP/mail) are used 
!--- for this example. You can open other TCP or UDP ports, if needed.

! 
ip classless 
ip route 0.0.0.0 0.0.0.0 <default gateway to isp>

!--- For NAT:

access-list 1 permit <ip network address of ethernet0> <wildcard mask>

!--- In this configuration, access-list 1 defines a standard access list 
!--- that permits the addresses that NAT translates. For example, if  
!--- your private IP network is 10.10.10.0, configure 
!--- access-list 1 permit 10.10.10.0 0.0.0.255 in order to allow NAT to translate 
!--- packets with source addresses between 10.10.10.0 and 10.10.10.255.

!
end

Проверка.

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

Обратитесь к Устранению проблем Маршрутизации RFC1483, если сервис ADSL не работает должным образом.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 71132