Cервисы организации сетевого доступа к приложениям : Модули контента Cisco серии 500

Настройка WCCP версии 2 на Catalyst 3550

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ предоставляет пример конфигурации для версии 2 протокола WCCP на Catalyst 3550 с Модулем контента Cisco 560.

Перед началом работы

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Предварительные условия

Для данного документа отсутствуют предварительные условия.

Используемые компоненты

Эта конфигурация была разработана и протестирована с помощью программного обеспечения следующих версий.

  • Cisco Catalyst 3550 рабочих Cisco Выпуск ПО IOS� 12.1 (11) EA1a

  • Модуль контента Cisco 560 рабочих Приложений Cisco и Программное обеспечение сетей передачи контента (ACNS) Выпуск 4.2.3

Сведения, представленные в этом документе, были получены от устройств в специфической лабораторной среде. Все устройства, используемые в этом документе, были запущены с чистой конфигурацией (конфигурацией по умолчанию). При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

В данном документе используется сеть, изображенная на следующей схеме.

/image/gif/paws/29461/diagram.jpg

Конфигурации

В данном документе используются следующие конфигурации.

  • Catalyst 3550

  • Модуль контента 560

Catalyst 3550
GIULIO#sh run
Building configuration...
Current configuration : 3426 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
!
hostname GIULIO
!
enable password ww
!
ip subnet-zero
ip routing



!--- Only TCP port 80 may be redirected.
!--- You need to issue the sdm prefer extended-match command
!--- on the switch. Refer to the Verify and Troubleshoot section for 
!--- further information.


ip wccp web-cache
!
!
spanning-tree extend system-id
!
!
!
interface FastEthernet0/1
�no switchport
�ip address 10.48.66.217 255.255.254.0
!
interface FastEthernet0/2
�no ip address
!
interface FastEthernet0/3
�no ip address
!
interface FastEthernet0/4
�no ip address
!
interface FastEthernet0/5
�no ip address
!
interface FastEthernet0/6
�no ip address
!���������
interface FastEthernet0/7
�no ip address
!
interface FastEthernet0/8
�no ip address
!
interface FastEthernet0/9
�no ip address
!
interface FastEthernet0/10
�no ip address
!
interface FastEthernet0/11
�no ip address
!
interface FastEthernet0/12
�no ip address
!
interface FastEthernet0/13
�no ip address
!
interface FastEthernet0/14
�no ip address
!
interface FastEthernet0/15
�no ip address
!
interface FastEthernet0/16
�no switchport
�ip address 33.33.33.33 255.255.255.0
�duplex full
�speed 100
!
interface FastEthernet0/17
�no ip address
!
interface FastEthernet0/18
�no ip address
!���������
interface FastEthernet0/19
�no ip address
!
interface FastEthernet0/20
�no ip address
!
interface FastEthernet0/21
�no ip address
!
interface FastEthernet0/22
�no ip address
!
interface FastEthernet0/23
�no ip address
!
interface FastEthernet0/24
�no ip address
!
interface FastEthernet0/25
�no ip address
!
interface FastEthernet0/26
�no ip address
!
interface FastEthernet0/27
�no ip address
!
interface FastEthernet0/28
�no ip address
!
interface FastEthernet0/29
�no ip address
!
interface FastEthernet0/30
�no ip address
!
interface FastEthernet0/31
�no ip address
!
interface FastEthernet0/32
�no ip address
!
interface FastEthernet0/33
�no ip address
!
interface FastEthernet0/34
�no ip address
!
interface FastEthernet0/35
�no ip address
!
interface FastEthernet0/36
�no ip address
!
interface FastEthernet0/37
�no ip address
!
interface FastEthernet0/38
�no ip address
!
interface FastEthernet0/39
�no ip address
!
interface FastEthernet0/40
�no ip address
!
interface FastEthernet0/41
�no ip address
!
interface FastEthernet0/42
�no ip address
!
interface FastEthernet0/43
�no ip address
!
interface FastEthernet0/44
�no ip address
!
interface FastEthernet0/45
�no ip address
!
interface FastEthernet0/46
�no ip address
!
interface FastEthernet0/47
�no ip address
!
interface FastEthernet0/48


!--- On this WCCP implementation, only input redirection is allowed.


�no switchport
�ip address 1.1.1.1 255.255.255.0
�ip wccp web-cache redirect in
!
interface GigabitEthernet0/1
�no ip address
!
interface GigabitEthernet0/2
�no ip address
!
!



!--- This access list 100, if associated as 'in' to Fa0/48, 
!--- can show if packets are reaching the Catalyst from the PC client.


access-list 100 permit tcp any eq www any log
access-list 100 permit tcp any any eq www log

access-list 100 permit any any any log

ip default-gateway 10.48.66.1
ip classless
ip route 0.0.0.0 0.0.0.0 10.48.66.1
ip http server
!
!
!
!
line con 0
�exec-timeout 0 0
�password cisco
line vty 0 4
�exec-timeout 0 0
�password ww
�login
line vty 5 15
�login
!
end

GIULIO#

Модуль контента 560
agra#sh run 
  hostname agra 
  ! 
  ! 
  ! 
  ! 
  ! 


!--- The Standby feature on the Content Engine  is optional in the 
!--- implementation, but it works fine with the Catalyst.

  interface FastEthernet 0/0 
  �ip address 122.122.122.1 255.255.255.0 
  �standby 1 ip 33.33.33.31 255.255.255.0
  �standby 1 priority 120 
  �no autosense 
  �bandwidth 100 
  �full-duplex 
  �exit 
  interface FastEthernet 0/1 
  �ip address 122.122.123.1 255.255.255.0 
  �standby 1 ip 33.33.33.31 255.255.255.0  
  �standby 1 priority 80 
  �no autosense 
  �bandwidth 100 
  �full-duplex 
  �exit 
  ! 
  ! 
  ip default-gateway 33.33.33.33 
  ! 
  primary-interface FastEthernet 0/0 
  ! 
  ! 
  ! 
  ! 


!--- The logging console is only used for troubleshooting, as it may cause 
!-- high CPU on the Content Engine in production.
� 
  logging console enable 
  logging console priority debug 
  ! 
  ! 
  ! 
  ! 
  ! 
  ! 
  ! 
  
  wccp router-list 1 33.33.33.33 
  wccp web-cache router-list-num 1 l2-redirect 

!--- The assign-method-strict is not necessary.

  wccp version 2 


!--- Catalyst 3550 implementation of WCCP allows only Layer 2 redirection, 
!--- and not generic routing encapsulation (GRE). In addition, only TCP 
!--- port 80 may be redirected. 

  ! 
  ! 
  username admin password 1 bVmDmMMmZAPjY 
  username admin privilege 15 
  ! 
  ! 
  ! 
  ! 
  authentication login local enable primary 
  authentication configuration local enable primary 
  ! 
  !               

agra#

Проверка и устранение неполадок

Этот раздел предоставляет сведения, можно использовать, чтобы подтвердить, что конфигурация работает должным образом и устранять неполадки далее.

  • Для включения перенаправления WCCP в Коммутаторе Catalyst необходимо выполнить команду sdm prefer extended-match (и перезагрузить коммутатор). Путем запуска команды show sdm prefer вы в состоянии видеть фактическую конфигурацию Аппаратных средств TCAM/ASIC в коммутаторе.

  • Поскольку реализация WCCP в Catalyst 3550 ограничена, выполнение команды show ip wccp не показывает количество перенаправляемых пакетов. Этот индекс остается в 0. Кроме того, тот же Catalyst может иметь множественные Модули контента в кэше - ферме, но позволен только один WCCP catalyst. Выходные данные команды show ip wccp на Catalyst показывают ниже.

    GIULIO#sh ip wccp 
    
    Global WCCP information: 
      ��� Router information: 
      ������� Router Identifier:������������������  33.33.33.33 
      ������� Protocol Version:�������������������  2.0 
    
    ��� Service Identifier: web-cache 
      ������� Number of Cache Engines:�������������  1 
      ������� Number of routers:���������������������1 
      ������� Total Packets Redirected:��������������0 
      ������� Redirect access-list:����������������  -none- 
      ������� Total Packets Denied Redirect:�������  0 
      ������� Total Packets Unassigned:��������������0 
      ������� Group access-list:�������������������  -none- 
      ������� Total Messages Denied to Group:���     0 
      ������� Total Authentication failures:���������0 
      �
                                  Statistics - Requests
                                                    Total             % of Requests
                                ---------------------------------------------------
         Total Received Requests:                       4                         -
                  Forced Reloads:                       0                       0.0
                   Client Errors:                       0                       0.0
                   Server Errors:                       0                       0.0
             URL Blocked (Reset):                       0                       0.0
                     URL Blocked:                       0                       0.0
          Sent to Outgoing Proxy:                       0                       0.0
    Failures from Outgoing Proxy:                       0                       0.0
    Excluded from Outgoing Proxy:                       0                       0.0
                 ICP Client Hits:                       0                       0.0
                 ICP Server Hits:                       0                       0.0
                   If-Range Hits:                       0                       0.0
               HTTP 0.9 Requests:                       4                     100.0
               HTTP 1.0 Requests:                       0                       0.0
               HTTP 1.1 Requests:                       0                       0.0
           HTTP Unknown Requests:                       0                       0.0
               Non HTTP Requests:                       0                       0.0
              Non HTTP Responses:                       0                       0.0
          Chunked HTTP Responses:                       0                       0.0
            Http Miss Due To DNS:                       0                       0.0
         Http Deletes Due To DNS:                       0                       0.0
    
    
    agra#sho stat http savings 
                             Statistics - Savings
                            Requests                          Bytes
             -----------------------------------------------------------
      Total:                       4                           3132
       Hits:                       3                           2349
       Miss:                       1                            783
    Savings:                    75.0 %                         75.0 %
    
    
    agra#sho stat netstat 
    Active Internet connections (w/o servers)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State      
    tcp        0      0 33.33.33.31:8999        10.48.66.123:2011       ESTABLISHED 
    
    udp        0      0 127.0.0.1:10000         127.0.0.1:32346         ESTABLISHED 
    
    udp        0      0 127.0.0.1:10001         127.0.0.1:32347         ESTABLISHED 
    
    udp        0      0 127.0.0.1:10002         127.0.0.1:32345         ESTABLISHED
  • Если список доступа 100 применен к входящему трафику на FastEthernet 0/48, сообщение, подобное придерживающемуся, должно быть передано консоли для каждого пакета HTTP, передаваемого клиентским браузером Интернету:

    *Mar� 1 04:19:09: %SEC-6-IPACCESSLOGP: list 109 permitted tcp 1.1.1.2(1828)    -> 10.48.66.125(80), 1 packet �    
    
    
  • На Модуле контента следующие команды позволяют вам видеть количество пакетов, переданных Модулем контента:

    • show statistics http requests

    • покажите netstat статистики

    • покажите статистические сохранения http

    Все пакеты, отосланные в Интернет, имеют IP - адрес источника, идентичный Модулю контента, кроме тех случаев, когда Модуль контента находится в транзитном режиме, и запросы отправлены IP - адресом источника клиентского компьютера вместо этого.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 29461