Протокол IP : Протокол IS-IS

Использование бита перегрузки с ISIS

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Данный документ знакомит с командой set-overload-bit настройки протокола промежуточная система-промежуточная система (IS-IS), ее назначением и применением с командой wait-for-bgp и подавлением ключевых слов. В этом документе понятия промежуточная система (IS) и маршрутизатор взаимозаменяемы.

Предварительные условия

Требования

У читателей данной документации должны быть базовые знания о:

  • Протокол BGP и протоколы маршрутизации IS-IS.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Cisco выпуск ПО IOS� 12.1 (9)

  • Cisco 2500 и маршрутизаторы серии "3600"

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Традиционное использование перезагрузки

Если на маршрутизаторе недостаточно системных ресурсов (памяти или CPU), на нем невозможно сохранить базу данных о состоянии канала или запустить SPF. В данной ситуации маршрутизатор должен предупредить другие маршрутизаторы области, установив определенный бит в пакетах LSP. Когда другие маршрутизаторы обнаруживают, что этот разряд задан, они станут использовать данный маршрутизатор не для передачи трафика, а для пакетов, направленных в сети, напрямую подключенные к перегруженному маршрутизатору, и префиксы IP.

В связи между промежуточными системами IS-IS маршрутизатор немедленно распространяет волновым методом собственные LSP даже до отправления полного последовательного числа PDU (CSNP) пакетов. Таким образом бит перегрузки используется для того, чтобы остальная часть сети не направляла транзитный трафик через недавно перезагруженный маршрутизатор.

Для каждого LSP ISO/IEC 10589:1992 leavingcisco.comопределяет специальный бит под названием Бит Перегрузки Базы данных LSP. В проекте упоминается условие перегрузки (в разделе7.3.19): "В результате неверной конфигурации сети, или конкретных временных условий, возможно, что будет недостаточно ресурсов памяти для хранения полученных PDU состояния канала связи. При возникновении такой ситуации IS необходимо предпринять некоторые шаги, которые в случае возникновения расхождения между базой данных LSP этой IS с базами данных других IS предупредят использование такими IS путей пересылки, проходящих через перегруженную IS."

Когда IS-система оказывается в таком состоянии, она устанавливает этот бит во фрагменте 0 генерируемого ею пакета LSP для маршрутизатора, не являющегося псевдоузлом.

Кроме того, в проекте в разделе 7.2.8.1 отмечается, что другие промежуточные системы (IS) не должны использовать перегруженную IS в качестве транзитного маршрута, однако связываться с непосредственно подключенными конечными системами (ES) они смогут. Напрямую подключенные интерфейсы в течение этого времени по-прежнему доступны, как и IP-префиксы. Cisco IOS не использует бит перегрузки для этой функциональности, невзирая на то, что возможность постоянно установить разрядное перегрузкой была введена в IOS с идентификатором ошибки Cisco CSCdj18100. В системе Cisco установка служебного бита означает доступность непосредственно подключенных интерфейсов и IP-префиксов.

Расширенное использование бита перегрузки

Способ бита перегрузки IS-IS был расширен с идентификатором ошибки Cisco CSCdp01872 (только зарегистрированные клиенты). Маршрутизатор можно настроить таким образом, что он будет отображать свой LSP вместе с битом перегрузки в течение определенного промежутка времени после перезагрузки. То, когда таймер истекает, перегрузка укусила, очищено, и LSP повторно лавинно рассылается.

Эта новая функция полезна для Интернет-провайдеров (ISP), которые работают с протоколом пограничного шлюза (BGP) и IS-IS для предотвращения некоторых сценариев "черной дыры". Благодаря настройке бита перегрузки для фиксированного периода времени сразу после перезагрузки маршрутизатор не получает транзитный трафик, пока протокол маршрутизации выполняет объединение.

Следующая команда реализует метод установки данного бита на определенный период времени после перезагрузки. Эта команда занимает временной диапазон от 5 до 86400 для бита перезагрузки для сохранения настройки после перезагрузки.

router isis
set-overload-bit [on-startup [<timeout> | wait-for-bgp] ]

Например: :

Router(config-router)#set-overload-bit on-startup 3500 wait-for-bgp

!--- Set the overload bit for 5 minutes (default is 10 minutes).

Когда BGP сходился, эта функция также позволила настроить маршрутизатор для автоматического отключения бита перегрузки. Для получения дополнительной информации об ожидании BGP, посмотрите Исключение переменного поглощения Обмена информацией между промежуточными системами (IS-IS) RFC3277 leavingcisco.com.

В соответствии со спецификацией маршрутизатор BGP может не отправлять сообщения для поддержания активности, пока он отправляет обновления. Таким образом, сообщения об активности посылаются только после отправки всех обновлений. Когда пакеты Keepalive получены от всех Соседних BGP узел, BGP, как полагают, сходился.

Если сообщения активности BGP не получены от всех соседей BGP и сконфигурирован wait-for-bgp, то IS-IS отключит бит перегрузки через 10 минут.

Когда set-overload-bit настроен, интернет-провайдеры могут хотеть подавить определенные, некоторый префиксы IP от того, чтобы быть объявленным в собственных LSP маршрутизатора. Например, может быть нежелательно разрешать распространение IP-префикса с уровня 1 на уровень 2, что сделало бы маршрутизатор транзитным узлом для IP-трафика.

Идентификатор ошибки Cisco CSCdr98046 (только зарегистрированные клиенты) передает большему контролю, что происходит, когда перегрузка укусила, используется в ее расширенной емкости. Данное Усовершенствование позволяет маршрутизатору уровней 1-2 (L1L2) IS-IS, который выполняет перераспределение маршрутов IP с уровня 1 на уровень 2 или с уровня 2 на уровень 1, продолжать отображение этих перераспределенных маршрутов в своем LSP, когда установлен бит перегрузки.

Использование подавить ключевого слова, можно настроить маршрутизатор L1L2, чтобы перераспределить и объявить Ip route от Уровня 1 в Уровень 2 или наоборот даже когда настроен set-overload-bit. Синтаксис команды приведен ниже:

[no] set-overload-bit [on-startup [<n> | wait-for-bgp]] | [suppress [interlevel | external]]

Подавить межуровневое ключевое слово говорит маршрутизатору не объявлять префиксы IP, изученные из другого уровня IS-IS, если перегрузка укусила, установлен. Подавить внешнее ключевое слово говорит маршрутизатору не объявлять префиксы IP, изученные из других протоколов, если перегрузка укусила, установлен. По умолчанию не должен подавлять и поддерживать идентификатор ошибки Cisco CSCdp01872 (только зарегистрированные клиенты) поведение.

Параметр suppress вступает в силу только тогда, когда настроен ваш собственный бит перегрузки, а не тогда, когда его получают или конфигурируют (например, можно иметь set-overload-bit on-startup, а бит будет не установлен).

router isis
set-overload-bit on-startup 40 suppress interlevel

В вышеупомянутом случае перегрузка укусила, фактически не установлен, пока маршрутизатор не повторно загружен, и таким образом, необходимо продолжить пропускать префиксы IP между уровнями. Когда вы повторно загружаете и фактически устанавливаете бит, необходимо подавить межуровневые объявления.

Пример конфигурации

Следующий сетевой график использован для показа команды set-overload-bit и параметров wait-for-bgp и suppress.

/image/gif/paws/24509/TOPO.gif

Здесь представлена конфигурация, содержащая опцию wait-for-bgp в маршрутизации 2.

Конфигурация второго маршрутизатора
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255

!--- Creates loopback interface and assigns
!--- IP address to interface Loopback0.

!
interface Ethernet0/0
ip address 135.8.1.1 255.255.255.0
ip router isis 
!

!--- Assigns IP address to interface Ethernet0/0 
!--- and enables IS-IS for IP on the interface.

!
!
interface Ethernet1/0
ip address 135.8.2.1 255.255.255.0
ip router isis 
!

!--- Assigns IP address to interface Ethernet1/0 
!--- and enables IS-IS for IP on the interface.

!
!
router isis
passive-interface Loopback0
net 12.0020.0200.2002.00
set-overload-bit on-startup wait-for-bgp
!

!--- Enables the IS-IS process on the router.
!--- Makes loopback interface passive 
!--- (does not send IS-IS packets on interface).
!--- Assigns area and system ID to router.
!--- Sets the overload bit on startup to wait for BGP
!--- using the default timeout of 10 minutes.

Маршрутизатор был недавно перезагружен, и перед сходимостью eBGP можно заметить, что бит перегрузки установлен на LSP маршрутизатора 2 в базе данных IS-IS уровня 1.

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
r2.00-00              0x00000017   0x2372        284               0/0/1

Ниже приводятся выходные данные команды debug isis update, сведенные по протоколу BGP на маршрутизаторе 2:

*Mar 1 00:00:51.015 UTC: BGP(0): Revise route installing 1.1.1.1/32 
-> 135.8.1.1 to main IP table

Маршрутизатор 2 не восстанавливает LSP уровня 1, так как протокол BGP сходится, и бит перегрузки очищается. Поэтому вы видите сообщение Important fields changed (Важные поля изменились) в выходных данных команды debug isis update, приведенных ниже.

*Mar 1 00:00:51.087 UTC: ISIS-Upd: Building L1 LSP
*Mar 1 00:00:51.087 UTC: ISIS-Upd: Important fields changed
*Mar 1 00:00:51.087 UTC: ISIS-Upd: Full SPF required

Теперь маршрутизатор 2 завершил сеанс обновления BGP с соседним устройством:

*Mar 1 00:00:52.127 UTC: BGP: 135.8.1.1 initial update completed

Если снова посмотрим на LSP уровня 1 маршрутизатора 2, увидим, что маршрутизатор 2 сбросил бит перегрузки (потому что BGP сошелся), и что поле Seq Num LSP увеличилось на 1 (потому что создан новый LSP):

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
r2.00-00              0x00000018   0xAD87        287               0/0/0

Здесь приведена конфигурация маршрутизатора 2 с настроенной утечкой маршрута L1L2 и очищенным битом перегрузки.

Конфигурация второго маршрутизатора
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255

!--- Creates loopback interface and assigns
!--- IP address to interface Loopback0.

!
interface Ethernet0/0
ip address 135.8.1.1 255.255.255.0
ip router isis 

!--- Assigns IP address to interface Ethernet0/0 
!--- and enables IS-IS for IP on the interface.

!
!
!
interface Ethernet1/0
ip address 135.8.2.1 255.255.255.0
ip router isis 
!

!--- Assigns IP address to interface Ethernet1/0 
!--- and enables IS-IS for IP on the interface.

!
!
router isis 
redistribute static ip metric 11 level-1
redistribute isis ip level-2 into level-1 distribute-list 100
passive-interface Loopback0
net 12.0020.0200.2002.00
!

!--- Enables the IS-IS process on the router.
!--- Configured L2 to L1 route leaking
!--- Makes loopback interface passive
!--- (does not send IS-IS packets on interface).
!--- Assigns area and system ID to router.

!
ip route 200.200.200.200 255.255.255.255 loopback0 

!--- Static route to 200.200.200.200 via loopback0.

access-list 100 permit ip any any

!--- Access list 100 is used to control which route
!--- gets leaked from Level 2 to Level 1.

Обратите внимание, что база данных первого уровня маршрутизатора 2 показывает, что бит перегрузки очищен в LSP L1 маршрутизатора 2.

IS-IS Level-1 LSP r2.00-00        
LSPID       LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL        
r2.00-00 * 0x0000005D   0xC252        180           0/0/0        
Area Address: 12        
NLPID: 0xCC         
Hostname: r2
IP Address: 2.2.2.2
Metric: 10 IP 135.8.2.0 255.255.255.0
Metric: 10 IP 135.8.1.0 255.255.255.0
Metric:  0 IP 2.2.2.2 255.255.255.255
Metric: 10 IS r2.02
Metric: 10 IS r3.01
Metric: 11 IP-External 200.200.200.200 255.255.255.255
Metric:138 IP-Interarea 1.1.1.1 255.255.255.255

Если взглянуть на IP-маршруты, которые получает маршрутизатор 3, то мы увидим, что он получил информацию о кольцевом адресе 1.1.1.1 маршрутизатора 1 от утечки маршрута на L2L1. Заметьте также, что Маршрутизатор 3 также получает перераспределенный статический маршрут 200.200.200.0/32.

r3#show ip route isis
200.200.200.0/32 is subnetted, 1 subnets
i L1 200.200.200.200 [115/21] via 135.8.2.2, Ethernet0/0
1.0.0.0/32 is subnetted, 1 subnets
i ia 1.1.1.1 [115/148] via 135.8.2.2, Ethernet0/0
2.0.0.0/32 is subnetted, 1 subnets
i L1 2.2.2.2 [115/10] via 135.8.2.2, Ethernet0/0
135.8.0.0/24 is subnetted, 2 subnets
i L1 135.8.1.0 [115/20] via 135.8.2.2, Ethernet0/0

Теперь настроим команду set-overload-bit на маршрутизаторе 2 с помощью параметра supress. Мы будем подавлять обе внутренних и внешних маршрутизации. Синтаксис командного языка следует:

[no] set-overload-bit [on-startup [<n> | wait-for-bgp]] | [suppress [interlevel | external]]

подавите межуровневый, препятствует тому, чтобы маршрутизатор объявил префиксы, изученные из Уровня 2. команда suppress external предотвращает перераспределение.

r2(config-router)#set-overload-bit suppress interlevel external

В базе данных маршрутизатора 2 уровня 1 можно увидеть, что бит перегрузки теперь установлен в LSP маршрутизатора 2 уровня 1. Подавлены 200.200.200.200/32 и 1.1.1.1/32. Они не включаются в базу данных первого уровня.

IS-IS Level-1 LSP r2.00-00
LSPID       LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
r2.00-00 * 0x0000005F   0x23C6       266            0/0/1
Area Address: 12
NLPID: 0xCC 
Hostname: r2
IP Address: 2.2.2.2
Metric: 10 IP 135.8.2.0 255.255.255.0
Metric: 10 IP 135.8.1.0 255.255.255.0
Metric: 0 IP 2.2.2.2 255.255.255.255
Metric: 10 IS r2.02
Metric: 10 IS r3.01

Когда включается отладка пакетов обновления isis на маршрутизаторе 2, в выходных данных появляется сообщение Important fields changed (Изменены важные поля), когда собираются пакеты с информацией о состоянии уровня 1 и уровня 2. Это показывает, что содержимое LSP изменилось; другими словами, LSP теперь имеет набор битов перегрузки. Новый LSP требует, чтобы был выполнен полный SPF.

*Mar 1 03:16:08.987 UTC: ISIS-Upd: Building L1 LSP
*Mar 1 03:16:08.987 UTC: ISIS-Upd: Important fields changed
*Mar 1 03:16:08.987 UTC: ISIS-Upd: Full SPF required
*Mar 1 03:16:08.987 UTC: ISIS-Upd: Building L2 LSP
*Mar 1 03:16:08.987 UTC: ISIS-Upd: Important fields changed
*Mar 1 03:16:08.987 UTC: ISIS-Upd: Full SPF required
*Mar 1 03:16:09.035 UTC: ISIS-Upd: Sending L1 LSP 0020.0200.2002.00-00, seq 61, ht 299 on Ethernet0/0
*Mar 1 03:16:09.095 UTC: ISIS-Upd: Sending L2 LSP 0020.0200.2002.00-00, seq 65, ht 299 on Ethernet1/0

Маршрутизатор 3 обновил таблицу маршрутизации, которая больше не содержит сети IP 200.200.200.200 и 1.1.1.1.

r3#show ip route isis
2.0.0.0/32 is subnetted, 1 subnets
i L1 2.2.2.2 [115/10] via 135.8.2.2, Ethernet0/0
135.8.0.0/24 is subnetted, 2 subnets
i L1 135.8.1.0 [115/20] via 135.8.2.2, Ethernet0/0

Сведения о DDTS

  • Идентификатор ошибки Cisco CSCdj18100 (только зарегистрированные клиенты) - Представленный возможность установить перегрузку укусил вручную.

  • Идентификатор ошибки Cisco CSCdp01872 (только зарегистрированные клиенты) - Представленный возможность установить перегрузку обдумал запуск. Ждите, пока BGP не сигнализировал конвергенцию или заставил таймер очищаться, перегрузка укусила.

  • Идентификатор ошибки Cisco CSCdr98046 (только зарегистрированные клиенты) - маршрутизатор IS-IS L1L2, который перераспределяет Ip route от Уровня 1 в Уровень 2 или Уровень 2 в Уровень 1, может продолжить объявлять эти перераспределенные маршруты в своем LSP, когда перегрузка укусила, был установлен.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 24509