Широкополосные кабельные сети : DOCSIS

Использование команды max-cpe в DOCSIS и CMTS

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ объясняет отношение между новым max-cpe кабельного модема n команда и параметром MAX-CPE, заданным в файле конфигурации DOCSIS. Файл конфигурации DOCSIS загружен в кабельный модем и может быть закодирован на uBR7200 series маршрутизаторах рабочая Cisco 12.1 (2) EC1 Выпуска ПО IOS� или выше.

Перед началом работы

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Предварительные условия

Компания Cisco рекомендует предварительно ознакомиться со следующими предметами:

  • Сведения в этом документе даны на основе аппаратного процессора Cisco uBR7246 (NPE150) (версия В) и программного обеспечения Cisco IOS (UBR7200-IST-M) версии 12.1(2)EC1.

  • В этом документе описаны кабельные модемы только в режиме моста.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Общие сведения

Клиентам необходимо, чтобы система CMTS позволяла большему количеству CPE подключаться к кабельному модему, несмотря на то, что количество хостов ограничено значением в файле конфигурации кабельных модемов. Изменения, позволяющие разрешить большему количеству CPE подключаться к кабельному модему, были представлены в CSCdp52029 ( только для зарегистрированных клиентов) в Cisco IOS Software Release 12.0(9.5)SC и Cisco IOS Software Release 12.1(1.0.3)EC1.

Это требование было создано из-за неспособности кабельного модема для проведения подсчета CPE, выделенных в синхронизации с количеством CMTS. Когда кабельный модем инициализирован, единственный случай, в котором он может синхронизировать MAX-CPE с CMTS - когда он посылает номер MAX-CPE на CMTS в процессе запроса регистрации.

Если кабельный модем перезагружается, нет потока к CMTS для передачи уведомления о сокращении числа размещенных CPE до нуля. Кабельный модем, однако, запустится снова с нуля. Если новый CPE позади кабельного модема запросит подключиться к сети, то кабельный модем разрешит его к тому, поскольку его количество MAX-CPE является теперь нулем. CMTS с ненулевым счетчиком MAX-CPE, однако, даст сбой в запросе, и на CMTS будет следующее сообщение:

 
%UBR7200-5-MAXHOST: New host with IP address x.x.x.x 
 and MAC yyyy.yyyy.yyyy on SID 3 (CM zzzz.zzzz.zzzz) is ignored.

Это усилено фактом, что, если неуказанный, запись MAX-CPE по умолчанию в файле конфигурации DOCSIS установлена в один.

Примером является ситуация, когда кабельные модемы извещают CMTS, что число MAX-CPE в запросе регистрации равно одному. Заказчик кабеля хочет, чтобы функциональность энергетического цикла кабельного модема позволила удалить портативный компьютер их установщика и вернуть на кабельный модем PC конечного пользователя. Это откажет потому что. После повторной загрузки кабельный модем будет иметь количество MAX-CPE обнуленным, однако, CMTS будет все еще помнить запись переносного компьютера установщика, и который равняется количеству MAX-CPE одного.

Существует обходной путь, доступный путем запуска clear cable host x. x . x . x команда, где x.x.x.x равняется или IP или MAC-адресу хоста, который будет очищен на CMTS. Данное временное решение не рекомендуется для кабельных клиентов.

Реализация

Команда new configuration добавлена в CMTS. Для определения максимального числа разрешенных хостов на модем (заменяющий значение MAX-CPE в файле настройки кабельного модема) выполните max-cpe кабельного модема n команда в режиме конфигурации кабельного сопряжения. n равняется 1 - 255.

CMTS включает до n числа узлов для кабельного модема. Когда установлено в неограниченный, или n больше, чем значение MAX-CPE в файле конфигурации кабельного модема, эта команда отвергает значение файла конфигурации. DHCP сервер управляет количеством IP-адресов, назначенных узлам, подключенным к одному кабельному модему.

Если в конфигурационном файле кабельного модема указано число узлов больше n, параметр файла конфигурации создает прецедент. Это до кабельного модема для управления количеством активных узлов.

Если использовать команду cable modem max-cpe unlimited, система CMTS не будет применять ограничение на число устройств CPE, подключаемых к одному кабельному модему. С этой настройкой контроль максимального числа конечных абонентских устройств осуществляет кабельный модем, а сервер DHCP контролирует число IP-адресов, назначенных оконечным абонентским устройствам, подключенных к кабельному модему.

caution Внимание: Неосторожное использование команды cable modem max-cpe unlimited может открыть уязвимость в системе безопасности, так как появится возможность возникновения DoS-атак. В частности, это может позволить пользователю иметь большое число IP-адресов, таким образом делая сеть неработоспособной после резервирования всех IP-адресов одним пользователем. Все же это рекомендуется, если включена команда cable modem max-cpe unlimited, количество IP-адресов, назначенных CPE за однокабельным модемом, будет строго контролироваться DHCP-сервером.

Путем выдачи команды no cable modem max-cpe включена настройка по умолчанию. Значение MAX-CPE, указанное в файле конфигурации, будет использовано CMTS, чтобы ограничить число CPE, подключенных к одному кабельному модему.

Когда max-cpe кабельного модема n выполнен, команда show cable modem detail отображает значение MAX-CPE согласно конфигурации в файле конфигурации DOCSIS для кабельного модема, и, если возможно, значение, настроенное.

Обратитесь к примеру выходных данных журнала ниже. CMTS сконфигурировано для MAX-CPE равного 4, и MAX-CPE, установленного в unlimited.

test-cmts#show cable modem detail 
Interface ...... SID MAC address .... Max CPE Concatenation Rx SNR
Cable4/0/U0 1 .... 0001.9659.47bb 1 ............. yes ................ 37.37
Cable4/0/U0 2 .... 0001.9659.47ab 1 ............. yes ................ 33.70
Cable4/0/U0 3 .... 0001.9659.47bf .1 ............. yes ................ 30.67
Cable4/0/U0 4 .... 0001.9659.3ef7 .1 ............. yes ................ 28.84
Cable4/0/U0 5 .... 0001.9659.47eb 1 ............. yes ................ 30.89

test-cmts#conf t
Enter configuration commands, one per line. End with CNTL/Z.
test-cmts(config)#cable modem max-cpe ?
<1-255> Number
unlimited Max CPE not enforced

test-cmts(config)#cable modem max-cpe 4
test-cmts(config)#end
test-cmts#
00:05:11: %SYS-5-CONFIG_I: Configured from console by console


test-cmts#show cable modem detail
Interface ...... SID MAC address .... Max CPE Concatenation Rx SNR
Cable4/0/U0 1 .... 0001.9659.47bb 1 (4) .........yes ................37.00
Cable4/0/U0 2 .... 0001.9659.47ab 1 (4) ........ yes ................33.54
Cable4/0/U0 3 .... 0001.9659.47bf .1 (4) ........ yes ................30.70
Cable4/0/U0 4 .... 0001.9659.3ef7 .1 (4) ........ yes ................ 29.00
Cable4/0/U0 5 .... 0001.9659.47eb 1 (4) ........ yes ................ 30.92

test-cmts#conf t
Enter configuration commands, one per line. End with CNTL/Z.
test-cmts(config)#cable modem max
test-cmts(config)#cable modem max-cpe ?
<1-255> Number
unlimited Max CPE not enforced

test-cmts(config)#cable modem max-cpe unli
test-cmts(config)#cable modem max-cpe unlimited 
test-cmts(config)#^Z 
test-cmts#
00:06:06: %SYS-5-CONFIG_I: Configured from console by console


test-cmts#show cable modem detail
Interface ...... SID MAC address .... Max CPE Concatenation Rx SNR
Cable4/0/U0 1 .... 0001.9659.47bb 1 (ul) .........yes ............... 36.64
Cable4/0/U0 2 .... 0001.9659.47ab 1 (ul) ........ yes ............... 33.26
Cable4/0/U0 3 .... 0001.9659.47bf. 1 (ul) ....... .yes ............... 30.73
Cable4/0/U0 4 .... 0001.9659.3ef7 .1 (ul) ...... . yes ............... 29.15
Cable4/0/U0 5 .... 0001.9659.47eb 1 (ul) ...... . yes ............... 30.95

test-cmts#wr t
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname test-cmts
!
boot system flash ubr7200-ist-mz.121-2.EC1
no logging buffered
!
cable modem max-cpe 4
ip subnet-zero 
!
interface FastEthernet0/0
ip address 10.200.68.4 255.255.255.0
half-duplex
!
interface Cable4/0
ip address 10.200.69.49 255.255.255.240 secondary
ip address 10.200.69.33 255.255.255.240
ip accounting precedence input
ip accounting precedence output
no keepalive
cable max-hosts 10
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable upstream 0 frequency 20000000
cable upstream 0 power-level 0
cable upstream 0 rate-limit
no cable upstream 0 shutdown
cable upstream 1 shutdown
cable upstream 2 shutdown
cable upstream 3 shutdown
cable upstream 4 shutdown
cable upstream 5 frequency 20000000
cable upstream 5 power-level 0
cable upstream 5 rate-limit
cable upstream 5 shutdown
cable dhcp-giaddr policycable
helper-addrress 10.200.68.11
! 
router rip
network 10.0.0.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.200.68.1
ip route 10.200.32.0 255.255.224.0 10.200.68.2
no ip http server
!
line con 0
exec-timeout 0 0
password ww
login
transport input none
line aux 0
line vty 0 4
password ww
login
!
end

test-cmts#

Примечание: Несмотря на то, что CMTS, разрешает заданный номер хостов через кабельные модемы, сами кабельные модемы будут все еще ограничены для разрешения только количества CPE, разрешенных в файле конфигурации DOCSIS.


Дополнительные сведения


Document ID: 22177